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Lesson 2

 

Working with Frames

 

InDesign frames can hold either text or graphics. 

As you work with frames, you’ll notice that 

InDesign provides a great amount of flexibility 

and control over your design.
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In this introduction to working with frames, you’ll learn how to do the following:

 

•

 

Resize text frames

 

•

 

Use anchor points to reshape a text frame

 

•

 

Copy a graphic into a frame

 

•

 

Convert a graphics frame to a text frame

 

•

 

Wrap text around an object

 

•

 

Create and rotate a polygon frame

 

•

 

Center and scale an object within a frame

 

Getting started

 

To ensure that the tools and palettes function exactly as described in this lesson, you must delete 

or deactivate (by renaming) the InDesign Defaults file and the InDesign SavedData file.

 

1

 

If InDesign is running, choose File > Exit.

 

2

 

To locate the InDesign defaults files, do one of the following:

 

•

 

(Windows) Choose Start from the Windows taskbar, and then click Find > Files or Folders. For 

Named, type 

 

InDesign 

 

and click Find Now. Drag the InDesign Defaults file and the InDesign Saved-

Data file into the Recycle Bin. Do not delete any other InDesign file. Close the Find dialog box.

 

•

 

(Mac OS) Choose File > Find from the Finder menu. Type 

 

InDesign

 

 and choose Find. Drag the 

InDesign Defaults file and the InDesign SavedData file into the Trash. Do not delete any other InDe-

sign file. Close the Find windows.

 

If you want to return to your previous settings, drag the files from the Trash or Recycle Bin to the 

original folder after you finish the tour. Click Yes when asked whether to overwrite the existing files.

 

You’ll now open the final publication so that you can see what it will look like when you complete 

the lesson. This publication is a two-page magazine article on origami.

 

3

 

Start InDesign.

 

4

 

Choose File > Open, and open 02_b.indd in the ID_02 folder.
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5

 

Leave this file open (in the background) so you can use it as a visual reference during the lesson.

 

Opening the working document

 

The document you’ll open contains the framework necessary to complete this lesson. The master pages 

include guides and text frame placeholders similar to the master pages you created in Lesson 1. The 

working document also includes layers and color swatches that will help you design your document.

 

1

 

To open the working document, choose File > Open, and open 02_a.indd in the ID_02 folder.

 

2

 

Choose File > Save As, name the file Work02 in the ID_02 folder, and then click Save.

 

Resizing text frames

 

You can move, resize, and manipulate text frames. The tool you use to select a frame determines how 

you can change it:

 

•

 

The type tool ( ) lets you type or edit text within the frame.

 

•

 

The selection tool ( ) lets you move or resize the text frame using its bounding box. The 

 

bounding 

box

 

 is a rectangle that represents the object’s horizontal and vertical dimensions. When you select a 

text frame, it appears as a bounding box with eight solid handles.

 

•

 

The direct-selection tool ( ) lets you select and edit a frame’s individual 

 

anchor points

 

 (hollow 

handles that determine a frame’s shape).

This document includes two layers: Art and Text. You’ll lock the objects on the Art layer so that you 

won’t accidentally select the shapes while you resize the text frames.

 

1

 

Click the Layers palette tab, and then click the lock box to the left of the Art layer. 

The objects on the Art layer are now locked. You’ll now resize the bounding box of a text frame.

 

2

 

To hide all palettes except the toolbox, press Shift+Tab.

 

3

 

Using the selection tool ( ), click anywhere in the main story text frame on the left page. Notice 

that the text frame has eight solid handles.



 
WORKING WITH FRAMES

 

PAGE 4 OF 18

 

4

 

Drag the top center handle up to resize the height of the frame so that it snaps to the next 

horizontal guide above (near 22 picas on the vertical ruler).

Notice that after you resized the frame, text flows throughout the entire frame. Also, the bottom 

image has a text wrap applied to it, so the text flows around the image.

 

Using anchor points to reshape a text frame

 

When working with frames, it is important to pay attention to which selection tool you’re using. 

When you use the selection tool ( ) to resize a text frame, the text frame maintains its rectangular 

shape. When you use the direct-selection tool ( ), dragging the anchor points will change the shape 

of the frame.

 

1

 

With the text frame on page 4 selected, click the direct-selection tool ( ) in the toolbox.

Four hollow handles, called 

 

anchor points

 

, now appear on the selected text frame.

 

2

 

Position the pointer over the upper left anchor point and then click and hold down the mouse 

button until the pointer becomes a triangle ( ). Drag the anchor point so that it snaps to the 

horizontal guide below it, as shown, and release the mouse button.

Make sure you drag only the anchor point—if you drag just below the anchor point, you’ll move the 

text frame.
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3

 

Select the selection tool ( ).

 

A

 

. Bounding box

 

B.

 

 Frame

 

Now you can see the difference between the bounding box and the path of the text frame. Notice 

that the bounding box is a rectangle with eight solid handles.

Next, you’ll resize the text frame on the right page of the spread so that it mirrors the text frame on 

the left page.

 

4

 

Select the direct-selection tool ( ), and click anywhere in the main story text frame on the right 

page to display the anchor points on the text frame.

 

5

 

Drag the upper left handle of the text frame up to the next horizontal guide so that the text frame 

on the right page mirrors the left page, as shown. Again, make sure you drag only the anchor point, 

not the entire text frame.

 

6

 

Choose File > Save.

 

When no insertion point is placed, you can press 

 

a

 

 or 

 

v

 

 to toggle between the selection and 

direction-selection tools. Your Quick Reference Card provides a list of many other shortcut keystrokes.

 

Resizing graphics frames

 

To understand the difference between resizing a frame and resizing the bounding box, you’ll import 

an image and then resize the frame. First you’ll unlock the Art layer and lock the Text layer.
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1

 

Press Tab to show the hidden palettes. In the Layers palette, unlock the Art layer and lock the Text 

layer. Click the Art layer to select it.

 

2

 

To center the right page in the document window, click the Pages palette tab, and then double-

click the page 5 icon. If the toolbox covers the top of the left-most column on page 5, drag the 

toolbox out of the way.

 

3

 

Choose View > Hide Guides. You won’t be snapping the object to any guides.

 

4

 

Choose Edit > Deselect All to make sure no items are selected (if another frame is selected, the 

graphic you place will be inserted into the selected frame).

 

5

 

Select the selection tool ( ). Choose File > Place, and then double-click 02_c.tif in the ID_02 folder.

The pointer changes to a loaded graphics icon ( ).

 

Note:

 

 If the pointer appears with a line through it ( ) when you try to use the selection tool, the current 

layer is locked but still selected. You cannot add objects to a locked layer. Select and unlock the Art layer 

in the Layers palette and proceed.

 

6

 

Click near the top of page 5 to place the graphic as shown. 

When you place a graphic in your document, the content fits within a frame. The content and the 

graphics frame are separate items, each with its own bounding box.
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7

 

Using the selection tool ( ), make sure the placed graphic is selected. Drag the lower right 

handle away from the center of the graphic to enlarge the frame. Don’t worry about dragging a 

precise distance.

You have just resized the bounding box of the frame, but the content remains the same size. The 

content and frame are separate objects; the frame determines which part of the content is shown. 

Now you will crop the image by resizing the frame.

 

8

 

Drag the lower right handle towards the center of the frame to crop the photograph so that the 

origami image is centered within the frame, as shown.

 

9

 

Choose File > Save.

 

Changing the shape of the frame

 

When you resized the frame using the selection tool ( ), the frame maintained its rectangular 

shape. Now you will use the direct-selection tool ( ) to reshape the frame.

 

1

 

With the image still selected, click the direct-selection tool ( ). Notice that the selected object 

now has hollow points, indicating that the frame is selected.

Now you will use the pen tool to add a new anchor point to the frame.
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2

 

Click the pen tool ( ). Hold the pointer over the center of the bottom line of the object so that 

the pen tool has a plus sign ( ), and click. A new point is added.

The pen tool lets you add or remove points. To move these points, you must use the direct-

selection tool.

 

3

 

Select the direct-selection tool ( ). While holding down Shift, drag the lower right anchor point 

approximately half-way toward the top of the image, as shown.

The Shift key constrains the point on the line.

 

4

 

Holding down Shift, drag the lower left anchor point the same distance so that the shape looks 

like a home plate in baseball.

 

5

 

Holding down Shift, drag the upper left point a short distance to the right. Then drag the upper 

right point an equal distance to the left, as shown.
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Now you will center the image within the frame.

 

6

 

With the direct-selection tool ( ) still selected, click the image inside the frame to select it.

 

Selected frame (left) and selected content (right)

 

In general, when you select an object with the direct-selection tool, hollow points appear. The 

exception is imported graphics, which always display a rectangle with eight handles. This is a 

reminder that you can only move or resize imported bitmaps, not radically alter their shape as you 

can with frames.

 

7

 

Drag the selected object up and to the left so that the origami figure is centered within the frame.

The frame acts as a mask to the content. As you can see, the content and frame of a graphic can be 

manipulated independently.

 

Resizing the graphic and frame simultaneously

 

Now you’ll make the graphic and frame a bit larger. You can use the Control or Command key to 

resize the frame and content simultaneously. As is true in most graphics programs, you can hold 

down the Shift key while dragging to resize an object proportionally.

 

1

 

Select the selection tool ( ), and select the graphic on page 5.
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2

 

Holding down Ctrl + Shift (Windows) or Command + Shift (Mac OS), drag the lower right 

handle towards the center of the object to reduce its size, as shown. 

Notice that both the content and the frame are resized. As you can see, the Ctrl or Command key is 

useful for resizing the content and frame simultaneously. 

 

3

 

Choose File > Save.

 

Converting a graphics frame to a text frame

 

Frames can hold either text or graphics. Next, you’ll copy and paste the graphics frame so that you 

can replace the image in the copied frame with text.

 

1

 

With the frame still selected with the selection tool ( ), choose Edit > Copy.

 

2

 

Choose Edit > Paste, and then drag the pasted graphic so that it overlaps the other frame, as shown.

 

3

 

Select the direct-selection tool ( ), and click the image in the pasted frame. Choose File > Place, 

and then double-click 02_d.doc in the ID_02 folder.

When you place the text file, the text flows into the selected frame and replaces the contents, even if 

it’s a graphics frame like this one.

As you can see, frames can contain either text or graphics. Now you’ll make sure the text frame 

belongs to the Text layer instead of the Art layer.

 

4

 

Click the Layers palette tab. Click the lock icon ( ) next to the Text layer to unlock objects on 

the Text layer.

In the Layers palette, the small dot to the right of the layer name indicates which layer the selected 

object belongs to. You can change an object’s layer by dragging this dot to a different layer.
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5

 

With the text frame selected, drag the small dot from the Art layer to the Text layer.

The text frame now belongs to the Text layer. The Art layer is above the Text layer in the Layers 

palette, so the object on the Art layer hides part of the object on the Text layer.

 

Wrapping text around an object

 

You can wrap text around the frame of the object or around the object itself. Now you’ll see the 

difference between wrapping text around the bounding box and wrapping text around the graphic.

 

1

 

Using the selection tool ( ), select the five-sided graphics frame (not the text frame) on page 5.

 

2

 

Choose Object > Text Wrap. Select the second wrap option so that the text wraps around the 

bounding box.

The text wraps around the bounding box of the image, not around the image itself.

 

3

 

Next, select the third wrap option so that the text wraps around the contour of the image.

The text wraps around the graphic instead of the bounding box.

 

A.

 

 Text wrapped around bounding box

 

B.

 

 Text wrapped around 
content

 

4

 

Close the Text Wrap palette.

The text frame is not large enough to hold all the text in the frame, so you will resize it.

A B
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5

 

Using the selection tool ( ), click the text frame to select it. Holding down Shift, drag the lower 

right handle away from the center of the frame to enlarge it until you can see all the text.

 

6

 

Choose File > Save.

 

Fitting the content to the frame

 

Now that you have completed page 5, you will turn your attention to page 4. Because the four objects 

on page 4 are grouped, you cannot use the selection tool ( ) to select one of the frames unless you 

ungrouped the objects first. However, you can use the direct-selection tool to select an object within 

a group. You’ll add a photograph to the second shape from the top. 

 

1

 

Click the Pages palette tab, and then double-click the page 4 icon. To zoom in, select the magni-

fication tool ( ), and then drag across the top three shapes.

 

2

 

Select the direct-selection tool ( ), and then select the frame with the black stroke. Choose File 

> Place, and then double-click 02_e.tif in the ID_02 folder.

The object is placed within the frame. However, because the graphic is much larger than the frame 

that masks it, you can see only a small part of the graphic. To fix this, you’ll fit the content within 

the frame.
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3

 

With the frame still selected, choose Object > Fitting > Fit Content to Frame to resize the graphic 

so that it fits in the frame.

 

Before and after using Fit Content to Frame.

 

Changing the stroke color of the frame

 

Now you’ll change the stroke color of the shape to red. A frame’s outline is called a 

 

stroke

 

. A color or 

gradient applied to a frame’s enclosed area is called a 

 

fill

 

. The icons in the toolbox determine whether 

the fill or stroke is affected.

 

A. Fill B. Stroke

When a frame contains a bitmap graphic like this one, you must click the edge of the frame to select 

the frame; selecting inside the frame selects the graphic.

1 Using the direct-selection tool ( ), click the graphic within the second frame. Notice that the 

graphic is selected, not the frame.

A

B

A

B
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2 Using the direct-selection tool ( ), click the edge of the black frame to select the frame instead 

of the graphic.

A. Selected graphic B. Selected frame

3 Click the Stroke box ( ) in the toolbox. Choose Window > Swatches, and then select Red in the 

Swatches palette (you may need to scroll).

4 Choose File > Save.

Drawing a polygon
Now you’ll draw a polygon and place a graphic within the frame. To make the page less cluttered, 

you’ll hide objects on the Text layer.

1 Choose View > Fit Page in Window. Click a blank area of your document window to make sure 

no objects are selected.

2 Click the Layers palette tab, and then click the eye icon next to the Text layer to hide the Text layer. 

Make sure the Art layer is selected.

Objects on the Text layer are hidden. 

3 Choose View > Show Guides.

4 Double-click the polygon tool ( ) on the toolbar.

You can change the number of sides as well as the inset percentage, which bends the polygon lines 

inward to form a star-shaped object in some cases.

5 For Number of Sides, type 4. For Star Inset, type 15 and then click OK.

A B
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6 Holding down Shift to maintain an equal height and width, drag to create a shape that is the 

width of two columns, as shown below.

A. Bounding box B. Frame

Note: If the pointer appears with a line through it ( ) when you try to use the polygon tool, the Text 

layer is hidden but still selected. You cannot add objects to a hidden layer. Select the Art layer in the 

Layers palette and try again.

Changing the weight of the stroke
Now you’ll change the stroke thickness of the polygon’s frame and place a graphic within the polygon.

1 With the polygon still selected, make sure the Stroke box ( ) in the toolbox is selected.

You’ll open the Stroke palette to change the weight, or thickness, of the stroke.

2 Choose Window > Stroke. For Weight, type 4 and press Return or Enter. Close the Stroke palette.

3 Select Red in the Swatches palette.

Next, you’ll place a graphic within the frame.

4 With the object still selected, choose File > Place.

5 Double-click 02_f.tif in the ID_02 folder.

The graphic is placed within the selected frame. You’ll scale this graphic after you rotate the frame.

6 Choose File > Save.

A B
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Rotating the frame
The content resides within the polygon frame. The frame and content are independent of each 

other, so you can rotate the frame without rotating the content. If you use the selection tool ( ), you 

can rotate both frame and content. If you use the direct-selection tool ( ), you can rotate either.

1 Select the direct-selection tool ( ), and then click the edge of the polygon frame (not inside 

the frame).

The selection tool that is used to select the object determines which object will be rotated.

2 Select the rotation tool ( ).

The crosshair icon, which appears in the upper left handle, determines the point of the rotation. You 

can change the crosshair location by clicking the corresponding point in the proxy icon of the 

Transform palette. 

A. Crosshair B. Proxy icon

3 Click the center point in the proxy icon of the Transform palette to move the crosshair icon to the 

center of the selected frame.

4 Drag any handle to rotate the object 45° in either direction, as shown. To be precise, you can type 

45 in the Rotation box of the Transform palette and press Return or Enter.

If you hold down Shift while dragging the point, the object snaps to 45˚ increments.

Notice that the polygon shape rotates around its center. This is because you selected the center point 

in the proxy icon.

5 Choose File > Save.

A

B



WORKING WITH FRAMES
PAGE 17 OF 18

Centering and scaling the graphic
Now you’ll center the graphic within the frame and then scale the graphic so that it fills the frame.

1 Click the selection tool ( ), and then click a blank area of your document window to make sure 

no objects are selected.

2 Using the selection tool ( ), click the graphic inside the polygon to select it. Choose Object > 

Fitting > Center Content.

The graphic is centered within the frame.

3 Select the direct-selection tool ( ), and click the center of the graphic to select the content (not 

the frame).

4 Select the scale tool ( ). In the Transform palette, select the center point in the proxy icon.

5 Holding down Shift, drag a corner handle outward until the graphic fills the polygon frame. 

Release the Shift key.

6 Choose Edit > Deselect All.

Finishing up
Now you’ll place the graphic at the bottom of the page and wrap the text around it. Then you’ll hide 

guides and palettes to look at the finished spread.

1 In the Layers palette, click the left-most box next to the Text layer to show objects on the Text layer.
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2 Select the selection tool ( ), and drag the polygon to the bottom of page 4, centered between the 

grouped objects and the bottom margin, as shown.

Notice that this object is overlapping the text. You’ll wrap text around it.

3 With the object still selected, choose Object > Text Wrap. Select the third wrap option.

4 Close the Text Wrap palette, and then choose Edit > Deselect All.

Now you’ll hide guides, frame edges, and palettes to view your spread.

5 Choose View > Fit Spread in Window. Choose View > Hide Frame Edges, and then choose View 

> Hide Guides.

6 Press Tab to hide the palettes.

Congratulations. You have finished the lesson.
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