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How are we doing? Email techbookseditor@futurenet.com and let us know if we’ve lived up to our promises!
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Welcome!
… to Apple’s latest innovation – meet El Capitan, 
the new and greatly improved version of OS X

Apple has done it again! 
Hot on the heels of last 
year’s OS X 10.10 Yosemite, 
it has released the new 
OS X 10.11 El Capitan, 
which takes using a Mac 
to even greater levels of 
excellence. While the look 

and feel of El Capitan is very much like Yosemite 
(El Capitan is, after all, a particular rock formation 
in Yosemite National Park), there have been 
some important additions that make using a 
Mac easier than ever. 

Of particular note is Split View, a great new 
way of working with two apps at once, and 
there have been some important improvements 
in Mission Control that make it easier than ever 
to switch between your open programs and 

work more productively on your Mac. There are 
also great improvements in Photos, Spotlight 
and Notes, and Disk Utility has been updated. 
We cover all these innovations in the guide you 
hold in your hands. 

Apple has been busy in other areas since 
Yosemite was released, too. For example, there’s 
the new Apple Music service, which we cover in 
full here, and a brand new version of iTunes to 
play with.  Apple’s iCloud service is also going 
from strength to strength, making it easier than 
ever to collaborate on documents with other 
people, and back your data up to the cloud. 

I hope you enjoy this guide to El Capitan, and 
it helps you to get more than ever out of using a 
Mac. OS X just keeps getting better and better.

Ultimate Handbooks are designed 
to give you a complete guide to 
a device or piece of software you 
own. We aim to help you get more 
from the products you love and we 
guarantee you’ll get the following 
from each book…

 A reference guide you can keep on 
your desk or next to your computer 
and consult time and time again 

when you need to know how to 
do something or solve a problem 

 New skills you can take with you 
through your life and apply at home 
or even in the workplace

 Expert advice to help you do more 
with your hardware and software – 
from solving new problems to 
discovering new things to try out, 

we’ll show you the best ways 
to do everything

 Clear recommendations for other 
products, accessories and services you 
can use with your device or software 
to get the best possible results

  Advice you can take everywhere 
thanks to the free digital edition of this 
book – see page 178 for more details

Graham Barlow, Editor
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The all-new, all-singing, all-
dancing, OS X 10.11 El Capitan is 
here – and you’ll love it! Like its 
predecessor, OS X 10.10 

Yosemite, it continues the theme of 
Californian place names: El Capitan is the 
name of a rock formation situated within 
Yosemite National Park. Also like Yosemite, 
this new version can be downloaded for free 
from the Mac App Store. (Find out about 
upgrading from an older Mac or migrating 
from a Windows PC on page 34 onwards.)

If you have an iPad or an iPhone, you’ll 
be right at home with El Capitan’s fresh-
looking interface, which takes many a cue 
from iOS – in fact, as of their 2015 releases, 
all three of Apple’s operating systems 
(watchOS being the other) use the same 
system font – a custom one called San 
Francisco. Where Yosemite was criticised 
for its sometimes overzealous application 
of transparency effects, Apple has toned 
them down to make El Capitan even more 
pleasant to look at and use.

Probably our favourite improvements in 
this version are the improvements to 
managing how your apps are laid out on the 
screen. Mission Control does a much better 
job of directing you to whatever window you 
need to work in with just a simple gesture on 
your trackpad or mouse and then a click. 
Even OS X’s full-screen mode is massively 
improved with the ability to display two apps 
alongside each other: allocate all the available 
screen space to the apps on which you need 
to focus and shove all other distractions aside.

The latest OS X offers the perfect combination of simplicity and power

Welcome to El Capitan

El Capitan even borrows a trick from the iPhone and iPad, 
enabling you to simply swipe on emails to deal with them.

El Capitan’s Notification Centre provides three different 
ways to sort notifications.

Maps can provide you with directions that use public 
transport, though only for select locations, such as London.

El Capitan’s interface has a fresh, clean look with a new system font, a couple of new desktop backgrounds, and simplified icons to provide a real ‘easy on the eyes’ experience. 
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Like other recent versions of OS X, 
El Capitan is available from the  
Mac App Store as a free upgrade.
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UPDATED
See page 52  

for more

UPDATED
See page 102  

for more

MISSION 
CONTROL

MAIL

SPLIT 
VIEW

NEW
See page 54  

for more

This is OS X’s zoomed-out view of all 
the documents and other windows 
that you’ve opened. It lays 
things out in a much 
clearer fashion in 
El Capitan, and 
features new 
shortcuts for 
managing and 
merging apps – 
including the all-
new Split View!

This is one of our favourite new 
features in OS X. Previous versions 
enabled you to focus on a task by 
switching an app to full-screen mode –

but you could only see one app 
at a time. Now you can put 

two of them side by side, 
which is helpful when 
you need to research 
a subject – try it out 
by pairing Safari and 

El Capitan’s much 
improved Notes app.

We love the improvements to Mail 
in El Capitan, which make it more 
comfortable to use in full-screen mode. 
When you need to refer to another 
message, perhaps to copy and paste, 
you no longer have to save the one 
you’re already working on as a draft. 
Simply click outside of its 
window to stash it at 
the bottom of the 
screen – and you 
can have several 
emails on the go 
thanks to support 
for tabs in the 
message window.
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UPDATED
See page 116  

for more

UPDATED
See page 66  

for more

NEW
See page 85  

for more

Welcome to El Capitan   |   GET STARTED

FIND YOUR
POINTER

SPOTLIGHT

NOTES
This app used to store nothing but text – but 
no more! You are now able to a include wide 
variety of media types in your notes: checklists, 
links to web pages (with a small preview), PDFs 
and other kinds of file, photos, map locations 
and more. This makes Notes a great place to 
keep track of gift ideas, research or school work, 

and your options when 
booking a holiday, buying 

a car, or upgrading your 
old Mac to a brand-
new model.

The search engine built into OS X gains 
new powers in El Capitan, including the 
ability to search more online services for 
data. That includes the weather, sports 
scores and fixtures, and video sites. 
Spotlight is even improved enough to let 
you express yourself in natural language 
when looking for files on 
your Mac, rather than 
typing keywords that 
might appear in a 
file’s name or in  
its contents.

Every Mac user must have been in the 
position of not being able to spot 
where their cursor is on a busy 
desktop. El Capitan has a new feature 

to help you find it. All you have to 
do is wiggle it around using 

your mouse or trackpad 
and El Capitan will 

temporarily enlarge it to 
make it easier to locate 
the pointer – a simple 
yet truly effective 

addition to OS X.
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SAFARI

UPDATED
See page 98  

for more

UPDATED
See page 130  

for more

The latest version of Apple’s web 
browser ensures your most visited sites 
are always at hand, because you can 
pin them open at the left-hand side of 
the app – they’ll be there, waiting for 
you, even after you close and reopen 
the app. Also, with more sites than ever 
including advertisements that play 
sound, there’s now a way to quickly 
identify which tab is 
playing audio 
and mute it.

Apple recently replaced its well-known 
iPhoto software with an app simply 
called Photos. The version that comes 
with El Capitan provides a greater 
degree of control over your photos, 
from enabling third-party apps to 
extend its editing capabilities, to the 
ability to tag multiple photos with a 
location, to support for viewing Live 
Photos taken with an iPhone 6s or 6s 
Plus. We really like that Apple has made 
it easier to identify the people in your 
photos, so you can more quickly find 
those featuring 
specific people 
in the future.

PHOTOS
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Words: Lucy Hattersley, Alan Stonebridge

A
pple’s latest update to 
OS X, El Capitan, takes 
its quirky name from a 
vertical rock formation 
in Yosemite National 
Park. Like its namesake, 

El Capitan rises from Yosemite, the 
version of OS X it replaces, building 
upon its solid foundation to deliver a 
stronger operating system that’s 
packed with feature enhancements.

In many ways, El Capitan is like a 
modern version of Snow Leopard, the 
2009 version of OS X in which Apple 
introduced hardly any new features. 
Instead, it rewrote underlying code 
and focussed on improving 
performance for the long term. 
However, that doesn’t mean there are 
no new features in El Capitan. Far 
from it. There are some real gems to 
discover, both in plain sight the 
moment you start using it and as you 
dig deeper – but you don’t need to go 
looking because we’ve picked out 
dozens so you can make the most of 
your new system right away.

You can add all sorts of things to the 
new Notes app, from audio recordings 
to checklists to website links, making 
it far more capable as a scrapbook. 
Mail works much better in full-screen 
mode. And, Safari gives you a way to 
silence intrusive sites and to pin open 
sites you use often, so they’re 
accessible in an instant with a 
keyboard shortcut.

Changes in the Photos app, 
introduced into OS X in early 2015, 
make it more convenient and more 
powerful, not least thanks to the new 
ability to use third-party editing tools 
within it. This saves you the hassle of 
haivng to exporting pictures when you 
want to do anything remotely 
ambitious with them.

The Mac also takes great strides in 
window management thanks to a 
much improved Mission Control and 
the all-new Split View mode, which 
enables two apps to run side by side, 
hiding other Desktop distractions so 
you can focus more clearly on the task 
at hand.

There are many great new things to 
learn about in OS X El Capitan, so let’s 
get started…

Hidden secrets  |   GET STARTED
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A
pple is determined to make 
Spotlight the go-to place for 
finding anything using your Mac. 
Not just files and folders, but 

also online information, weather reports, 
your contacts and much more.

In recent years, Apple has started to blend 
search results from the internet with the ones 
from your Mac, adding a few new sources to 
make Spotlight more effective at answering 
a range of questions.

El Capitan gives you the ability to find 
certain things – files, folders and email – by 
expressing yourself using natural language.
Spotlight then interprets your meaning to give 
you more accurate results, such as files you 
worked on a week ago when you want to 
continue a project.

One small but very welcome improvement 
is that you can also move the Spotlight 
window around. Once the window is showing 

Get better – and more – answers than ever  
before from OS X’s built-in search engine

results, you can resize the window’s height to 
show more results – important now that 
Spotlight can search many more sources, 
including various online services.

Among them is weather – you only need to 
enter that word to get results for your current 
location, though you can easily look up the 
forecast for other locations, too. Like Siri on 
iOS devices, Spotlight can look up team 
standings and upcoming fixtures when you 
enter the name of your favourite football 
team. It even looks up stock values, though 
how useful you’ll find that depends on your 
opinion of the iPhone’s equivalent app

While Siri remains lamentably absent from 
OS X, you can use your Mac’s Enhanced 
Dictation feature – and either a double-press 
of a key or, thanks to a returning feature from 
Yosemite, a spoken key phrase to trigger it – 
to open and control Spotlight. Read on to 
find out how to do all of these things…

1>Move and resize
Spotlight’s window is no longer a fixed in 
size or position. First press ç+[Spacebar] 
to open Spotlight, then enter your request.
With some results shown, you can click 
and drag from the areas either side of the 
search field to reposition the window. 
The window can be resized from its top or 
bottom edge (remember that you can hold  
å to resize in both directions at once). 

2>Reset Spotlight
After you have repositioned it, the box 
will appear in the same place the next 
time you press ç+[Spacebar]. To reset 
the window’s size and position, click and 
hold on Spotlight’s icon in the menu bar.

3>Find files using 
natural language
Rather than using arcane syntax to 
restrict the kinds of files that Spotlight 
returns, the Mac’s built-in search engine is 
now smart enough to infer some meaning 
from what you enter. It can make sense of 
phrases like ‘photos from last week’ or 
‘messages to Kate’.

You can also express yourself this way 
in Mail. However, Apple only states that 
you can use natural language there and 
for file searches in Spotlight; you might 
find that you can use specific phrases in 
other contexts (see next step), but we’ve 
found that Spotlight isn’t quite intelligent 
enough to recognise simple variations.

4>Weather and other info
Weather, stock prices and sports fixtures 
and results are key categories that have 
been added to Spotlight’s search results. 
Just enter ‘weather’ to get a ten-day local 
forecast for your local area, or specify 
a location, such as ‘weather in Glasgow’. 
Spotlight isn’t so flexible here as it is for 
file searches; deviate too much and it 
won’t understand. It returns sports 
fixtures and match results when you type 
a team name, but only for American and 
Premier League football, basketball, ice 
hockey and baseball. To look up stock 
market information, enter the word ‘stock’ 
followed by a company name or its stock 
symbol – AAPL, BT or TSCO, for example.

Spotlight

GET STARTED  |   Hidden secrets
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5>Web video
Search results can include videos from 
the likes of YouTube, Vimeo and Vevo 
under the Web Videos category (but only 
if ’Allow Spotlight Suggestions…’ is on in 
Spotlight’s preferences). With one of these 
results selected, the video’s description, 
duration, date uploaded and number of 
views are displayed. Clicking the result 
takes you to the video in Safari. 

With so many different kinds of result 
shown in Spotlight, keyboard navigation 
can be more important than ever before. 
So, remember that holding ç when 
pressing the … or æ key jumps to the 
first result in the next category in the 
corresponding direction.

6>Speak your terms
The continued absence of Siri on the Mac 
is disappointing. A trick to smooth things 
over is to combine Spotlight’s natural 
language search with OS X’s Enhanced 
Dictation feature, so you can speak your 
search terms directly into Spotlight.
First turn on Enhanced Dictation in 
System Preferences > Dictation & Speech. 
When the required download completes, 
press ç+[Spacebar] to open Spotlight, 
and double-tap ƒ to open to open 
dictation. Speak your search terms and 
results will appear; you can keep saying 
words to refine them. Double-tap ƒ again 
to stop dictating and use Spotlight’s 
keyboard shortcuts to browse the results.

7>Voice control
Saying what you’re looking for isn’t the 
limit of using your voice to interact with 
Spotlight. El Capitan includes new 
Dictation Commands for navigating the 
Spotlight window. In System Preferences, 
go to Accessibility > Dictation > Dictation 
Commands and check the box labelled 
‘Enable advanced commands’. This adds 
additional commands to the Navigation 
category, for selecting the next or 
previous result, opening the one that’s 
selected, and for scrolling up and down 
through the preview shown on the right of 
Spotlight’s window. Click a command in 
this pane to see variations on the listed 
phrase that you can use instead.

Besides things like Maps, 
Spotlight now connects to  
more online data sources 
so it can find web videos, 
weather and sports results.

Hidden secrets  |   GET STARTED



E
l Capitan’s revised 
Notes app enables 
you to add almost any 
kind of file to your 

notes 8>. You can even add 
audio and video files directly 
inside a note, and play them 
back there too. 9> A neat trick 
is to record audio notes in 
QuickTime and attach them to 
notes. They show a play 
button, and they work on iOS.

The Attachments Browser 
enables you to view every file 
and piece of media you’ve 
attached to your notes. This 
makes it easy to find things 
visually. The browser’s tabs 
enable you to switch between 
viewing documents, photos 
and videos, sketches, maps, 
websites, and audio. 10> Click 
an item to select it and then 

press the spacebar to preview 
it in a Quick Look window, or 
double-click to open it in an 
appropriate app.

11> You can add a location 
directly from the Maps app to 
a note. Click the Share button 
then choose Notes. The Share 
sheet offers a choice of adding 
the location you’re looking at 
to a new note or an existing 
one. You can add items from 
many other apps from the 
Share menu too, including 
web pages from Safari, which 
display the page title, the site 
address, a two-line summary 
and an icon or an image from 
the page. The Quick Look and 
double-click shortcuts work on 
maps and websites, too. 

12> You can style the text in 
your notes using a range of  

predefined text styles: Title, 
Heading and Body, as well as 
three different types of lists: 
bulleted, numbered and 
dashed. These styles make the 
app a far more effective tool 
for structuring long notes, 
making them an easier read. 

13> Click the button that 
shows a tick in a circle and a 
circle will appear at the start of 
the paragraph you’re editing. 
This enables you to add a 
checklist of items, just like you 
can in Reminders. Each time 
you press ®, a new item is 
added to the list. To stop 
adding items, add an empty 
line and press ® once more.

One slight disappointment is 
the lack of sketch facility in the 
Mac version of Notes. In iOS 9 
you can draw sketches in 

Notes, but on OS X you can’t 
create or edit them; double-
clicking a sketch opens it in 
Preview as a non-editable 

14> Deleted notes are now 
moved to a Recently Deleted 
folder rather than being wiped 
immediately. You aren’t 
prompted to confirm ‘deletion’; 
pressing ∫ or the button that 
shows a trash can moves a 
note to Recently Deleted, from 
which it’s permanently deleted 
after 30 days. 15> Like in Mail, 
a long swipe left while the 
pointer is over a note in the list 
will delete it. 

16> If the ‘On My Mac’ 
account in the folder list is 
redudant for you because all 
of your notes are synced to 
iCloud, it can be hidden from 
Notes’ application menu.

A new look for Notes
Make notes that contain almost anything,  

including checklists, online research and voice memos

The ability to add files, 
links and checklists to the 
stock Notes app, and sync 
using iCloud, might tempt 
you back from Evernote.

GET STARTED  |   Hidden secrets
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S
plit View enhances full-screen 
apps by enabling you to display two 
apps side by side. Full-screen mode 
has always made sense on devices 

with small screens, like iPads and the MacBook 
Air, but its usefulness was less convincing on 
an iMac or other large display. Split View is 
designed to make it more practical on them as 
well, and it makes it much easier to work with 
two apps on any screen size.

Like full-screen mode for a single app, Split 
View hides the Dock and the menu bar, so you 
make use of all available space and remove 
many distractions. Rather than using a gesture 
to move back and forth between two full-
screen apps, Split View improves productivity; 
you might put a text editor on the left and Safari 
on the right when researching a subject.

There are multple ways to enable Split View. 
17> Click and hold the green button at the top-
left of any window that can be switched to full-

Split View multitasking
El Capitan makes full-screen mode more  

effective to assist your productivity

screen mode. You’ll notice half of the screen 
displays a blue overlay (which depends on 
which side of the screen the pointer is on). 
Move the pointer to the side on which you want 
that app to appear, then let go. Other windows 
that are capable of switching to full screen then 
appear in Mission Control fashion on the other 
side of the screen. Click one of them to set it as 
the other half of that Split View workspace.

18> If you already have one app in full-
screen mode, simply open Mission Control and 
drag a window from the centre over the Spaces 
bar at the top of the screen; when it expands to 
show previews of your spaces, drop the 
window onto an app that’s already in full-screen 
mode to combine the two in Split View mode.
See the page opposite for additional details of 
how Mission Control works in El Capitan. 

19> To take one app out of Split View, move 
the pointer to the top of the screen to reveal the 
menu bar and both apps’ title bars, then click 

the green button at the top-left of the title bar of 
the app you want to make a window again. 
The other app remains in full-screen mode. 

You can adjust the space dedicated to each 
app by placing the pointer over the dividing line 
between them, so the cursor changes to show 
either a single-headed or a double-headed 
arrow. Drag this left and right to adjust the 
space allocation 20> OS X automatically 
assigns what it thinks is a sensible split of the 
screen based on the apps you’ve combined. 
Whether you’ve adjusted the split yourself or 
you dislike OS X’s assumption, double-clicking 
the divider snaps to an even 50% split.

Irrespective of the apps you combine and the 
width of your display, Split View can display no 
more than two apps together.

The one sour note for Split View is that it 
requires apps to support full-screen mode. 
Older versions of Adobe apps and Microsoft 
software doesn’t support it.
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Window management
Managing windows and full-screen apps is easier than ever  

with El Capitan’s enhanced version of Mission Control

El Capitan

Yosemite

Mission Control in Yosemite (top) cascades windows from the same app together. In El Capitan (bottom), 
every window gets a full preview. The Spaces bar has also been reduced to give more space to app previews.

A
pple has reintroduced a more 
helpful layout as a default setting 
for Mission Control. Windows are 
now spread out, with no overlaps, 

rather than stacked up according to the app 
they belong to, making it easier to find the 
one you want. 21> You can return to having 
windows stacked up (Yosemite’s default) by 
turning on ‘Group windows by application’ in  
System Preferences > Mission Control.

22> A new gesture for opening Mission 
Control cuts the number of steps for moving 
a window to a new space; try dragging it 
past the top of the screen.

The Spaces bar at the top of the screen 
has changed to initially display only the 
names of your desktops and full-screen 
apps. This gives more space for the window 
previews below. Moving the pointer up to the 
top of the screen reveals graphical previews 
of each space, as does dragging a window.

As in previous versions of OS X, dropping 
a window onto another desktop moves it 

there. However, there are subtle changes to 
what happens when you drop a window onto 
empty spaces or full-screen apps in the bar.  
23> Previously, dropping a window onto an 
empty area would make a new desktop and 
move it there. Now you must explicitly drag it 
to the space that slides in at the right of the 
bar, marked with a +, because El Capitan 
reserves the empty areas for another 
purpose. 24> Drag a window belonging to 
an app that supports full-screen mode over 
an empty part of the bar and a new space 
named after that app to appear, then let go 
to switch the window to full-screen mode.

Similar actions work as a shortcut to Split 
View. 25> Merge two apps by dragging a 
window or an app that’s already in full-screen 
mode onto another full-screen app in the 
Spaces bar. As before, placing the pointer 
over a space and click either the cross down 
Control enables you to remove Spaces from 
Mission Control. Any windows that are in that 
space are moved to their previous desktop.

26>Split apart apps
Holding down the å key while the pointer 
is hovering over the Spaces bar at the top 
of Mission Control reveals a close icon for 
each space (as it did in earlier versions of 
OS X). Apps that are in full-screen mode 
or Split View display two arrows pointing 
towards each other; when clicked, those 
apps are switched back to being windows 
on the desktop on which they originated.
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M
any of Mail’s new features are 
focussed on make working it 
more practical to work with in 
full-screen mode, especially 

when composing messages.
New messages are still created in a panel 

that’s displayed in the middle of the screen, 
but you no longer have to save the message 
as a draft before you can look at other 
messages. 27> However, clicking outside of 
the pane now causes it to slide out of the 
way to the bottom of the screen. Click on 
the small bar down there to bring the 
composition panel back into view. This is 
more convenient for copying and pasting text 
or dragging attachments from one message 
into a new one.

It isn’t just Mail’s main window that can be 
made to take over the whole screen. 28> 
Any message window can be switched to full 
screen from its green button, enabling you to 
compose a message on one side of the 
screen and refer to something else – even an 
other message – on the other in Split View.

You can also have several part-composed 
messages on the go, without having to save 
them as drafts. 29> Each time you create a 
new message (by pressing ç+N or clicking 
the corresponding button in the toolbar), 
a new tab is added to the pane. Rather than 

Swiping to manage messages, full-screen flexibility,  
and multiple message tabs make Mail effective than ever

reach for your mouse or trackpad, you can 
switch tabs using ß+ç+[ and ß+ç+].

Managing unread messages is easier with 
gestures that have worked their way across 
from iOS to OS X. 30> Swipe to the right 
while the pointer is over a message in a 
mailbox’s list to mark it as unread, or swipe 
to the left to trash or archive it. Do this with 
two fingers on a trackpad, or one finger on 
a Magic Mouse. 31> If you prefer to archive 
mail, the latter gesture can be switched from 
Trash to Archive in Mail > Preferences > 
Viewing > Swipe Left To.

32> Mail inspects incoming messages for 
contacts and events to add to your calendar. 
If someone emails you with information about 
an event, Mail will search for details (time, 

date, location, and so on) and suggests that 
you add it to Calendar. 33> Similarly, it looks 
for new contact information, filling out phone 
numbers, emails and addresses for people 
in your contacts (and suggests when to 
create a new contact record). In both 
instances, you’ll see a prompt at the top of 
the message. Click the blue ‘add…’ word at 
the right of that row to add or update an item 
in the related app.

34> One small addition that’s easily  
overlooked is the strikethrough button in 
Mail’s Format bar (which is revealed by 
clicking the ‘A’ button in the toolbar), rather 
than having to open OS X’s built-in Fonts 
window. This is helpful for indicating changes 
or suggestions when collaborating on text.

Multi-Touch gestures 
make it much easier 
to quickly clear out 
unwanted messages.

Messaging with Mail
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Power up Photos
Your photo library and editor packs more  

punch with third-party extensions and geotagging

35>Extensions
Photos’ editing capabilities take a big step forward with support 
for extensions, which enable third-party developers to make 
image-editing tools from their own apps available inside Photos 
(much like on iOS). This saves you exporting an image, editing it 
elsewhere, and bringing it back into Photos. Open a photo and 
click Edit > Extensions > More to view those available on your 
Mac. Extensions are bundled with apps from the Mac App Store.

37>Manually attach locations
One of the great things about snapping photos with an iPhone is 
geolocation tagging, which lets you know where photos were 
taken. Photos now enables you to manually attach location data 
to photos that lack it, and modify it on those that do. Select an 
image and open the Info window (ç+I) and you’ll see a row 
labelled Assign a Location at the bottom of it. Type a place name 
or postcode and pick one from the app’s suggested matches.

36>Faces and Selfies and Screenshots
Faces has an improved interface. Click Albums > Faces and you 
can now select multiple photos (holding ç to build a selection) 
and then drag them onto a face in the middle of the screen to 
identify all of them as being that person in one fell swoop. This 
greatly speeds up how quickly you can name people that the 
app identifies in your photos, and in the process you more 
quickly guide its identifications in the future.

38>Batch renaming
In Yosemite, the app’s Info window only enabled keywords to 
be set on multiple photos at once, but in Photos 1.1 you can 
simultaneously add the same title, description and, of course, 
location data for all photos in your selection. If you then choose 
to export photos that have the same title using that title as their 
filename, those past the first one will have a number in brackets 
appended to their name.
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Surfing with Safari
Silence noisy sites, stream online video to  

Apple TV, pin open important sites and much more!

CCCoommppppaattiibbllee wweebb vviiddeeooss 
ccccccccccccaaaaaaaaaaaannnnnnnnnnnn bbbbbbbbbbbbbbeeeeeeeeeeee ssssssssssssttttttttttttttrrrrrrrrrrrreeeeeeeeeeeeaaaaaaaaaaaammmmmmmmmmmmeeeeeeeeeeeedddddddddddddd ttttttttttttttoooooooooooo 
aaaaaaannnnnnn AAAAAAAAAApppppppppppppppppppplllllllllleeeeeee TTTTTTTTTTVVVVVVVVVV wwwwwwwiiiiiiiiiittttttttthhhhhhhhhhooooooouuuuuuuttttttttt 
mmmmmmmmiiiiiiiiiirrrrrrrrrrrrrrrroooooooorrrrrrrriiiiiiiiiinnnnnnnngggggggg tttttttttthhhhhhhhhheeeeeeee wwwwwwwwhhhhhhhhhhoooooooolllllllllleeeeeeee 
of your Mac’s display

W
e spend more time in Safari 
than most other apps, so it’s 
fitting that Apple’s web browser 
has received more new features 

than other app in El Capitan.
Probably the most welcome addition is the 

ability to mute the audio content from a 
website. Sites are increasingly auto-playing 
video and having the accompanying audio 
(usually an advert) blasting out from your Mac 
is excruciatingly annoying. Any tab that is 
playing audio displays a blue speaker icon in 
the Smart Search field – filled in when the 
audio is coming from the current tab, and an 
outline when it’s from another tab. 39> Click 
this blue icon and the sound from the current 
tab will be muted. Hold å when clicking it to 
mute all other tabs. Be aware that muting 
audio does not stop the video portion playing.

40> If you have multiple tabs open, a small 
black audio icon appears on the right-hand 
side of any that’s playing audio. Clicking one 
of these mutes that specific tab, or you can 
hold å while clicking to mute all other tabs. 
41> Hold ≈ and click a tab’s speaker icon to 
see the same options to mute that tab/others, 
and the titles of all tabs that are playing audio; 
42> you can click one of these titles to jump 
straight to that tab.

Safari goes further in improving how you 
interact with online media. AirPlay Video lets 
you stream video content to an Apple TV 
without having to mirror the whole of your 
Mac’s display. 43> Compatible video on a 
website displays an AirPlay icon to the right of 
its volume control. Clicking this lists AirPlay 
video receivers on your network and selecting 

one (typically an Apple TV) sends the video 
directly to your television.

Safari’s Reader feature, which presents a 
clean view of only the text and images that are 
the real content of a page, offers presentation 
settings beyond resizable text. 44> Open 
Reader by clicking the paragraph icon at the 
left of the Smart Search field when viewing a 
suitable page, then click the AA icon on the 
field’s right side to open Reader’s appearance 
settings, which include four background 
colours (white, sepia, grey and black), eight 
fonts, and the old font size adjustment options.

Pinned Sites gives you quick access to sites 
you use often. 45> Pinning a site couldn’t be 
easier: choose Window > Pin Tab, or click on a 
tab’s title and drag it to the left of the tab, or 
≈-click a tab and choose Pin Tab. The tab 
becomes a small square on the left side of the 
tab bar, showing only a site icon. They remain 
open when you close and reopen Safari, and 
the sites in them run in the background, so 
you’ll hear sounds such as message alerts.

Some of Safari’s keyboard shortcuts have 
changed. Previously, ç+1, ç+2 and so 

on opened bookmarks from corresponding 
positions in the Favorites Bar. 46> These 
shortcuts now switch between tabs you have 
open, including pinned ones. 47> Now, also 
holding down å loads an item from the 
Favorites Bar (even if the bar is hidden).  
48> These two sets of shortcuts can be 
reversed by turning off ‘Use ç-1 through ç-9 
to switch tabs’ in Safari > Preferences > Tabs.

49> Extensions now require developers 
to be part of the paid-for Apple Developer 
program, the upsides being that their code 
must be signed by Apple for security, and they 
can update themselves as long as Safari > 
Preferences > Extensions > Automatically 
update… is enabled. 

At long last, Safari catches up with other browsers with the inclusion of speaker icons in its Smart Search 
field and on tabs that enable you to mute sites that are making a racket in the background.

Reader is more flexible than before in how pages are 
presented, offering you a choice of page colours and 
fonts in addition to an adjustable text size.
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E
l Capitan may not have had a radical 
refresh, but it contains plenty of 
interesting and practical tweaks that 
improve your time spent using it.

50> One that we adore is that you can 
quickly locate the pointer just by shaking it. This 
enlarges it temporarily to help you spot it on a 
busy or large desktop. If you find it annoying, 
perhaps because you fidget with your mouse 
or trackpad, the behaviour can be disabled by 
turning off ‘Shake mouse pointer to locate’ in 
System Preferences > Accessibility > Display.

51> If you previously used Yosemite and 
turned on its option to reduce transparency 
effects, consider turning it back off again (in 
the Accessibility pane, under Display). Many 
of the more objectionable instances of it have 
been toned down, such as text scrolling 
behind semi-opaque foreground elements, 
which affected legibility.

52> Invaluable on small displays is the 
ability to hide the menu bar until you need it, 
just like you’ve been able to do with the 

Practical pointers
It’s the little things that make El Capitan sing.  

Here are the under-the-hood tweaks to investigate

Dock for years. You can enable this in 
System Preferences > General.

53> The Share menu has gained actions 
to add what you’re looking at to Reminders or 
Notes. If you can’t see these options, click on 
Share > More and ensure that they’re checked. 
They’re handy for keeping track of web pages 
as part of research notes, to remind you about 
things like event tickets going on sale, and you 
can add copies of documents from Pages, 
Numbers and Keynote to your notes, too. Note 
that the first time you open Notes you’ll be 
asked to upgrade to a new format for storing 
them in iCloud; only do this if all your devices 
are able to run El Capitan or iOS 9.

54> The fake clicking noise that Force 
Touch trackpads make by turning on Silent 
Clicking in the Trackpad preferences pane.

55> A Find My Friends widget can be 
added to Notification Centre’s Today view. Click 
Edit at the bottom of that view and then click 
the plus in a green circle next to the widget. 
Find My Friends will display a location warning; 

tap Allow to enable it to use your current 
location. You might find this useful to know, say, 
when to set out to pick up family or friends.

56> Safari now lets you clear your browsing 
history in a less disruptive fashion. Open either 
its application menu or the History menu and 
then hold å to append “…and Keep Website 
Data” to the option that covers your tracks. This 
preserves cookies, which might contain settings 
for web apps, for example.

57> It’s easier to manage your downloads 
on the fly now, rather than ending up with a 
burgeoning folder full of them. Open Safari’s 
General preferences, click the pop-up menu 
labelled ‘File download location’ and choose 
‘Ask for each download’.

58> In OS X’s colour picker (accessible 
in apps such as TextEdit using ç+ß+C), 
the Crayons tab is replaced with a Pencils tab 
with a broader selection of colours. With text 
selected, the appropriate pencil pops up out 
of the arrangement to remind you which colour 
you applied to it.

1What is it? 
Two-factor authentication is a new 

security system from Apple. It’s similar to 
two-step authentication, but easier to use 
because codes are sent directly to your 
devices (rather than as an SMS text 
message). It also doesn’t require users to 
print out, and safely store, a super-secret 
emergency key (previously, this caused 
problems for people who lost them). It also 
makes it possible for Apple to help you to 
recover your account if you completely forget 
your password and lose all your devices.

2 How to set it up 
Two-factor authentication is being rolled 

out by Apple to users in stages, so you don’t 
sign up for it. Instead, it’ll be offered to you 
during setup. If you’ve already configured it, 
then you can check your status by choosing 
System Preferences > iCloud > Account 
Details > Security. To turn on two-factor 
authentication you must give Apple at least 
one phone number. In fact, it’s best to  
provide Apple with a second number as a 
backup, in case you lose (or change) your 
phone number down the line.

3 Manage your devices 
With two-factor authentication set up, 

a six digit code is sent to your other devices 
(running El Capitan or iOS 9) when you try to 
log on to Apple services when you enter your 
password to use a service such as iCloud, 
or buy from the iTunes or App Stores. Enter 
the code to confirm that you actually made 
the request. This way, even if somebody 
hacks your passcode they still can’t log on 
to your account. Manage your trusted 
devices in System Preferences > iCloud > 
Account Details > Devices.

59> How to set up two-factor authentication

GET STARTED  |   Hidden secrets



E
ven Finder has a few new features. 
One feature that will be welcome if 
you’re not used to the fairly subtle 
convention of selecting a file or folder 

and then clicking its name or pressing ® to 
rename it is 60> the addition of a Rename 
option to the contextual menu that appears 
when you ≈-click the item instead.

If you use Terminal or programming tools in 
which you need to refer to a file or folder, typing 
the whole path to it is tedious and prone to 
error, but you don’t have to run the risk. 61> 
Instead, ≈-click the item and then hold down 
å; you’ll notice that the usual Copy command 
in the menu changes to ‘Copy <Item> as 
Pathname’. With Terminal, you could already 
preview achieve this by dragging an item onto 
its window to insert its path into the command 
line, but the ability to copy it to the Clipboard 
provides greater flexibility over what you do with 
that information – and it’s also easier than 
dragging a file from one space into another if 
you prefer to run Terminal in full-screen mode.

Finder
Your file management app now makes it 

easier to work in the cloud

Yosemite already puts 
progress bars on each file 
being synced with iCloud 
Drive. However, you might 
find yourself saving not just 
the odd small document 
now and then, but much 
larger amounts of data 
between your Macs and 
possibly iOS devices too.

62> To be sure that 
syncing activity between your Mac and iCloud 
Drive has completed, Finder’s sidebar displays 
a circle next to iCloud Drive (if you’ve removed 
it, go to Finder > Preferences > Sidebar to get it 
back) which gradually fills to reflect progress. 
This is helpful if, say, you need to get some files 
onto a MacBook before departing. Open up a 
Finder window, watch the progress indicator 
and only close the lid once the circle 
disappears, telling you the sync is complete.

With an especially large amount of data 
transferring to or from iCloud Drive, the circle in 

the sidebar might fill pretty slowly. So, Finder 
has a second, more detailed progress indicator 
avaiilable. 63> Turn on its path bar (View > 
Show Path Bar) and then browse to iCloud 
Drive (Go > iCloud Drive). At the bottom of the 
Finder window you’ll see an indication of how 
many items are being copied, the total amount 
of data being copied, and an updating total of 
how much has copied across so far. Note that 
the figure to the left that shows remaining 
capacity isn’t indicative of your iCloud Drive 
space; that’s referring to your Mac’s free space.

Disk Utility
Disk Utility has a new, more 
approachable look, though 
features such as writing a disk 
image or folder to a CD or 
DVD have been dropped.
64> Its left-hand pane now 
categorises disks as internal, 
external and disk images, 
reducing the chance you’ll 
mistake, say, an SD card and 
a USB flash drive of the same 
size and erase the wrong one.

65> The right-hand pane is 
now purely informational, 
showing details of whatever 
you’ve selected on the left in a 
colour-coded breakdown of its 
contents, much like the one 
for iPods and iOS devices 
connected to iTunes.

Operations are now invoked 
solely from button in the 
toolbar. Some will be greyed 
out, indicating they’re not 

applicable to your selection 
on the left. 66> First Aid is 
equivalent to Repair Disk in 
older versions, checking for 
low-level structural issues. The 
option to repair permissions is 
gone because El Capitan is 
supposed to check and repair 
them silently for you.

67> The Partition feature 
now shows a disk’s structure 
as a pie chart. The order of 
partitions on a disk starts 
from top-centre and works 
clockwise around the chart. 
When partitioning a disk, 
the app will split whichever is 
selected (blue after you click 
it) when you click the + button.

68> If you need to restore 
the contents of a disk from an 
image, or another drive, that 
option is still available – but in 
the Edit menu, not Images.

El Capitan’s version of Finder makes it much clearer when files are being 
synced to or from iCloud – right down to the last megabyte.
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F
or all the improvements each version 
of OS X brings, there’s always room 
for improvement – whether that’s in 
options for putting notifications in an 

order that works for you, protecting your 
Mac App Store account against accidental 
purchases, or assuring you that the website 
you’re designing will look great on computers 
and mobile devices alike. El Capitan takes 
steps to make existing features work better.

69> iBooks has the same presentation 
options as Safari Reader. You can set the page 
background to white, sepia, grey or black, each 
with complementary but automatically-chosen 
font colours, and select from eight fonts, 
including Apple’s new San Francisco font that’s 
used throughout OS X, iOS and watchOS.

Whether you’re a parent or simply concerned 
about making accidental purchases from the 
Mac App Store, 70> open the App Store pane 
in System Preferences and look at the bottom 
of it to find new password settings that define 
how soon after making a purchase – and 
entering your password – the Mac App Store 
will request your password for subsequent 
purchases – immediately or only after 15 
minutes. Free downloads can require your 
password every time, or not at all.

71> Traditionally, OS X would ‘zoom’ a 
window to a best fit for its content when you 
double-clicked the window’s title bar. More 
recently, that action has minimised windows 
into the Dock – a sensible change for anyone 
coming from Windows, which also behaves 

The little things
We’re still not done yet! These last few tips alone 

reveal even more of El Capitan's greatness

that way. In fact, Yosemite gave a choice of 
these two behaviours, but as a checkbox that 
made it unclear to inexperienced Mac users 
what behaviour – if any – you would get when 
the box was unchecked. Apple has cleared up 
this ambiguity with a pop-up menu that 
explicitly lists the zoom and minimize options.

72> Notification Centre now offers three 
sorting options, up from two in Yosemite. The 
first setting, Recents, puts your notifications in 
reverse chronological order from the top of the 
tab down. The second one, Recents by App, 
groups notifications by application, so when 
you receive a notification from Mail, say, all of 
that app’s items move to the top of the list, 
even if that means some newer notifications 
from other apps will appear below Mail’s. The 
third setting, Manually by App, groups items 
similarly to the second one. However, when this 
option is selected, apps in the list shown in the 
Notifications preferences pane can be dragged 
up and down the list to set the order in which 
they’re listed in Notification Centre. So, you can 
set Calendar or Reminders, say, to always 
appear at the top so you don’t miss anything.

73> Image Capture includes a new feature 

that helps to organise photos imported from 
multiple cameras, rather than dumping them 
into one folder. Connect a camera to your Mac 
and then click the Import To pop-up menu near 
the bottom of the app’s window, then select 
‘Make subfolders per camera’ to create folders 
named after your camera or its storage card.

74> Maps can now provide directions that 
use public transport, though only in a few cities. 
Choose which vehicles are included in route 
suggestions under View > Transit Driections.

75> If you design web pages, you’ll want 
to enable Safari’s Develop menu (from its 
Advanced preferences) and then choose 
Responsive Design Mode from that menu. 
This feature is intended to help ensure your 
pages look good on mobile devices as well 
as large displays like your Mac‘s. It places 
controls above the page you’re viewing that 
enable you to switch to various screen 
resolutions and iOS devices, then choose 
Responsive Design Mode from it to reveal 
controls that show how the current page will 
look on various screen resolutions and iOS 
devices. Switch between landscape and 
portrait orientations by clicking the device icons.

Switch Maps to its Transit view, then zoom out a long way and look for blue transit badges on cities in which 
the app can suggest routes that use bus, subway and light rail, commuter rail and ferry services.

Notification Center now provides three options for 
sorting your notifications: Recents, Recents by App, 
and Manually by App.
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When you first switch on a 
brand new Mac, there are 
a few steps to go through 
before you can get going 

with it. For starters, you’ll need to 
personalise your Mac, and optionally 
connect it to the internet and Apple’s 
iCloud service. The Setup Assistant 
guides you through these important 
steps in just a few minutes.

You’ll need to confirm the language 
you want to use and verify your keyboard 

layout. The latter of these steps is 
especially important if you aren’t using 
an Apple keyboard, which is most likely 
if you’ve moved to the Mac from a 
Windows PC and kept your existing 
mouse and keyboard.

User accounts
You’ll also create an administrator 
account and assign a password to it. 
The password is important because it 
protects access to your Mac’s contents 
and the ability to make major changes to 
it. There’s nothing to stop you using this 
account as your own, but it’s better for 
security if you create a second account 

for personal use and set its account type 
to Standard. This account, and others for 
your whole family, can be created after 
you’ve finished the Setup Assistant’s steps 
and reached the desktop. These options 
can be altered later, should you go astray 
or change your mind (see page 79). You 
also get an option to register your Mac 
with Apple, but this isn’t compulsory. 

Migrating
If you’ve been using a Windows PC or 
another Mac, the Setup Assistant gives 
you an opportunity to transfer data from 
the old machine. This includes your files, 
Mac apps, stored email messages and 
personal settings. 

If you use an Apple trackpad or Magic 
Mouse, the direction in which you move 
a finger to scroll differs from a Windows 
PC. However, this can be reversed after 
the Setup Assistant completes its job. 
If you need help with this and other 
gestures that help you to get around 
in OS X, turn to page 50.

Set up your new Mac
If you’ve got a new Mac, here’s how to get started with it

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11

It’s good security 
practice to create 
a second ‘Standard’ 
account for personal 
day-to-day use

1 Confirm your country and keyboard
First, specify your country, then click Continue. Your country 

determines the keyboard layouts offered on the next page. Choosing the 
correct layout on that page is important if you’ve connected a keyboard 
that isn’t from Apple or has a non-standard layout. If your keyboard layout 
isn’t shown – perhaps you’re using a Welsh keyboard – tick Show All under 
the list of layouts.

2 Connect to a network
You’ll next see a list of nearby Wi-Fi networks. Click yours, provide 

its password and click Continue. If your network isn’t listed, perhaps 
because it’s set to not broadcast its name, choose Other to provide its 
name manually. You might need to scroll down the list to see this option. 
If you’re using an Ethernet cable or don’t want to go online, click Other 
Network Options, choose the appropriate option, then click Continue.

HOW TO | SET UP YOUR NEW MAC IN MINUTES

When setting up your Mac, you’ll be asked whether to 
connect it to your Apple ID, or create a new one. This is 
not mandatory, but many of 
Apple’s services depend on Apple 
ID. The most notable is iCloud, 
which synchronises your 
calendars, contacts and other data 
between your Mac, iPhone and 
iPad. Find out more on page 76.

About Apple ID
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5 Create an administrator account
Accept terms and conditions for OS X and iCloud, then create an 

admin account. This is needed to make changes such as security settings. 
It can use the your Apple ID’s credentials or different ones. Click Continue 
and, if you signed into iCloud, choose whether to use iCloud Keychain, 
and then set whether diagnostics info is shared with Apple and app 
developers. This can be revised in Security & Privacy preferences.

3 Migrate from an old computer
The next page asks if you want to transfer information from your 

old Mac – either directly or from a Time Machine backup of it – or from a 
Windows PC. Even if you have an old computer, you don’t need to do this 
now. It can be done later by running the Migration Assistant utility. See 
page 34 for instructions on how to use it to with an old Mac, or page 36 
to transfer data from a Windows PC. Click Continue to proceed.

6 Register your Mac
The final step is to register your Mac with Apple by providing your 

address and other contact details. Again, this is entirely optional. When 
you advance past this, the Setup Assistant might take a few minutes to 
do some last-minute work behind the scenes. When it’s finished, the 
desktop will fade into view. Now the fun begins. If you’re new to Macs or 
unfamiliar with El Capitan, you’ll find a tour of the desktop on page 42.

4 Sign in with your Apple ID
You’ll be asked whether to enable Location Services, and then 

whether to sign in with an Apple ID. This is recommended: it enables data 
to be synced between your Mac and other devices over the internet using 
Apple’s iCloud service, and to use Find My Mac, which can locate a missing 
Mac (see page 76). You might already have an Apple ID for buying from 
the iTunes or App Stores, or you can create one here if you don’t have one.

Although the Setup Assistant offers to 
transfer your data from another computer  
– either an old Mac or its Time Machine 
backup, or a Windows PC – this doesn’t 
have to be done at this stage. The Migration 
Assistant is available at the desktop to 
perform the transfer later on. To locate this 
tool, click the Finder’s icon in the Dock, then 
press ç+ß+u to open the Utilities 

folder, where it is located. Simply double-
click the Migration Assistant icon to open it.
 Migrating your data can be done via 
a hard drive or a network or direct cable 
connection. Pages 34 to 37 show you how 
to use the Migration Assistant in two 
circumstances: if you’re upgrading from a 
previous Mac or migrating from a Windows 
PC. If the latter scenario applies to you, visit 

support.apple.com/kb/DL1557 in your PC’s 
web browser to download the Windows 
Migration Assistant, which needs to be 
running to perform the migration.
 Of course you’ll need to run the Migration 
Assistant only once, but remember that you 
can call upon its services again if you 
upgrade from your current Mac to a newer 
model at any time in the future.

Using the Migration Assistant
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Here’s how to ensure your settings and data move with you

Migrate from an old Mac

1

2

3

4

5

It’s an idea to have 
an up-to-date Time 

Machine backup on 
a removable disk 

before you start

You can upgrade to OS X 
El Capitan on Macs from as 
far back as 2007 – see 
http://bit.ly/1z2xzld for the 

full supported list. In terms of software, 
you’ll need to be running at least OS X 
10.6 (Snow Leopard) – if you’re still 
running 10.5 (Leopard), then you’ll first 
have to buy an upgrade to 10.6 and 
install it before you can move to 
El Capitan (which itself is free). You’ll 
also need an Apple ID to download the 
upgrade from the Mac App Store.
 In theory, all your settings and data 
will be preserved when you migrate. 
However, because theory and practice 

sometimes differ, it’s a good idea to 
ensure that you have an up-to-date 
Time Machine backup on an external 
drive or removable disk before you start 
(see page 156). If your Mac is set up to 
make regular backups, then all you need 
to do is check when the last successful 
one ran. Click the Time Machine status 
icon in the menu bar and choose Open 
Time Machine Preferences. If the latest 
backup is older than today, run a new 
one; if your settings get wiped when 
upgrading, you’ll then be able to 
restore them from this backup.

Get the updates
You’ll also need to ensure that the most 
recent OS X updates are installed so that 
you can access the App Store, because 
this is the only way to get an El Capitan 
upgrade. Note that the update process 
will be different depending on whether 
you’re updating from 10.9, 10.8, 10.7 or 
10.6. In 10.6 Snow Leopard, go to the  
menu, select Software Update and wait 

while it checks for new software. Once 
updates have been identified, choose 
Show Details to see which ones are 
available – see the annotation below 
for help. To save some time, you can 
opt to install only the Mac OS X Update 
Combined. Once all applicable updates 
have been downloaded and installed, 
you may need to restart your Mac.

Then, once you’ve made sure there’s 
a recent backup in place, go to the  
menu, then open the App Store to 
get and install El Capitan. In OS X 10.9, 
10.8 and 10.7, Click on the Featured tab 
and look for ‘OS X El Capitan’ a little way 
down under Quick Links on the right.

In the guide opposite we’ll show you 
how to migrate data from another Mac, 
by connecting the two via a network 
cable. This might not be useful to you 
now, if you’ve got just the one Mac, but 
in the future when you upgrade to a 
new machine, you can use this method 
to transfer your data and ensure that 
nothing vital is overlooked.

SKILL LEVEL
Anyone can do it

IT WILL TAKE
1 hour

YOU’LL NEED
OS X 10.11, Time 
Machine backup 

on disk

VISUAL GUIDE | UPDATING TO EL CAPITAN FROM SNOW LEOPARD

Software Update

1  Open the  menu and select 

Software Update. This will 

check for relevant updates. 

Available software

2  Click Show Details to see the 

available updates. You can click 

on each one to see more details. 

Select items

3  Use the tickboxes to choose which 

updates to install, or just select 

Mac OS X Update Combined. 

Update details

4  This pane includes detailed info about 

the currently selected update. You 

may need to agree to some terms to go on.

Install Updates

5  Click the Install button to begin 

downloading and installing 

your selected updates.
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HOW TO | USE THE MIGRATION ASSISTANT

Run on the old Mac

1 Open Utilities 
To migrate data you need either a Time 

Machine backup on a removable disk or an 
older Mac connected to your new one with 
El Capitan already on it. Once you have your 
backup connected, open Applications and 
scroll through to the Utilities folder.

4 Migration method
If you’re migrating from a networked 

Mac, choose ‘From another Mac or PC’. While 
Migration Assistant displays ‘Looking for other 
PCs’, run the Assistant on the source Mac, 
choose ‘To another Mac’ and click Continue. 
Check the passcode on both Macs is the same.

5 Items to migrate 
Whichever way you migrate, you need to 

quit other apps and programs on any machine 
running the Migration Assistant. Click Continue 
again. On the target Mac, the Assistant displays 
a list of items that can be migrated – user 
settings, applications, files and folders. 

2 Migration Assistant
Within Utilities, find and launch Migration 

Assistant. You’ll need to prevent the computer 
from going to sleep during a potentially lengthy 
migration: from the  menu, choose System 
Preferences > Energy Saver and slide the 
Computer sleep fader to the Never position.

6 Perform the migration
In the list, select the items that you want 

to migrate by ticking or unticking the boxes 
next to them. To view smaller items within a 
group, click the arrow next to the group. Click 
Continue to begin the process of migrating the 
data. How long this takes will depend on the 
amount of data selected and the connection 
method you’re using. Obviously, using a 
physically-connected disk will be the fastest 
method; if you’re connecting over a wireless 
network, the transfer will be a lot slower than 
over a Thunderbolt or FireWire cable. Once the 
transfer has completed, migrated users will have 
their own Home folders on the target Mac. To 
check that settings and documents for a 
particular user have migrated successfully, 
log out and log back in as that user.

3 Migration type
The simplest migration works using a 

Time Machine backup on a connected external 
disk. On the destination Mac, choose ‘From 
another Mac, PC, Time Machine Backup or 
other disk’ and click Continue. Select the disk 
that the backup is on and click Continue again.

If migrating between two connected 
Macs (via a network or cable), you’ll 

need to run Migration Assistant on the 
source Mac. Assuming you’ve applied 
the latest updates, go to Applications 

> Utilities > Migration Assistant. 
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When you’ve decided to 
migrate from a Windows PC 
to a Mac, it’s important to 
make sure all your settings 

and precious data move from one to 
the other as smoothly as possible. OS X 
El Capitan includes a Migration Assistant 
designed to handle the various knotty 
problems that such a transfer can entail.

It’s not just a matter of picking up all 
your documents and other files from one 
computer and dropping them onto the 
other (though that will work fine for 
many files – see the box below). There 

are numerous types of data involved, 
many of which need to be converted or 
imported into new programs to work 
properly. For example, the Migration 
Assistant takes all your email from 
Outlook, Outlook Express, Windows Mail 
or Windows Live Mail and imports it into 

the Mail program on your Mac. It not 
only takes all the messages but also 
additional information about them, such 
as whether they’ve been read, flagged, 
forwarded or replied to. 

Email’s not the only difficult transfer 
to deal with. All contacts from Outlook, 
Outlook Express or Windows Contacts 
get imported into the Contacts app. 

Calendars from Outlook are transferred 
to Calendar. All iTunes libraries are fully 
transferred; your bookmarks from the 
most popular Windows browsers are 
transferred to Safari. Any custom user 
details, such as your display picture, 
location and keyboard settings are 
also moved to the right place.

Windows Migration Assistant can 
do this for every user account on your 
Windows PC. It isn’t possible, however, 
to merge an imported account with an 
existing account set up on your Mac. 
Each imported one needs to go into 
a new account, which is why it’s best 
to use the Migration Assistant when 
you first set up your Mac.

You can do this by choosing ‘From a 
Windows PC’ in the Setup Assistant that 
appears when you first turn on your Mac. 
However, you can also launch Migration 
Assistant at any time from the Utilities 
folder. Note that your Mac and Windows 
PC need to be connected to the same 
network for the Assistant to work.

Migrate from Windows
Use Windows Migration Assistant to move files to your new Mac

SKILL LEVEL
Taking things further

IT WILL TAKE
2 to 4 hours

YOU’LL NEED
OS X 10.11, a Windows 
PC connected to the 

same network

It’s not just a matter 
of picking up files 
from one computer 
and dropping them 
onto the other 

HOW TO | MIGRATE FROM WINDOWS

Transferring large amounts of data over a network can 
be a very time-consuming process. Consider moving big 
files like photos and videos using an external USB drive, 
which is usually much quicker than doing so over a 
network connection. Then use the Migration Assistant 
to transfer settings and other kinds of data that are 
more difficult to find and move manually.

Minimise moving time

1 Install Windows Migration Assistant
Start at your existing Windows computer. Download Windows 

Migration Assistant from http://support.apple.com/kb/DL1557. Once 
it’s downloaded, launch the file and follow the instructions to get it 
installed. Once that’s done, the tool will open. You may need to give 
permission for the Migration Assistant to proceed, depending on the 
version of Windows that you’re using and your security settings.

2 Make contact
Once the Migration Assistant starts, you’ll see a simple window 

explaining what it does. The assistant collects information from your 
Windows PC, including your account settings, personal files and emails, 
so that you can transfer them all to your Mac. Both computers need to 
be connected to the same network for it to work, and they’ll begin the 
process by contacting each other.
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Before you begin using the Windows 
Migration Assistant, it’s worth ensuring 
that you have both your Mac and your 
PC set up to their best advantage. A little 
advance preparation can help ensure 
that you don’t encounter any hiccups 
or bottlenecks down the line.

On your Windows computer, make sure 
you have a backup of your data, and keep 

this in a safe place in case of any gremlins 
at any later point. Now remove any files 
that you definitely won’t want to migrate. 
This advance filtering will save you a lot of 
time when transferring the data that you 
do want to move. Also, if you have time, 
consider defragmenting the drive in the 
Windows computer so that the data is 
quickly available. Where possible, try to 

connect your computers to a wired network 
instead of a wireless one – you’ll find that 
the performance is considerably better and 
this will ensure that your data transfers as 
quickly as possible.

These simple steps could shave some 
considerable time off the migration process, 
which can be very lengthy even with the 
minimum of data to move across. 

Preparing for migration

5 Select your system
As long as your PC is still running the Windows Migration Assistant 

and both computers are on the same network, your Mac should find and 
display it. Click Continue to confirm that this is the PC you want to migrate 
from. The program generates a six-figure code, which is displayed on your 
Mac. Go back to your PC and check that the number displayed is the 
same. Now click Continue on the PC.

3 Call the Mac
Click Continue to start the Migration Assistant in Windows. It will 

begin polling the local network to contact any local Mac that’s running 
the Mac version of the assistant. Until this contact has been made, the 
Windows portion of the program can go no further, so it’s time to move 
over to your Mac. If you’re setting it up for the first time, look out for the 
appropriate step of the Setup Assistant.

6 Select items
Back at the Mac, click Continue. You’ll now see a list of the accounts 

available on the PC. Select those you want to migrate. Also choose items 
within the selected accounts that you want transferred (click the triangle 
next to an account’s name if you can’t see them). Click Continue. Both the 
PC and the Mac will display progress bars as data is transferred. This can 
take a while (a few hours or more), depending on the quantity of data.

4 Launch Migration Assistant
If your Mac is already set up, open Migration Assistant from the 

Utilities folder (within the Applications folder). When you reach the page 
that asks if you want to migrate from a Mac, a Time Machine backup or a 
Windows PC, choose ‘From a Windows PC’. Click Continue. You’ll be 
prompted for your username and password. Click Continue once more 
and your Mac will start looking for your Windows PC.
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Have you switched to OS X 
from Windows? You’ll find 
there are Mac counterparts 
to almost all mainstream 

Windows programs, or Mac apps that 
can open files created with them. But 
perhaps you work in a specialist industry 
and need to use arcane Windows-only 
software, or you want to play Windows 
games. Don’t worry! There are a number 
of ways you can run Windows software 
on your Mac. These include virtual 
environments such as Parallels Desktop  
(www.parallels.com) and Fusion 
(vmware.com). Or there’s Boot Camp.

Boot Camp is a free utility that comes 
with OS X, and it takes advantage of the 
fact that Windows PCs and Macs contain 

the same family of Intel processors. 
With Boot Camp, you can choose 
whether to start your Mac in either OS X 
or Windows. Unlike the virtualisation 
apps just mentioned, which run both 
operating systems at once and thus 
affect performance, Boot Camp makes 
the most of your hardware. Note that 
you’ll need your own copy of Windows 
to install, and modern Macs support 
only 64-bit versions of Windows 7, 8, 8.1 
and 10 – go to http://apple.co/1JUZLO4 
to find out which your Mac can run.

The Boot Camp Assistant helps you 
through the whole process of putting 
Windows on your Mac. It enables you 
to install Windows by ‘partitioning’ the 
startup disk – that is, creating a separate 
area that’s set aside just for Windows. 

Device drivers
To ensure that all your devices work 
properly under Windows, you’ll need to 
install the right device drivers for your 
Mac hardware. The Boot Camp Assistant 
will guide you through downloading 
everything that’s required for your 

specific Mac hardware – you won’t 
have to download things individually. 

You’ll need a Windows installation 
disc as well, but most modern Mac 
models don’t have CD/DVD drives. In 
this case you can use an ISO image file 
– in effect, a file which replicates the 
structure of a real DVD – to create 
a bootable USB drive (recent Macs don’t 
need a USB drive; they temporarily put 
the Windows install files on their internal 
drive). When the assistant downloads 
drivers and additional software, it 
incorporates them into the image.

Boot Camp Assistant enables you 
to decide how to divide up your hard 
drive between Windows and OS X. 
Before you install Windows, Boot Camp 
Assistant resizes your Mac partition. This 
process may involve moving data to a 
new position on the disk, so it’s a good 
idea to have a full backup of your data 
first. Once Windows is up and running 
you’ll need to install the drivers 
downloaded by the assistant. When you 
start up your Mac, hold å at the chime 
to choose between OS X or Windows.

Turn your Mac into a dual-booting, multi-purpose computer

SKILL LEVEL
Taking things further

IT WILL TAKE
1 hour

YOU’LL NEED
OS X 10.11, 

Windows 7, 8 or 8.1 
(64-bit versions)

Run Windows in Boot Camp

VISUAL GUIDE | PARTITIONING YOUR DRIVE WITH BOOT CAMP

Installation

1  The installer is waiting for an 

installation DVD or USB flash  

drive to install Windows.  

OS X

2  This part of your drive holds your  

Mac files. It will need to be resized  

to make room for the Windows area.  

Windows

3  This is the space that will hold 

Windows. Click and drag the  

divider between it and the OS X partition to 

change the space allocated to each of them. 

Divide

4  If you wish, you can click this button 

to divide the disk space evenly 

between the two operating systems. 

1

2
3

4

You can choose 
whether to start in 
OS X or Windows, 
thus making the most 
of your hardware
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1 Boot Camp Assistant
Open Launchpad and then open the 

Other folder. Inside here you’ll find Boot Camp 
Assistant. This will guide you through the 
process of making room for Windows and 
gathering all the software necessary to install 
it. Click Boot Camp Assistant to launch it.

4 Identify your install disc
Unless you have a very recent Mac, you’ll 

need either an optical drive or, more convenient 
with modern Macs, a USB flash drive. Windows 
often comes as an ISO file these days. Select it, 
and the flash drive to turn into an install disk 
(which will be erased), then click Continue.

6 Windows partition
You now need to create a partition on 

your Mac’s startup disk. Boot Camp suggests 
a possible layout, but you can change this by 
clicking and dragging the line between OS X 
and Windows or by clicking Divide Equally. 
Next, connect your install disk and click Install.

2 Setup Guide
At the bottom-left corner of the app’s 

opening page is a button that opens Apple’s 
online help for installing Windows.  can 
optionally print off a setup guide to help you go 
through this process – you won’t be able to use 
your computer for reference as you partition the 

5 Download software
Boot Camp Assistant carries out the tasks 

you’ve selected, downloading drivers and then 
prompting you for a blank CD/DVD or a blank 
USB drive to write it to. If you’re creating a 
Windows install disk on a USB flash drive, the 
installer and drivers will be copied to it now.

8 Install Windows
Follow the prompts to begin installing 

Windows (there a few screens to go through). 
Once you’ve installed Windows, insert the disc 
or drive containing the drivers you downloaded 
earlier. You’ll need to install these to make good 
use of your Mac’s hardware in Windows.

7 Partition and install
The app will resize your OS X partition 

to make space for Windows. This can take some 
time, depending on the size of your drive and 
what’s on it. Once the space is allocated, the 
new partition is created and Boot Camp 
Assistant prompts you to restart.

3 Select Tasks
If you need to create an installation USB 

flash drive from an ISO image, select the option 
here. (If you have a DVD drive, you don’t need 
to do this.) Tick both ‘Download the latest 
Windows support drivers from Apple’ and  
‘Install Windows 7 or later version’.

HOW TO | INSTALL WINDOWS ON YOUR MAC USING BOOT CAMP

It’s best to allow Windows to format 
the partition that will hold it. You may 

notice that your Mac partition isn’t 
recognised by the Windows installer. 

Don’t worry, it’s still there – the 
installer just can’t read its file system.

Formatting
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The basics
Master the key elements of  
using a Mac and the new OS X
42 The El Capitan desktop
  Don’t worry if it all looks a bit different,  

get to know the essentials here

44 Master the Finder
  The core element behind your Mac’s storage 

and organisation; make the most of Finder

48 Customise the Finder sidebar
  Shortcuts for a more efficient Finder

50 Discover OS X’s gestures
 Manipulate your Mac with multi-touch!

52 Master Mission Control
  No matter how busy you get, Mission Control 

will help you to navigate your screen

54 Arrange apps in Split View
 Employ El Capitan’s great new way of working

56 Manage your login items
  Speed up boot times and more!

57 Launch apps quickly
  Rocket-fast access to your apps with Launchpad

58 Using Notification Center
 Pop-up alerts about email, events and more

62 Discover the Today view
 The really urgent stuff – with added widgets!

64 View files with Quick Look
  Need to check something in a hurry? 

Use Quick Look to preview files

65 Discover the Dashboard
 Your customisable control panel 

66 Search with Spotlight
 Find content on your Mac – and the internet
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2

6

4

1

7

5

Whether you’re new to the Mac or have 
upgraded to El Capitan from a much older 
version of OS X, the new desktop might look a 
bit different from what you’re used to. Don’t 

worry, though: the basics are much the same as before 
(and much like Windows Explorer, if you’re coming to from 
a PC). Here’s an overview of Finder – the app you’re 
actually using when you view the desktop, open and 
manage windows, navigate around your hard drive and 
organise your files and folders.

The El Capitan desktop
It’s easy to get around the OS X desktop – here are the essentials

5 Sidebar
Each window in Finder 

shows this sidebar (unless you 
hide it by choosing View > Hide 
Sidebar). It provides quick access 
to storage devices, computers on 
your local network, folders that 
you use regularly, and other 
items you add to it (see page 48). 
Choose what it displays in Finder 
> Preferences > Sidebar. Click the 
sidebar item you want to view 
and the window content 
changes to show that item.

4 Desktop
You can customise the OS X desktop with your 

own images: click the  menu, select System Preferences, 
then Desktop & Screen Saver. Go to the Finder menu > 
Preferences for more options, including whether icons for 
external media and connected servers show up on the 
Desktop. In fact, the Desktop is just a folder too: click 
Desktop in a Finder window sidebar and you can also view 
its contents in a window, just as you can the contents of 
any other folder.

1 Apple menu
Click the Apple logo at the top-left and you’ll find 

lots of handy stuff for managing your Mac. Software 
Update is vital for keeping software up to date, and App 
Store is for finding new apps. As well as options to sleep, 
restart and shut down your Mac, another useful command 
is Force Quit, which you can use to close a misbehaving 
app (or any app, though you’ll lose any unsaved work).

2 Menu bar
On the Mac this menu bar strip is always present  

– unless you hide it or switch to ‘full-screen’ mode – and it 
changes according to which application is currently active. 
After the  menu, the first bold word you see is always 
the name of the specific application you’re currently in, 
and its menu holds commands to do with that app, such 
as quitting, editing its preferences and hiding it.

3 Menu bar items
At the right-hand end of the menu bar, no matter 

which app you’re using, you can view vital info about your 
Wi-Fi connection, battery charge (on laptops), volume 
level and more. Click an icon to view details or change 
settings. Some other services and apps add icons here. 
Some of these can be removed by holding ç and 
dragging them off the menu bar, but others will need a 
command to quit them. Click the rightmost icon to open 
Notification Centre and see events; click the magnifying 
glass to search for things in Spotlight (see page 66). 6 Folders and views

Your account’s folder includes various 
special folders, such as Movies, Music and 
Pictures, which are intended to store those 
media and are useful to keep in the sidebar. 
‘AirDrop’ may appear here too – it isn’t a 
folder, but a way to transfer files between 
nearby Macs and iOS devices, even if they 
aren’t connected to the same Wi-Fi network 
(see page 91). You can view the contents of a 
folder in different ways using the four 
buttons at top left: as icons; as a list that 
can be sorted by attributes such as date 
modified; in a hierarchy; or in Cover Flow.
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8

3

9

10

10 Trash
 Drag and drop files here to delete them. Files stay in the 

Trash until you empty it from the Finder menu or by right-clicking 
here and choosing Empty Trash. To restore a file before it is deleted 
forever, open the Trash, right-click the file and select Put Back. Drag an 
external drive or CD/DVD here and the icon changes to an eject icon.

8 The Dock
There’s a divider towards the right of the Dock; 

apps sit to the left of this and files and folders that you 
want quick access to can be dropped to the right. 
Minimised windows flow down to this right-hand area, 
too. You can rearrange the icons in the Dock by simply 
dragging them left or right (but not across the divider). 
You can choose to keep favourite apps in the Dock, so 
you can launch them simply by clicking their icons: just 
drag an icon into the Dock, or right-click on the icon of 
a running app and select Options > Keep In Dock. To 
remove the icon of an app you rarely use, just drag it 
out of the Dock – the icon (but don’t worry, not the 
app!) will vanish in a puff of smoke.

9 Stacks
Just to the right of the Dock’s dividing line 

are shortcuts to commonly used folders on your 
Mac – known as stacks in this context. Click one to 
see its contents; click an item within it to open that 
item, or click the ‘Open in Finder’ arrow icon to 
open the entire folder as a normal Finder window. 
You can change a stack’s appearance (from a ‘fan’, 
as in the main image, to a grid as shown above, or a  
list) by right-clicking it and selecting a View option 
from the menu that appears. The Downloads folder 
is already placed here, and it will bounce to signal 
when a download is complete. You can add any 
other folders you wish, such as one for a project 
you’re working on, by dragging them from a Finder 
window to this area. Let go when the other icons 
have slid out of the way to make room for it.

7 Apps
The Dock shows currently 

running apps (the ones with a 
little black arrow under their 
icon), but not the individual 
windows for these apps – usually 
you can right-click on an app’s 
icon and it will list the windows 
it has open. Except for some 
system utilities, apps stay open 
even when you close the last 
window, so you have to quit 
them; the easiest way to do this 
is usually by pressing ç+q.

The three coloured ‘traffic light’ buttons 
at the top-left corner of OS X windows are 
used to close the window, minimise it, or 
show it full-screen. (Helpful symbols 
appear in the buttons when you move the 
pointer over them, as shown.) Click the red 
button to close the window. Yellow is for 
minimise – click this and the window flows 
down into the right-hand side of the Dock; 
click the thumbnail of it there to reopen it 
as it was before. Click the green button to 
make the window expand to completely 
fill the screen, covering everything. If you 
å-click the green button, the window will 
resize to the largest optimum size for the 
content (which varies in different views).

Close and minimise
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Finder is an essential tool for every Mac owner. 
No matter what other bells and whistles OS X  
has gained over the years, Apple continues to 
describe Finder as ‘The Macintosh Desktop 

Experience’ – it’s central to how you browse your Mac’s 
storage and organise your files using folders, tags and other 
attributes. And Finder hasn’t changed in its basic operation 
since the first release of OS X back in 2001. That says 
something about how good it is.

The simplest of tasks, such as copying and moving files, will 
be familiar if you’ve used any version of Windows before – so 
you have nothing to worry about if this is your first Mac.

With Finder, everything is set up for you to be able to find 
your files and folders quickly and access your discs and servers 
as fast as possible. And there are a number of ways you can 
customise it to make your Mac a more personal experience to 
you. For instance, you can choose which folders, devices and 
drives appear in the sidebar, choose to either show mounted 
discs on the desktop or not, change which items appear in the 
toolbar and much, much more.

At some point you’re going to want to locate files that you 
saved weeks, months or even years ago. Finder has that well 
covered, too. Items can be tagged with, say, a project name, 
and it’s possible to retrieve all files with a specific tag in an 
instant – even if they’re saved in different places. Finder also 
provides a powerful tool, Smart Folders, to locate things based 
on a multitude of complex criteria.

Over the following pages we’ve got some expert tips to 
share with you that will put you in more assured control – 
we’ll start with the basics and move to more advanced 
operations (that are still easy to perform, but will enhance 
your Mac experience).

It goes without saying that you don’t need to memorise all 
that’s presented in these pages, but at some point you’ll 
probably come back to ensure you know how to work out 
what’s using up space, how to rename several files quickly, 
and how to share files. Let’s get started…

Master the Finder
Learn how to manage and locate files with this most important app

3 Select several items
To select every item between one and 

another, click the first, then hold ß and click 
the second (if you click the first and last item 
with ß held down it will select them all). To 
pick up a more scattered bunch of items 
(perhaps you want to select only a few files in a 
folder) click the first and then hold ç while 
clicking others. You can now copy or move the 
selected items, just like an individual item.

1 Copy files  
and folders

To duplicate an item, click it and 
press ç+D (or right-click it 
and choose Duplicate). Copy it 
elsewhere on the same disc by 
holding å while dragging it – a 
green badge with a + confirms 
that a copy will be made when 
you let go. Dragging to another 
disc copies by default.

2 Move files  
and folders

Normally, dragging an item into 
another folder on the same disc 
moves it. To move it to another 
disc, hold down ç while dragging 
it – no green + badge will appear 
next to the pointer, which confirms 
that the file will be moved (if you 
don’t hold down the modifier key 
the item will be copied). It’s a 
handy shortcut to know!

THE BASICS   |   Master the Finder

Smart Folders look a lot like ordinary folders, but 
they’re distinguished by a purple icon. Smart 
Folders are ‘smart’ because they enable you to add 
criteria that automatically place files matching 
those criteria in the folder. To create a Smart Folder 
go to File > New Smart Folder. In the Finder 
window that appears, search for the name of the 
files that you want to add to the folder (you may 
want all files in a certain project in a Smart Folder, 
for instance). You can add criteria by hitting the + 
button and save the folder by hitting Save. See tip 9 
for an alternative way to create Smart Folders.

Smart Folders
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4 Quickly group items
You may end up with several items loose 

on the desktop that you want to gather up in a 
new folder, but don’t want to spend the time 
creating a folder and selectively dragging them 
in. A little-known shortcut is to select the files 
you require and press ç+≈+N, or right-click 
one of the selection and choose New Folder 
with Selection. Rename the new folder by 
typing straight away. 

Write a CD/DVD
Although modern Macs don’t have optical drives, you 
can still burn discs using OS X. With a CD/DVD writer 
attached to your Mac, choose File > New Burn Folder 
and drag items into it. Open it and choose View > Show 
Status Bar to monitor the required disc capacity. Click 
Burn (top right) to write the folder’s contents to a disc.

5 Merge folders
If you copy or move a file into a folder where 

an identically-named file exists, a warning appears 
in which you can choose to replace the existing file 
or to keep both, which adds ‘copy’ to the new file’s 
name. For folders it’s a little different, with the 
Finder offering only to replace the existing one. 
If you hold å you’ll have the option to merge 
contents – handy if you want to add to a collection 
of photos or documents, for instance.

6 How to batch 
rename files

In OS X Yosemite, you don’t need 
to worry about spending time 
renaming files individually as it 
includes a handy batch rename 
feature. With several items (files or 
folders) selected, right-click and 
choose the option that says 
something like ‘Rename 3 Items…’ 
This opens a panel in which you 
can search for and replace text in 
the existing filenames, prefix or 
append something to them, or 
reformat them. 

Master the Finder   |   THE BASICS

El Capitan makes it possible 
to directly delete a file rather 
than via the trash – select the 
file in question, then hold the 
D key and choose File > 
Delete Immediately… 

Finder is a simple, yet powerful, tool that helps  
you organise all of your files, folders and devices. Airdrop 

explained

Delete now

This option may appear in the 
Finder window sidebar. Like 
the Share menu, it’s a method 
of transferring files between 
Macs and iOS devices without 
them needing to be 
connected to the same 
network or to each other by a 
cable. See page 91 for more.
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7 Compress files
You can copy one or more items into a 

zip archive (so you can easily email them to a 
friend or colleague, for example) by selecting 
them and then right-clicking and choosing 
Compress… Double-click an archive to unpack 
it to the same folder. If it contains two or more 
items, they’ll be placed in a folder named after 
the archive.

8 Search for files
Finder makes it incredibly easy to find 

your files. Simply type something into Finder’s 
search bar and it suggests attributes to search 
upon, such as filename, kind, and the sender or 
website where a file originated. Click one to 
choose that criterion. In the options bar, you 
have the option of searching your entire Mac, 
any hard drive or server that is attached, or only 
the folder you were viewing before typing. No 
more lost files!

11 The Inspector
Pressing ç+å+I opens a window 

much like the one in the previous tip, but the 
information displayed in this one updates as you 
add or remove items from your selection. This 
makes it a good way to calculate the combined 
size of a bunch of files and folders.

9 Smart Folders
Press ç+å+Space to open a Spotlight 

Search window. This looks a lot like a Finder 
window, but you can click the + in its options 
bar to build complex criteria that files must 
match. You can, rather handily, then click Save  
to preserve your criteria as a Smart Folder, the 
contents of which update automatically.

10  The Get Info window
 The Get Info window is one that  

you’ll find yourself using a lot. With an item or 
multiple items selected, right-click it or them 
and choose Get Info (or press ç+I) for a 
summary of that file. Click the triangle next to 
’Open with’ to pick which application an 
individual file will open with, or to tell Finder 
that you want all files of that type to open with 
a specific app in future (for example opening 
PDF files in Adobe Acrobat Reader rather than 
the default Preview app).

Using the Get Info command you can find out essential 
information about files,  folders, discs and servers.
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12  Create and 
  manage tabs

You can create several Finder windows to work 
with different folders simultaneously, or you  
can open locations in tabs within one window 
to minimise clutter on your desktop. Do this  
by choosing File > New Tab. When copying or 
moving an item, simply drag it over a tab and 
then wait a moment for the Finder to switch  
over to it.

13 Merge all windows
 Even if you intend to use tabs in 

Finder, it’s extremely easy to end up with several 
windows – again cluttering up valuable desktop 
space. These windows can easily be combined 
into a single window by using the ‘Merge All 
Windows’ command. With many tabs open, it 
can be hard to find the one you want. Swipe 
horizontally with two fingers on a trackpad (one 
on a Magic Mouse) to scroll along the tab bar.

14  Aliases
 Aliases are shortcuts to items to 

which you want quick access – often from the 
desktop. To create them simply hold ç+å 
when dragging an item (the pointer changes to 
a curved arrow). Release to create an alias and 
leave the original in place. Double-clicking the 
alias opens the original.

15  Attach tags to  
  a new file

When you’re saving a new file, many apps show 
a box labelled ‘Tags’ below the one in which you 
name the file. Type a keyword or phrase and 
press ® to create a new tag and attach it to the 
file, or pick existing tags from the list that drops 
down from the box when you click in it. 
Obviously, doing this makes finding your files at  
a later date even easier.

16 Tag existing files
 Tags can be attached to existing files 

– and folders – by selecting them in the Finder, 
clicking the tag button in the toolbar and then 
typing a new tag or select an existing one. You 
can attach multiple tags to a file. Alternatively, 
drag an item onto one of the tags listed in the 
sidebar to attach it.

17  Find by tag in  
  the sidebar

The list of tags in the sidebar isn’t simply for 
assigning tags to files. Click one and the pane to 
the right will show all files and folders with that 
tag attached. Right-click a tag to rename or 
delete it, which updates the tag wherever it’s 
attached. In addition, you can assign colours  
to tags here.

18  Find by tag in 
  the search bar

 Tags appear among the suggestions when 
you type into Finder’s search bar. When adding 
criteria in a Spotlight search window, click the 
attribute name, choose Other… and search for 
the Tags attribute. This enables you to search for 
a whole tag name, or just part of one.

19  Right-click for 
  more options

When you right-click a file or folder, the bottom 
item in the pop-up menu is Services. Move the 
pointer over it to see more actions that you can 
perform on the item. Some apps add Services as 
a way for you to quickly process items, and you 
can create your own using Automator.

20  Share files with  
 other people

Select an item and click the Share button in 
Finder’s toolbar (or right-click and choose 
Share). You can send items in an email or 
iMessage, or AirDrop them to a nearby Mac or 
iOS device. Apps you install may add options 
here, which will be indicated by a numbered 
badge next to ‘More…’.

It can be frustrating having to open up files to see their contents (maybe you’ve been lazy 
naming them in the first place?). Luckily, many kinds of files don’t need to be opened in order 
to see what they are. Select a file and tap the Spacebar to open a Quick Look window. PDFs, 
images, fonts and many other kinds of file can be checked out this way. See page 64 for more.

What is Quick Look?
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Customise the Finder sidebar
Be more efficient with Finder sidebar shortcuts and searches

QUICK LOOK  
FINDER’S SIDEBAR

1
2

3

4

At some point we’ll be 
able to verbally tell a 
Mac what we want to 
work on or with and 

it’ll quickly serve the respective 
document or app. In the meantime, 
we must make do with manual 
searches via El Capitan’s Spotlight, 
or use a file manager. 

Finder is an app built into every 
Mac for rummaging around your 
drive (and beyond) and it can be 
customised a little, helping you 
work faster and more efficiently.

One area that can be bent to 
your will is the sidebar. This is 
initially populated with shortcuts 
Apple has determined most Mac 
users will require, including All My 
Files, Applications and Documents, 
but as our walkthrough shows, you 
can add your own. Also, some 
applications – such as Dropbox – 
provide direct integration with 
Finder and add shortcuts, although 
these can always be removed.

Folders in the sidebar work as 
they do elsewhere in Finder, 
meaning you can drop items into 
them. This makes the sidebar a 
handy place to temporarily house 
a folder shortcut if you plan on 
moving a lot of documents to it. It’s 
typically faster to drag documents 
to the sidebar of any Finder window 
than to a specific Finder window or 
Dock shortcut. 

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11 (although 
most steps work with 

previous versions)

The sidebar
1  By default, the 

sidebar appears at 

the left-hand side of all 

Finder windows, 

providing fast single-click 

access to folders, mounted 

media, shared computers 

and tags. 

Sidebar groups
2  Items stashed in the 

sidebar are grouped 

into simple categories: 

Favorites, Devices, Shared 

and Tags, to help make it 

easier to find what you’re 

looking for.

Sidebar items
3  You can store 

custom items under 

Favorites. Folders and 

searches are the best 

things to place there. Add 

documents and apps if 

you like, but avoid too 

much clutter. 

Preferences
4  In Preferences you 

can adjust what’s 

shown in the Finder 

sidebar. Individual folder 

preferences and view 

options can also be 

amended to suit. 

Finder can be 
customised a little, 
helping you work 
faster and more 
efficiently too
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HOW TO | MASTER THE FINDER SIDEBAR

1 Understand the basics
Firstly, the sidebar can be hidden. 

App install windows often hide the sidebar, 
for example. View > Hide/Show sidebar 
(å+ç+S) toggles its visibility. Also, select a 
sidebar item and it loads relevant items into the 
window. So click Applications to see your apps. 

4 Access a hidden folder
Your user Library folder is hidden by 

default, but can be added to Finder’s sidebar. 
Hold å and go to Go > Library. Ensure the 
Finder path bar is visible (View > Show Path Bar) 
and drag Library to the Favorites section of the 
sidebar. The folder is then just a click away. 

6 Save a search
In any Finder window, press ç+F to 

load the search view – results can be restricted 
to a folder or your entire Mac. Define results 
criteria and click Save. In the sheet that appears, 
check Add To Sidebar and click Save. Your 
dynamic smart search appears in the sidebar. 

2 Show predefined items
Go to Finder > Preferences and choose 

Sidebar. You’ll see items grouped into Favorites, 
Shared, Devices and Tags. Checking an item 
adds it to Finder sidebars; deselect an item and 
it will be removed. (Most items can be managed 
manually, though that’s a slower process.) 

5 Manage the sidebar
Add too many items and the sidebar 

becomes cluttered and requires scrolling, so 
prioritise. Delete unused items and click-drag to 
move key ones up. Categories can be dragged 
via their titles, or collapsed by clicking the Hide 
button (shown when the cursor’s over the title). 

8 Make everything bigger
Sidebar items can be resized. In System 

Preferences, click General and set ‘Sidebar icon 
size’ to Large (this may affect other apps.) Third-
party utility XtraFinder (trankynam.com/
xtrafinder) adds sidebar colour, via Appearance 
> Show colourful icons in the sidebar. 

7 Use All My Files
All My Files is a smart search that groups 

your files, initially by type and in reverse 
chronological order. The folder’s view and item 
arrangement can be adjusted via the toolbar 
and it will remember changes when reopened. 
The same goes for other folders in the sidebar. 

3 Add and remove items
If you want quick access to a folder not 

shown in Finder’s preferences, select it and use 
File > Add to Sidebar (≈+ç+T), or just drag 
the folder into Favorites. To remove any item’s 
shortcut, drag it outside the Finder sidebar or 
≈-click it and select ‘Remove from Sidebar’. 

Open up

Changes made to Finder’s sidebar are 
reflected in Open and Save dialog boxes. 
Placing frequently accessed folders near 

the top of the sidebar is a time-saver. 
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Discover OS X’s gestures
Control your Mac with the multi-touch gestures in OS X El Capitan

Two-finger double-tap 
Tap twice with two fingers to zoom in on the 
part of a website or document that’s under the 
pointer. Apple calls this Smart Zoom, since it 
looks at where you’ve tapped and zooms in to 
give you the best possible view of that area. So 
if you’re looking at a multi-column website, 
Smart Zooming on a column will focus on it. 
Repeat this gesture to zoom out.

Three-finger tap
Move the pointer over a word in a text 
document, email or website in Safari – even 
one that’s part of a hyperlink. Now tap on your 
trackpad with three fingers. The word under the 
pointer will be highlighted and a dictionary 
definition and thesaurus entry pops up. This 
gesture is a truly fantastic timesaver when you 
come across words you don’t understand.

Two-finger swipe
Rest two fingers on your trackpad and swipe 
them to the right to move back to the previous 
page in Safari, or the preceding page in a 
document you’re looking at (in Preview, for 
example). Swiping your fingers to the left 
has the opposite effect – like pressing your 
web browser’s Forward button or going to 
the next page in a long PDF file. 

Three-finger swipe left/right 
Place three fingers on your trackpad and swipe 
left or right to move between the workspaces 
you’ve created in Mission Control or apps you’ve 
switched to full-screen mode. As you swipe left 
or right, the next one slides into view. If the 
ordering of apps and spaces becomes 
confusing, get a quick overview by opening 
Mission Control and looking at the top row.

Three-finger swipe up 
Lay three fingers alongside each other on your 
trackpad and swipe them upwards to bring up 
Mission Control, OS X’s handy nerve centre (see 
overleaf). From here, you can see the windows 
of all running apps. Click one to switch to it. 
Alternatively, swipe three fingers upwards or 
downwards to jump back to the window you 
were using previously.

Pinch out to zoom in 
To zoom in on a document, say a photo or a 
PDF, place your thumb and index finger close 
together and spread them apart. To zoom out 
again, pinch the same fingers back together. If 
you’ve ever used an iPhone, iPad or iPod touch, 
this gesture will be familiar, and it can be used 
really effectively with two-finger scrolling to 
move around a web page on a small screen.

HOW TO | USE GESTURES ON A MAGIC TRACKPAD
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ontrolling your Mac using multi-finger gestures on a trackpad or 
Magic Mouse is one of OS X’s key features and borrows from the 
touchscreen experience of the iPhone and iPad. But remembering 
all the options can be tricky at first, so here’s a useful guide to the 

gestures you’re likely to use the most often. Remember that existing gestures 
which you might have used in older versions of OS X, such as dragging two 
fingers up and down a trackpad to scroll, still work in El Capitan. Note that when 
we talk about ‘tapping’ your mouse or trackpad, we mean tapping lightly rather than 
clicking the button. To change settings, see System Preferences. 

Four-finger spread 
Place your thumb, index, middle and ring 
fingers close together on the trackpad and 
spread them outwards. All of the windows fly 
off the screen to reveal your desktop, so you 
can reach the files and other icons on it. Drag 
the same four fingers back together to pull 
the windows back into view. This will work 
as a left- or right-handed gesture.

One-finger double-tap  
Tap the top of your Magic Mouse twice 
to zoom in on the part of a website or 
document under the pointer. Apple calls 
this Smart Zoom, since it looks at where 
you’ve tapped and zooms in to give you the 
best possible view. This requires turning on 
‘Smart zoom’ in  > System Preferences >  
Mouse > Point & Click. Repeat to zoom out.

One-finger swipe  
Lay one finger on top of your Magic Mouse 
and swipe it to the right to move back to the 
previous page in Safari or the preceding 
page in a document. Swiping to the left has 
the opposite effect – like clicking your web 
browser’s Forward button. This requires 
turning on ‘Swipe between pages’ in  > 
System Preferences > Mouse > More Gestures.

Four-finger pinch
Place your thumb and first three fingers slightly 
apart on the trackpad, then pinch them all 
together. This will bring up Launchpad, the 
iPhone- and iPad-like screen that contains all 
of the apps you’ve got installed. Click the app 
you want to open, type a name to search for 
an app, or leave the Launchpad window again 
by spreading the same four fingers outwards.

Two-finger double-tap  
Double-tap two fingers on top of your 
Magic Mouse to bring up Mission Control, 
OS X’s nerve centre (see overleaf). From 
here, you can see the windows of all 
running apps. Click one to switch to it. 
Alternatively, double-tap two fingers on 
your mouse again to jump back to the 
window you were using previously.

Two-finger swipe 
Place two fingers on your Magic Mouse and 
swipe to the left or right to move between 
the workspaces you’ve created in Mission 
Control or apps you’ve switched to full-screen 
mode. As you swipe, the next one slides into 
view. If the ordering of things becomes 
confusing, get a quick overview by opening 
Mission Control and looking at the top row.

To use multi-touch gestures to control your Mac, you’ll 
need a Magic Mouse or a Magic Trackpad, a MacBook 
Air (all models), a white MacBook (late 2009 and 
newer), or an aluminium unibody MacBook or 
MacBook Pro (early 2008 and newer).

How to multi-touch

Use gestures on a Magic Mouse

C
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Master Mission Control
El Capitan adds new features to the clever task switcher

QUICK LOOK 
STAY IN CONTROL 

1

2
3

4

Mission Control has 
been a feature of 
Apple’s OS X operating 
system since 2011, 

when it appeared as part of the 
release of OS X 10.7 Lion, but it’s 
roots go back to Exposé, which 
debuted way back in 2003 with OS 
X 10.3. As the name implies, Mission 
Control is envisaged as the control 
centre from which you run your 
Mac. In reality, you could happily 
use your Mac for years without ever 
activating it, but it’s very handy 

when you need to find that one 
crucial app you’ve lost behind a 
dozen open folders, or you simply 
need to get a handle on exactly 
what apps you’ve got running.

Smart, yet simple, is the mantra 
underlying Apple’s latest release, 
and the new Mission Control 
beautifully exemplifies this 
philosophy. In El Capitan the 
desktop background in Mission 
Control is not blurred, and 
thumbnails of the virtual desktops 
don’t appear until you move your 
cursor over them.

Here we’re going to show you 
how to use the new El Capitan 
features of Mission Control, manage 
your apps and different desktop 
spaces and finally how you can 
customise Mission Control in the 
Settings app. So, let’s take control 
of your Mac and get started!

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11 El Capitan 

(some features work in 
older versions)

Running apps
1  When you enter 

Mission Control all 

the apps currently running 

on your system minimise 

to their own, well-

organised areas of the 

screen, so you can see 

what’s going on. 

Top bar
2  Move the cursor to 

the top of the 

screen in Mission Control 

to reveal the top bar, 

where you can access all 

your desktop spaces. 

Desktop spaces
3  The different 

desktop spaces 

you’ve created are a bit 

like multiple monitors you 

can swap between, and 

can be accessed from the 

top bar. Click the + icon to 

open a new space. 

The Dock
4  The Dock stays 

visible throughout 

Mission Control, which 

means you can still 

launch your favourite 

apps at any time. 

It’s your go-to 
when you need to 
find a crucial app 
you’ve lost behind a 
dozen open folders
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1 Activate Mission Control
Activating Mission control is done by 

swiping upwards with three fingers anywhere 
on your trackpad. Once you do this, all your 
open applications will spread to different 
corners of the desktop, showing you exactly 
what you’ve got running. To return to a standard 
desktop just swipe back down the same way

4 Moving apps
If you have a lot of apps open you might 

like to organise them onto different desktops to 
make them easier to manage. Open Mission 
Control and drag and drop an app into a new 
desktop at the top of the screen. Drop it onto 
the plus symbol at the top right and you’ll 
create a new desktop to drop the app into. 

6 Mission Control settings
You can customise Mission Control  

in System Preferences. Open up System 
Preferences from the Dock and choose Mission 
Control in the top line of icons. Here you can 
choose a different way of launching Mission 
Control from the pop-up menu. Try it! 

2 Switching apps
Once you activate Mission Control your 

apps still run as normal in their minimised state, 
so videos will keep playing and web pages will 
continue to update, for example. If you want to 
switch to a particular app just click on it. This 
returns you to a standard application view, but 
with the app you selected in the foreground. 

5 Adding app spaces
You’re not limited to putting apps into 

desktop spaces – you can also drag them to the 
top bar and let them float in a space of their 
own. These apps don’t belong to a desktop – 
they can be accessed via Mission Control or the 
å + † app switcher. You can drop another app 
on them to enter a Split View mode. 

8 Change shortcuts
You can change the keyboard, trackpad 

or mouse shortcuts to Mission Control, 
Dashboard and Show Desktop in the Mission 
Control settings, but if you press the ß, ≈, å 
or ç keys while looking through the list you’ll 
find you can add these keys to the choices. 

7 Dashboard settings
Dashboard is turned off by default in El 

Capitan. In the Mission Control settings you can 
turn it back on and choose whether to overlay 
Dashboard onto of your desktop or give it its 
own space. Choose an option and hit ™ to 
launch Dashboard. 

3 Adding a new desktop
With OS X you’re not just limited to one 

desktop – you can have many desktop spaces. 
In Mission Control, simply move your cursor up 
to the top bar and it will expand to reveal them. 
To add a new desktop space simply click on the 
+ symbol in the right-hand corner. To delete a 
space hover the cursor over it and click the x. 

HOW TO | HOW TO NAVIGATE EL CAPITAN’S MISSION CONTROL

GROUP BY APP
By default, thumbnails in 

Mission Control are displayed 
as a single layer in El Capitan. 

You can change this by 
checking ‘Group windows by 

application’ in the Mission 
Control settings. 
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Dragging open windows 
around your desktop – 
opening and closing or 
minimising and 

maximising them – has always been the 
way we’ve worked in OS X. But no 
matter how carefully you tried to 
arrange your open windows, it’s never 
been a perfect system for keeping 
everything organised. Sure, Mission 
Control can be invoked (see page 52) as 
a quick way of seeing everything that 
you’ve got open at once and switching 
apps with ease, and there is also the 
new(ish) full screen view on most apps 
these days that reduces distraction by 
utilising the whole of your display, but 
overall using OS X still seems to require 
an inordinate amount of time resizing 
and repositioning window edges.

That’s why Apple has come up 
with the new Split View option in OS X 
El Capitan. This is an entirely new way 
of working with two apps at once that 
could revolutionise the way you use 
your Mac, especially if you have a 
smaller screen like those on the new 

MacBook or MacBook Air where every 
millimetre counts.

With Split View you have two apps 
open side-by-side, and filling the entire 
screen as if they’re both running in full 
screen mode. The ratio between them 
is delineated by a black bar, which can 
be moved left or right and resizes each 

window accordingly. In short, it’s a 
really nice way of working.

Becoming a master of Split View is 
all about knowing where and what 
to click and when to click it. Here we 
reveal the secrets to Split View. Get 
ready to change the way you use 
your Mac forever.

Arrange apps in Split View
Split View is here to boost your productivity. Let’s find out how it works!

1 Locate your first app
The first step in activating Split View 

is to make sure both apps you want to run 
are open, then locate the first app you’d like 
to use and left-click and hold on the little 
green traffic light button in the top left-hand 
edge of its window. Now drag the app to the 
left-, or right-hand edge of the screen and 
release the mouse or trackpad. It should lock 
itself to that side of the screen.

2 Find a second app
With one app taking up half of your 

screen your other running apps become 
thumbnails in the other half of the screen. 
The next step is to simply select one of the 
thumbnail apps by clicking on it. The app 
will zoom to perfectly fill the other half of 
your screen. You’re now in Split View mode. 
It is, in effect, like having both apps running 
in full-screen mode simultaneously. 

3 Manage the distance
Between the two apps is a black line. 

Put your cursor on this line and it changes to 
an arrow icon, indicating that you can adjust 
the amount of the space each app uses. To 
exit Split View mode, move your cursor to 
the top of the screen and the menu bar 
appears. Click on the green traffic light icon 
and you’ll exit Split View mode. Alternatively, 
hit the œ key. 

HOW TO | USE SPLIT VIEW THE QUICK WAY

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11 El Capitan

You can drag and drop content from one window to another in Split View mode
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1. Maps
1  As you’d expect from an Apple app, Maps behaves 

perfectly in Split View mode. Here we’ve got Maps 

open in the window on the left of the screen, and Photos 

open on the right. Both apps function normally, and you can 

move from one to the other. Only the app that has the 

current focus will respond to keyboard commands though. 

2. Photos
2  Here we have the Photos app running happily in Split 

View mode, showing how you can use it to zoom in 

on a photo while using another app on the other side of the 

split screen. The Photos app has had some significant 

improvements in El Capitan, but the most exciting is the 

ability to use third-party extensions. You can download 

compatible imaging apps from the App Store and access 

them from within Photos, greatly extending its capabilities. 

Separator line
3  The black line in the centre of the screen that 

separates the two ‘full screen’ windows in Split View 

mode can be dragged to the left or to the right so that you 

can have the perfect sized workspace. Simply hover your 

mouse cursor over the line and you’ll see the icon change to 

indicate that the line can be dragged to the left or to the 

right. The app windows will resize accordingly, keeping 

everything in correct perspective.  

Traffic light icons
4  Move the cursor to the top of the Split View screen 

and the menu bars for the selected apps appear, 

showing the red, amber green traffic light icons in the top 

left of each window. To exit from Split View mode you click 

and hold on the green icon - alternatively, pressing the œ 

key will get you out of Spit View, just like it does when 

you’re in regular Full Screen view. To go back to Split View 

mode, simply click and hold on the green traffic light icon 

and choose the second app from the thumbnails provided. 

iOS 9 compatibility
5  The Split View option available in El Capitan is also 

available in iOS 9 when it’s running on newer iPads, 

like the iPad Air 2 and the new iPad Pro. There are two 

modes in iOS 9, Split View, which works just like El Capitan, 

and also a Slide Over mode, which has one window greyed-

out and available for display only. 

Split View in Mission Control
6  If you activate Mission Control (use the three finger 

upward gesture on the trackpad) and drag an app 

from your current desktop space to an app that occupies its 

own space (not inside another desktop) in the workspace 

bar at the top of the screen, then it will run both apps in 

Split View mode automatically. Drag the app to the left or 

right to determine which side of the screen it should occupy. 

1

2

3

5

6

4

TAKE NOTE!
The perfect app to use in Split View 

mode is Notes, as you can cut and paste 
information from apps like Maps and 
Safari into the note you are making, 

while keeping both windows in view. As 
well as cutting and pasting text, you can 
also drag and drop images or links from 

web pages into the note you are making. 
It’s features like this that mean Split View 
isn’t just window dressing – it’s going to 

make using your Mac much more 
productive, while helping everything 

to look great in your workspace.

VISUAL GUIDE | GETTING TO GRIPS WITH SPLIT VIEW
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When an application is 
set up as a login item, 
it automatically opens 
when you log into your 

account. It’s perfect for apps and add-
ons which you want to be ‘on’ all the 
time. Dropbox, for example, is a great 
means of sharing files between 
computers, and it sits discreetly in the 
menu bar when not in use. If it’s set as a 
login item, it’s always there, ready to go.

Twitter and Stickies are similarly well 
suited to launching at login so they’re 
ready to use, as are various server apps 
that enable you to play media stored on 
your Mac from other devices. You can 
even launch an app as a hidden item – 
behind the scenes, as it were.

But for all its strengths, it’s possible to 
be too enthusiastic about OS X’s Login 
Items feature. If you set too many apps 
(or files and folders) to open, your Mac 

will become very slow to start up, and 
you may well end up wasting the time 
you wanted to save!

Some ill-mannered applications even 
designate themselves as login items 
without your consent – and if you’ve 
been using your Mac for a while, there 
are bound to be a few bits and pieces in 
there that you no longer use and have 
forgotten about. So it pays to check 
your list of login items… 

1 System Preferences
Each user of your Mac can have their own 

set of items set to open when they log in, so you 
need to configure login items separately for 
each user account. Go to the  menu, select 
System Preferences and then click on Users & 
Groups in the fourth group down. 

4 Adding items
To add apps or files to the Login Items 

list, click the + button under the list, navigate to 
the app or file, then click Add. Alternatively, you 
can navigate to the app or file in Finder and 
simply drag and drop it into the Login 
Items list.  Either method has the same result.

2 Login Items
The current user of your Mac will be 

highlighted in this window, and the pane will 
by default show the password options for that 
user account. We need to switch to Login 
Items, so click the Login Items tab at the top 
to start managing its contents.

5 Removing items
To remove a login item, highlight it in the 

list and click the – button below the list. This 
stops it opening on login. Be careful, though, if 
it’s an item you don’t recognise: it might be a 
helper app required by something you’ll want to 
use. Best find out what it is before removing it. 

6 Files and folders
You can set files and folders as login 

items on your Mac as well as apps. Doing so 
opens the document or folder window when 
you log in. It can be useful to add something 
related to a project you’re currently working on, 
but do remove it when you no longer need it.

3 The Hide tickboxes
All the items in the Login Items list will 

open at login, but there’s also a ‘Hide’ tickbox to 
the left of each item. If this is ticked, the item 
is opened at login as a hidden item – just like 
hiding something in the Dock. This means you 
might not be aware that it’s open and running.

Have apps ready for use, or speed up boot time by disabling them

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11

Manage your login items

HOW TO | TRIM YOUR LOGIN ITEMS LIST
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Launch apps quickly
Make the most of El Capitan’s Launchpad to get at your apps 

Launchpad puts every app that’s 
installed on your Mac at your 
fingertips for easy access. The way it 
works is essentially the same as on 

an iPhone or iPad: icons that you click to open 
an app, and can rearrange as you please.

There are several ways to get into Launchpad. 
The first is to click its icon in your Mac’s Dock: it’s 
a silver circle with a rocket on it. If you’ve got a 
trackpad, place your thumb and first three fingers 
slightly apart on the trackpad’s surface, then 
pinch them together to make Launchpad appear. 
When you’re done, just make the gesture in the 
opposite direction to make Launchpad vanish.

Launchpad can cover several screens, arranged 
horizontally. To move between them, swipe two 
fingers sideways on a trackpad, swipe one finger 
on a Magic Mouse, click and drag the screen 
horizontally with other mice, or tap the left and 
right arrow keys on a keyboard.

Launch Launchpad
Launchpad contains all the apps on your Mac, 
with Apple’s apps listed first. When you install 
new apps they’ll be added to the first screen 
from the left with available space. To rearrange 
the icons, move the pointer over one, hold down 
your mouse or trackpad button, then drag the 

1 Lift off!
Click the Launchpad icon in the Dock 

and then click an app’s icon to launch it. If you 
have a lot of apps, swipe between multiple 
screens – the number of screens available is 
indicated by tiny dots just above the Dock. Click 
and drag an icon to move it to a new position  
in Launchpad.

2 Add to folders
As in iOS, apps can be organised into 

folders. To create a folder within Launchpad, 
all you need to do is drag one app icon onto 
another. The folder is named after the genre 
of one or both of the apps (based on their App 
Store category), but you can rename the folder 
and also add more apps to it later.

3 Customise folders
To open a folder, just click it; to launch 

apps inside it, click their icons in the normal way. 
To move apps around within a folder, click and 
drag them; to remove an app from a folder, drag 
it over the Desktop behind. The folder closes so 
you can drop the icon elsewhere. To rename a 
folder, click its title and type a new one.

HOW TO | ORGANISE WITH LAUNCHPAD

icon where you want it and let go. To move it to 
the next screen, drag it to the right-hand edge of 
the current one; after a short pause, the next 
screen will slide into view. You can also drag an 
app icon from Launchpad into the Dock.

Group behaviour
You can put apps into folders to better organise 
them by dragging the icon of one app over 
another. You’ll see a white frame appear around 
the icon; let go of your mouse or trackpad 
button to create the folder. It’ll be given a name 

based on the kind of app you’ve grouped, but 
you can change it: click to open the folder, click 
its name, then type a replacement.

Launchpad also makes it easier to delete apps. 
Click and hold on an app icon (or hold the å 
key) until they all start to jiggle and some will 
display an X. Click this to uninstall that app (but 
beware: there’s no ‘undo’ option – you’ll have to 
redownload the app). You can delete only apps 
bought from the App Store – Apple’s standard 
apps can’t be uninstalled. You also need to be 
logged in with an administrator account.

Launchpad offers a quick way to launch and manage all the apps on your Mac. Like on iOS devices, you create folders.

Launchpad   |   THE BASICS
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Using Notification Center
OS X can alert you to emails, messages and other events

Notifications displays little pop-ups 
on your screen to tell you about 

emails, events, iMessages and more

There’s nothing worse than 
realising you were due in 
a meeting 10 minutes 
ago, or have forgotten a 

birthday. Luckily, Notification Center can 
make such disasters a thing of the past. 
It displays little pop-ups on your screen 
to tell you about a new email, an event 
in your Calendar, a new iMessage, or a 
note you’ve left for yourself using the 
Reminders app (see page 111). 

Notifications also appear in the 
Notification Center sidebar, which you 
access by clicking the rightmost icon in 
the menu bar. You can also place two 
fingers on the right-hand edge of your 

Mac’s trackpad and swipe left onto the 
trackpad to slide it into view. You control 
notifications mainly in System 
Preferences. Many apps also provide 
extra control over their notifications in 
their Preferences window – open the 
app in question and press ç+,.

Set your preferences
The Notifications pane in System 
Preferences provides overall control 
of how the system works. On the left 
is a list of apps that are able to display 
things in Notification Center. Past 
versions of OS X allowed you to drag 
and drop items between two lists to 
enable or disable them, but this is no 
longer the case in El Capitan. Below this, 
the ‘Notification Center Sort Order 
setting lets you choose the order in 
which notifications appear – El Capitan 
now gives you three choices: a straight 

chronological view, plus options to 
group by app – either by time received 
or by choosing your own sort order.

When you click an app in the list, 
you can decide the behaviour of its 
notifications. There are various ways an 
app can make you aware of something. 
Banners appear briefly in the top-right 
corner of the screen, then disappear 
into Notification Center. Alerts appear 
in the same place, but remain until 
dismissed.

You can decide whether an app 
can display things in the sidebar, and 
whether one, five, 10 or 20 items show 
up. You can opt to display a badge on 
an app’s Dock icon to indicate how 
many items await your attention, and 
whether it can play alert sounds. As you 
tick or untick the boxes, the summary 
text under an app’s name in the list 
alters to reflect your choices.

SKILL LEVEL
Anyone can do it

IT WILL TAKE
20 minutes

YOU’LL NEED
OS X 10.11
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1 Get started
We’ll show you how to customise the 

Notifications for the Mail app. The process is 
very similar for other apps, so once you’ve done 
this you’ll be able to do the same for all your 
apps. To get started, go to  > System 
Preferences and select Notifications.

4 Dock icon alert
The ‘Badge app icon’ tickbox refers 

to the little red circles with numbers in them 
which appear on the icons of certain apps in 
your Dock. In Mail’s case, this badge will appear 
when you’ve got new messages waiting to be 
read – a useful extra visual cue.

6 Ordering your list
Set the order in which things appear in 

the Notification Center using the ‘Notification 
Center Sort Order’ menu. If you want the newest 
alerts at the top, set it to ‘Recents’ or ‘Recents by 
App’, or choose ‘Manually by App’ to drag the 
apps in the list above into the order you want.

2 Find your app
In the column on the left, click Mail. We’ll 

start by deciding what kind of alert the app is 
allowed to display when a new email arrives 
and Mail is open. If you want to be sure you 
don’t miss an email, click Alerts, which remain 
on screen until you dismiss them.

5 Sounds
Lastly, you can enable or disable sounds. 

You can pick a different sound in Mail’s own 
Preferences, under General. Alongside that 
setting you can set Mail’s badge to reflect 
unread messages in more folders than just the 
inbox – useful if you sort messages using rules.

8 Notification Center
Now click the Notification Center icon at 

the far right of the menu bar, which will show 
you all recent Banners from your various apps, 
in the order you set up. Click a notification to 
jump to its app, or click the X alongside an app’s 
name to clear all its Notifications.

7 Receiving Notifications
Now, when a new email arrives and Mail 

is open, you’ll see the white bar appear in the 
top right of your screen. If it’s a Banner, it will 
soon disappear. If it’s an Alert, you’ll need to 
click either Close (to dismiss it) or Open, which 
takes you to the email.

3 How many entries?
The alternative option is a Banner, which 

will display for a few seconds and then vanish 
into the Notification Center. First, tick Show in 
Notification Center, then use the drop-down 
menu to the right to choose how many of this 
app’s items will appear there.

HOW TO | CUSTOMISE YOUR NOTIFICATIONS

Apps can show notifications on the lock 
screen (when you’re logged in but your 

Mac is locked). Review this for all apps to 
keep private stuff under wraps. Some apps, 
including Mail, let you hide notifcations or 

just message previews.

Lock screen alerts
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Decide which apps will attract your attention 

1

2

3

4

Selected apps
1  In this panel you will see the apps 

that can appear in your Notification 

Center. Removing apps is slightly different 

in El Capitan that previous versions of OS X: 

select the app, then untick ‘Show in 

Notification Center’ to hide it from view.

Alert style
2  Click an app in the list, and then 

decide on the right how it displays 

alerts – we explain the different options in 

box 3. Click on the Do Not Disturb option at 

the top to bring up its options and decide 

when you don’t want notifications. 

Other options
3  Choose here whether notifications 

show on your lock screen, how  

many alerts the app can display in 

Notification Center’s sidebar, and whether 

it can display a numbered badge on its icon 

or play sounds. 

Sort order
4  Use this menu to decide the order in 

which messages appear. ‘Recents’ 

displays them in chronological order; 

‘Recents by app’ groups them by app. 

‘Manually by app’ allows you to drag and 

drop apps into your desired running order.

THE BASICS   |   Notification Center
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One of the most 
noteworthy things about 
OS X is how it’s not just 
working more closely with 

iOS, but also adopting some of the best 
bits from the iPhone and iPad. The big 
revamp to Notification Center in iOS 8 
proved especially popular on mobile 
devices, enabling users to use the new 
Today view to see regularly accessed 
information, and add widgets to 
customise the experience.

The Today view made its way into 
OS X in 10.10 Yosemite, providing at-a-
glance views of calendar events, 
reminders, weather forecasts, stock 
prices, and more. It remains to be seen 
whether developers get behind the 
system as wholeheartedly as they have 
on iOS, but even though it’s still 
relatively early days there are a number 
of very useful third-party widgets 
available in the Mac App Store. Here 
we’ll show you how to use these and 
Apple’s default widgets, along with the 
Today view in general.

One thing worth noting if you try out 
a lot of widgets – and then discard a 
bunch of them that you don’t actually 
want to stick with – is that OS X has a 

tendency to cache them in memory, 
even if you uninstall their parent apps. 
A restart fixes this, but it’s quicker to 
open Terminal and reboot Finder by 
typing the command ‘killall Finder’. Hit 
®, and you’ll find your Finder windows 
briefly disappear and then reappear. 
When you open Notification Center, 
any uninstalled widgets will be gone.

Discover the Today view
Expand Notification Center’s Today view with add-on widgets

1 Open Notification Center
To access Notification Center, click the icon on the  

far-right of the menu bar. It then slides across, above other 
on-screen content. As in iOS, you get a Today tab for time-
sensitive info and widgets. If your screen can’t show it all, 
scroll up and down with a two-finger drag/swipe. 

2 Get started with editing
The first time you access Today view, you’ll see Apple’s 

default layout. The Weather app will ask for permission to use 
your location; click OK in the Weather widget. Click Edit (at 
the foot of the panel) to expand Notification Center to see 
installed widgets (left) and those you can add (right). 

HOW TO | GET STARTED WITH TODAY VIEW

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11, internet 

connection, Apple ID, 
one or more third-

party widgets

The system provides 
at-a -glance views 
of calendar events, 
reminders, weather 
forecasts and more

Yosemite’s Notification Center has become more useful by integrating the extensible Today view.

Screen 
Corner

If it can be fiddly 
to hit Notification 
Center’s menu-

bar icon, try 
dragging your 

pointer to a hot 
corner. Open 

Mission Control 
in System Prefs, 

click Hot Corners, 
choose a corner 
menu and select 

Notification 
Center. 

THE BASICS   |   Today view 
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5 Access weather details
Some widgets, such as Weather, provide more info 

when interacted with. By default you see current conditions, 
but click a location and an extended forecast is provided, 
showing the next few hours and also the coming days. Using 
the same process as step 4, you can add further locations. 

7 Add third-party widgets
You add third-party widgets in the same way as the 

built-in ones, and may need configuring. Note that Today 
view is primarily designed for ‘at a glance’ information that’s 
important to you, so put what you consider most useful at 
the top, and resist the temptation to install too many here. 

8 Interact and experiment
Some third-party widgets may interact with their 

associated parent apps. For example, if you use the 
Countdowns widget to set reminders, you’ll need to click 
the Settings button next to Add to open the main app if 
you want to edit any of your countdown timers. 

3 Switch some widgets
Widgets can be added/removed via drag and drop or 

using the +/– buttons. Try removing Stocks by clicking its – 
button; it’ll move to the right-hand pane. Add World Clock by 
clicking the + ; it’ll move to the left. Drag the drag-handles at 
the right of widget titles to reorder your installed widgets. 

6 Detect third-party widgets
The Today view in El Capitan is extensible, which 

means you can add third-party widgets installed via the Mac 
App Store. Also, some apps have an associated widget. When 
a new widget is detected by your Mac, the Edit button (at the 
foot of the Today view) will alert you about new items. 

4 Customise a widget
Various widgets can be customised. Click Done to stop 

editing, then move your pointer over the World Clock widget, 
and click the i to put the widget into edit mode. Click Add to 
create a new clock, then type and select a location for it. 
Drag the clocks to reorder them. Click Done when finished. 

Keyboard 
shortcut

To use the 
keyboard to 

activate 
Notification 

Center, open 
System Prefs, and 
select Keyboard > 

Shortcuts > 
Mission Control. 

Tick Show 
Notification 

Center, and click 
the shortcut area. 

Press your shortcut 
(such as ç+^) 

to define it.

JARGON 
BUSTER
Widgets are tiny 
applications that 
are typically very 
straightforward 

and often have a 
single, focused 
purpose. Many 

operating 
systems provide 

the means to 
house them in 
a single zone, 

rather than have 
them clutter 
your device. 

HOW TO | GET STARTED WITH TODAY VIEW CONTINUED

Today view   |   THE BASICS
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1 Trackpad options
If you’re using a trackpad (a laptop or a 

Magic Trackpad), you can also tap with three 
fingers on the item you want to preview. To 
close the preview, tap the spacebar again (or 
œ, or ç+Y), or click the X in the top corner 
of the Quick Look window. 

2 Multiple files
Quick Look can preview multiple files  

at a time, even if they’re different file types. To  
view multiple files, first highlight them all:  
click one, then ç-click on the others you want 
or ß-click another to highlight all the files in 
between that one and the first one you clicked; 
or press ç+A to select all the files in a folder. 
Then tap the spacebar (or your preferred 
shortcut). If you hold down the å key as you 
do so, Quick Look will open your file(s) in a full-
screen/slideshow mode. Confusingly, tapping 
the spacebar will now stop or restart the 
slideshow instead of exiting Quick Look as it 
normally does. Instead, you need to tap œ  
(or press ç+Y) to close it.

3 Look in the Trash
Quick Look even works with files in  

the Trash: if you try to open these by double-
clicking them, you’ll get an alert saying you 
need to drag them out of the Trash first, but 
Quick Look makes it easy to give them a final 
check before you empty the Trash and they are 
gone forever.

4 Preview the lot
If you have multiple files open in Quick 

Look, you can navigate them in various ways. 
You can click the previous/next arrows in the 
Quick Look window, or tap the left and right 

arrow keys on your keyboard. Usefully, tapping 
the up or down arrow will change which files 
are selected in the Finder beneath, and Quick 
Look’s window will update to preview whatever 
file is selected.

5 Index sheet
If you’ve selected multiple items, you 

can view them in an ‘index sheet’ rather than 
one at a time: click the icon for this or press 
ç+® to swap to this view and back again.  
If the items won’t fit on a single index sheet, 
scroll the page to see more, or tap the Page 
Down key on your keyboard (or use ƒ plus 
the down arrow if it doesn’t). Use the same 
controls to view later pages of PDFs and other 
files with multiple pages.  

6 Zooming in…
Quick Look is designed only to preview 

files, but it is sometimes possible to zoom in for 
a closer look: try holding down å and clicking 

or scrolling with your mouse scrollwheel if it has 
one; click-and-drag to move the image around 
when zoomed in; release å to zoom out again.

7 Share from Quick Look
In OS X El Capitan there’s also a button to 

Share the current file – send it to contacts via 
email or iMessage, copy it to a nearby Mac using 
AirDrop, add it to iPhoto, post it to Flickr and so 
on. The options you get here may vary 
according to the type of file and which social 
networks you’ve enabled. 

8 Quick Look plug-ins
There are file types Quick Look can’t 

preview by default. Fortunately, you can install 
plug-ins to enable it to handle additional file 
types. Take a look at quicklookplugins.com, for 
example (making sure that the plug-in you’re 
interested in will work under El Capitan). Then 
you simply download the one you’re after, add it 
to Library/QuickLook and restart.

View files with Quick Look
Get a preview of your files with one of the handiest OS X features

You don’t need to open an image or 
other file to take a quick look at it, 
thanks to a built-in feature in OS X 
called – what else? – Quick Look. All 

you need to do is simply click the file in the 
Finder to highlight it, then tap the spacebar to 
preview it. Alternatively, you can press ç+Y, 
go to File > Quick Look on the menu bar, or 
right-click the file and select Quick Look from the 
pop-up menu that appears.

If you select multiple files, 
Quick Look has the option to 
view them on a single ‘sheet’ 
– ideal for comparing!
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1 Add widgets
Open Dashboard and click the + symbol 

in the bottom left of the screen to open the 
Widget Gallery. This contains all your installed 
widgets, but not all of them are displayed on 
your Dashboard by default. Just click on the 
widget you want to add (one at a time).

2 Remove widgets
To remove a widget from Dashboard, first 

click the – sign (bottom-left), then click the X 
that appears on its icon. It will vanish with a cute 
animation. To delete a widget entirely, first click 
the + to open the Widget Gallery, then click-
and-hold on the unwanted icon, then click its X. 
As simple as that.

3 More widgets
There’s a huge range of additional 

widgets available, both for practical uses (parcel 
tracking for example) and just for fun (how 
about William Shatner facts?). In the Widget 
Gallery, click on More Widgets to go to the 
widget download page in Safari. Select a 
category, then a widget, and click on More Info 
to find out about it.

4 Can’t install?
If you want to give a widget a try, click 

the Download link. Once it’s downloaded, OS X 
will ask you to confirm that you want to install it. 
Depending on your security settings, however, 
you might sometimes get an alert saying that 
the widget can’t be installed. Don’t worry, 
though. Click OK in the alert to dismiss it, then 
return to Finder, open System Preferences and 
click Security & Privacy. At the bottom of the 
preference pane is the relevant setting 
controlling which apps can be installed. 

Dashboard   |   THE BASICS

Dashboard is a great way to quickly access mini 
apps and information – all at the press of a key!

5 Install anyway!
However, you don’t need to change the 

setting in the previous tip – doing so could be 
risky. Instead, verify that the text at the bottom 
of the Security & Privacy pane is the same as the 
widget you’ve just tried to install, and if so, 
simply click Open Anyway. With this one-off 
permission, the widget will appear in your 
Widget Gallery in a shimmer of sparkles.

6 Dashboard appearance
By default, Dashboard opens as a ‘space’ 

with a blurred version of your desktop 
background. If you prefer, you can make it 
transparent, so your widgets seem to ‘float’ over 
your desktop. To do this, simply open System 
Preferences, select Mission Control and change 
‘Dashboard: As Space’ to ‘As Overlay’. In this 
mode you’ll be able to close Dashboard simply 
by clicking on the desktop behind it. Or, if you 
wish, you can completely disable Dashboard by 
selecting ‘Dashboard: Off’.

7 Widget preferences
To configure a widget’s settings and 

preferences, simply click the i that appears in  
its bottom corner. The widget then flips over to 
reveal the options you need.

8 Web clips
You can add a shortcut to a web page or 

service to your Dashboard, so that when you 
click this, you’ll be taken straight to the live page 
in Safari. First open the web page in Safari, then 
go to File > Open in Dashboard. A highlight box 
appears on the web page. Move the mouse 
pointer to highlight any area that will help you 
recognise the site, then click. Drag the corner 
handles to make the box as big as you want the 
widget to be. Now click the Add button and the 
widget will appear in your Dashboard. Click its i 
button to change its look; click i and then Edit to 
adjust its size or drag within the frame to change 
what part of the page is visible – it will update 
whenever that part of the page updates.

Discover the Dashboard
Use this customisable control panel for handy gadgets and widgets

Dashboard gives you quick access 
to a large selection of useful utilities 
and mini apps called widgets. There 
are a number of ways you can 

access Dashboard, the easiest being to click the 
Launchpad icon in your Dock and then click 
Dashboard, or (once Dashboard is running) just 
press the ™ key. (If you prefer, you can set a 
custom shortcut in System Preferences > Mission 
Control.) Let’s take a look at what it can do…
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Spotlight has long 
made it easier to find 
content on your Mac, 
and, more recently, 

online. By OS X 10.10 Yosemite, you 
could search for local documents, 
perform quick conversions and 
sums, and locate nearby stores and 
restaurants. With OS X 10.11 El 
Capitan, Spotlight has access to a 
number of new sources. Now, you 
can get the weather forecast for 
anywhere in the world, find out the 
latest sports scores, and check 
transit information for locations 
covered by Apple Maps. 

Spotlight has also gained some 
natural-language smarts. The idea 
is you type a search query as a 
phrase – ‘email from Paul in April’; 
‘spreadsheet I worked on last week’ 
– and get relevant results. 

More generally, it’s worth noting 
Spotlight is navigable using the 
keyboard. ç+Space opens it, of course, 
and you can use … and æ to navigate 
the results list. For a selected item, 
ç+r, I, and b, respectively reveal 
it in Finder, get its info, and search for 
the term in Safari. œ clears the search 

term. Press ‘ and the current selection 
becomes the new search term 
(updating the results accordingly). 
ç+z acts as an undo. You can also 
hold ç to find the path to any selected 
document. All these are great time-
savers for the keyboard-centric.

Spotlight in El Capitan
More easily find things on your Mac – and beyond

1 Weather forecasts
Type ‘weather’ and you should get a result under the 

title ‘weather’ and/or ‘top hits’. Select it to see current 
conditions, predictions for the next six hours, and a ten-day 
forecast. Tap Return to visit Weather.com. To see the forecast 
for a specific location, add the location after ‘weather’. 

2 Sports scores
Scores for (mostly American) sports can be found, 

such as American football and baseball, but the English 
Premier League and other major football leagues are also 
available. Type something like ‘Arsenal score’ and you’ll find 
the most recent result. Scroll down and you’ll see fixtures. 

HOW TO | DISCOVER SPOTLIGHT’S BEST FEATURES

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11, a web 
connection, some 

documents for 
Spotlight to search

TAME 
RESULTS
Visit Spotlight 

in System 
Preferences and 

click Search 
Results. If there 

are certain 
results you 

don’t want to 
appear, untick 
the relevant 

checkboxes. To 
remove the 

smart results 
noted elsewhere 

in this 
walkthrough, 

untick Spotlight 
Suggestions. 

With Spotlight, you 
can get the weather 
forecast for anywhere 
in the world

Spotlight in El Capitan has a number of new tricks, such as natural-language search
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5 Online videos
In theory, Spotlight enables you to quickly find 

online videos, but right now the system appears limited. 
Type in a search term – be specific – followed by ‘YouTube’ 
or ‘Vimeo’ and you might get a result. Hit Return and Safari 
will open to play your chosen video. 

7 Local shopping
This isn’t new to El Capitan, but Spotlight enables 

you to access other information lurking in Maps. Type 
‘Apple Store’ and you’ll see your nearest stores under a 
Maps heading. Many other terms are recognised: cinemas, 
pubs, shopping, even types of food. 

8 Recent apps
For compatible apps, search for and select an app and 

recent documents will be listed under the icon in the preview 
area. You can click one to open it. If you’re wedded to the 
keyboard, you can instead hit Tab to move your focus to the 
documents list, and then use the arrow keys and Return. 

3 Fixtures and squads
To see the results of a specific game without looking 

through the fixtures list, use a search term along the lines of 
‘Chelsea Everton game’. You can see a team line-up using the 
rather American-sounding ‘roster’. So ‘Liverpool roster’ or 
‘Yankees roster’ will list a team’s players and their positions. 

6 Transit info
At present, transit is disappointingly limited in Apple 

Maps, and it’s of perhaps limited use in Spotlight anyway, 
unless you cart a MacBook about. In the UK you can type in 
a London station to list its connections, see photos of the 
station, and, somewhat bizarrely, see reviews on Yelp. 

4 Stocks and shares
Apple seems obsessed with stocks and shares, given 

that it welds a Stocks app to every iPhone, so at least some 
people must find this information useful. If that’s you, type a 
ticker symbol into spotlight to see the current share price. 
You can also type a company’s name, followed by ‘stock’. 

GET SOME 
PRIVACY

If you don’t want 
Spotlight fishing 
around specific 

folders, drag 
them to the 

Privacy list in the 
Spotlight System 

Preferences 
pane. Note that 

if you use a 
cloning app, 
adding the 

entire drive is a 
good idea, 

because 
otherwise 

Spotlight will 
index it.

JARGON 
BUSTER
Drag and drop: 

In El Capitan, the 
Spotlight 

window can be 
dragged 

anywhere on the 
screen. You can 

also drag from its 
bottom edge to 
resize it vertically 

(although not 
horizontally). To 
revert Spotlight 

to its default 
position, click-
hold its menu-

bar icon for a few 
seconds. Also, 
note you can 

drag documents 
you find in 

Spotlight, to 
make a copy 

in Finder. 

Spotlight   |   THE BASICS
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Setup & preferences
Make OS X work for you

70 Setting up your desktop
 Customise Finder to suit your needs

72 Alter the look of your Mac
 Change your desktop, screen saver and more…

74 Setting OS X preferences
 Modify your Mac in System Preferences

76 Using iCloud with a Mac
 Backup your data and sync with other devices

78 Set up iCloud Keychain
  Sort out your various passwords

79 Manage user accounts
 Control who does what on your Mac

80 Get more information about your Mac
 System information is at your fingertips

82 Enable El Capitan’s dark mode 
 Don’t like the colourful interface? Just mute it

84 Manage multiple displays 
 Make sense of multiple docks and menu bars

85 Master your mouse 
 Control your keyboard, mouse and trackpad

86 Set up your sound
 Fine-tune your sound settings and use AirPlay

87 Using Bluetooth
  Pair up with speakers, printers, headphones

88 Set up a printer
 Discover El Capitan’s built-in printer support

89 Network and sharing
 Set up a home network and share files

93 Move tasks between devices 
 Use Handoff to work on the go 

94 Facebook integration
 Stay in touch with built-in Facebook sharing
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VISUAL GUIDE | FIND YOUR WAY AROUND FINDER

1

2 3

5

6

7

4

Setting up your desktop
Configure Finder’s many options so it looks and works as you like

No windows?
1  When you start up your Mac, do you 

see just your background image? To 

open a window, click the Finder icon in the 

Dock (it’s always at the far left), press 

ç+N (the shortcut for File > New 

Finder Window), or double-click the hard 

drive icon on your desktop, if one appears.  

Sidebar
2  The Finder window sidebar gives you 

quick access to various folders – click 

one and the window changes to display its 

contents. You can change the order of items 

and add new items here, including Smart 

Folders, which you don’t have to add items 

to – instead, they automatically update to 

display content that matches the criteria 

you preset. The ‘Tags’ folders in the sidebar 

work like this. See facing page for more. 

View options
3  Different windows can display their 

content in different ways. Just click 

one of the four view buttons in the toolbar 

below the window’s title to set its view. Icon 

view is great for clarity; use the slider that 

appears in the window’s Status Bar (bottom 

right) to resize the icons. List view is ideal if 

Get to grips 
with the various 
elements of the 
OS X desktop

You can change 
a range of things, 
from the shortcuts 
in the sidebar to 
the view settings

Whether you’re coming to OS 
X from Windows, updating 
from an older operating 
system or entirely new to 

computing, there’s a lot to take in. The 
more you use a Mac, the more you want to 
configure every little detail to suit the way 
you want things to look and work. We’ll 
start by showing you how the different 
parts of the desktop and Finder windows 
work, and how to set them up.

There’s a surprisingly wide range of 
things you can change, from which 

shortcuts appear in the sidebar of Finder 
windows to how the contents of each 
window are displayed (as icons or in a list, 
etc), but some settings affect all windows 
(like what the sidebar includes) and some 
only a single window (like the view style 
and whether the sidebar and other 
window elements are displayed at all).

Let’s take a look at how to tailor the 
Finder to your own preferences so that 
you can locate, view and manage your 
files and documents the way you want 
and make your Mac even easier to use.

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11

you like to reorder items by date or size, say, 

instead of filename – just click on a column 

heading to sort by that criterion. Cover Flow 

is a kind of hybrid of the two, and Column 

View displays folder levels hierarchically, 

plus a handy preview of the selected item.  

Window elements
4  From the View menu you can choose 

to hide or show window elements 

such as the sidebar, the Path Bar, which 

displays the location of items hierarchically, 

and the Status Bar, which details selected 

items and, where relevant, free drive space. 

Tags
5  To tag an item, right-click it and select 

a tag, click tags in the sidebar, or click 

Add Tags under Column View’s preview.

Dock options
6  Click System Preferences > Dock and 

you can choose whether the Dock lies 

at the foot of the screen or either side, how 

large it is, whether it’s always visible or pops 

up when you mouse near it, and whether 

icons magnify as you mouse over them – 

handy because Dock icons become smaller 

when there’s a large number of open apps.

Quick folder access
7  Drag a folder into the Dock to create 

a ‘stack’ for fast access to its contents. 

Right-click to set how it opens, its sort order 

and more. Minimised windows also appear 

here, and you can even drag files here.
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Find out which features of OS X can put controls and status indicators in the right-hand side of the menu bar.

HOW TO | CUSTOMISE THE FINDER

1 Customise the sidebar
To specify what appears in Finder window sidebars, 

go to Finder > Preferences, click the Sidebar tab and tick the 
items you want. To add a specific folder to the sidebar, simply 
drag it to the sidebar between existing items in the Favorites 
section – a blue line shows where it will appear; let go when 
it’s in the right spot. To add a file, disk or app, click the item 
to highlight it and then go to File > Add to Sidebar or press 
ç+≈+t; it will appear at the foot of the Favorites.

To change the order of items in the sidebar, simply drag 
them up or down the list (within their section – you can’t 
drag Favorites under Shared, for example). To remove items, 
either right-click and select this option or just drag them out 
of the sidebar and they’ll vanish in a puff of smoke. (To add 
them again, go to Finder > Preferences > Sidebar and tick the 
items you want.) You can’t reorder or remove items in the 
Shared category, but you can hide them by mousing over the 
heading and clicking Hide. To hide an entire category, go to 
Preferences and untick all the options under that category.

2 Add Smart Folders to sidebar
The items in the Tags section in the sidebar aren’t 

mere folders but more like saved searches: you don’t add 
items to them yourself, but clicking one displays matching 
items automatically. Before OS X 10.7 Lion, the sidebar 
included Smart Folders to quickly display items created 
Today, Yesterday or in the Past Week, All Images, and so on. 
Here’s how to restore these handy options. We’ll use Today 
as an example. From the desktop, press ç+F to open a 
search window. Change the Kind drop-down to Created 
Date, then the second drop-down to ‘today’. Now click the 
Save button in the top-right of the window. Name the Smart 
Folder ‘Today’, and ensure that Add To Sidebar is ticked. Click 
Save, and the Smart Folder appears in the sidebar; move it up 
or down the list as before. Repeat for any or all of the other 
search options you want quick access to.

3 Customise the toolbar
In addition to hiding or showing various Finder 

window elements, you can customise the toolbar – the row 
of buttons that appears beneath a window’s title. Go to View 
> Customize Toolbar and drag the buttons you want into the 
current window’s toolbar; drag items out to remove them. 
While the panel is open, you can also drag buttons left or 
right to change their order. All your windows will be affected.

4 Quick navigation
A window’s title bar isn’t just for information: right-

click on the title to see the path to the folder you’re viewing; 
click on any of the enclosing folders to jump out to that level 
of the folder hierarchy.

5 Navigate with keystrokes
Especially if you have lots of folders packed with 

items, it can be quite tedious to navigate through them by 
scrolling and clicking. If you have an idea of where you want 
to go, using the keyboard can be much faster. It can also be 
easier for users with certain motor difficulties. To view your 
Applications folder in the current window, press ç+ß+A; 
to view the contents of the Desktop as a folder, ç+ß+D; 
for your Documents folder, ç+ß+O. For other shortcuts, 
look in the Go menu. Usefully, these shortcuts also work in 
most Open and Save dialogues too.

6 Which way is up?
By default, when you want to scroll the contents of 

a window to see more, you roll your mouse’s scrollwheel (or 
swipe a finger on a Magic Mouse or trackpad) in the direction 
in which you want the content to move, as if pushing a piece 
of paper. This is called ‘natural scrolling’. If you prefer the 
opposite (the way scrollbars used to work), go to System 
Preferences > Mouse or Trackpad (the setting is independent 
for each). Under Scroll & Zoom, untick ‘Scroll direction: natural’. 
In System Preferences > General, you can choose whether 
scroll bars are always visible or hidden until you start scrolling.

7 Menu bar items
At the right-hand end of the menu bar, you’ll find icons 

that display the status of various features of OS X, such as 
sound volume, Wi-Fi and (on laptop models) battery power; 
click one to view or change its settings. To see which features 
offer this, open System Preferences, click in the Search box at 
the right-hand side of its title bar, and type ‘menu bar’. In 
addition to a list of results, the relevant panes are highlighted. 
Third-party apps like Dropbox use menu bar icons to give you 
easy access to commonly-used features, too.

QUICK 
TIP

Removing items
When you drag a 

shortcut out of 
the Dock or the 
Finder window 

sidebar to 
remove it, the 

icon vanishes in 
a puff of smoke. 

Don’t panic, 
though: the app 

or folder itself 
won’t be deleted! 
The exception is 
Smart Folders – 
to add one back 
to the sidebar, 
you’ll need to 

save it again as 
in step 2.
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Since the arrival of OS X 
more than a decade ago, 
Apple has had a tendency 
to lock down its operating 

system’s visual appearance in order 
to ensure as much user interface 
consistency as possible. By contrast, 
it was possible to customise the 
appearance of older versions of the 
OS to a far great degree, much to the 
delight of Mac buffs, who have always 
tended towards individualism (if not 
occasional eccentricity…). 

Options for ‘reskinning’ OS X have 
been few in number and have quickly 
fallen out of favour. This is mostly 
because making major changes has 
become an increasingly complex matter, 
meaning it risks leading to system 
instability. You might want a Mac to look 
like something from your favourite sci-fi 
film, but that’s not such a joy when 
your computer becomes less reliable 
as a consequence. That’s why previously 
popular programs such as ShapeShifter, 
which enabled you to make sweeping 
changes to the whole look of the 
desktop, were never even updated to 
Leopard (OS X 10.5), let alone El Capitan.

Nevertheless, Apple realises you need 
at least a few customisation options, 
if only to personalise your Mac a bit. 

Accordingly, you can change your Mac’s 
desktop background and screensaver; 
it’s also possible to make minor changes 
to various global appearance settings,  
including muting system-wide colours 
– a useful option if you don’t want 
any visual distractions.

If you’re really brave, or very 
experienced, and you don’t mind 
messing about in configuration files  
and other technical niceties without  
a friendly UI to guide you, you could 
always try GeekTool (http://projects.
tynsoe.org/en/geektool). As the name 
implies, this utility is aimed at the more 
knowledgeable user and is meant for 
more than decorative ends, but if you 
get to grips with it you’ll be able to 
create amazing customisations.

Alter the look of your Mac
Use the Appearance and Desktop & Screen Saver preferences

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11

You can change your Mac’s desktop 
background, screensaver and some  
minor global appearance settings
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1 Desaturate interface
Launch System Preferences and select 

General in the top group. In the Appearance 
menu you can choose from Blue or Graphite. 
The first of those is the default; select Graphite 
and traffic light window buttons, menu handles, 
checkboxes, and more, turn grey.

4 Fewer Recent Items
The Recent Items menu shows 10 items 

each for applications, documents and servers 
by default, but you can choose from 50 right 
down to none. Your choice is reflected in the 
 > Recent Items menu; set this to None and 
the menu item disappears altogether.

6 Change your desktop
In the Desktop & Screen Saver pane, 

select a sidebar group and then an image to 
change your desktop. For a slideshow, click 
Change picture, and configure options to taste. 
Custom folders from Finder can be dragged to 
the pane, and appear under Folders.

2 Update highlights
Highlighted text is shown in blue in the 

foreground and grey in the background. Use the 
Highlight Color option to amend the foreground 
colour, such as making it Graphite (or silver) 
when using the Graphite option. If you wish, 
you can use Other… to select a custom colour.

5 Hide the menu bar
You’ve long been able to hide the Dock 

in OS X. In El Capitan, the menu bar can similarly 
be hidden. In General, tick Automatically hide 
and show the menu bar. The menu bar will 
disappear. It will subsequently be visible when 
you move the cursor to the top of the screen.

8 Reduce transparency
Desktops show through the menu bar. If 

your picture is detailed, this can make the menu 
bar hard to read. Go to the Accessibility pane, 
choose Display, then tick Reduce Transparency. 
This makes the menu bar solid, but also removes 
transparency from elsewhere in OS X.

7 Change screensaver  
Still in the Desktop & Screen Saver pane, 

click the Screen Saver tab. Select an option in 
the left-hand pane, and set how soon it kicks in. 
Click the pic in the right pane to preview it. Click 
Hot Corners… to choose where you can move 
the pointer to manually start the screensaver.

3 Scrolling and icon size
There are a number of settings here that 

determine the visibility of scrollbars. They’re set 
to Automatic by default, but you can force them 
on by selecting Show Scroll Bars: Always. You 
can also alter the size of icons in the sidebar of 
Finder windows.

HOW TO | CHANGE YOUR MAC’S VISUAL APPEARANCE

A screensaver is ideal if others could 
access your Mac while you’re away from 

it. In System Preferences > Security & 
Privacy, you can specify that a password 

is required to unlock your Mac once 
the screensaver has kicked in.

Screen protection
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2

11

4
5

1

3

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11

The System Preferences window is your 
Mac’s nerve centre: if you want to tweak 
how something works in El Capitan, this 
is where you’ll usually do so. You’ll find 

System Preferences in the  menu. It’s laid out in rows 
of easily identifiable icons with a brief name description 

given underneath. Clicking 
each icon opens what’s 
known as a pane with the 
available settings within.

When viewing a pane, 
clicking the button with a 
grid of dots at the top will 
take you back to the main 
window, or you can use 
the back and forward 
buttons at top left, similar 
to those in Safari. Here, 

we’ll show you the essential options that every new 
Mac owner needs to check out, such as security and 
internet accounts, and others that simply help to 
personalise your Mac.

Setting OS X preferences 
Master System Preferences to get your Mac working your way

4 Each to their own
Everyone who uses your Mac can have their 

own account, enabling them to set their own desktop 
background and work in their own environment, 
without having access to your setup. After you set up 
multiple accounts, your Mac starts up with a login 
screen, and accounts can be switched at any time 
within OS X. It’s best to 
use a Standard account 
most of the time and log 
in as Administrator when 
needed. To apply Parental 
Controls, select an account 
and then tick ‘Enable 
Parental Controls’. See step 
5 for more details.

1 Colours
To alter the colour that appears 

when you highlight text, click General 
and make your choice from the second 
drop-down menu, labelled Highlight 
Color. If you’re not happy with the 
standard hues, why not choose your 
own? Simply select the Other… option, 
which will open up a colour picker 
wheel. The top drop-down menu 
enables you to switch the standard OS X 
blue colour to graphite (or grey, to most 
of us). This is the colour you see in scroll 
bars and whenever you click menus. 

2 Stop dozing off
To prevent your Mac going to sleep after 

a short time, open up the Energy Saver pane. This 
contains sliders where you can set how long your 
computer must sit idle before it goes to sleep. If 
you’ve got a notebook, you can set different times 
depending on whether you’re plugged into the mains 
or running off the battery. The Energy Saver pane is 
also where you can schedule your Mac to start up 
or shut down at a specified time. Note that this is 
separate from the screensaver, which you configure 
in the Desktop & Screen Saver pane.

3 Internet Accounts
El Capitan makes it easy to set up 

accounts for all your favourite email 
services and social networks, with many 
settings preconfigured for you. All you 
have to do is add your login details and 
El Capitan will do the rest. To add an 
account, click the + button on the 
bottom left of the pane and then 
choose the service you want to set up. 
You can also set up accounts manually 
using the Add Other Account option.

6 Notifications
Mirroring the iOS equivalent, El 

Capitan has a Notification Center. Click 
the button at the far right of the menu 
bar and you get two tabs: Today shows 
widgets you can arrange and install; and 
Notifications lists alerts from apps, such 
as missed calls and Facebook messages. 
In the Notifications pane, you define 
how and when alerts appear.

5 Parental controls
Do you want to stop your 

children opening certain applications or 
websites? Parental Controls is where you 
ensure they stay safe. It even attempts to 
block adult content automatically, or 
you can set a list of banned sites 
manually. You can also limit how long 
the kids can spend on your Mac, prevent 
them changing their password and hide 
profanity in Dictionary.
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6

7

8

9

10

7 Share and share alike
Sharing files over your home wireless or wired 

network is easier than you may think. The Sharing pane 
contains a list where you can switch the various services on 
and off, including screen, file and printer sharing. If you’re 
not sure what a particular option does, click its name and 
an explanation will appear top right. Below this, you’ll see 
further settings – usually, who you’d like to give access to. 
See page 90 for more.

11 Changing desktop
Bored with the background image on your desktop? Set an alternative in 

the Desktop & Screen Saver pane. In the left column, pick a folder that has images in 
it, and tick ‘Change picture’ below. Use the drop-down menu to decide how often it 
changes. Avoid the five-second and one-minute options, as the constant swapping 
just gets distracting – if you want to look at your photos like this, try a slideshow!

9 Lock it down
Even if you’re the only 

person who uses your Mac, it’s 
worth keeping your machine 
safe. Use the Security & Privacy 
pane to require a password 
to wake your Mac from its 
screensaver, to disable automatic 
login, and to set up the FileVault 
encryption system. It may also be 
worth setting up the firewall (but 
note that it may prevent some 
apps from working unless you 
specifically grant them network 
access). Manage this by clicking 
the Firewall tab followed by the 
Firewall Options… button.

10 Search Bar
If you’re not sure where 

a particular option lives, try typing 
some keywords into this search bar. 
A drop-down list will show you the 
named preferences that match, 
and as you use the up and down 
arrow keys to move through that 
list, you’ll see the relevant pane’s 
icon highlighted. Click it to jump to 
the correct pane. Note that you can 
also search System Preferences’ 
panes using Spotlight. Press ç 
plus the spacebar and type your 
keywords – the results will appear 
in the System Preferences category.

8 Sound settings
Most of the time, the 

volume keys on your Mac’s 
keyboard are all the audio control 
you need, but the Sound pane 
offers that little bit more. You can 
select input and output devices, 
which you’ll need to do if you use 
your speakers during the day but 
want to switch to headphones in 
the evening. Another useful setting 
to note here is the audio input 
level – tweak this if you use a 
microphone with OS X’s speech 
recognition features, for example.
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Do you use an iPad, iPhone or iPod touch in 
addition to your Mac? Assuming it runs iOS 5 or 
later, you can make use of a free Apple service 
called iCloud.

To put it simply, iCloud enables you to sync your music, 
photos, contacts and various other kinds of data – including 
your documents – wirelessly and automatically to the ‘cloud’. 
This means that they’re stored on Apple’s servers and are 
available on any compatible devices – your iPad, iPhone, iPod 
touch, Mac or PC – wherever you might be and whenever  
you need them (as long as you can get online and open  
a web browser).

Even if you have just the one Mac and no iOS devices (we 
know, we know, it’s very unlikely!) it’s worth linking it to iCloud, 
so that you’ve got an online backup of your stuff – the service 
works seamlessly with many of your Mac’s built-in apps, 
including Mail, Calendar and Safari.

Apps can access your iCloud Drive directly in the Open and 
Save windows, so it’s like an extra remote drive (see page 108). 
Here we’ll show you how to set iCloud up on your Mac, and 
also how to use Find My Mac, a key feature (accessible from an 
iOS device or on the web) that enables you to pinpoint your 
Mac’s location if it goes astray (but remains online), send a 
message to it so that whoever finds it can contact you to 
arrange its return or, if you’ve given up hope of getting it back, 
even wipe all your data remotely.

You can also keep track of all of your iOS devices and 
perform the same locking/wiping actions on them (it’s very 
handy being able to wipe your data if you lose your iPhone!).

iCloud can keep a whole range of things in sync between 
all your devices, including iCloud.com emails, notes, calendars, 
contacts, Safari bookmarks, website logins, documents and 
data from compatible apps, and more. You can decide which 
of these things you want to keep synchronised. What it 
doesn’t do is back up much of the other contents of your 
Mac’s hard drive; you’ll still need to use your Time Machine 
or online backup routine to take care of that.

Using iCloud with a Mac 
Wireless backup and syncing with other computers and iOS devices

3 Configure your  
iCloud backups  

Following on from tip 2, tick or untick the boxes 
to set what is synced with iCloud (and therefore 
your different Macs and iOS devices). You can 
choose to sync Mail, Reminders, Notes, Contacts, 
Calendars and more – explore the list and see 
what’s right for you. Some offer further options. 
At this point, if there’s an alert symbol next to 
Find My Mac, click the adjacent button. 
Resolving it might be as simple as enabling 
‘Wake for network access’ in System Preferences 
> Energy Saver.

1 Enable iCloud  
First of all, you have to 

enable iCloud in El Capitan. To do 
this, click  > System Preferences > 
iCloud and sign into your account 
(or create one if you haven’t done 
so yet). Enter your Apple ID and 
password (see boxout over the 
page) then click Sign In. For now, 
we’ll enable both data backup  
and Find My Mac, but we can 
easily tweak what’s backed up 
(which we look at in tip 3).

2 Location 
Services  

Naturally, it’s essential to grant the 
Find My Mac service access to your 
location for it to do its job. If you’re 
happy with this, click Allow. You 
might be asked to OK various other 
options, after which you’ll see a list 
of the different bits of data that 
iCloud can sync with your Mac.

SETUP & PREFERENCES   |   iCloud

If you’ve set up Find My Mac and your Mac is 
connected to the web, you can find where it is. 
On an iPhone, iPad or iPod touch, install the Find 
My iPhone app. On a Mac or PC, use a web 
browser to go to www.icloud.com and sign in. A 
map will load with all your registered devices 
shown as pins. To locate one, click All Devices and 
choose its name from the list. If you’ve misplaced 
your Mac or fear it’s fallen into the wrong hands, 
click its name to see your options: you can make 
it play a sound to help you locate it, make a 
message appear on its screen, remotely lock it or 
wipe all the data. 

Find a lost Mac
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4 Buy more storage
You get 5GB on iCloud for free. But as you 

add things (on all your devices), the capacity bar 
at the bottom fills up. And believe us, it doesn’t 
take long to fill up that space (especially if you 
want to backup one or more iOS devices). You 
can however, click Manage to cull your backups 
of large apps or other devices, or – perhaps a 
more sensible option – click Buy More Storage. 
A 50GB plan costs  just 79p a month, and you’d 
be foolish not to upgrade for that price. You can 
also upgrade to 200GB (£2.49 per month) or a 
whopping 1TB (£6.99 per month).

Apple has long utilised cloud sync for photos with 
Photo Stream, but  iCloud Photo Library takes things 
further, keeping all your photos and videos in the cloud. 
It’s available with iOS 8.3 and later, or OS X 10.10.3 and 
later, or online by using the Photos app at iCloud.com. 
Note that you may need to buy more iCloud storage to 
use iCloud Photo Library. Also, don’t rely solely on it – 
always keep local back-ups of your photos and videos.

5 Access over the web
If you’re away from your Mac and need to 

access something in iCloud, you can do so from  
any computer connected to the internet. If you try 
to access the site from an iOS device it will refer you 
to setting up your iCloud account – and if you’re 
trying to use an Android phone or tablet you may 
get an unsupported browser warning. Go to www.
icloud.com and sign in on the Mac or PC you’re 
using. This provides you with access to your iCloud.
com email, contacts, calendars, notes, reminders, 
photos and more. It’s handy to know your data is 
just a click away, wherever you are.

6 Get your 
documents  

If you enabled iCloud Drive, you 
can click its icon at icloud.com to 
download your files, edit them 
locally in whatever software is 
available, then upload them again. 
You can even use web app versions 
of Pages, Numbers and Keynote 
within your browser in OS X, 
Windows or Linux. 

iCloud   |   SETUP & PREFERENCES

Using iCloud, photos, calendars, songs, apps and other data can be synced across your OS X and iOS devices.

Your Apple ID

iCloud Photo Library
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1 Get started
Open System Preferences and click  

the iCloud icon. We’ll assume you’re already 
signed into your account (see pages 76 and 77).  
Scroll down the list of features and turn on  
the Keychain option, enter the password for 
your Apple ID, then click the OK button. 

2 High security
Enter a four-digit security code, or see tip 

3 for stronger options. If you forget it, Keychain 

can’t be set up without resetting the online 
copy – an existing copy can be retained on your 
Mac to start over, though. Enter a code, click 
Next, then confirm it.

3 Set a stronger code
Alternatively, click Advanced to set a 

more complex code that can contain letters 
and symbols, or to have a complex, 24-character 
code generated for you – you’ll probably want 
to write that one down and keep it somewhere 
safe because it’s hard to memorise (unless you 
have a photographic memory, that is).

4 Risky situation
Choosing to have no security code 

doesn’t make your account less secure, but it’s 
troublesome if you have only one device and 
it’s lost or becomes inoperable. You won’t be 
able to set up Keychain on a replacement 
device and will have to start over from scratch.

5 Verification codes
Enter a mobile phone number that can 

receive SMS messages, then click Done to finish. 
Keychain is now ticked in iCloud’s preferences. 
Messages are sent only when you try to enable 

Keychain on another device, which requires a 
verification code from the SMS.

6 AutoFill in Safari
In Safari’s preferences, click AutoFill and 

tick ‘User names and passwords’. When you log 
in to a website, Safari asks whether to save 
your credentials to iCloud Keychain. Of course, 
this isn’t compulsory for every website – you 
might exclude your online banking details.

7 Bank cards
Also under AutoFill is an option to 

remember bank cards. Cards can be removed 
and amended by clicking the adjacent Edit 
button. If Safari recognises you’ve entered 
card details in a form, it offers to store them – 
except the signature strip’s security code.

8 Sync across devices
When you enable Keychain on another of 

your Macs running El Capitan or on your iPhone, 
iPad or iPod touch with iOS 7 or later, you’ll be 
asked to approve the action from a device on 
which it’s already set up, or get a verification 
code sent to the mobile phone number you 
specified earlier (see tip 5).

Set up an iCloud Keychain
Access website logins and bank cards on all your Apple devices

Remembering login details for a 
multitude of websites isn’t easy. 
Passwords either end up being 
difficult to remember, or you make 

them so simple that they’re easy for others to 
work out. But Safari and other web browsers can 
save your credentials so you can set a stronger 
password and never have to memorise it.

You might want to log in to the same websites 
on an iPhone, iPad, iPod touch or another Mac. 
iCloud Keychain saves you having to enter the 
same login details on all of your devices. It can 
remember bank card details as well – but it won’t 
store the security code from the signature strip. 
Apple says that your Keychain is protected with 
256-bit AES encryption.

Secure your 
keychain

1  Setting up iCloud 

Keychain involves 

more than just ticking 

a box in iCloud’s 

preferences. You’ll need 

to set a security code, 

and remember it to 

sync the keychain to 

additional devices.

Safari asks for 
permission

2  iCloud Keychain 

depends on 

Safari’s AutoFill feature. 

When both things are 

turned on, Safari 

recognises when you log 

in to a website and asks 

permission to save the 

details to your Keychain.

Bank card 
details

3  Safari can store 

bank card details, 

too. They can later be 

modified and removed 

in Safari’s preferences, 

under AutoFill > Credit 

Cards > Edit. Changing 

the card number 

requires the password 

for your user account.

QUICK LOOK  
KEY FEATURES
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1 Get access
Launch System Preferences (from the  

 menu at the top left of your screen). Click  
the Users & Groups icon. You’ll probably have  
to unlock the pane before you can make any 
changes: click the padlock at the bottom 
left and enter an admin password. 

2 Add accounts
To add accounts, click the + button at 

the foot of the users list. A drop-down sheet 
will give you options of Administrator, Standard, 
Managed or Sharing Only user. If you need to 
delete a user at any time, just select them, then 
click the – (minus) button at the foot of the list.

3 Pick a password
Choose a password for the user. This can 

be an iCloud password (the default in El Capitan) 
or a separate one. With the latter, type it in and 
click the key button to get insight into how 
secure the password is, along with tips for 
improving it. You can also have your Mac 
suggest passwords.

4 Picture perfect
For each account’s icon you can pick from 

the built-in images, drop in one of your own, or 
use the built-in camera (if your Mac has one) to 
snap a picture. For the current account, use the 
Login Items tab to choose apps and services 
that launch when that account is activated.

5 Forgotten passwords
If logged in as an administrator, you can 

reset the account passwords of non-admin users 

(but not things such as their website logins). Son 
forgotten his password? Just log in as you, pick 
him from the list, and click Reset Password. You 
can also add a password hint to help him out.

6 Parental controls
‘Managed with Parental Controls’ 

accounts are standard accounts with ‘Enable 
Parental Controls’ ticked. Click the button to 
open the Parental Controls prefs pane. Under 
Apps you can limit the user to specific apps, 
simplify the Finder or freeze the Dock.

7 Restrict content
In the Web tab you can restrict which 

websites this user can view, either trusting the 
Mac to detect the appropriateness of sites or 
specifying a whitelist of approved URLs. Under 
People you can define a permitted contacts list 
for Mail, Game Center gaming or messaging.

8 Time limits
Under Time Limits, you can control when 

your kids can log onto the Mac or limit how 
long they can spend on it. Under Other, you 
can hide profanities in the Dictionary or restrict 

printers. There’s also a Logs button at the 
bottom where you can see exactly what each 
user has been up to.

9 Guest User account
Having friends or family to stay? The 

Guest User account lets them use your Mac 
without you having to worry about what they 
might do, as any files and settings they create 
are automatically deleted when they log out.

10      Automatic login
By default, your Mac automatically logs 

you into the one admin account you create at 
setup. To change this, click Login Options at the 
foot of the user list and switch ‘Automatic login’ 
off; you’ll now have to log in manually at 
startup. Also turn on fast user switching…

11 Toggle users
With fast user switching, you can swap 

between users without logging out. (If you do 
want to log out, select this in the  menu.) 
Click on the icon or name in the menu bar 
and choose a user to switch to; you’ll be asked 
for the password before the desktops switch.

Manage user accounts
Keep your files and settings safe with different user accounts 

Many desktop computers are used 
by more than one member of a 
household. Instead of bringing you 
together, though, this almost 

inevitably leads to arguments – not just over 
whose turn it is, but how they’ve set things up, 
where they’ve saved files on the hard drive or 
even what desktop picture they want. In OS X, 
however, anyone using the computer can have 
their own user account, which holds all their 
settings, email and files separately from everyone 
else’s. Let’s take a look at the options.

Each user can have their own unique 
picture, desktop background and 
settings. Great if your Mac is shared!
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Get more info about your Mac
Use About This Mac and System Information to discover more about your Mac

QUICK LOOK  
MORE INFORMATION

1

2

3

4

Macs are so simple 
that it’s easy to forget 
the technology sitting 
under the hood. And 

Apple likes it this way. Instead of 
worrying about what version of 
Bluetooth they have, or what 
firmware revision the graphics card 
is using, people can enjoy OS X and 
get on with things. 

But there are still many people 
who are in awe of Apple and OS X 
technology and are keen to know 
what power is under the hood. 

Apple has two superb services in 
OS X that provide exactly the sort of 
information ‘power users’ would be 
after: About This Mac and an app 
called System Information.

System Information enables you 
to drill down into every aspect of 
the hardware inside of your 
computer. With System Information 
you get a detailed report on the 
exact type, version and firmware 
revision of every piece of hardware 
that makes up your Mac. Both 
About This Mac and System 
Information can become 
invaluable tools when it comes 
to troubleshooting problems.

In this tutorial we’ll look at the 
information available in About This 
Mac and how to access the more 
detailed data in System Information, 
as well as a few tips and tricks for 
features you may not have noticed.

SKILL LEVEL
Anyone can do it

IT WILL TAKE
30 minutes

YOU’LL NEED
OS X 10.11

About  
This Mac

1  The About This Mac 

window displays 

basic info on the hardware 

inside your Mac. The tabs 

enable you to see the 

information visually. 

System Report
2  Click on System 

Report to open a 

separate app called 

System Information (in 

the Utilities folder) for a 

much wider range of 

detailed information.

 

System 
Information

3  The System 

Information 

window is split into two. 

The sidebar is used to 

select areas of hardware, 

networking and software 

on your Mac. 

Extra info
4  Click on items in the 

sidebar to see extra 

information you might 

overlook. You can save, 

print and even get your 

Mac to speak out some 

information. 

System Information 
enables you to drill 
down into every 
aspect of your 
Mac’s hardware
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HOW TO | USE ABOUT THIS MAC AND SYSTEM INFORMATION

1 About This Mac
Click the Apple icon in the Menu bar and 

choose About This Mac. The About This Mac 
window pops up, displaying the Overview tab. 
The Overview tab displays the version of OS X 
and basic info on the processor, memory, and 
graphics card, along with your serial number. 

4 Using the Support links
The Support tab offers links to info under 

the headings: OS X Resources and Macintosh 
Resources. The links take you to the Help 
window, a PDF User manual and the OS X 
Support website. Under Macintosh Resources 
are links to specs, as well as hardware support. 

6 System Information
The System Information app on your Mac 

offers more detailed information about your 
Mac, and devices attached to it. Choose 
Overview and click System Report to open the 
System Information app (or double-click the 
app in the Utilities folder). 

2 Viewing more tabs
The About This Mac window has a series 

of tabs to get more detailed information about 
your Mac, they are: Displays, Storage, Memory, 
Support and Service. Clicking these tabs enables 
you to view more detailed visual information 
about each aspect of your hardware. 

5 Check your Service
Check the status of your Mac’s warranty 

direct from the Service tab. Click Check my 
Service and Support Coverage Status and Allow 
to the Serial Number alert window. If Apple has 
your registration information, it lets you know if 
your Mac is still under warranty. 

8 Save Info
Save a system report about your Mac. 

The info is saved as an SPX file that can be 
opened by the System Information app, and you 
can view information about your computer on 
another Mac. Create an SPX file by choosing File 
> Save. Choose a location and save to it. 

7 Show More Info
Use the sidebar to view different aspects 

of your Mac’s hardware and software. The main 
window displays the information. It’s worth 
checking the Menu bar that appears at the top 
of the screen. Access even more information by 
choosing File > Show More information. 

3 Quick links
Each area of the About window has links 

to related items. In the Displays tab is a Display 
Preferences button. In the Memory tab is a link 
to Memory Upgrade Instructions, clicking this 
opens up the Apple Support website detailing 
how to expand the memory in your Mac. 

Speak & Print

If you want to write down the serial 
number, it’s best to get OS X to speak it 

out. Click File > Speak Serial Number and 
make a note of it. You can also print out 
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Yosemite introduced a 
colourful new interface 
with translucency effects 
to the Mac. This has been 

further refined in El Capitan and looks 
great, but sometimes you might prefer a 
more muted OS X experience. That 
preference is covered by a visual effect 
referred to as ‘dark mode’. With this 
enabled, OS X’s menu bar, Dock and 
Spotlight are affected.

The Dock switches from its usual 
bright self to a dark grey. The menu bar 
at the top of the screen, and the menus 
that drop down from it, adopt the same 
effect, with black backgrounds and 
white text. This especailly makes sense 
when paired with editing software that 
itself has darkened hues, such as Adobe 
Photoshop, because the menu bar in 
particular becomes less of a distraction 
from the task at hand.

One word of caution, though: some 
menu bar icons don’t work well with 
this effect. So after you switch it on, take 
the time to check that you can still see 
all of your icons at the top-right.

In addition to dark mode, a few extra 
tweaks in System Preferences can even 
more dramatically alter the look and feel 
of OS X. The appearance setting can be 
switched from its default of blue to 
Graphite, which takes out the colour 
from buttons and many other parts of 
windows. The effect is most noticeable 

to the Close, Minimize and Full Screen 
buttons, which lose their red, amber 
and green colours and fade to greys.

There are additional colour controls  
in OS X, including the highlight colour 
and, in the Accessibility pane, an option 
to remove transparency, radically 
changing the look of your Mac.

Enable OS X’s dark mode
Give El Capitan a moody makeover

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11

Dark mode doesn’t affect every 
window, but it’s complementary 
to some kinds of app.

1 Afraid of the dark?
In System Preferences, click General and 

then tick ‘Use dark menu bar and Dock’. Click an 
item in the menu bar to see a drop-down menu 
in the new style. Most menu bar icons should 
support dark mode, but even those that aren’t 
clearly visible will still work – just click on and 
use them as normal. Right-clicking a Dock icon 
shows its contextual menu in the new style, too.

2 Appearances
In the General preferences pane of 

System Preferences, change the Appearance 
setting to Graphite to remove colour from many 
window elements. Also set the highlight colour 
to Graphite. This changes the colour behind 
selections in menus and in lists, such as in Mail. 
You can pick any colour, but this choice works 
well with dark mode’s muted colour scheme. 

3 Take it further
Go back to the main System Preferences 

and click Accessibility, and then Display. Turn on 
Reduce Transparency to make the menu bar and 
Dock opaque, revealing none of the desktop 
background. Enabling Increase Contrast adds 
borders around buttons and many other 
controls. It’s even possible to drain all colour 
from the screen by ticking ‘Use grayscale’.

HOW TO | GIVE EL CAPITAN A DARKER LOOK
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1 Multiple menu bars 
The desktop looks slightly different on 

some of your displays when two or more are 
connected. Each display has its own menu bar, 
but only one appears solid, while the others 
are translucent. The solid one indicates which 
display contains the window that has the focus.

2 The Dock
The Dock appears on the primary display 

by default – remember, that’s the one shown 
with a menu bar on the Arrangement tab of the 
Displays preferences pane. It might look like you 
have to move the pointer to that display to use 
the Dock, but that’s not the case…

3 Access the Dock
Whether the Dock is set to always-on 

or auto-hide, it can be accessed on any display 
provided it’s set to the bottom edge and 
displays are arranged horizontally.

4 The app switcher
Hold ç and press † to open the app 

switcher. It appears on one display, but you 
might notice that it doesn’t stick to the same 
one. It actually follows the Dock – wherever the 
Dock last appeared, that’s the display on which 
the switcher will next be shown.

5 Unified spaces
Moving between Spaces affects only 

the display on which the pointer is positioned. 
You can disable Mission Control’s ‘Displays have 
separate Spaces’ setting to revert to OS X’s old 
behaviour, which ties them together but also 
reverts to having a single menu bar and Dock. 

6 Independent spaces
With that option enabled, apps running 

full-screen (such as Photos, say) or two in Split 
View can take over one display while other apps 

remain visible on another monitor. And 
remember, you can swipe between different 
spaces on those displays without affecting the 
full-screen app you have running.

7 Dashboard
Dashboard is off by default in El Capitan 

because it’s largely replaced by Notification 
Center’s Today view. A reason to turn it on 
though is to monitor parts of web pages using 
web clips. It can be shown as a Space in its own 
right, or as an overlay on any Space.

8 Mission Control
Swiping horizontally on the central 

preview again changes only that display’s space. 
Windows and stacks of them can be dragged 
between displays – even onto another Space’s 
thumbnail. You can even drag those thumbnails 
to move entire Spaces between displays.

9 Don’t group by app
With windows organised between 

monitors and Spaces, you might find Mission 
Control easier to manage by turning off its 
‘Group windows by application’ setting.

Manage multiple displays
Make sense of multiple menu bars, the Dock and Mission Control

It’s been possible to connect 
multiple displays to a Mac for a long 
time, but the impact on the desktop 
left a lot to be desired. Most issues 

have been addressed in recent OS X releases, but 
there are still a few quirks that might confuse 
you, including where the ç+† task switcher 
will appear. With that in mind, we’ve prepared 
this guide so you can understand how the menu 
bar, the Dock and Mission Control will behave 
when you’re working across multiple displays.

Spaces
1  Spaces are shown 

at the top of each 

display when you open 

Mission Control. It’s 

possible to create a 

number of Spaces on 

each of your displays 

independently.

Dock 
arrangement

2  In Mission Control, 

the Dock appears 

only on your primary 

display, but it can be 

made to appear on any 

display when you’re 

working on the desktop.

Moving 
windows

3  Windows and 

Spaces can be 

dragged between 

displays. You need to be 

in Mission Control to 

drag a Space. To drag an 

open window put your 

cursor on the top bar of a 

window and drag it over 

to the second monitor.

Dashboard
4  When Dashboard 

is enabled as a 

Space, it appears on the 

primary display but can 

be moved.

QUICK LOOK  
MULTICONTROL
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1 Keyboard options
In the Keyboard pane’s Keyboard tab, Key 

Repeat and Delay Until Repeat, respectively, 
define how quickly held keys repeat and how 
long it takes before this happens. Use the values 
Fast and Short and on subsequently holding 
Delete, characters will rapidly be erased.  

2 Adjust function keys
Modern Mac keyboards use function keys 

for special features, such as brightness and 
playback controls. In Keyboards, the Use all… 
checkbox can switch them to being standard 
function keys. To then access the special 
features, you hold Fn and a function key.

3 Edit shortcuts
Click the Shortcuts tab to edit keyboard 

shortcuts. Can’t get your fingers around the keys 
that take a screen grab, for example? Select 
Screen Shots, then the first item, then click the 
shortcut (ç+ß+3) and press a new one. Try 
to avoid clashing with common shortcuts.

4 Trackpad options
Trackpad options are in the Trackpad 

system preferences pane. Under ‘Point & Click’, 
you can enable and configure Secondary click 
(otherwise known as right-click), ‘Look up’ (for 
dictionary definitions), Three-finger drag and 
Tracking Speed. You can disable ‘Tap to click’ if 
you keep clicking by mistake when navigating 
the trackpad.

5 Scrolling and zooming
Under Scroll & Zoom, the first option 

defines scroll direction: ‘Natural’ means content 
follows the direction of your fingers, rather like 
on a touchscreen device. You can also enable 
pinch to zoom, smart zoom (which zooms 
around what’s under the pointer) and rotation. 

6 Advanced gestures
The More Gestures tab offers advanced 

gestures for moving between apps and pages 
and activating features. Hover over any option 
to see a video of how it works. Click the arrow 
for extra options for gestures.

7 Basic mouse controls
In the Mouse pane you configure mouse 

buttons, and adjust tracking speed (how fast the 
pointer moves) and double-click speed (how 
quickly you have to click a second time for it to 
be counted as a double-click). In Accessibility’s 
Display section, there’s a setting to shake the 
pointer, which temporarily makes it grow.

8 Toggle mouse gestures
Magic Mouse users get two tabs in the 

pane Mouse: Point & Click and More Gestures. In 
the former, you can disable ‘natural scrolling’, 
change right-click to the left, and turn off smart 
zoom. Under More Gestures you can enable 
swipe actions and a shortcut to Mission Control.

9 Custom shortcuts
To create your own shortcut for any app, 

open the Keyboard preferences pane, go to 
Shortcuts > App Shortcuts, click the + sign and 
select an app. Type the exact menu command, 
then press your desired key combination. Click 
Add to finish.

Master input devices
Control keyboard, mouse and trackpad preferences

Under El Capitan, it is possible to 
dictate into any application you’d 
normally type into and even control 
your Mac using spoken commands. 

Most of the time (if not all of it) though, you’ll 
tend to use traditional input devices: keyboards, 
mice and trackpads. The problem is that these 
devices in their default states might not work 
precisely as you want them to – and that can be 
very frustrating.

We often find that tracking, which maps 
physical movement to the pointer, to be absurdly 
slow, forcing multiple swipes to get the pointer 
across the screen; we regularly prod the trackpad 
only to accidentally click; and the lack of 
keyboard shortcuts for useful actions in certain 
apps drives us nuts. 

So here’s how to alter the settings for these 
things (and more) in the Keyboard, Mouse and 
Trackpad settings in System Preferences – it’s 
incredibly simple.

The tips here assume you’re using standard 
Apple kit, such as a Magic Mouse, Magic 
Trackpad or MacBook trackpad. If you’re using 
third-party input devices or older Apple kit, then 
the options you see might be a little different 
from those shown.

Using the separate Keyboard, Mouse and Trackpad system preferences panes you can easily customise all of your input devices.



86  |  OS X El Capitan Handbook

SETUP & PREFERENCES   |   Audio sources

1 Change sound alerts
When your Mac needs to warn you about 

something, it usually plays an alert sound. To 
change the default sound to something else, 
go to System Preferences > Sound, click on 
the Sound Effects tab and choose which one 
you’d like to use instead.

2 Sound alerts through…
When you connect external speakers 

to your Mac, you might find that sound alerts 
you’ve set are played through them. To stop this 
from happening, select Sound Effects and go to 
the ‘Play sound effects through’ menu and select 
Internal Speakers.

3 Define output sources
If you’ve connected some headphones or 

speakers to your Mac but can’t hear any sound, 
go to System Preferences > Sound, click the 
Output tab and select the device you want to 
use. Speakers may use USB or the headphone 
port, so test your settings to make sure which.

4 Define input sources
On Apple notebooks and iMacs, the 

internal microphone is set as the initial input 

source. You can change this by clicking the Input 
tab (if you want to use an external microphone). 
Select your chosen input from the list. Note 
that some apps, such as Skype, override this 
with their own settings.

5 Test input levels
With input devices it’s a good idea to 

check levels to ensure you don’t end up with 
distorted audio. If using a microphone, select it 
and speak into it. You’ll see the Input level meter 
rise and fall. Adjust the Input volume slider if it 
always sits very low or at the maximum level.

6 Menu bar sounds
System Preferences > Sound gives you 

the option to display your Mac’s sound settings 
in the menu bar. Click the speaker icon to adjust 
the volume; and å-click it instead for a drop-
down menu of connected input and output 
devices – speakers, microphones and so on;  
click one to select it.

7 Bluetooth speakers
To connect your Bluetooth speaker, first 

put it into pairing mode (see the manufacturer’s 
instructions on how to do this as different 
devices will have different methods) and then 
go to System Preferences > Bluetooth. Select 
the speaker from the list of devices and 
then click the Pair button. All being well, it will 
now be ready to use.

8 AirPlay speakers
AirPlay and iTunes make it easy to listen 

to music all around the house – just add an 
AirPlay speaker (there are many available 
including excellent offerings from Bowers & 
Wilkins) to each room and then connect to 
them via a wireless network. To use an 
AirPlay-compatible speaker, put it into 
discovery mode (check the manufacturer’s 
manual regarding how to do so) then open 
iTunes, click on the AirPlay icon in the iTunes 
toolbar and then select the device or devices 
you wish to route the output to. 

Define your audio sources
Configure your Mac’s sound settings and find out how to use AirPlay

Whether you want to listen to 
music, make recordings, or chat to 
friends and family, your Mac and OS 
X give you plenty of options. You’ll 

find basic sound settings in System Preferences > 
Sound, but there’s more to the Mac than that. 
You can, for example, listen to music wirelessly 
by teaming your Mac with a set of Bluetooth or 
AirPlay compatible speakers. As well as being 
able to listen to sounds from different sources 
and in different ways, your Mac also enables you 
to make and record sounds. Most Macs include 
an internal microphone that you can use with 
apps like FaceTime or Skype to make voice and 
video calls, but you can also connect external 
microphones and musical instruments. Fire up 
an app like GarageBand (provided with new 
Macs for free, otherwise £3.99) and you’ll be able 
to turn your Mac into a complete home 
recording studio. Let’s take a thorough look at 
the options for changing your sound input and 
output settings…

OS X El Capitan’s comprehensive Sound preferences enable you to fine-tune both input and output.
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1 Set it up
For ease of setting up, it’s best to have 

the Bluetooth menu visible in your Mac’s menu 
bar. If you can’t see it, go to  > System 
Preferences > Bluetooth and tick ‘Show 
Bluetooth in menu bar’ at the bottom. The icon 
will now appear among the group to the right 
of the menu bar. To alter its position, hold ç 
and drag it to where you want. Click the icon, 
turn on Bluetooth and you’re ready.

2 Keyboards, mice  
and trackpads

Let’s start by pairing an input device to your 
Mac. Make sure the kit is switched on and in 
pairing mode. If it’s an Apple keyboard, mouse 
or trackpad that isn’t currently paired to 
anything else, it’ll enter pairing mode almost 
as soon as you switch it on, indicated by a 
blinking light. Now click the Bluetooth menu bar 
icon and select Open Bluetooth Preferences… 
You’ll now be able to see a list of Bluetooth 
devices that can be paired with your Mac. If 
nothing appears, double-check that the device 
is in pairing mode and that it’s positioned close 
enough to your Mac (within 10m).
 Once you’ve found the device you want, click 
on the Pair button to its right. If it’s a keyboard, 
you’ll be asked to type in a code on the 
keyboard as a security measure. Do this and hit 
®. Note that you’ll need to do this fairly quickly 
or the device may leave pairing mode. Once 
paired, you may be asked to identify the 
keyboard’s layout so that it’ll work properly –  
the Keyboard Setup Assistant will guide you 
through this. Once you’ve gone through this, 
you’ll be returned to the Bluetooth preferences.

3 The menu bar icon
Now that you’ve paired something to 

your Mac, look at the Bluetooth menu bar icon 
and you’ll see it has changed from the black 
Bluetooth logo it was before. The row of dots 
across it indicates that something is connected 
to your Mac over Bluetooth and the two 
are actively talking to each other.

If you now switch off your keyboard or 
mouse, you’ll see the icon change and a 
message will appear on your screen telling you 
the connection has been lost. To get things 
working again, simply switch on the device and 
it should reconnect. If a device doesn’t 
automatically reconnect, connect it manually by 
selecting it in the Bluetooth menu.
 If you’ve got several Bluetooth devices paired 
to your Mac and want to know which ones are 
currently connected, click the Bluetooth menu 
and look under Devices. The ones listed in bold 
are connected. 

4 Headsets  
and speakers

You can get Bluetooth speakers and headsets 
that connect to your Mac. Pair your headset or 
speaker set as you did with the keyboard earlier. 
To change audio settings, go to System 
Preferences > Sound. If your headset has a 

microphone as well as speakers and supports 
the correct profile for voice, it’ll appear under 
Output and Input. 

5 iPhone options
One of the ways you can use your 

iPhone’s internet connection on your Mac (if 
your data plan allows) is to pair over Bluetooth. 
Pair your iPhone with your Mac by going to 
Settings > Bluetooth on the iPhone. Then go to 
Settings > Personal Hotspot and ensure this is 
also turned on. Next, select your iPhone in your 
Mac’s Bluetooth preferences pane, right-click 
and then click on Connect to Network. If that 
doesn’t work, go to System Preferences > 
Network > Bluetooth PAN. Pick your iPhone  
from the Devices list, then click Connect.

6 Share files with  
other devices

If you have a non-Apple mobile, you can pair it to 
your Mac to transfer files between the two. To 
send a file to your mobile, pair the mobile, then 
double-click on its entry in the list of Bluetooth 
devices to open the Select File To Send window. 
To get anything off the device, select Browse 
Device…You’ll now be able to browse the 
phone’s files on your Mac.

Using Bluetooth
Get to grips with how Bluetooth works and what it can do to help you

You might already be very familiar 
with Bluetooth without realising it: 
it’s how the Apple Wireless 
Keyboard, Magic Mouse and Magic 

Trackpad all talk to your Mac, if you use them. 
The technology sends signals over radio waves, 
with the majority of devices able to transmit 
over distances up to 10m (33ft). 

Technically, you can connect up to seven 
Bluetooth devices to your Mac, but Apple 
recommends a practical limit of three or four at 
once. Over the following six tips, we’ll show you 
how to set up and use your Bluetooth devices 
using OS X El Capitan’s built-in options.

Bluetooth   |   SETUP & PREFERENCES

If your Bluetooth device is  
in pairing mode, it will appear in 
System Preferences > Bluetooth.
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1 Update software
Go to  > Software Update and install 

any available updates. Make sure your printer is 
plugged in, the ink is loaded and the paper tray 
filled. For a USB printer, connect it to your Mac. 
OS X will find any software required, and ask you 
to OK it. If it can’t find any, use the printer’s DVD. 

2 Network printing
To connect a printer to your network 

rather than directly to your Mac, follow the 
printer’s instructions for connecting via Wi-Fi, 
Bluetooth or Ethernet. To connect wirelessly, you 
might need to input your router’s WEP/ 
WPA code, or connect through USB first. (With 
AirPlay printers, you typically only need to click 
+ in Printers & Scanners to get started.)

3 Print window
Now when you press ç+P or select 

File > Print, you can pick the printer at the top of 
the print window. To see more options or fewer, 
click Show or Hide Details at the bottom left.

4 Print options
If you have more than one printer 

connected to your Mac or its network, select 
which to use via the Printer pull-down menu. 

The Presets menu lets you select and add to a 
range of preset menu options, which is useful 
if you need custom settings for a specific job.

5 More print options
Other print options include number of 

copies, printing specific pages, changing paper 
size, scaling to shrink, and enlarging or fitting 
the job on the page. Others may vary between 
printers. Do check the Paper Type/Quality 
settings if you’re printing images or using high-
quality photo paper. 

6 Print to PDF
The PDF button (bottom left) enables 

you to create a PDF and do various things with 
it, including mailing it to a contact. This is an 
extremely handy feature – and a great 
alternative to just sharing a document if the 
recipient doesn’t have the associ ated app (or 
you don’t want them to be able to edit it).

7 Preference pane
If a printer doesn’t appear in the list or 

you want to change the defaults, go back to   
> System Preferences and select Printers & 
Scanners. To add a printer, click the +; to remove 
one, click its name and then click the –. Set the 
default printer and paper size at the bottom. 

8 Manage Print Queue
When printing, your printer appears 

in the Dock. Click it to see the Print Queue. You’ll 
see a list of current print jobs. You can pause 
printing, cancel jobs, check how much ink you 
have left and manage your printer setup.

9 Duplex printing
Many printers include a duplex 

function, which enables them to print on both 
sides of the paper. To use this, tick the box 
labelled ‘Two-Sided’. Using the central pull-
down menu, select Layout and you can 
change duplex settings.

Set up a printer
Take advantage of El Capitan’s built-in printer support… 

Whether you print brochures for 
your business or just the occasional 
letter to your bank manager, a 
printer is a vital part of every Mac 

set-up. OS X has access to the latest printer and 
scanner software from the world’s leading 
manufacturers, so you mostly only need to 
connect your device; if any additional software is 
needed, OS X will download it. This means there’s 
no complex setting-up to do.

And printers aren’t that expensive. You can get 
a good multifunction inkjet, which also scans and 
photocopies, for under £200. If your needs are 
modest, a simple desktop inkjet printer can be 
bought for less than £30.

If you have any printers that support AirPrint, 
Apple’s own wireless print system, OS X will 
automatically use AirPrint. If you want to use 
another printer or system, go to the Printers & 
Scanners preferences pane to set your preferred 
one. Let’s take a look at the options… 

Setting up and using a printer is easy with OS X El 
Capitan – in most cases just plug in and you’re away!
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1 Share from a Mac
A USB printer attached to a Mac can be 

shared with other Macs over a network – but 
only when the host Mac is turned on. In System 
Preferences > Sharing, click Printer Sharing and 
tick the box next to your printer. 

2 Put it on your network
You can network many USB printers by 

connecting to the USB port on Apple’s AirPort 
Express, AirPort Extreme or Time Capsule. Some 
other routers offer this, using their own software 
for setup.

3 Configure your AirPort
AirPort kit can host a Wi-Fi network, if 

you haven’t got one, but you can also have it 
join another router’s network and put your 
printer in a different room. In AirPort Utility, in 
the Express’s Wireless settings, set its mode 
to ‘Join…’ and enter your network’s details.

4 Find the printer
With your Mac and AirPort Express on the 

same network, open System Preferences > 
Printers & Scanners. Click the + on the left and 
select Add Printer.

5 Add the printer
Click the printer’s row. Below, you can 

change its name and location to something 

meaningful to you, such as ‘Office printer’. Click 
Add. For many popular printer models, OS X will 
download the printer’s software. Afterwards, the 
printer is listed in the Printers & Scanners pane. 

6 A less formal route
The printer can also be added to a Mac 

on your network right at the moment you need 
to print something. Choose File > Print and click 
the option that lets you select a printer; it 
should appear under ‘Nearby Printers’. Choose it 
to install its software, then print your document.

1 Prepare your Apple TV
With your Apple TV and Mac on the same 

network, go to Settings > AirPlay in the Apple 
TV’s menu. If the first item is set to Off, select it 
to toggle it on. Optionally, select Security and 

set a password that must be entered on devices 
before they can stream to the Apple TV (you 
may want to do this if you’re in a shared house, 
for example).

2 Ready AirPort Express
AirPort Express can receive audio over a 

network and play it through speakers plugged 
into its audio jack – great for listening to music 
in the bedroom, for instance. Open AirPort 
Utility, then edit your AirPort Express’s settings: 
click the AirPlay tab, switch on AirPlay, and 
optionally set a password to control access.

3 Stream from iTunes
If iTunes detects an AirPlay receiver on 

the network, an AirPlay icon appears with the 
controls at the top left. Click it, pick a receiver 
(note the different symbols for audio and video 
devices) or even pick several, and then enter 
the password if needed. Then all that’s left to do 
is sit back and enjoy!

Thanks to the networking and file-
sharing features built into OS X,  
it’s easy to move files between 
computers, share your music or 

even share an internet connection. There are 
loads of things you can do – such as watch your 
Mac videos on a large-screen HDTV, or enjoy TV 
shows and movies from the internet (using an 
Apple TV). Or backup wirelessly and share files 
with others in an instant. Here though, let’s look 
at two of the most common things you’ll want to 
do with your home networking – share a USB 
printer and stream your tunes wirelessly.

HOW TO | TURN A USB PRINTER 
INTO A NETWORKED ONE

HOW TO | USE AIRPLAY  
WIRELESS STREAMING

Use AirPlay to send video from your Mac or iOS device to your HDTV via an Apple TV, or to 
stream music wirelessly to compatible speakers.

Networking and sharing
Set up a home network to share and stream files
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1 Configure it…
To configure what’s shared on your Mac, 

open  > System Preferences and choose 
Sharing. You’ll immediately see a list of options 
that reveal what you can share from this Mac 
with others: files, your printer, a USB or internal 
CD/DVD drive, or even the Mac’s screen, 
enabling others to observe your computer or 
you to see another person’s, and to take control 
of it for remote troubleshooting purposes.

2 File sharing made easy
The key options you’ll want to check 

out begin – naturally – with sharing files. Under 
El Capitan, many apps have a Share button 
which gives you a quick and easy way to send a 
photo or a link via Mail or Messages, upload a 
video to Vimeo, share a file via AirDrop and 
so on. All you need to do is sign into the social 
network or service you want to use, and it’s then 
available as an option in the Share menu.

3 Finder file sharing
In Finder, file sharing enables you to 

share specific folders, giving both yourself and 
specified other people access to the contents 
from another computer. Start by ticking File 
Sharing in the System Preferences Sharing pane. 
You’ll see a list of existing shared folders, with 
the names of users and groups who have access, 
and the level of access each has. 

4 Access privileges
There are three levels and an option to 

explicitly provide no access to someone. Read & 
Write enables others to copy files from the 
folder, add files to it or delete them. Read-Only 
enables them to copy files from the folder to 
their own computer. The third option, Write Only 
(Dropbox), enables people to copy files from 
their own computer into the folder but not 

access existing files within it. You can add or 
remove both shared folders and users by 
clicking the + and - buttons underneath Shared 
Folders and Users. Then either browse for a 
folder you wish to share or select a user or 
group to enable access.

5 Configure access
To configure access to your own shared 

folders for other people on the same Mac, first 
return to System Preferences and click Users & 
Groups. You have two basic choices. First, you 
can configure the Guest account so people can 
connect without having to provide a username 
and password: to do this, select the Guest 
account and verify that ‘Allow guests to connect 
to shared folders’ is ticked. 

Alternatively, you can set up a dedicated 
‘sharing only’ user account with access to shared 
folders and your screen: to do this, click + to 
create a new shared user, and select Sharing 
Only from the New Account dropdown menu.
 

6 Share peripherals
These days, Macs ship without a drive to 

read CDs and DVDs, which might become an 
issue if you need to install software from a disc. 
Rather than get an external drive, you can make 
use of a drive on an older Mac on the network. 
To do this, go to System Preferences > Sharing 
and tick DVD or CD Sharing, then decide 
whether or not to let people use that Mac’s 
drive without specific permission. Once DVD or 

CD Sharing is enabled, the Mac’s drive will 
appear in the Finder window sidebar on other 
Macs under the Shared heading. People can 
then click this and use the drive as if it was 
connected to their own Mac.

7 Screen sharing
In the Sharing preferences pane, there’s 

an option called Screen Sharing. This is a neat 
way to provide remote tech support for another 
Mac on your network. While this is generally 
restricted to Macs on your local network, there 
are ways of showing people your Mac screen 
over the internet too. The simplest is to use your 
Skype account. Start a voice call with another 
Skype user, then click the + button and choose 
Share Screen… to share your screen with your 
contact. If you’d like to do the same with a video 
call, you’ll need a Skype Premium subscription. 

8 iCloud tricks
Another clever use of sharing technology 

can be found in iCloud: if you’ve got two or 
more Macs using the same iCloud account, 
you can connect to them over the internet for 
whatever purpose you might have – perhaps 
you forgot to transfer a file, for example.

Just open the iCloud preferences pane and 
tick Back to My Mac. Once it’s set up, you’ll be 
able to see that Mac in the Shared section of the 
second Mac’s Finder sidebar and connect to it 
to transfer files. Switch on Screen Sharing and 
you’ll also be able to control it remotely.

Sharing from your Mac
Discover how to make the most of OS X’s sharing capabilities

With your Mac set up and connected 
to your home network, it’s time to 
start taking advantage of all the 
sharing opportunities that 

networking gives you. The most obvious use 
of networks is to shunt files quickly between 
computers – even between Macs and Windows 
PCs – but that only scratches the surface.

In OS X El Capitan you can 
choose exactly who gets 
access to your shared files.
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AirDrop makes transferring files as simple as dragging and dropping them on to the recipient in the Finder.

To share between two Macs, they 
need to be reasonably close so 

that they can talk to each other

Wave goodbye to emailing 
photos, documents and 
other files, because there’s 
a better way: AirDrop. It 

sends files between Macs and iOS 
devices over the air using an encrypted 
connection. What’s particularly great 
about it is that unlike traditional methods 
of sharing files, there’s no tricky setup 
involved – the devices involved in a 
transfer don’t even need to be connected 
to a Wi-Fi network (though AirDrop still 
works ‘invisibly’ if either or both machines 
are), because it establishes a direct 
connection between them.

When you select AirDrop in a Finder 
window sidebar or choose Go > AirDrop, 
you’ll see a window with icons for nearby 
people who have made themselves 

visible to receive files. Control your own 
visibility at the foot of the window: you 
can choose to be seen by everyone, only 
by your contacts, or not at all. When you 

drag files and folders and drop them 
onto someone’s icon, the recipient is 
prompted to accept or reject the transfer. 
If their iOS device has no app capable of 
reading what you’re sharing, it will direct 
them to the App Store.

AirDrop is available in other places 
besides Finder. Click the Share button 
that appears in Safari, Preview and other 
apps to share whatever you’re looking at. 
Using AirDrop in this way opens a sheet 
that again lists nearby people. Click one 
to send to them.

Wherever you access AirDrop, the 
words ‘Don’t see who you’re looking for?’ 
appear below the list of people. Clicking 
this and then ‘Search for an Older Mac’ 
switches to an older implementation of 
AirDrop that works only between Macs, 
running OS X Lion or later. This version of 
AirDrop can’t talk to iOS devices, but it 
works with many more models of Mac – 
if you have an older Mac in the house, 
you can check whether it’s compatible 
by referring to Apple’s list on its website 
at support.apple.com/kb/PH18947.

1 Start AirDrop 
On the devices you’d like to transfer 

files between, open the AirDrop window – 
click it in a Finder window sidebar, or choose  
Go > AirDrop, or press ç+ß+R. If 
Bluetooth or Wi-Fi is switched off, click the 
button to turn it on so AirDrop can work.

2 Send a file  
On your Mac, find the file you want 

to send. Drag its icon onto the icon for the 
other person’s device. The word ‘Waiting’ will 
appear under that icon, and a pop-up will 
appear on the receiving device, enabling the 
recipient to accept or decline the item.

3 Receive files
A blue arc grows around the edge of 

the person’s icon to indicate progress (click 
for an estimate of remaining time). Files you 
receive are saved to your Downloads folder, 
which is accessible from the Finder sidebar, 
the Go menu, or by pressing ç+å+L.

HOW TO | SHARE FILES USING AIRDROP

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
Another Mac running 

OS X 10.11 or a 
compatible iOS device 
running iOS 7+, with 
Bluetooth and Wi-Fi 

turned on

Send files to other Macs and iOS devices around you with ease

Share files wirelessly
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Working in the study, but left your iPhone in the lounge? Just pick up the call from your Mac!
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Call and text forwarding
Send and receive calls and texts on your Mac and other devices

1 Call a contact
You can either find someone in 

the Contacts app or search for them using 
Spotlight – it summarises their details 
without opening the Contacts app. Move 
the pointer over the word Audio (it has a 
phone icon next to it) and click. Under the 
‘Call Using iPhone’ heading, choose the 
number. You’ll see that a call window 
appears at the top right of the desktop. 
Alerts about incoming calls also appear here.

2 Number detection
Safari and Mail can detect phone 

numbers in text. Move the pointer over one 
and an arrow may appear to its right. Move 
over this, click, and choose the option that 
dials it. If the arrow doesn’t appear, selecting 
part of the number sometimes helps. If not, 
copy the number to the Clipboard, open 
FaceTime and paste into the search bar. 
Where the number is repeated below, 
click the phone icon next to it. 

3 Turn off forwarding
To prevent your Mac and other 

devices from ringing when your iPhone 
receives a call, look in FaceTime’s settings. 
In FaceTime on a Mac, choose FaceTime > 
Preferences… and select the Settings tab. 
On an iOS device, find FaceTime at the top 
level of the Settings app. In both of these 
places, untick the option labelled ‘iPhone 
Cellular Calls’ to prevent calls being 
forwarded to that device. 

HOW TO | USE CALL AND TEXT FORWARDING

SKILL LEVEL
Anyone can do it

IT WILL TAKE
Just a few minutes

YOU’LL NEED
OS X 10.11, an iPhone 

running iOS 8.1 or 
above, an iCloud 
account and a 
Wi-Fi network

Now it no longer matters if 
your iPhone is in another 
room when you receive a call 
or a text message. Provided 

that there’s a Mac or other Apple device to 
hand, there’s no need to rush to the iPhone 
to respond: iOS 8.1 and above allow your 
phone to forward voice calls and SMS or 
MMS messages to your iPad, your iPod 
touch and even your Mac. 
 We say forward, but in fact all of your 
devices – including your iPhone – will 
attract your attention, meaning there’s less 
pressure on you to keep your phone in 
your pocket. It works in the opposite 
direction, too, enabling you to initiate calls 
and send SMS and MMS messages from 
those devices by routing calls and texts 
over Wi-Fi back to your iPhone.

As in the case of other Continuity 
features in iOS and OS X, there are a couple 
of conditions to meet before your iPhone 
can start forwarding calls and messages to 
other devices. All of your devices need to 
be signed into the same iCloud account 

as your iPhone, and they also need to be 
connected to the same Wi-Fi network as 
the iPhone.

Phone calls are forwarded to the 
FaceTime app on your other devices. This 
feature is automatically enabled for you, but 
you don’t have to accept it on all of your 

devices – if you’d rather not receive calls on 
your Mac or iPad, the feature can be turned 
off on individual devices and left enabled 
on others – whatever combination suits 
you. Conversations by SMS and MMS 
take place in the Messages app 
on both iOS and OS X.
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HOW TO | GET STARTED WITH HANDOFF

If you started an email on your iPhone but are now sat at your desk, you can finish it off on your Mac!

Handoff is one of the 
‘Continuity’ features in 
OS X El Capitan and iOS. 
It enables you to start a 

task on one device and easily switch to 
another device to finish it. It might be 
a web page you’re reading, an image 
you’re adjusting, or an email you’re 
writing. There are other ways to achieve 
this – in these scenarios, iCloud Tabs, 
saving to iCloud Drive, and your Drafts 
mailbox – but Handoff makes the 
process quicker.

With your devices signed into the 
same iCloud account, in close proximity 
to each other, with Bluetooth turned 
on, and connected to the same Wi-Fi 
network, they tell each other what app is 
in the foreground. As you write an email 
on one device, say, the other will display 
its Mail app’s icon; when you interact 
with this, it tells the originating device 
to hand off the task – including the 
item you’re working on – to the device 
you’ve switched to.

Handoff requires a Mac with built-in 
Bluetooth LE, although some early 
models with it still don’t work with 
Handoff. Compatible models are listed at 
support.apple.com/kb/HT6337, but you 
can just look for a tickbox labelled ‘Allow 
Handoff between this Mac and your 

iCloud devices’ in the General pane of 
System Preferences – it will be there only 
if your Mac does support Handoff. Make 
sure this option is turned on and, on your 
iOS device, check that Handoff is 
switched on under Settings > General > 
Handoff & Suggested Apps.

Move tasks between devices
With Handoff you can start a task on one device and finish it on another

1 Receive from iOS
When a Mac app can take over from 

the foreground app on your iOS device, its 
icon will appear in the Dock, to the left of 
the Finder, with a tiny graphic of an iOS 
device next to it. Move your pointer over 
that icon to get confirmation of the sending 
device’s name. Click the icon to hand off 
the task: the app will open and, soon after, 
the content you were viewing on your iOS 
device will appear on your Mac.

2 Alternative method
There’s also another way to trigger 

Handoff, which is useful if your Dock is 
hidden or you don’t want to move the 
pointer all the way to it. Hold ç and tap the 
† (Tab) key to open the app switcher. The 
receiving app’s icon is shown at the far left. 
With ç still held, also hold ß, then tap † 
twice to highlight the handoff app. Now 
release all the keys. Alternatively, move the 
pointer over the icon and let go of ç. 

3 Receive from OS X
To continue a task from your Mac 

on a locked iOS device, look for an app icon 
at the bottom left of the Lock Screen. Swipe 
upwards from it and the app will open and 
show whatever you were working with on 
your Mac. If your iOS device is unlocked, 
double-click the Home button and tap the 
Handoff notification at the bottom of the 
App Switcher screen. Editable content, such 
as a new email, will close on the Mac.

SKILL LEVEL
Anyone can do it

IT WILL TAKE
Just seconds

YOU’LL NEED
An iOS device that’s 

running iOS 8+ and a 
Mac that’s running 
OS X 10.11; an app 

that supports 
Handoff, such as  

Mail or Safari
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HOW TO | CONNECT YOUR ACCOUNT

1 Link your Mac
Open System Preferences. In the third 

row down, click Internet Accounts. This is where 
you manage your various online accounts for 
email, appointments and social networking for 
the likes of Facebook and Twitter. Click Facebook 
in the list of services to begin.

2 Choose Facebook
In the right-hand pane you’ll see a range 

of online services that integrate directly with El 
El Capitan, including several social networks. 
Choose Facebook from the list, then enter your 
Facebook username and password. When you’re 
done, click Next to continue the process. 

3 Permission Summary
El Capitan provides you with a summary 

of the permissions that you’ll be granting to it, 
including access to your Facebook contacts, the 
ability to post updates and photos and working 
with apps. When you’re done reviewing this 
information, click Sign In to finish. 

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11, 

a Facebook account 

Social networking these days means staying in 
touch with friends and contacts anywhere, any 
time. We’re used to tweeting or sharing snaps 
from our iPhones, and El Capitan also integrates 

with social networks, making it easy to share pictures or web 
pages via Flickr or Vimeo, post to Twitter and more. Here we’ll 
focus on Facebook, but the principles are the same for the 
other supported social networks. 

Once you have Facebook configured in El Capitan, you can 
send things to it from a wide range of apps. Your Facebook 
friends are added to Contacts, complete with profile photos. 
Any changes they make to their details on Facebook are 
updated automatically in the Contacts app. 

Your Facebook notifications come straight to you in 
Notification Center. You can post to Facebook without 
needing to sign in through a web browser, because you’re 
already signed in with your Mac’s operating system! You can 
share photos, web pages and all kinds of other content 
directly from the Share button, which appears in a wide range 
of apps: simply select Facebook from the list, add a note, click 
Post and it’s done – you’ve updated your Facebook status. 

Extra options when sharing 
Once you sign into Facebook in OS X El Capitan, you can 
connect and share with friends directly from your desktop – 
it couldn’t be easier to keep in touch. You can share your 
location with your Facebook posts by clicking the location 
indicator at the foot of the Facebook Share Sheet. As long as 
Location Services is switched on and you’ve given Facebook 

access to it, you’ll share exactly where you were when you 
clicked Post. 

 You can also choose to share each post with a different 
group, rather than all your Friends, by selecting a group from 
the drop-down list at the top left of the Facebook Share Sheet. 

If you opt to share a photo to Facebook, you can select the 
album that you want to put it in. This option appears as a 
drop-down list at the top right corner of the Facebook Share 
Sheet. If you don’t provide a selection here, your post goes by 
default to your timeline. 

In these guides, we’ll explain how to link your Facebook 
account to El Capitan, then show you some of the options this 
gives you in a range of apps. 

Facebook integration
El Capitan keeps you in touch with Facebook contacts all the time 

Once you sign into Facebook in OS X, you can connect and share with friends 
directly from your apps. 
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1 Contacts
El Capitan accesses all your Facebook 

contacts and imports them into your local 
Contacts so you can use them from any 
application on your Mac. If you change your 
Facebook password, return here, click Details 
and provide your new password to OS X. 

4 Add a message 
You‘ll see a new Facebook Share Sheet. 

Click the drop-down list at the top left to set 
who the page will be shared with – by default, 
all your friends, but you can choose a list – 
which must be set up via the Facebook website. 
Type your status update, then click Post. 

6 Privacy options
Here you can select the applications 

that you want to have access to your location 
information. Ensure that Facebook is ticked, 
then return to the Share Sheet and click again 
to add your location, then click Post. For other 
privacy options visit the Facebook website. 

2 Import friend photos
You can also import contact photos from 

your friends’ Facebook avatars by selecting your 
Facebook account in the Internet Accounts pane 
in System Preferences. Click Get Profile Photos, 
and, when prompted, click Update Contacts to 
download the pictures to your address book. 

5 Use Location Services 
You can automatically add your location 

to a post too. In the bottom left of the Share 
Sheet is an arrowhead, indicating Location 
Services. If it’s not yet set up, click it and you’ll 
be taken to the Privacy options to configure the 
service to allow Facebook to use your location. 

8 Choose an album
At the top right of the Share Sheet is 

a drop-down list that enables you to choose 
where to post the picture. Select one of your 
existing photo albums, or choose Timeline to 
add it to your Facebook timeline. Click Post to 
publish it to your network of friends. 

7 Post a photo
Sharing a photo via Facebook is just as 

easy as sharing a web page. In the Finder, locate 
the picture you want to share, then right-click 
on it and select Share > Facebook. Now simply 
choose the people you want to share it with, 
and add a brief message

3 Share a page
Now you’re set up, sharing a web page 

via Facebook is easy. In Safari, browse to a web 
page you want to share. Click the Share button 
in the address bar and you’ll see a drop-down 
list of sharing options. Select Facebook from the 
list to share a link to the page. 

In Notification Center’s preferences, find the 
Share Button item in the list of apps. Turning 
it on adds buttons to post to social networks 

via the Notification Center sidebar. 

Quick tip

HOW TO | MASTER FACEBOOK’S FEATURES WITHIN EL CAPITAN 
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Mac apps
Find out about all the amazing 
apps that come with OS X
98 Browse the web with Safari
  Essential features of your Mac’s web browser

100 Advanced features of Safari
 Search quickly and protect your privacy

102 Master Mail’s new tricks
 Sign messages and send large files

106 Become an expert at Mail Markup
 How to manage emails like a pro!

108 Make a date with Calendar
  Organise your schedule with the built-in diary

110 Get from A to B with Maps
 Navigation, satellite photography and 3D!

111 Master OS X Reminders
  Create to-do lists and sync them across devices

112 iCloud Drive
  Keep files in sync between your Mac and iOS devices 

114 Download great books
 Use iBooks to discover new literature

116 Master the Notes app
  Jot important things down for later reference 

120 Get to know iTunes 12
 Find your way around the music hub

124 Discover Apple Music
  Apple’s new streaming music service 

130 Do more with Photos
  Enhance pictures with the Photos app

140 More apps for your Mac
 Yet more bundled apps…

141 Using the App Store
 Get more software from Apple

142 Free apps
 Lots of power for no money
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Browse the web with Safari
Take a tour of the essential features of your Mac’s web browser

QUICK LOOK  
ESSENTIAL TOOLS

3

4

1

2

Safari’s Share 
button makes it 

easy to post a link 
to a web page so 

you can share it

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11; (optionally) 

an iCloud account

The Sidebar
1  Click the Sidebar 

button near the left-

hand end of the toolbar (or 

press ç+ß+L) to 

browse bookmarks you’ve 

created, pages you’ve 

saved to read later, and 

links shared with you via 

some social networks.

Favourites
2  Your favourites  

and most visited 

sites are only ever a click of 

the search field away. They 

also open when you open 

a new tab.

The Smart 
Search Field

3  Click here to enter 

a website address 

or something you want 

to search for. As you type, 

Safari suggests sites to 

visit and relevant pages 

from your bookmarks and 

browsing history.

Share a page
4  Use this to post a 

link to a page on a 

social network, email a 

link, bookmark the page, 

and subscribe to the 

current site’s updates.

Safari does everything 
you’d expect of a web 
browser, but it’s also 
tightly integrated with 

Apple’s iCloud service and your 
Mac’s trackpad or Magic Mouse. 
It doesn’t matter that your Mac 
hasn‘t got a touchscreen – you 
can simply swipe horizontally with 
two fingers on a trackpad (or one 
finger on a Magic Mouse) to move 
between pages you’ve visited.

Once you’ve signed into social 
networks such as Facebook and 

Twitter, Safari’s Share button makes 
it quick and easy to post a link to a 
web page so your friends can also 
read it.

The browser’s integration with 
iCloud enables you to pick up an 
iOS device or switch to another 
Mac and have access to all of your 
bookmarks, your browsing history, 
and web pages you’ve saved to 
read later – even when you’re 
offline. It also keeps your website 
account details in sync between 
devices by saving them to a secure 
online keychain. Safari will even 
suggest a strong password when 
you create an account, which saves 
you wasting time trying to conjure 
one up.

So now let’s take a closer look 
at the headline features in Safari 
that you’ll quickly come to depend 
upon each day.
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HOW TO | SURF FASTER WITH SAFARI

1 Take a closer look
To zoom into a web page, spread 

two fingers apart on a trackpad. Alternatively, 
double-tap with two fingers (one finger on a 
Magic Mouse) to zoom around the text or 
image that’s currently under the pointer. Pinch 
or double-tap to zoom back out.

4 AutoFill passwords
Go to Safari > Preferences… and click 

AutoFill. If ‘User names and passwords’ is ticked, 
Safari offers to remember those details when 
you sign in to a website, and will fill them in for 
you in future. It can memorise other things, too, 
including card numbers – minus security codes.

6 Monitor downloads
A button appears at the far right of 

Safari’s toolbar when downloads are in progress 
– it isn’t always visible at other times, though. 
Click it (or press ç+L) to check on progress. 
Sadly, you can’t tear out this sheet to keep it at 
the side of the desktop as you do other stuff.

2 See all open pages
When zoomed all the way out of a page, 

pinch two fingers together to zoom out to an 
overview of all open pages or tabs. If there are 
many, Safari stacks them up by site. Start typing 
to search in page titles and reduce the number 
shown, or type a space to spread them all out.

5 iCloud Keychain
After you sign into iCloud and set up its 

Keychain feature (see page 78), website account 
and bank card details are kept in sync between 
your Macs and iOS devices. Safari will also begin 
to suggest strong passwords when you register 
with websites to save you coming up with them.

8 Get updates from sites
The sidebar also shows bookmarks and 

Shared Links – posts from people you follow on 
Twitter and LinkedIn that contain website links. 
Look for a RSS link on the page and click it – you 
can see that site’s updates in the sidebar 
without visiting it.

7 Add to Reading List
Move the pointer over the current page’s 

address and click the + that appears to its left to 
add the page to Reading List. This feature saves 
the entire page so you can view it even when 
offline. The list’s contents are accessible from a 
button on the toolbar, and the View menu.

3 Favourite sites
When viewing your favourite sites (see 

opposite), you can drag an icon from the 
Frequently Visited group into Favourites to 
ensure it sticks around. To add the current page 
to Favourites, click the site address and then 
drag the icon to its left down into that group.

Notifications
As an alternative to receiving site updates 
in the sidebar, some sites ask if they can 

show them as notifications (see page 58). 
Manage these in Safari > Preferences.



100  |  OS X El Capitan Handbook

MAC APPS   |   Advanced Safari

1 Spotlight suggestions
When you click the search field and type, 

Safari gets suggestions from your chosen search 
engine. It also lists matches from your favourites 
and bookmarks, plus Spotlight suggestions – 
news stories, Wikipedia articles, maps and 
contact details relevant to your keywords. It all 
adds up to a speedier search experience.

2 Quick Website Search
When you use a site’s built-in search, 

Safari learns how the address of its search page 
is constructed. Next time, type the site’s address 
followed by keywords in the Smart Search Field 
to get a shortcut that immediately submits your 
keywords and goes directly to search results.

1

2

3

3 Read pages easily
When you visit a page with lots of body 

text, a paragraph-like icon appears at the left of 
the search field. Click it for Safari Reader, which 
strips away extraneous content for a cleaner 
view of the body and images. Adjust the text 
size using the A characters at the top left.

4 iCloud Tabs
Click the Show All Tabs button in the 

toolbar, and look below the graphical previews 
of tabs open on your Mac. Here you’ll find lists 
of tabs left open on your other Macs and iOS 
devices signed into the same iCloud account.

5 Private browsing
To create a window in which visited 

pages, searches and form data are not saved, go 
to File > New Private Window. Such windows are 
distinguished from normal ones by a dark 
search field. They remain separate if you choose 
Window > Merge All Windows.

6 Privacy options
In Safari’s preferences, click Privacy. The 

first set of options determines whether sites 

save cookies – often used by advertisers, but 
also for other purposes. At the bottom, you can 
ask not to be tracked, but sites aren’t actually 
obliged to honour this.

7 Cover your tracks
You can quickly cover your browsing 

tracks from the last hour, today, or today and 
yesterday by choosing History > Clear History 
and Website Data… and the relevant entry.

8 Manage website data
Also in Privacy preferences, click Details 

under ‘Remove All Website Data…’ to review 
what sites have saved on your Mac: cookies, 
plug-ins and other local data may be used for 
legitimate functionality, but you can come here 
and delete data for a site you no longer trust.

9 Manage plug-ins
Safari uses clever techniques to stop 

plug-ins sucking up resources and battery 
power. You can check plug-ins and manage 
each one’s availability, to sites you’ve already 
visited and any others you may visit in future, at 
the foot of Safari > Preferences > Security.

Advanced features of Safari
Learn how to find things online quickly and protect your privacy

Safari is packed with features that 
make your experience of browsing 
the web much better. From the 
Smart Search Field to Safari Reader 

to private browsing mode, everything is geared 
towards making your browsing faster and more 
enjoyable. In the following nine expert tips you’ll 
discover exactly how to search smarter, read text 
on pages easily, sync tabs across devices, 
manage your privacy and security and more.

Pinned tabs
1  This feature has 

been part of rival 

browsers for some time, 

but is finally added to 

Safari in El Capitan: 

browse to a website and 

choose Window > Pin 

Tab to pin the site 

permanently to the tab 

bar for easy access.

Mute tabs
2  Many websites 

now automatically 

play any media that’s 

embedded on their 

pages, particularly ads. 

Safari now shows a 

sound icon next to a tab 

playing media – if it’s 

annoying, just click the 

sound icon to mute the 

tab, or click and hold to 

get an option to mute all 

other tabs instead.

AirPlay
3  Safari 9 now 

supports AirPlay – 

just browse to  a site 

containing a compatible 

video (such as YouTube) 

and look for the AirPlay 

button, then click it to 

select your target device.

QUICK LOOK  
NEW TOOLS



Not your average technology website

  Fascinating reports from the bleeding edge of tech
  Innovations, culture and geek culture explored

  Join the UK’s leading online tech community

EXPLORE NEW WORLDS OF TECHNOLOGY  
GADGETS, SCIENCE, DESIGN AND MORE

www.gizmodo.co.uk
 twitter.com/GizmodoUK     facebook.com/GizmodoUK
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Mail is the standard app 
you use for getting your 
email on a Mac. It’s been 
around since the start of OS 

X but has been through many changes. 
In an age where webmail is king it might 
seem old fashioned to use a dedicated 
email program instead of your browser 
to get your mail, but there are several 
advantages to using Mail, which we’ll 
reveal here.

At first glance Mail hasn’t changed 
much in El Capitan, compared to the 
previous Yosemite version, but if you look 
more closely you’ll find that there are 
plenty of new features to delight you. For 
example, it can automatically identify 
event details, show you addresses and 
spot updated contact information. You 
can use natural language searching, so 
for example if you search for “emails from 
Susan on Friday” Mail will understand 
you. If you have a trackpad you can use 
iOS-style swiping to trash mails or mark 
them unread, and in another iOS-inspired 
move you can work in full-screen mode 
with your email hiding itself when you 
want to see or copy from another 
message. If you’ve got multiple messages 
open in full-screen mode they’ll 

automatically appear in Safari-like tabs. 
Over the next few pages we’ll explore 

Mail’s many powers and show you how 
to make the most of them. Mail should 
be your go to application for getting 
email on your Mac, and with are help 
you’ll be flying through it in no time.

Make the most of Mail
El Capitan brings some great new features to Apple’s excellent email app

1 A fresh start
If you’re upgrading from a previous version of Mac 

OS X, Mail should automatically import everything you need: 
you’ll get all your messages and settings carried across. With 
a new Mac or a fresh OS X install, however, you’ll need to 
start from scratch. Click Mail > Accounts.

2 Choose your provider
System Preferences’ Internet Accounts pane will now 

appear. You’ve got a choice of common account types – 
iCloud, Gmail and so on. You can also enter details manually 
in Preferences > Accounts. In this tutorial we’ll bring in an 
existing Gmail account. iCloud support works the same way.

HOW TO | SET UP EMAIL IN EL CAPITAN

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11,  

an email account

DROP IT!
Mail Drop means 
you don’t need 
to worry about 

sending big files: 
if they’re too big 
for the recipient’s 

inbox, Mail will 
automatically 
send them an 

iCloud download 
link instead.

If you look closely 
you’ll find there are 
plenty of features  
to delight you

OS X El Capitan’s Mail should be your go-to app for getting email on your Mac.
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5 Watch it arrive
If you’ve entered the correct information and code 

(if applicable), you should now see your emails begin to 
appear. If you have a busy email account, this could take 
some time. You don’t have to wait for the messages to finish 
downloading: you can use Mail right now.

7 Sort with swipes
If your Mac has a trackpad you can quickly filter email 

just like you do in iOS - with swiping. Swipe left on a message 
to trash it, or swipe right to toggle the “read” filter to mark a 
message read or unread. No trackpad? No problem: use ç + 
ß + U to mark and ∂ to trash.

8 Anoint a VIP
Like iOS, Mail has a special VIPs mailbox that only 

includes messages from your most important contacts, and 
you can get OS X to notify you of those messages and no 
others. Making a new VIP couldn’t be simpler: ≈-click on the 
person’s name and choose Add to VIPs.

3 Enter your password
As you might expect, in order to receive your mail, 

the Mail app needs to know your email address and 
password. If you’re using iCloud you’ll be asked for your 
iCloud ID and password here; in this screen we’re providing 
details of our Google account so we can use Gmail in Mail.

6 See your labels
By default Mail shows you the inbox, but if you 

organise your email by folders (or in Gmail’s case, labels) 
then clicking on the Mailboxes button at the top left shows 
your email folders. You can create your own folders and 
subfolders by ≈-clicking and choosing New Mailbox.

4 Prove it’s you
iCloud, Gmail and other services offer two-factor 

authentication, so when somebody tries to connect an app – 
as we’re doing here – they need to prove they’re really you 
by entering a code sent to one of your registered devices. 
Without the correct verification code, the installation will fail. 

SHRINK 
IT!

Digital photos 
can be 

enormous. If 
you don’t need 

to send full-
resolution 

originals, attach 
your files then 
use the drop-
down arrow 

at the right of 
your email to 

select a smaller 
image size.

JARGON 
BUSTER

Internet 
Message Access 

Protocol 
Enables you to 
access email 

that’s stored on 
a remote server, 
such as iCloud 

or Gmail.
The older POP3 
standard usually 

deleted 
messages from 
the server when 
you downloaded 

them to your 
Mac.

Blind Carbon 
Copy  

A way of  
copying an email 

to someone 
without letting 
them see who 

else you’re 
sending it to.
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HOW TO | ATACH IMAGES AND MORE

1 Save the date
Mail is full of little features that make life 

easier, and auto-detecting events is one of 
them: incoming messages containing event 
details and dates generate a little note above 
the message saying “1 event found…” Click on 
Add to add the event to your Calendar.

4 Easily attach images
You can attach images or files in three 

ways: by sending them from an app’s Share 
Sheet (e.g. from Pages, or Safari), by dragging 
and dropping them from a Finder window, or by 
clicking on the paperclip icon in your email and 
browsing for the file(s) you want to include. 

6 Keep it friendly
Unless you override it (under Mail > 

Preferences > Viewing > Use Smart Addresses), 
Mail will show you friendly names rather than 
email addresses when you add them to the To, 
CC or BCC field. BCC is hidden by default, but 
you can display it via View > BCC Address Field.

2 Don’t get lost
If a message includes a street address 

you’ll see a little arrow appear to the right of it; 
clicking on the arrow brings up a little Maps 
window with three options: open in the Maps 
app, create a new contact with this address or 
add the address to an existing contact.

5 Contacts
Click on the blue + icon at the right 

of the compose window to bring up your 
contacts list, or you can just start typing a 
name or email address in the To: field. Mail 
remembers the people you’ve corresponded 
with and fills in the details.

8 Forward it on
The ≈-click menu also has some other 

useful features including moving messages and 
forwarding, which gives you the ability to send a 
copy of a message to somebody else, or to send 
it as an attached document. Forward does the 
former and Forward as Attachment, the latter.

7 Flag it up
You can quickly assign flags to make 

managing your email easier: just ≈-click on a 
message and choose the colour of flag you’d 
like. When you do this, a new Flagged mailbox 
appears in the mailbox list. Click on it and you’ll 
see all the messages you’ve flagged.

3 Full screen fun
Mail’s full screen mode doesn’t limit you 

to the email you’re writing: click on a message in 
the background and the current message hides 
at the bottom of the screen, enabling you to 
copy text or images from another message 
without exiting full-screen mode.

Safari  
sharing

In Safari, the Share Sheet includes an 
option to email the current page. The 
resulting email contains a drop-down 

enabling you to choose between sending 
a link, the entire page or a PDF.
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HOW TO | MAKE MAIL SMART

1 Make it yours
Mail’s Preferences panels contain lots of 

useful adjustments. The first, General, lets you 
decide how you should be notified of new 
messages, where attached files should be 
downloaded to and whether searching should 
also include the Trash and Junk folders. 

4 Change the view
Do you prefer old-school email apps? You 

can bring back the feeling by ticking “Use Classic 
Layout”. This tab also enables you to disable 
automatic loading of remote content, to adjust 
the way messages are previewed and to adjust 
highlighting and marking options.

6 Make the rules
If you get a lot of email, Rules can save 

your sanity: you can create complex rules of the 
“if it’s from here and says that and doesn’t do this, 
do that” variety and have them run automatically 
when new mail arrives. You can also use rules to 
colour-code incoming messages.

2 Dump the junk
Mail does a pretty good job of identifying 

and moving junk mail, but you can tweak how it 
does it in Preferences > Junk Mail. If you’re being 
swamped and Mail isn’t coping with the various 
tricks, you can also install third-party spam filters 
such as the superb SpamSieve.

5 Sign your name
Mail’s support for automatic email 

signatures – the sign-off at the bottom of your 
message – is particularly handy if you’re running 
multiple accounts: you can set signatures on a 
per-account basis so your iCloud sig doesn’t 
appear on mails from your Google account.

8 Mark and drop
El Capitan’s Mail has two great features: 

Mail Drop, which can tell if your attached files 
are too big for the recipient’s email, and which 
sends an iCloud download link instead, and 
Markup, a little arrow at the top right of image 
attachments that brings up tools for annotation. 

7 Make Mail Smart
Smart Mailboxes work just like Rules, but 

they create a new mailbox – if you’ve ever used 
Smart Playlists in iTunes, you’ll be at home 
immediately. Go to Mailbox > New Smart 
Mailbox and set your criteria, and Mail creates a 
new mailbox for all the messages that fit.

3 Ditch the defaults
Two tabs, Fonts & Colors and Composing, 

change how Mail looks and works while you use 
it. You can specify which fonts it should use, 
whether it should compose in plain text or rich 
text, whether it should check your spelling and 
what colours it should use in quotes

Smart  
behaviours

You can’t drag smart mailboxes into 
normal folders, but you can organise them 

in their own folders: click on Mailbox > 
New Smart Mailbox Folder to create one.
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Mark up messages in Mail
Annotate your attachments in Mail and send files that are too big for email

QUICK LOOK  
MARK UP MESSAGES

1 2 3

4

Mail in OS X has 
always been a sleek, 
uncluttered email 
client compared to 

many alternatives, and features 
Apple adds tend to be really useful 
for day to day users. Often they’re 
things you hadn’t even realised you 
needed. Markup in Mail is handy for 
making notes or highlighting areas 
on an attached image or PDF 
without having to open it first in 
another app, such as Preview. Say 
you want to attach a photograph 

and point out a person, or add 
some text notes. It’s easier to do 
with Markup than by writing 
lengthy explanations in a message.

Mail Drop is another useful 
technology that’s relatively new in 
OS X, and it works almost invisibly. 
When you are signed into iCloud 
on your Mac – which you almost 
certainly will be already – Mail 
detects when you try to send an 
attachment that’s large (typically 
over about 20MB) and offers to 
upload it to Apple’s servers rather 
than risking rejection by your ISP 
for going over size limits. 

If the receiver has OS X 10.10 
Yosemite or later, the attachment 
downloads to their Mail app 
automatically. If not, they get a 
link to download the attachment. 
It’s an excellent solution to sending 
large files.

SKILL LEVEL
Anyone can do it

IT WILL TAKE

10 minutes

YOU’LL NEED
OS X 10.11, an email 

account configured in 
Mail, an iCloud 

account

Sketch and 
shape tools

1  Draw freehand and 

Mail will tidy up 

your drawing, or you can 

keep your original efforts. 

You can also use easy tools 

to draw a variety of 

shapes here.

Signatures
2  Mail can use your 

trackpad to enable 

you to sign your name 

with your finger. Or, hold 

a paper copy of your 

signature up to have the 

FaceTime camera scan it.

Text tools
3  Add text to an 

image in a variety of 

fonts, and in different 

styles, colours and sizes 

and justifications.Markup 

saves time that would be 

spent doing this in a 

separate app. 

End results
4  Add whatever 

markup you like, 

but keep it clear and 

concise! Get your point 

across visually rather than 

with many words in a 

message’s body.

Annotating things 
with Markup is 
easier to do than 
writing lengthy 
explanations
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HOW TO | MARK UP A MESSAGE AND USE MAIL DROP

1 Create a new message
Open Mail and create a new message. 

Markup works on images and PDFs, so drag a 
file of either kind into the message window. 
Remember there’s an image size control at the 
top-right corner, which you should set to Actual 
Size if you’re going to mark up the document.

4 Add some text
Add text by clicking the ‘T’ in the toolbar, 

and set its properties using the Text Style tool 
(the ‘A’ in the toolbar). Set the text’s colour with 
that tool, and set its background fill and border 
with the two tools to the left of it. Move markup 
by clicking on it and then dragging on its box.

6 Sign your name
Here we’re using the trackpad option. 

Use your finger to write your signature across 
the trackpad. When finished, tap any key to save 
the signature. Press Clear to start over, or press 
Done and then choose the signature from the 
Sign tool’s menu to insert it as an annotation.

2 Open the Markup tool
Place the pointer over an attached PDF 

or image and a box containing an arrow appears 
at the attachment’s top-right corner. Click it and 
choose Markup to open the Markup tool. (The 
More item takes you to OS X’s Extensions 
preferences, where you can disable Markup.)

5 Add your signature
You can sign documents digitally using 

Markup. Click the Sign tool (fourth from the left 
in the toolbar) and choose whether to sign 
using your trackpad or by holding up a paper 
copy of your signature for your Mac’s camera to 
scan and import into the document.

8 Send a huge message
When you add attachments to a message 

Mail summarises the message’s total size. If this 
goes beyond about 20MB, Mail will use Mail 
Drop to send attachments to Apple’s servers. If 
the recipient has OS X Yosemite or El Capitan, 
the attachments will download automatically. 

7 Add large attachments
To use Mail Drop, ensure you’re signed 

into iCloud in System Preferences and, in Mail, 
go to Preferences > Accounts > Advanced. 
Check the Mail Drop option. It won’t count 
against your iCloud storage (handy if space is 
low) and should work with any email provider.

3 Sketch something
Select the Sketch tool from the far-left of 

the toolbar to sketch freehand. If Mail detects 
you’re trying to draw a particular shape it will 
auto-correct your sketch. In the palette that 
appears at the top-left corner after you draw 
something is an option to use your exact sketch.

SAVE TIME AND 
EFFORT WITH 

MAIL DROP

Mail Drop is a handy alternative to using 
third-party file transfer sites such as 

WeTransfer, or services such as Dropbox. 
Those services are good and have other 
functionality but they involve extra steps 

and extra effort if all you want to do is 
email someone some big files. Mail Drop 

works invisibly in the background.
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1X

Organising your life in Calendar has never 
been easier, thanks to practical 
enhancements in the latest version. They 
make it easier to plan your schedule and to 

make sure you leave plenty of time to get to meetings. 
You can create multiple calendars and assign each a 

different colour to help distinguish your commitments for 
the day, week or month ahead. Create additional calendars 
by choosing File > New Calendar – you can store calendars 
in iCloud for access on all your devices, or keep them 

locally on your Mac. Assign 
colours by right-clicking a 
calendar in the sidebar and 
choosing Get Info. Calendars 
can be selectively hidden to 
show only what you need. 

Click an event to see a 
summary of it. This doesn’t 
overwhelm you with spaces 
for every possible detail that 
can be added. Places to enter 
information appear only when 
you click one of the rows to 
invite someone to an event, 

add notes or set an alert, after which they’ll appear in the 
panel for review.

Event summaries disappear when you click elsewhere, 
but when you click and drag one it turns into a floating 
window so you can review the fine details of several 
events, including travel time, to help stay organised. 

Calendar integrates with the Maps app: type a location 
name for an event and Calendar looks for matches – 
choose one to link it to the event and display a small map 
on the event’s summary. Click this to go to the Maps app 
(see overleaf ) to get directions to send to your iPhone. 
Travel time can be added separately from an event’s real 
starting time to help avoid scheduling conflicts, and to 
avoid potential confusion.

3 Alerts
Setting an alert ensures you never 

miss an appointment – as long as you 
don’t just ignore it. You’ll receive alerts 
through Notification Center. If you select 
Custom, you can choose between an email, 
on-screen message or sound, or open a file. 
You can choose how long in advance of 
the event you are reminded about it, or 
set the alert to occur at a precise date and 
time. Note that you can set multiple alerts 
for an event – so you can set one a week 
before an event, and another, say, just an 
hour before.

1 iCloud 
integration

If you’ve signed into iCloud on your 
Mac (see page 76), your calendars 
should all appear in the Calendars 
app automatically. To check it’s set 
up, go to Calendar > Preferences > 
Accounts and see if your iCloud 
account is there. If not, click +, 
choose iCloud from the list of 
account types that appear, and 
enter your Apple ID and password. 
Switch to the General preferences 
tab and check that Default 
Calendar is set to one that belongs 
to your iCloud account. Now, 
whenever you add an event in 
Calendar, it will appear on any 
devices linked to your iCloud 
account, such as your iPhone.

2 Add new events
Click the + button, type 

a description of your event and 
when it is – say, ‘Lunch with Sarah 
tomorrow at 1pm’ – then press ®. 
Calendar cleverly interprets natural 
language to create an event the 
next day at 1pm called ‘Lunch with 
Sarah’. A pop-up appears in which 
you can review the details. Press  
® to confirm them, or click the 
various parts of the panel to add a 
location, alerts and notes, to invite 
people and set repeating events.

If you’d like others to view or edit your iCloud 
calendar, go to Edit > Share Calendar…, simply 
enter the recipients’ email addresses and click 
Done to send invitations. To stop sharing a 
calendar, click Edit > Stop Sharing. In the Edit 
menu there’s also an option to Resend Sharing 
Invitations, in case people need reminders or 
have forgotten to respond. The Sharing Settings 
option (also available when you right-click a 
calendar in the sidebar) lets you make a 
calendar public to share it online, and gives you 
an address for people using compatible apps.

Share a calendar

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11

Make a date with Calendar
Discover the great new features in OS X’s built-in calendar app
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6

7

8

4

5

3

4 Locations
Add a location to 

an event and the app offers 
suggested matches. So, if 
you type ‘Pizza Express’, nearby 
branches of that restaurant 
chain will appear. You can add 
extra detail to narrow the search. 
Suggestions can be ignored to 
store just your text, but if you 
choose one you’ll see a map. 
Click it to open Maps (see page 
110) for directions, and to send 
them straight to your iOS device.

5 Day view 
Click Day, and you’ll see an hour-

by-hour rundown of the day, showing 
what events you’ve got scheduled. The 
white space in between shows when 
you’ve got free time. Select an event 
from the list and its details will appear in the right-hand pane 
beneath the navigation tools that enable you to quickly jump 
between dates.

8 Searching 
If you can’t recall 

exactly when an upcoming 
appointment is, type a relevant 
word into the search bar to see 
all matching events. 

6 Weather
Just below the little map of an event, you’ll see a brief 

weather forecast – this is really handy for realising you need 
to grab a brolly before you set off for your appointment.

7 Browsing
Clicking Today at the top right of the calendar jumps straight to 

today, whichever view you’re in. The left and right arrows take you to the 
next time period in the view you’re in – the next day, week, month or year, 
or you can press ç+“ or ç+‘. You can also go straight to a specific 
date by pressing ç+ß+T, entering a date, then clicking Show.

The Month view scrolls 
continuously. As you 
scroll, clear markers 
appear in the first row 
of each month (see 
image), but when you stop scrolling 
they disappear, and whatever month 
dominates the window becomes listed 
at the top right of the window. Dates in 
the top row aren’t necessarily in the 
‘main’ month.

Month view
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QUICK LOOK | NAVIGATE IN MAPS

1

2

3

4

1 Search for somewhere
Type an address in the search bar and 

then press ® to drop a pin there, or click and 
hold to drop a pin at the pointer’s position. Click 
the i on a pin’s label to see more about it. Point 
of interest badges in the Standard and Hybrid 
views work just like pins – click one for details.

2 Pin options
From the expanded panel you can report 

incorrect data, mark the location as a favourite, 
and share it using the top-right button. Click the 
search bar and then Favourites to access saved 
locations (and any stored in the Contacts app). 
Click Edit and then a location to rename it.

3 Plan a journey
Click the Directions button (top left of 

the window), or press ç+R, to open a sidebar 

where you’ll detail the journey to make. Note 
that you don’t have to work in a single window: 
you can go to File > New Window to work in 
another without losing your place in the first.

4 Set your starting point
The start of your route defaults to 

‘Current Location’, but you can type over this 
to start elsewhere. The focus is automatically 
placed in the Start box when you reveal the 
sidebar, so type an address or a bookmark’s 
name, then press † to move to the End box.

5 Set your destination
You can enter an address or a bookmark 

name as your destination, but you can also use 
keywords for a business to find. Try ‘pizza’ or 
‘curry’ for example and wait a moment. Note 
that the suggestions given are nearby to where 
is visible on the map. Pressing ç+L will show 
your current location.

6 Method of travel
Below the End box are three buttons that 

determine the method of travel you’ll use to 

reach your destination. Maps now offers public 
transport (transit) as well as driving and walking 
directions. Choose one, then click in the End 
field and press ® to calculate a route.

7 Send to an iOS device
The map shows a suggested route and 

alternatives, each with estimated time. Click one 
to see its directions. Click the Share button to 
send them to an iOS device signed into the 
same iCloud account as your Mac.

8 On your iOS device
Your iPhone or iPad will show a 

notification that summarises the route. Swipe 
from left to right across it, unlock your device, 
and the route opens in iOS’s Maps app. Tap the 
Start button and your device will show and 
speak directions throughout your journey.

9 Enlarge labels
If you find it difficult to read the names of 

streets and other places on the map, they can 
be made bigger by  choosing View > Labels > 
Use Large Labels.

Get from A to B with Maps
Explore the world with colour maps, satellite photography and 3D 

When you need to get somewhere, 
the Maps app gets your journey 
underway without you having to 
struggle with typing on your 

iPhone’s smaller, on-screen keyboard.

Orienteering
1  Use the buttons at 

the bottom right 

to zoom in and out of 

the map, or move two 

fingers apart or together 

on a trackpad. While 

holding å swipe one 

finger vertically on a 

Magic Mouse (two on a 

trackpad) to adjust the 

vertical viewing angle. 

Hold å and swipe 

horizontally on a Magic 

Mouse, or twist with 

two fingers on a 

trackpad, to rotate 

the map. Clicking the 

compass aligns North to 

the top of the screen.

Different views
2  Map gives a clear 

view of the road 

network, while Transit 

overlays public transport 

links. Satellite view is 

best used to explore 

major cities.

City Tours
3  Click names 

followed by the ‘i’ 

button for a guide to 

that landmark.

Directions
4  This button opens 

a sidebar in which 

you can request driving 

and walking directions.
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Are you one of those people 
who like to organise their 
life around to-do lists? If 
so, you’ll be pleased to hear 

that El Capitan’s Reminders app is here to 
help. Just as on the iPhone, iPad and iPod 
touch, Reminders makes it easy to create 
to-dos and sync them seamlessly with all 
your devices using iCloud – with any 
changes made on one appearing on all 
the others.

You get a default Reminders list to 
start things off, but it’s easy to add new 
ones. You can also rename a list by 
right-clicking on its name, choosing 
Rename from the pop-up menu, typing 
a new name and finally pressing ®.

Reminders also enables you to set 
up categories of lists so you can get 
a quick overview of specific tasks such 
as birthdays and anniversaries. We’ll 
show you how to add items to your 

Reminders list, set up and both time- 
based and location-based alerts, and 
sync them using iCloud. To set iCloud 
up, open the  menu and go to System 
Preferences > iCloud. If you’re not 
logged in, type in your Apple ID and 
click Sign In > Next > Allow. Once 
that’s done, check that Calendars and 
Reminders is ticked. Next, sign in with 
the same Apple ID on any iOS devices 
you use by going to Settings > iCloud.

OS X Reminders
Never forget birthdays, meetings or the milk

SKILL LEVEL
Anyone can do it

IT WILL TAKE
5 minutes

YOU’LL NEED
OS X 10.11

1 Create a reminder
Open Reminders and click the + symbol 

(top right). Type the name of the reminder and 
press ®. This creates a simple ‘to do’ without a 
due date, time or location. To mark it as done, 
click the box to the left of the reminder and it 
will go into your Completed items.

4 Location aware
You can make reminders appear when 

you’re in a certain place – handy if you’re 
syncing your Reminders to an iPad or iPhone. 
To do this, create a reminder, click the i as 
in step 2 and tick ‘At a location’. You’ll need 
to have Location Services switched on.

2 Timed reminders
Repeat step one, but this time hover the 

mouse pointer over the ‘to do’ you’ve created. 
Click the i that appears. In the box that pops 
up, click On A Day, then click the date to make 
a mini calendar appear. Now simply choose 
the date to be alerted about your reminder.

5 Pick your place
Type the location in – an address from 

your Contacts, a postcode or the full address – 
and then hit ®. Pick the location you want 
from the list that appears, then choose when to 
be reminded. You can widen the range of the 
trigger by clicking and dragging on the circle.

6 Completed reminders
When you click the box next to a 

reminder, it’s marked as ‘Completed’ and will be 
moved to your Completed list. You can click on 
this to check on your completed tasks. Click to 
untick the reminder and it will be back on your 
reminders list. Reminders also appear in iCloud.

3 Choose your time
Click the date you want to be reminded 

about. Now click the hour to highlight it, then 
type in when you want the alert to appear. Do 
the same for the minutes, and finally click Done. 
Your reminder is now set and an alert will pop 
up on all your Apple devices.

HOW TO | SET UP AND USE REMINDERS
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Syncing documents across iCloud Drive is 
undeniably easy – but you do need to be a 
little careful when saving your documents. 
The contents of iCloud Drive are 
automatically synchronised between all of 
your devices, but you need to make sure 
that the device from which you make 
changes to a file is online so that those 
changes propagate to the other devices. 
Otherwise, your changes won’t appear on 
your other devices until you have a web 
connection. Bear this in mind when you’re 
editing documents on the move.

When you sign into an iCloud account in System 
Preferences, your Mac is able to sync data such 
as Safari bookmarks, calendars and reminders 
between your devices using the 5GB of storage 

space that Apple provides for free. That storage space can also 
be used to store your documents, so that you can work on a 
Pages file using your Mac, save it to iCloud and then pick it up 
on your iPhone or iPad. As you start saving documents and 
syncing files, it’s likely that you’ll need more storage – you can 
upgrade immediately by hitting the Manage button at the 
bottom of the iCloud dialog and then Buy More Storage. 
Apple’s recently slashed prices: for just 79p per month, you 
can get an extra 50GB iCloud storage; for £2.49, 200GB; and 
£6.99 will get you a massive 1TB. You don’t need to upgrade 
your storage plan but if you’re going to be using iCloud Drive 
a lot, it’s definitely worth considering.

You can access your iCloud Drive storage by clicking this in 
the sidebar of a Finder window, or by pressing ç+ß+I at 
any time – even when your Mac is offline (although the 
contents may then not be up-to-date).

iCloud Drive is a lot like having a USB flash drive or external 
hard disk for shuttling files back and forth as you move 
between computers, except that you don’t need to worry 
about disconnecting and taking it with you at the end of the 
day. As long as your Mac has an internet connection, anything 
you save to iCloud Drive gets automatically uploaded and 
then synced to your other devices – it’s incredibly convenient 
and useful.

What’s more, you can even access the contents of your 
drive on any computer anywhere through a web browser – 
just sign in at icloud.com when you’re away from your Apple 
devices. This pretty much means that your documents are 
with you wherever you go – and that’s pretty cool. Bear in 
mind that if you do edit documents at icloud.com, you need 
to remember to upload the modified version, again using your 
browser. After you do that, iCloud takes over and syncs it back 
to your Mac and iOS devices.

Using iCloud Drive
Keep your files in sync between your Macs and iOS devices

3 Tidy up storage
Click Manage at the bottom right of 

iCloud’s preferences to see what’s using your 
iCloud storage. Selecting an app reveals how 
much space its documents and data take up in 
iCloud, and a button to delete it all. This is fine 
for, say, a game you’ll never play again, but risky 
with documents you’ve created. It’s better to 
search Drive using the Finder.

1 Enable  
iCloud Drive

Sign in to your iCloud account in 
System Preferences. iCloud Drive 
is listed at the top of the list of 
iCloud features. Tick the adjacent 
box. If you used its predecessor, 
Documents in the Cloud, to store 
things, you’ll be asked whether to 
upgrade it to Drive. Be aware that 
iCloud Drive only works with 
devices running iOS 8 or later, or 
OS X 10.10 Yosemite or later.

2 Control 
your storage

With iCloud Drive turned on, click 
its Options button to see a list of 
apps that it works with. Your iCloud 
account provides 5GB of space for 
free, but as well as storage for these 
apps, it’s also used for iOS device 
backups and your email accounts. 
Unticking a box here removes  
any folder an app has created at 
the top of Drive, but luckily it 
doesn’t prevent you manually 
saving to Drive.

iCloud Drive in sync



OS X El Capitan Handbook  |  113 

iCloud Drive   |   MAC APPS

iCloud Drive works 
much like a 
removable drive, 
but files sync to it 
automatically and 
then to all your 
compatible Macs 
and iOS devices.

4 Save a document
If ‘Where’ is currently set to a local folder, 

you’ll see two iCloud Library items at the top of 
the dropdown that appears: one that saves to a 
folder named after the app you’re using (such as 
Keynote or Pages), and one labelled iCloud 
Drive under Favourites, which allows you to 
simply dump the file loose at the top of your 
iCloud Drive folder.

Patience pays off
When you save a new or modified document, it takes a 
moment to upload to iCloud Drive. Browse to its 
location in Finder and a progress bar will be shown on 
its icon until it’s synced to Drive. If you’ll next work on 
this file on a different device, ensure this is gone before 
shutting down your Mac.

5 Save wherever, and 
whenever, you want

Click the triangle next to the filename to expand 
the dialog to a view similar to a Finder window. 
Now you can easily browse all of Drive’s contents 
and save the file wherever you like, just as on an 
external drive directly attached to your Mac. Click 
New Folder to create whatever folder structure  
suits your workflow.

6 Search for files
Storing things in any way 

you want can make them hard to 
find later – it’s always best to set up 
a folder structure for your 
documents as outlined in tip 5. 
However, if you’ve already saved 
files across iCloud Drive and are 
unsure where they are, it’s not a 
problem. Go to Drive in Finder and 
type in the search bar (just as you 
would when searching for files 
locally on your Mac). In the bar’s 
suggestions list, pick an attribute 
(in our case, a tag). Finder will show 
matches regardless of location and 
kind. Finally, set the options bar to 
look only in Drive. Simple.

After you’ve searched upon 
tags (see tip 4) click the Item 
Arrangement button in the 
dialog’s toolbar and pick Tags. 
This changes the presentation 
of results so that matching 
files are visually broken up 
into groups by tag, which  
can help you to quickly sift 
through a large list of 
matching files.

Arrange files 
by their tags
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Much as you might 
expect, iBooks is 
Apple’s alternative to 
Amazon’s Kindle and 

other ebook readers. It’s been 
available on iPad and iPhone for 
some time, and is also available in El 
Capitan as a Mac app. Best of all,  
books that you’ve bought on your 
iOS device in the past can be 
re-downloaded to and read on 
your Mac as well. The iBook Store 
can be browsed on your Mac, and 
new books can be purchased and 
downloaded straight to it.

There’s a broad range of books 
available in the store, and some 

contain much richer content than 
a continuous flow of text. Some 
iBooks are made exclusively for 
Apple’s store to take advantage of 
interactive features – everything 
from audio and video content to 
textbook diagrams that magnify 
details when you click an 
annotation. The Children & Teens 
and Textbooks categories are 
particularly good places to find 
this kind of book.

If you’ve purchased books in the 
PDF and ePub formats from other 
online book stores, they can easily 
be added to your iBooks library 
provided they’re not copy-
protected. Go to File > Add to 
Library… and locate the file for the 
book you want to add. Note that 
while PDFs can be added to your 
library, they will open in Preview (or 
whichever app you have assigned 
to open the file type), hence some 
features available in iBooks are not 
available for such publications.

Download great books
Read great works of fiction and more with the iBooks app

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11

Page layout

1  Choose iBooks > 

Preferences for 

options that control 

how text is laid out. 

Bookmarks, highlights 

and collections can be 

synced between all your 

devices via iCloud.

Browse your 
library

2  These buttons 

switch between 

ways to view your books. 

As your library grows, 

use the search bar at the 

right-hand side to find 

keywords in book titles 

and authors.  

Downloads

3
 Interactive books 

which contain a 

lot of images can be 

huge – sometimes 

more than 1GB – and 

take ages to download. 

Click this button to 

monitor their progress. 

Collections

4  Click the + sign 

(bottom left) to 

create a collection. Drag 

book covers onto its 

name in the left-hand 

pane or, in other views,  

right-click a book 

and select Add 

to Collection. 

QUICK LOOK  
ORGANISE 

YOUR BOOKS

Some iBooks are made 
exclusively for Apple’s 

store to take advantage 
of interactive features
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Books can be bought on your Mac 
and sent straight to iOS devices. In the 

Settings app on iOS, go to App and iTunes 
Stores and flick the Books switch.

On all devices

1 The iBooks Store
Click on iBooks Store (top left) to open 

the store. Manage your account under Quick 
Links on the right. Browse using the category 
buttons at the top, typing in the search bar, or 
clicking book covers. Click ‘Free Books’ under 
your account details to view freebies.

4 Read a book
Click the Library button at the top left to 

return to your own library. Double-click a book’s 
cover in your library to open it. If you need to 
refer to several books at once – perhaps for 
research – press ç+L while reading one to 
open the library in a new window.

6 Text appearance
In the book’s title bar, click the ‘AA’ icon 

(top right) to change how text looks. The font 
can be resized, changed for a range of 
alternative serif or sans serif typefaces, and set 
against a white, sepia or black background to 
make it much easier on your eyes.

2 Download a sample
Click a book’s cover to see a description 

of it, and a star rating compiled from other 
readers’ feedback. Click Ratings and Reviews 
to read their thoughts in more detail. Click 
Get Sample beneath the cover to download 
an excerpt from the start of a book.

5 Fullscreen mode
Click the green icon at top left of a 

window to go fullscreen. Move the pointer to 
the screen’s top edge to see the menu bar and 
a blue button that switches back. When reading 
in a window, ç+1 and ç+2 switch 
between viewing one or two pages at a time.

8 Add bookmarks
Click the bookmark icon at the top right 

of the window or press ç+D to create a 
bookmark. You can add as many as you want, 
making them a useful alternative to notes for 
marking longer passages. Click the arrow next 
to the bookmark icon to see all bookmarks.

7 Take notes
Select a range of text and a panel pops 

up, with which you can mark the text with a 
highlight colour and, optionally, add a note. 
Click the square notebook icon at the top left 
of the window to review your notes. Click the 
page number next to one to jump to it.

3 Buy a book later
Next to the Buy Book button is a down-

pointing arrow. Click it to share a link to the 
book on social networks and by iMessage 
and email. The book can also be added to 
your wish list, which is accessible under 
Quick Links on the main store screen.

HOW TO | MAKE THE MOST OF iBOOKS
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In past editions of OS X, 
Notes felt like no more 
than a simple tool for 
syncing thoughts and 

flashes of inspiration between your 
Mac and iOS devices. No wonder the 
lure of rivals such as Evernote proved 
irresistible for so many.

With the move to El Capitan, Apple 
has thought again, pulled Notes to 
bits and started out from scratch. It 
still synchronises with iOS devices 
through your iCloud account, but 
now goes far beyond simple jottings.

It’s fully tooled up to act as a 
repository for everything that matters 
day to day, whether that be the 
shopping lists, jobs and recipes to 
which it has always been suited, or 
the photos, maps and grabs it takes 
in its stride in its latest incarnation.

There’s a wider range of formatting 
tools, and if you’re a fan of using lists 
to organise your life, you can now create 
checkboxes, allowing you to tick off a 
job (or an item on a shopping list) once 
it’s been completed. 

This is a significant improvement on 
earlier versions where you’d be more 
likely to scrub the job from the list 

entirely, at which point you can’t refer 
back to see what you’ve done.

We’ll show you how you can make 
the most of the new features so you can 
put the application at the heart of your 
workflow as your stack of notes builds 
into an essential, personalised 
information management tool.

Using the new Notes app
The updates to Apple’s synced notebook make it more than a simple jotter

1 Upgrade your notes
It’s not only the app that’s been revamped: the format 

of its files has been updated too. The first time you start 
Notes it’ll update your existing memos and warn you if any of 
your devices aren’t running El Capitan or iOS 9. You’ll need to 
bring them up to date before they can sync your new notes. 

2 Explore the interface
The three panes of the new Notes interface puts the 

note body on the right, a list of notes in the centre and the 
folders in which they’re organised to the left. Deleting a note 
creates a Recently Deleted folder, where it’ll be stored for 30 
days before being removed. 

HOW TO | GET MORE OUT OF NOTES IN EL CAPITAN

SKILL LEVEL
Anyone can do it

IT WILL TAKE
Five minutes 

whenever you  
add a note

YOU’LL NEED
OS X 10.11

DELETED 
NOTES
To restore a 

deleted note, 
drag it out of the 

Deleted folder 
into whichever 
folder you want 
to store it in. You 

can remove 
notes completely  
by right-clicking 

them in the 
Recently Deleted 

folder and 
picking Delete. 

With the move to El 
Capitan, Apple has 
pulled Notes to bits 
and started again

The updated Notes application is packed with new features, and far more flexible than its predecessors
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5 Add a web link
We can only check off potential destinations if we 

know more about them, so we’ve switched to Safari and 
clicked the Share button to the right of the address bar and 
picked Notes. The floating pane lets us choose which note to 
add the page to, plus a covering note. 

7 Add an image
Images do more than just brighten up or illustrate 

your notes: they can also make them easier to find. Open 
the Photo browser from the Window menu to browse your 
Photos and iMovie libraries, and drag in the image you 
want to use. 

8 Export your notes
You can share your notes using the same Share menu 

options as you’ll find in other core Apple apps, and print 
them as PDFs from the File menu. The latter option sadly 
strips out links (although their placeholders are retained) and 
renders checklists as unclickable circular bullets. 

3 Add a new note
Start a new note by clicking the ‘Create’ button at the 

centre of the toolbar. Whatever you enter on the first line will 
be used as its title. The remainder forms the body. Use the Aa 
button to select paragraph styles, which apply to the whole 
of the section of text in which the cursor is currently sitting. 

6 The Attachments browser
Over time, you’ll add a wide range of websites, maps, 

sketches, audio and other media to your notes, and you 
might forget which notes they’re in. Use ç + 1 to open the 
attachments browser, which shows you all the attachments 
in any note in your library, so you can sort through them.

4 Create a checklist
We’re thinking of potential holiday destinations, which 

would work well as a bulleted list or a checklist. The latter 
would allow us to tick off rejected locations. Highlighting 
them and clicking the checklist button (a tick in a circle) adds 
lozenges to each one, with which to check them off. 

OTHER 
NOTES
Notes in El 

Capitan marks 
a significant 

improvement, 
but it’s still 
locked into 
the Apple 

ecosystem. If you 
need to work 
cross-platform 
with PC and 

Android devices, 
check out the 

free Simplenote 
(simplenote.

com), developed 
by the team 

behind 
WordPress.

JARGON 
BUSTER

Checklist: 
interactive list of 

entries with a 
lozenge beside 
each one that, 

when clicked or 
tapped, changes 

colour and 
applies a tick to 

indicate 
completion.

Share button: 
button common 
to many Apple 

apps rendered as 
a box with an 
up-pointing 

arrow. 
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Audio CDs can be 
imported into your 
library so you don’t 

have to reach for 
a disc to play it

1
2

3

4

4

QUICK LOOK 
iTUNES’ LAYOUT 

When it comes to 
organising your music, 
movies, TV shows and 
other media, iTunes 

provides an easy way to build up 
your collection, and powerful 
features to help decide what music 
you hear. You can manually build 
playlists, but iTunes also enables 
you to specify a few criteria – say, 
tracks from the ’90s that you’ve 
rated four or five stars – and it’ll pick 
out matching tracks in an instant, 
even from a library that contains 

thousands of items, to save you the 
bother of doing it yourself.

You can buy from the iTunes 
Store from within iTunes. There’s 
a free ‘Single of the Week’ on the 
store’s front page, but to buy other 
things you’ll need to add a payment 
method – such as your bank card 
or funds from an iTunes gift card, 
available in many supermarkets.

Audio CDs can be imported into 
your library so you don’t have to 
reach for a disc to play an album. 
With many recent Macs, you’ll need 
to add an inexpensive external CD 
drive (generally less than £30).

iTunes is also how you copy 
music and other media from your 
library to an iPod or other iOS 
device, so you can enjoy it even 
when you’re away from your Mac. 
Here’s how to get around in iTunes 
and find its essential features.

Get to know iTunes 12
Find your way around the hub of your music and media library

SKILL LEVEL
Anyone can do it

IT WILL TAKE
20 minutes

YOU’LL NEED
OS X 10.11, iTunes 12; 

an Apple ID; optionally 
a CD drive

Kinds of media
1  Choose the kind of 

media you want to 

view. CDs, iPods and 

other iOS devices appear 

here when connected. 

Click the ellipsis (…) for 

more types, then click 

Edit to set what’s shown 

here by default. 

Different views
2  Choose the way in 

which the chosen 

media kind is presented. 

Each one includes a link 

to browse more of its 

type in the iTunes Store.

Reorganise
3  Change how what 

you’re viewing is 

sorted, such as by artist 

or year for music – 

options vary between 

media, and some add 

an alphabetical index on 

the left-hand side. 

Recent media
4  Some views show 

this shortcut to 

save you searching for 

newly added media. Use 

the drop-down or View 

> Recently Added to set 

how far back its list goes. 
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1 Buy a track or album
Ensure you’ve signed into the iTunes 

Store: click Sign In (left of the search bar) and 
provide your Apple ID details. With a bank card 
or credit from an iTunes gift card added to your 
account, find an item you want, click its price 
and enter your ID’s password to buy it. 

4 Set up CD import
Insert an audio CD in your Mac’s internal 

or external CD drive and iTunes will look up 
track names online. If they can’t be found, or 
you want to make changes, click once on a row 
to select it, and again on a detail to edit it – or 
right-click and choose Get Info to edit all details. 

6 Other digital music
AAC and MP3 files from other stores 

with no copy protection can be imported by 
dragging and dropping them onto the iTunes 
icon in the Dock. They’ll be copied to your 
library folder, provided the respective box is 
ticked in iTunes > Preferences > Advanced. 

2 Monitor downloads
Small items such as music will download 

quickly, but video can take a while. Click the 
button that appears to the right of the search 
bar to monitor progress, to pause downloads, 
and to drag items up and down in the queue to 
change the order in which they’re downloaded. 

5 Import a CD
If the CD’s details weren’t found online, 

click Options and submit yours to save others 
time if they import the same disc. Click Import 
CD and choose a format and quality – AAC and 
iTunes Plus are the same quality as tracks from 
the iTunes Store. Click OK to import the CD. 

8 Make a playlist
Choose File > New > Playlist to create a 

playlist. Right-click a track and choose Add to 
Playlist, or drag it and then drop it onto a playlist 
in the panel that slides in. The contents of Smart 
Playlists are generated when you specify criteria 
to match, such as a range of years and ratings. 

7 Search your library
Click and type in the search bar to find 

things in your library. Results are listed by kind. 
Click one to view it, or double-click to play it. 
Click the magnifying glass and untick Search 
Entire Library; only results of your chosen format 
then appear in the main window as you type. 

3 Automatic downloads
Go to iTunes > Preferences and click 

Store in the new window to choose which of the 
media that you purchase on, say, your iPhone is 
automatically downloaded to your Mac. In iOS, 
use Settings > iTunes & App Store to make those 
choices about purchases made on your Mac. 

HOW TO | USE iTUNES’ ESSENTIAL FEATURES

Move the pointer over a track, then click one 
of the five dots to its right to rate it. To rate 

what’s currently playing, roll over its name at 
the top of iTunes and click the ellipsis. 

Rate songs
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1 Choose what  
plays next

To see what’s up next, click the icon at the right 
of the playback monitor. To add a track, right-
click it and select Add to Up Next. Or, drag and 
drop a track or several onto the playback 
monitor to add them to Up Next. 

4 The MiniPlayer
Click the current track’s artwork in the 

playback monitor to switch from the large 
window to the MiniPlayer, which fits neatly at 
the side or corner of the desktop. Search for 
artists, albums and songs by pressing ç+F 
and typing, and add things to Up Next by 
clicking the + at their left side.

6 iTunes Match
For a subscription, this matches music in 

your library, even tracks you added yourself, 
with items in the iTunes Store to make them 
available on all your devices. If a track can’t be 
found in the store, then your original will be 
shared. Choose Store > Turn On iTunes Match.

2 Genius Playlists
Choose Store > Turn On Genius to send 

details of your listening habits to Apple. It uses 
details from millions of people to create Genius 
Playlists. After data is received from Apple, right-
click a track and choose Start Genius to listen to 
tracks thought to go well together.

5 Copy media to  
your device

Connect your iPod or iOS device and click its 
icon in iTunes. In the sidebar this reveals, click a 
category and choose what to copy. Click the 
Apply button, then Sync. Or, under Summary, 
choose to manually manage media, then drag 
items and drop them onto your device.

8 Family Sharing
This groups up to six Apple IDs to share a 

payment method and each other’s purchases. 
The family organiser can also approve a child’s 
purchase requests. From a Mac signed into the 
iCloud account that will be the organiser, go to 
System Preferences > iCloud > Set Up Family.

7 Home Sharing
Home Sharing enables media from your 

library to be streamed to up to four more Macs 
and iOS devices over your network. On a Mac, 
choose File > Home Sharing > Turn On… and 
enter your Apple ID. In iOS, go to Settings > 
Music and enter the same details at the bottom.

3 Genius Mixes
Genius data is also used to create genre-

themed mixes. Select the Playlists view, and 
choose Genius Mixes. Move the pointer over a 
mix and double-click to play it. Click a mix’s 
name once, and then again to rename it. Right-
click a mix for an option to remove it.

HOW TO | GET MORE OUT OF iTUNES

iTunes can stream music to one or more 
speakers using AirPlay. With such a speaker 
on your network, click the AirPlay icon that 

appears to the right of iTunes’ playback 
controls to choose which speakers in your 

home the music is played on.

AirPlay
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1 The Beats 1 radio station
Click the Music view and then Radio near the top of 

the window. The centrepiece of iTunes’ radio features is 
Beats 1, which is the top item here, and you don’t need an 
Apple Music subscription to tune in. Click the Listen Now 
button to hear it, or click anywhere else on the Beats 1 
banner to see what’s playing now, over the next few hours, 
and regular shows. Click Complete Schedule and scroll 
down to see upcoming guest presenters.

Apple says Beats 1 isn’t dedicated to a particular kind of 
music. If it isn’t playing the sort of things you want to hear, 
you can request songs by calling one of the phone numbers 
at http://applemusic.tumblr.com/requests.

2 Previous shows
The Beats 1 summary page also lists featured shows. 

Click one to see a list of its previous episodes. You have a 
choice of listening only to the tracks that were played in 
each episode (under Playlists), or replaying entire shows 
with their commentary (under Connect).

3 Themed stations
Click Radio again and scroll down for a selection of 

themed stations that play continuous mixes. (An Apple 
Music subscription is required to play them – see overleaf 
for details about it.) These are a good way to revisit classics 
you might have forgotten, and to discover new things. 
When listening to them or Beats 1, indicate you love the 
current track by clicking the heart in iTunes’ status area. 
Alternatively, to add the track to your library without it 
influencing suggestions in the For You page, move the 
pointer over the status area, click the More Options ellipsis 
and choose Add to My Music.

4 Make your own station
The final type of station gives you more direct 

influence over what it plays (and also requires a sub). Click 
the More Options ellipsis next to an item and choose Start 
Station to use that item as the basis for a continuous mix of 
tunes from Apple’s library which the company’s analysis of 
listening habits suggests go well with your choice. Click the 
star (top-left) to tell iTunes you want to hear more or less 
like the current song.

5 Connect with artists
The Connect page is a place for you to read, watch 

and listen to updates from your favourite artists. Like Beats 
1, you don’t need a subscription to use it, though you won’t 
be able to add music posted there to your library. As well as 
artists you identify when setting up Apple Music (see page 
120), you’ll automatically follow artists whose music you’ve 
previously bought from Apple, even if just one track. 
To change who you follow, click the silhouette-like icon 
to the right of the status area, then Following. Artists are 
also followed when you add music from Apple’s library to 
yours. To prevent this, click your name in the same menu 
and switch off Automatically Follow Artists.

6 Read artists’ updates
Artists can post photos, videos and songs to 

Connect. This may be songs or playlists from Apple Music’s 
library that are available to stream using your subscription 
(or to buy from the iTunes Store), or they may be demo 
versions and unreleased tracks. An Apple Music 
subscription enables you to add music to your library so 
that you don’t have to dig back through posts in Connect to 
hear it again in future.

7 Interact with artists
Below each post are three icons. Click the heart to 

indicate to the artist that you like their update. Click the 
speech bubble to read other people’s comments and add 
your feedback. The third icon is for sending a link to the 
post to social networks or in a private message. If you find 
an artist’s post or another user’s comment to be 
objectionable, click the downwards-pointing arrow to the 
right of it to reveal an option that draws it to the attention 
of Apple’s moderators.

There’s a wealth of information about Beats 1 shows and DJs tucked away behind the banner on the Radio page.

Interact with artists using the icons shown under every item in Connect.

HOW TO | PLAY RADIO STATIONS AND CONNECT WITH ARTISTS

BEING 
SOCIAL
Every comment 
in Connect (and 
shared playlists) 

shows the 
author’s name 
and, optionally, 

a unique 
nickname. 

Set these by 
clicking the 

silhouette-like 
account icon 

then your name 
in the top row of 

the menu.

iTunes 12   |   MAC APPS
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1  Start by selecting the Music 

view from the group of icons 

at the top-left of iTunes.

2  Next, explore the For You, 

New and Connect pages. The 

Radio page is always available even 

if you turn off Apple Music features, 

because Beats 1 can be played even 

if you don‘t subscribe to the service. 

3  When you click the search bar, 

you’ll see options to search 

either your library or Apple Music’s 

massive online collection. Use this 

to explore what’s on offer.

4  When you’ve found an album 

or track in Apple’s library that 

you want to hear, just double-click 

it to stream it immediately. 

5  Alternatively, put the pointer 

over a track and click the More 

Options button (…) that then 

appears. Wherever you see this 

button, it will reveal things you can 

do with that item, whether it’s a 

track, an album or a playlist. 

6  If you add music from Apple’s 

library to your own using an 

iOS device, when you browse to that 

music in iTunes on your Mac, you’ll 

see a cloud icon next to it. Click this 

if you want to be able to play the 

track even when you’re offline.

7  As you add things from Apple 

Music to your personal library, 

the Recently Added item becomes 

very useful as it saves you scrolling 

to or searching for things you likely 

want to hear a lot right now.

8  The most important thing in 

the More Options menu is 

Add to My Music, which adds the 

corresponding item to your library. 

The item will then appear on all of 

your devices, not just your Mac, and 

you can download a copy on any of 

them to play offline.

9  The More Options button is 

also available for the track 

that’s currently playing. However, it 

only appears in the status area at 

the top of iTunes’ window when 

you put the pointer over that area.

10  Clicking a heart icon tells 

Apple you love the adjacent 

item. Your feedback is used to guide 

the suggested playlists and albums 

that are shown in the For You page.

11  Stations can be started from 

tracks, albums or artists. 

They play music from Apple’s 

library, and they’re good for hearing 

new things that suit your mood.

12  Even with an active Apple 

Music subscription, you might 

still want to buy music to keep, or 

just to transfer from your Mac to 

another device that plays AAC files. 

13  You can share a link to an item 

to social networks, and by 

methods such as email and AirDrop.

pple has at last 
introduced a music 
streaming service 
that, for a monthly 
fee comparable to 
similar services such 

as Spotify, gives you access to millions of 
songs by artists big and small. For £9.99 
a month, or £14.99 to allow five other 
family members to use it too, you can 
explore hundreds of years of 
musical heritage and hear brand-new 
releases on your iPad, iPhone, Mac, 
Windows PC and Apple Watch – and 
Apple TV and Android devices from 
autumn 2015. 

Here we’re looking at how to use the 
service in iTunes on your Mac, but many 
of our tips also work in the Music app on 
your iPhone, iPod touch or iPad. With 
iCloud Music Library switched on in 

iTunes’ preferences, whatever you add 
from Apple Music’s library to your own 
collection using iTunes on your Mac will 
also become available on your other 
devices, and vice versa. 

The Apple Music service is about 
more than just giving you a massive 
library of music to explore at your own 
leisure. It also includes the Beats 1 
internet radio station, genre-based radio 
stations, and personalised stations that 
you create by selecting a song or artist 
that fits your mood. 

Just as important, there’s a strong 
focus on discovering new albums and 
artists to listen to – both new releases 

and back catalogue material that fits 
your tastes. Apple Music tries to do this 
intelligently, based on some simple 
guidance from you when setting it up, 
explicit feedback you give it by marking 
things as ‘loved’, and your listening 
habits. Apple Music’s suggestions of 
things to listen to also appear on on 
all your devices.

The service also connects you to 
your favourite artists in the same way 
you might follow them on social 
networks. This doesn’t require a 
subscription except to add audio from 
their posts to your library.

You might already follow your 
favourite artists on other networks, and 
right now many we’ve followed seem 
not to be posting to Apple Music, but it’s 
very likely that in time you might find it 
a useful way to keep artists’ musings 

separate from your actual friends.
One thing that might strike you as 

odd about Apple Music is that it’s so 
separated out from the iTunes Store. 
You’ll need to type into a search bar to 
reach most of what’s in its library, yet 
you can add things to your personal 
collection, where you can rate tracks, 
add them to playlists, and download 
them to play offline just like tracks 
you’ve bought.

Take note of the heart icon you see in 
iTunes. This button is crucial to getting 
the most out of Apple Music when it 
comes to Apple’s curation process of 
listening recommendations.

Apple Music
Apple’s music streaming service brings big new features  
to iTunes. Here’s how to make the most of them…

The Apple Music service is about more  
than just giving you a massive library  
of music to explore at your own leisure

Complete guide to

VISUAL GUIDE | APPLE MUSIC
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When you first open iTunes 
in El Capitan, you’ll be 
invited to enrol in a three-
month trial of Apple Music. 

Enrolling requires that the Apple ID you 
use to sign into the iTunes Store has a 
bank card registered for payment, rather 
than just having credit on your account 
from iTunes gift cards, so Apple has a 
means to take automatic payment for 
the monthly subscription beyond that.

You don’t have to take up an Apple 
Music subscription to keep using iTunes 
to play your purchases from the iTunes 
Store or elsewhere. Should you decide 
you don’t want Apple Music, you can 
hide almost all of its features in iTunes’ 
preferences: switch off Show Apple Music 
under General, and disable Apple Music 
Connect under Parental. To sign up later 
on, make the service visible once again 
and then go to the For You page to start 
your trial from there.

If you have a subscription to iTunes 
Match – or were planning to sign up to it 

to make your music collection, including 
tracks not bought from the iTunes Store, 
available to download from all your 
devices – Apple continues to offer that 
annual service. Its functionality is part of 
Apple Music, so if you decide the extra 
features of the latter are worth a total 

annual cost that’s over five times as 
expensive, click your name at the 
top-right of iTunes, then Account Info, 
enter your password, then click Turn Off 
Auto-Renew next to iTunes Match. You 
can also turn off renewal of your Apple 
Music sub by clicking Manage.

Get started with Apple Music
It takes just a few minutes to sign up and start listening to millions of tracks

1 Choose your plan
iTunes will prompt you about signing 

up for a three-month trial. If you don’t accept 
right away, click For You at the top of the 
Music view to sign up later on. Otherwise, 
click the button that starts the sign-up 
process and choose an individual or a family 
membership (the latter requires set-up of 
Family Sharing: see http://apple.co/1J6drVq).

2 Account management
You’ll be asked to accept Apple’s T&Cs 

and confirm the purchase of a membership 
plan, because signing up for the three-
month trial automatically enables recurring 
payment at the end of it. If your Apple ID is 
part of a family and you aren’t its organiser, 
you’ll be asked to accept that an Ask to Buy 
request will be sent to them.

3 Say what you like
Help Apple Music recommend music. 

Click once on circles of genres you like, twice 
on those you love, or put the pointer over 
those you dislike and click the cross that 
appears. Your choices influence the artists 
suggested when you click Next. Repeat the 
process, clicking More Artists if needed. You 
only need to identify three; then click Done.

HOW TO | SET UP APPLE MUSIC

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
iTunes 12.2 or later, 

an Apple ID, 
a bank card

To change your basic choices that guide suggestions, click your name (top-right) then Choose Artists For You.
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1 Share a playlist
By subscribing to Apple Music, you’ll discover that you’re 

able to do a little more with your playlists. Links to any regular 
playlist you choose (but not Smart Playlists or Genius Playlists) 
can be shared on Facebook or Twitter, or privately by email, 
iMessage, or by copying the link to the Clipboard to paste it 
somewhere else.

Click Playlists near the top of iTunes’ main window and then 
select a regular playlist in the list on the left. After that, look to 
the right-hand side of the playlist’s header area and click the 
Share button there – then you can choose the method by 
which you want to send the link.

When you share to a social network, the way your playlist is 
presented to others differs depending on the network. On 
Twitter, your tweet will include your assigned artwork (see 
below), but Facebook currently just displays ‘Connecting to the 
iTunes Store’, so it’s wise to replace the status update iTunes 
provides with some text that explains to people what the link 
will take them to.

2 Subscribe to Apple’s playlists
Playlists you find in the For You, New, Radio and Connect 

pages can be added to your music library so you can listen to 
them at any time in future with just a few clicks. Click the More 
Options ellipsis next to a playlist’s name and choose Add to My 
Music, then switch to the Playlists view. Notice that the sidebar 
on the left contains a couple of playlist categories; one for 
Apple Music playlists you’ve added to your library and, lower 
down, those you’ve created.

You can’t reorder these categories, and you can’t create 
folders to organise Apple Music playlists, as you can for your 
own. As a consequence, you might find that you have to scroll a 
long way to reach your playlists. However, you can collapse the 
Apple Music Playlists category by moving the pointer over its 
heading and then clicking the word ‘Hide’ that appears next to 
it. In the same place, click ‘Show’ when you want to see the 
category’s contents again.

3 Custom artwork
When you create a playlist, there are a couple of new 

personalisations that you can make besides its name that are 
related to the Apple Music streaming service. If you’re going to 
share the playlist, you might want to fill out a description for 

others to read. Click Edit Playlist at the top-right of any playlist 
you’ve already created in order to do this.

At the top-left of your playlist’s contents will be a placeholder 
or a mosaic of album artwork based on the contents you’ve 
added to it. Simply click it to add your own artwork. You can 
always take a photo using a Mac’s built-in camera, but it’s the 
Other option that we find is the most useful; choose it and 
you’ll be able to select an image file that’s stored on your Mac, 
usually in the JPEG or PNG formats. The cool thing about this 
option is that it enables you to design your own artwork in any 
graphics app that’s available to you, much like you might once 
have designed custom inlays for mixtapes.

4 Filter your playlists
Playlists are one of the most enjoyable features of iTunes. 

But after a few months or even years of using Apple Music, you 
might end up with many more playlists in your iTunes library 
than you would otherwise have created yourself. In this case, 
remember that you don’t have to browse through all of them in 
the sidebar of the Playlists view, because playlists are included 
among the results when you type in the search bar at the 
top-right of iTunes. All you have to remember is that when you 
click in the search bar, make sure you’re only searching within 
your library, not the entirety of Apple Music’s collection, 
otherwise the results returned will balloon.

When typing into the search bar, you just need to provide a 
few details of what you’re looking for – perhaps an artist name, 
or one or two keywords that describe the type of playlist you’re 
looking for; bear in mind that many pre-created Apple Music 
playlists include phrases such as ‘Inspired by…’, ‘Intro to…’,‘ 
Deep Cuts’ and ‘Family Tree’ in their name. Depending on your 
mood at any moment, entering these phrases into the search 
bar might well prove useful in narrowing the list of results if 
you’re seeing too many, helping you to reach a specific 
playlist in seconds, rather than browsing through all your 
playlists for hours on end!

With iCloud Music Library switched on, your playlists are synced between your Mac and iOS devices.

Click a playlist’s artwork to reveal several options for replacing it.

HOW TO | USE APPLE MUSIC’S ADDITIONAL PLAYLIST FEATURES

SMART 
SEARCH

You can omit 
tracks you own 
outright from 

Smart Playlists in 
order to hear only 

those you have 
added to your 

library from 
Apple Music. 
Simply add a 

condition that 
checks whether a 

track’s iCloud 
Status is 

‘Apple Music’.  
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1 Get music recommendations
The New and For You pages are key to discovering new 

music. The former shows new releases, much like the front 
page of the iTunes Store, and is worth checking out 
occasionally if you find that you rarely visit the store after 
subscribing to Apple Music. (Bear in mind, though, that not 
everything sold in the iTunes Store is available in the Apple 
Music library.)

2 Personalised for you
The For You page should more quickly guide you to 

suitable sounds, old and new, because its contents evolve in 
response to information you feed back to Apple. It draws on 
what you’ve said you love (by clicking the heart icon next to 
an item or in the status area at the top of iTunes’ window) to 
suggest specific albums and curated playlists, such as 
introductions to artists. However, it doesn’t cross-reference 
with what you own, so you might see albums you’re already 
familiar with.

To indicate a suggestion isn’t the sort of thing you want to 
hear in future, click the More Options ellipsis next to an item 
and then choose Recommend Less Like This.

3 New releases
The New page has numerous categories for you to 

explore, some of which are persistently featured, while others 
are timed to major music industry events. Click the Curator 
Playlists banner a little way down the page for collections 
from well-known music publications.

The page defaults to showing music of all kinds. You can 
narrow it to suit your tastes, or just what you’re looking for 
right now, by clicking All Genres just under the carousel of 
highlights, and picking a more specific type. The list of genres, 
like the one in the iTunes Store, lacks some obvious categories, 
such as folk, easy listening and indie rock, so you’ll need to 
make educated guesses about where such sounds fall within 
Apple’s broader categories. Also note the explicit New Artists 
genre, should you want to get off the beaten track.

4 Curated playlists
There’s a mix of different items on the New page, 

including individual tracks and hot albums. Scroll down a little 
way and you’ll find links that take you to special playlists 

containing what Apple’s music editors are into, music suitable 
for activities such as driving, exercising and to wake up to, and 
from music magazines and sites. 

5 Recent hot tracks
Scroll down to the bottom of the page to find A-Lists, 

which gather notable tracks from various genres. Apple’s 
descriptions for them suggest they’re compiled from tracks 
released in the current week, but at launch we found Taylor 
Swift’s Shake It Off and several other tracks released over the 
last few months, suggesting A-Lists might be a good way to 
catch up on what’s popular in the medium term, much like 
Now That’s What I Call Music! albums.

6 Check your subscription
After trialling Apple Music for three months, your 

subscription will renew automatically on a monthly basis, but 
you can cancel at any time if you don’t think it’s worth the 
money. In fact, unlike many trial offers from companies 
offering streaming media, you don’t have to wait until the end 
of your trial period to ensure you don’t spend a penny on the 
service, at least until you make up your mind about 
continuing to subscribe.

Start right now by clicking your name (the silhouette-like 
icon near the top-right of iTunes’ window) and choose the 
Account Info option. In order to view and make changes to 
your account, you’ll be asked to enter the email address and 
password for the account you use for the iTunes Store and 
your Apple Music trial (also known as your Apple ID). When 
you’ve cleared the authentication, scroll down the next page 
to find the Settings heading. Within that group, look for the 
‘Subscriptions’ header and click the word ‘Manage’ to the right 
of it. Look for Apple Music Membership in the list of your 
subscriptions (which might also contain digital magazines if 
you also use an iPhone, iPod touch or iPad), click Edit next to 
it, and change the Automatic Renewal setting to ‘Off’.

Your listening habits and items you mark as ‘loved’ influence playlist and album suggestions in the For You page.

The New page presents curated highlights of what’s hot right now.

HOW TO | GET MUSIC RECOMMENDATIONS WITH APPLE MUSIC

WATCH
OUT

In the New page, 
there’s more to 

discover in each 
category than is 
obvious. Unlike 

the iTunes Store, 
where scrolling 

horizontally 
reveals extra 

items, look for 
chevrons next to 

headings; click 
those headings to 

see more.
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With El Capitan you get the 
new Photos app, which 
replaced iPhoto. You can 
check out the new El 

Capitan-specific features on page 36, 
but here we’ll look at the basics of how 
it works. If you’ve used the Photos app 
on an iPhone, iPod touch or iPad, the 
Mac version will seem familiar. It 
provides the same ways to explore your 
photo library, the same methods for 
organising photos into curated albums 
and sharing them with other people, 
and the same easy-to-use yet powerful 
toolset that makes it possible even for a 
newcomer to make photos look great.

When you select the Photos view at 
the top of the window, the app displays 
all of your photos in chronological order. 
The arrow buttons at the top-left of the 

window zoom in and out through 
several levels. At the most zoomed-out, 
photos are grouped into years. Click 
and hold on a thumbnail to see a larger 
preview, and let go to have that photo 
enlarge to fit the window. Alternatively, 
just click once to see Collections. These 
group photos by broad geographical 
regions, possibly over long periods 
of time. The click-and-hold technique 
works here too, or you can click a 

thumbnail to see Moments, photos 
taken over shorter periods of time and 
at more precise locations. Double-click 
a picture here to enlarge it, and then 
swipe left and right (with two fingers 
on a trackpad, one on a Magic Mouse) 
or use the arrow keys to step through 
the Moment. You don’t need to click the 
back button to quickly reach a specific 
photo. Instead, click the button to the 
right of that one to split the view, which 
will show other pictures from the 
Moment down the left of the window.

The app manages the contents of 
these views for you, based on data that 
your camera attaches to each photo you 
take. If your camera isn’t a phone, ensure 
that its clock is correctly set. Some 
cameras – especially those built into 
phones – can automatically attach 

Learn how to manage your photo library with Apple’s Photos app

SKILL LEVEL
Anyone can do it

IT WILL TAKE
Give yourself at 
least 30 minutes

YOU’LL NEED
OS X 10.11, some 

photos to play with

Make more of your 
photos in OS X

The Mac version of 
Photos has eight 
built-in filters and 
manual controls for 
manipulating colour

Photos is packed with 
simple yet powerful 
tools for editing images.
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location data to photos. If yours can’t 
then don’t worry, thanks toEl Capitan, 
Photos now enables location data to  
be attached manually.

You can curate your best photos into 
albums, either manually or by specifying 
criteria such as locations and keywords 
you’ve attached. The latter method, 
creating a Smart Album, is powerful 
because album content updates all the 
time to reflect changes in your library.

Thankfully, Photos hasn’t ditched its 
predecessor’s creative projects, so you 
can add your photos to books, calendars 
and greeting cards, and have these 
mementoes professionally printed.

Photos can use iCloud to make your 
entire photo library available on all of 
your Apple devices (well, those running 
iOS 8 or later) without you having to 
choose when and what to sync. Take a 
photo with your iPhone and the next 
time that device goes online using Wi-Fi, 
the photo will sync to iCloud and then 
appear on your Mac. It works the other 
way too, for photos added on your Mac.

Thanks to El Capitan, Photos now 
has the extensibility found in its iOS 
counterpart, so photography apps are 
unable to make their filters and editing 

tools available within it. There are also 
eight built-in filters. That’s not all the 
creative control at your fingertips, 
though. You also get manual controls 
for manipulating colour.

It’s not all bad news where expansion 
is concerned, either, because Photos 
provides an AppleScript library, which 
enables developers to extend it. OS X 
Automation (macosxautomation.com) 
has already tapped into this to provide a 

set of Automator actions, which are a 
much easier method of tailoring the 
app to your needs than learning a 
scripting language. On the site, you’ll 
find examples of how you might use 
these actions, including one that opens 
the Maps app at the location where the 
selected photo was taken. After reading 
our tutorial, it’s worth exploring these 
actions to see how they might help you 
get even more from the new Photos.  —>

GO OLD
SCHOOL
If you dislike 

Photos’ layout, 
you can bring 

back the sidebar 
method of 

navigating your 
albums and 
projects by 

choosing View > 
Show Sidebar.  

This removes the 
view buttons 

from the top of 
the window and 

expands their 
contents down 
the app’s left-

hand side.

Photos turns dark when editing images, which is a great opportunity to use El Capitan’s so-called dark mode.

See more or less
1  Drag this slider to resize the 

thumbnail previews below.

Various views
2  Photos shows your pictures in 

chronological order. Albums 

contains your curated collections. 

Shared shows photos you’ve 

published to iCloud for others to 

see, and Projects is where you 

design calendars, books and other 

things to be professionally printed.

Make things
3  Click the + button to make 

albums and to showcase your 

photos in printable projects.

Share things
4  Click the Share icon to email a 

selected item, publish it to a 

social network or share it via iCloud. 

QUICK LOOK | FIND YOUR WAY AROUND PHOTOS FOR OS X
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iPhoto Events are converted into albums and placed in a folder called iPhoto Events in the Albums view.

If you’ve already amassed a library of 
photos in either iPhoto or Aperture, 
Photos can import its contents. In most 
cases this will be a straightforward 
process. If you have just one library on 
your Mac, then you only need to open 
Photos and click Get Started. The app 
will copy the contents of your existing 
library into a new one that’s used only 
by the Photos app, and the old one will 
remain so that you can continue to use 
iPhoto or Aperture. (That said, making a 
backup first would be wise, just in case 
you run into an unexpected problem.)

When you click Get Started, Photos 
might complain that permissions on 
your library need to be repaired before 
it can be imported. To fix this, first make 
sure the old app is not open, then hold 
down ç+å as you double-click the 
app icon to open the app, and keep 
those keys held down while it opens. In 
the case of Photos you’ll see an option 
to Repair Library; in iPhoto you’ll see a 
panel of maintenance options. Run the 
option that repairs permissions, then 
close the app and try again in Photos.

If Photos detects that there’s more 
than one iPhoto or Aperture library on 
your Mac, it will ask which you want to 
import. Afterwards, Photos’ File > Import 
option doesn’t import or merge another 
library; it is for importing files stored 
loose on a disk into the current library. 
Photos provides no way to merge the 
contents of two libraries (at least not 
without an iCloud trick – more shortly).

Just as in iPhoto and Aperture, you 
can create and switch between several 
libraries in Photos. To import a second 
library into Photos, close the app, then 
hold down å as you reopen it to see 
a list of other detected libraries, along 
with options to browse for one that isn’t 

shown and to create an empty library. 
Choose another library to import and 
a new copy for use with Photos will be 
created alongside the original version.

 Photos uses a feature of the Unix 
system on which OS X is built to enable 
its library and iPhoto’s to point to the 
same data without duplicating it: iPhoto 
stores only references to your images, 
not copies of them. An advantage of 
this is that you can trash your iPhoto 
library without losing the data that it 
and Photos share.

If you’ve ever used the option to store 
photos outside of the library package 
(possible in both iPhoto and Aperture), 
those master files will remain where 
they are and be referenced from your 
old and new libraries. Referenced files 
have a consequence for iCloud Photo 
Library – they won’t be uploaded to it. 
Find out on page 130 about this feature 
and how to overcome this limitation.

You can migrate as many iPhoto and 
Aperture libraries as you want, and one 
will be designated as the System Photo 
Library. Only this one’s contents are kept 

in sync with iCloud Photo Library and 
appear in the Media Browser in other 
apps, including Pages and iMovie.

Earlier, we mentioned a trick for 
merging libraries. In the dialog that 
appears when you open Photos with 
å held, the System Photo Library is 
indicated. Open a different one, choose 
Photos > Preferences > General, turn on 
‘Use as System Photo Library’ and, in the 
iCloud tab, turn on iCloud Photo Library. 
The library’s contents will be merged in 
iCloud with whatever has previously 
been uploaded. Note, however, that this 
cannot be undone. 

Photos will warn you if your iCloud 
storage is insufficient for all of your 
photos. If you don’t want to pay for 
more, or the maximum tier of 1TB isn’t 
enough, follow Apple’s suggestions at 
support.apple.com/HT204410.

iPhoto and Aperture enable you to 
rate a photo by assigning it a star  
rating out of five, and to flag a photo  
as a reminder to do something with  
it. Photos doesn’t have such granular 
options. Instead, you can simply mark 
a photo as a favourite. However, your 
ratings and flags aren’t lost when  
moved to Photos. Apple’s solution is to 
convert these attributes into keywords, 
which you can look up from the search 
bar and inspect in the criteria of a Smart 
Album. If you want to carry on using 
ratings for your photos, you can always 
add them as keywords yourself – see 
page 134. 

Star ratings and flags 
are converted into 
keywords, which can 
be inspected by a 
Smart Album’s rules

If you use iPhoto 7 or 
earlier, run its library 
through iPhoto Library 
Upgrader (support.
apple.com/kb/DL1523)

LOOSE 
FILES

Photos that are 
stored outside of 

the library 
package can be 
copied into it. 

Select them and 
then choose File 
> Consolidate. 

The app will tell 
you if none of 
the selection is 

stored externally, 
otherwise it asks 
you to confirm 

before it 
proceeds. 

IN DEPTH | IMPORT YOUR EXISTING iPHOTO OR APERTURE LIBRARY
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1 Create an album
Go to File > New Album. Enter an album 

name. You’ll see your photos as moments (shots 
taken around the same place and time). Click a 
photo to select it for inclusion in the album, or 
move the pointer over a moment’s title row and 
click Select Moment to mark all of its contents.

4 Organise your albums
In the Albums view, those you’ve created 

can be dragged around to rearrange them. 
Folders can be used to group albums (and other 
folders). Choose File > New Folder to make one. 
When a folder is selected, the Play and Share 
buttons will act upon its entire contents. 

6 Mark a favourite photo
To mark a photo as a favourite and have 

it appear in the Favorites album, put the cursor 
over it and click the heart at its top-left, or select 
several photos and click the heart on one to 
mark them all. Or, while viewing a single photo, 
click the heart in the toolbar or press the . key.

2 Add photos to an album
While marking photos for inclusion, click 

Selected (top-left) to review your choices. Click 
a photo again to remove the tick and exclude it. 
When you’re satisfied, click Add (top-right) to 
see the album’s new contents. Click Albums or 
the back arrow in the toolbar to see all albums.

5 Play a slideshow
Select one or more albums or folders, or 

open an album and select some of its contents 
(ç-click to select more than one item), then 
click the Play button in the toolbar to choose a 
presentation theme and music (including tracks 
from iTunes) to accompany your slideshow.

8 Quickly find people
The Faces album shows people detected 

in your photos. Double-click to name one. You’ll 
see other photos thought to be of them, and be 
asked to confirm or correct. When you’re done, 
the person’s face appears larger in the album 
and acts a shortcut to all photos of them. —>

7 Show more information
Go to Window > Info to see metadata for 

the selected photo, such as camera settings and 
place taken (if recorded). You can add a title, 
description and keywords (press ® after each), 
all of which Smart Albums can inspect. You can 
also manually identify people.

3 Create a Smart Album
Go to File > New Smart Album to set 

rules that automatically gather photos from 
your library. Click the + to add more criteria, and 
choose whether any or all of them must match. 
To modify a Smart Album’s criteria later, click the 
cog next to the Smart Album’s name.

SLIDESHOWS
Slideshows created with the 
Play button aren’t saved, but 

those made with the + 
button are kept in the Projects 
view. They can be turned into 

videos using File > Export. 

HOW TO | ORGANISE YOUR PHOTOS
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HOW TO | CATEGORISE AND SHARE YOUR PHOTOS

1 Add keywords
Keywords can be added to a photo by 

two methods. The first is to select a photo and 
go to Window > Info. In the panel that opens, 
you can type keywords or phrases. Press ® 
after each one. You’ll be offered suggestions 
from previously-used keywords as you type.

4 Subscribe to an album
When someone shares an album with 

you, you’ll be alerted by email and whatever 
methods you’ve configured for Photos in the 
Notifications pane in System Preferences. Open 
the app, click Shared and double-click Activity 
to see options to accept or reject the invitation. 

6 Import shared photos
To keep a copy of shared photos (in case 

their owner removes them from the shared 
album), select them, right-click on one of them 
and then choose Import. Note that if you try to 
edit a shared photo, you’ll be offered the option 
to import it to make that possible. 

2 The Keyword Manager
Go to Window > Keyword Manager to 

see all keywords you’ve used. Click one to apply 
it to the photos you’ve selected, or remove it if 
already applied. Click Edit Keywords to create or 
erase keywords (the latter removing them from 
photos, too) and to assign keyboard shortcuts.

5 Shared album settings
Double-click an album in the Shared 

view to open it. At its top-right is an option to 
add to it, and a button with a silhouette of a 
person. Click the latter to check who can view 
the album, who can add to it, and whether you 
get notifications for new items and comments.

8 Delete photos
When you right-click a photo and choose 

Delete, it is hidden on all of your devices. For a 
short time, it can be recovered by going to File > 
Show Recently Deleted. Click photos you want 
to keep, then Recover, or click the Delete button 
to properly get rid of them right away.

7 Hide photos
A photo can be hidden from the Photos 

view by right-clicking it and choosing Hide. 
(It will remain visible in albums to which it has 
been added.) To unhide a photo, choose View 
> Show Hidden Photos Album, browse to that 
album, right-click a photo and choose Unhide. 

3 Share photos on iCloud
You can share photos with other people 

using albums hosted on iCloud. Select some 
shots, go to File > Share > iCloud Photo Sharing, 
and click New Shared Album. Name it and enter 
names or addresses of contacts to share it with, 
and then click Create to send the invitation. 

COMMENTS
To comment on or indicate 

that you like a photo in a 
shared album, double-click it 

to view it larger and then 
click the speech bubble at 

its bottom-left corner.
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HOW TO | EDIT AND ADJUST YOUR PHOTOS

1 Quickly edit a photo
Select a photo and press ®. The app’s 

interface turns dark to put the emphasis on the 
picture. OS X’s dark mode (in System Preferences 
> General) complements this look. Among the 
tools on the right, Enhance will try to improve 
your photo with a single click.

4 Clear up blemishes
The Retouch tool clears up blemishes by 

sampling pixels from one area as the basis for 
filling in another. The tool picks a source area; 
you can override its choice by å-clicking 
somewhere. Let go and then brush out the 
unwanted detail. [ and ] adjust brush size. 

6 In greater detail
Click the arrow to the right of the Auto 

button and the components of that adjustment 
are revealed. They can be adjusted individually 
using the same click and drag action. Do this for 
Light, but drag on its main bar to see how this 
changes its components by different amounts.

2 Adjust framing
Rotate turns a photo in 90° increments. 

Use the Crop tool to rotate to any angle while 
maintaining the overall rectangular shape. 
You can manually drag the white border to crop 
without rotating. Clicking Auto attempts to level 
a tilted shot along a detected horizon.

5 Advanced adjustments
The Adjust tool displays adjustable 

attributes as horizontal bars. Click and drag 
along a bar to adjust that attribute. Moving the 
pointer over an adjustment’s title row reveals an 
Auto button which, like the Enhance tool, sets 
the attribute to a good level with just one click.

8 Reuse a photo’s look
If you find you adjust the same attributes 

often, tick them all in the list and select ‘Save as 
Default’ in the list. To apply adjustment values 
from one photo to another, right-click the photo 
and choose Copy Adjustments, edit another, 
right-click it, and choose Paste Adjustments. —>

7 Even more adjustments
Click the tick next to an adjustment to 

disable it, or click its name to reset or remove it. 
Click Add (top-right of the list) for other effects 
that work in the same way except for Levels: on 
this you drag the dots below the histogram to 
fix things such as colour balance and exposure.

3 Apply a filter
The Filter tool offers a range of pre-made 

looks for your photos. Click one to toggle it on 
or off so you can judge the result. Click Done at 
the top-right to apply it. The same eight filters 
are available in Photos on iOS, so any you apply 
will be preserved as you move between devices.

ROLL BACK
Changes to a photo can be 
reversed by editing it again 

and clicking Revert. To make 
independently editable 

copies, select a photo and 
then press ç+D.
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1 Upload from iOS
Using your iOS device, take a photo. 

Next, connect your device to a Wi-Fi network. 
That’s it – your device will upload the photo you 
took to iCloud. You can confirm this is done in  
Settings > iCloud > Photos, which shows a 
count of how many uploads are pending.

3 With other cameras
If you use another type of camera, don’t 

worry – pictures you import to your Mac’s photo 
library will be uploaded to the online one, too. 
After importing, open Photos’ preferences and 
click iCloud if you want to monitor the progress 
of the upload, or if you want to postpone it.

2 Upload burst photos
All shots in a burst photo (where, on a 

recent iOS device, you hold down the shutter 
release to take several photos and then let iOS 
pick the best) are uploaded by default. To save 
space in iCloud, turn off Upload Burst Photos so 
only shots marked as favourites are uploaded.

Using iCloud Photo Library
Discover how your photos are stored online and synced to your devices

iCloud Photo Library 
is Apple’s new 
method for making all 
your photos available 

on all of your devices, no matter 
what camera they’re taken with or 
which device’s photo library you 
import them into. To use it, your 
Mac must have OS X El Capitan 
and your iOS devices must be 
running the first iteration of iOS 8 
at a minimum.

In Photos’ preferences, click 
iCloud and tick the iCloud Photo 
Library box. Photos then starts 
uploading photos from its library 
to iCloud. This can take a while, so if you 
need bandwidth to, say, more reliably 
stream online video, return here and 
click the ‘Pause for one day’ button. 
(That button then changes to one you 
can click to manually resume photo 
uploads without waiting.)

Enable iCloud Photo Library in iOS 8 
in Settings > iCloud > Photos. While 
connected to Wi-Fi, your iOS device will 
upload the photos it contains. 

Both OS X and iOS offer a choice of 
whether photos are downloaded at full 
quality or as smaller versions optimised 

for the device you’re using. Bear in mind 
that you’ll need plenty of iCloud storage 
for all of your photos, and that it’s also 
used to store email, backups and more.

In Photos’ preferences, under General, 
is an option that determines whether 
image files you drag into the app are 
copied into the app’s monolithic library 
file. If you turn this off, dragged photos 
are referenced in their current location 
rather than copied. This gives you some 
freedom to organise the originals, but 
has a significant drawback: referenced 

photos aren’t uploaded to iCloud Photo 
Library. To determine whether your 
library links to any photos in this way, 
switch to the Photos view and press 
ç+A to select everything. Next, go to 
File > Consolidate. If all your shots are 
stored inside the library, the app will 
confirm. Otherwise, you’ll be warned 
first that the process can’t be undone.

Note that iCloud Photo Sharing is 
a separate feature with a different 
purpose – it enables you to share 
photos with other people and, 

PHOTO 
STREAM

This old method 
of getting 

photos onto 
other devices 

(bit.ly/photostr) 
remains available 
in case you have 

devices that 
can’t run iOS 8 or 
El Capitan. If you 

don’t need it, 
make sure it’s 

disabled in the 
iCloud tab 
in Photo’s 

preferences.

With iCloud Photo Library enabled, photos taken with your iPhone are automatically added to your Mac.

HOW TO | MOVE TO iCLOUD PHOTO LIBRARY
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Preview is one of the 
unsung heroes of OS X. 
Its status as the default 
app for opening images 

and PDFs means it’s often not taken as 
seriously as it should be. Preview is fast, 
powerful and very versatile. What other 
free app enables you to edit and resize 
pictures, open iWork documents and 
open many Microsoft Office ones too? 
Let’s see what Preview is capable of.

Preview’s ability to open PDFs makes 
it a great alternative to apps like Adobe 
Reader, but you can also use it to fill in 
PDF forms: when you open one, Preview 
automatically detects the fields you 
need to fill in. You can even add a digital 
version of your signature if you want to.
To do this, sign a piece of white paper 

in black ink, open a document in 
Preview and then select Annotate in 
the top menu bar. From the drop-down 
menu that appears select Signature, 
then Create Signature from Camera… 
Now hold up your signed piece of 
paper to your Mac’s camera and line it 
up with the blue line on the display.

Signing up
Once the signature has been detected, 
it will appear in the box. If you’re happy 
with it, click Accept and you’re returned 
to your document. Your mouse pointer 
will now turn into crosshairs, enabling 
you to click the place in the document 
where you’d like to place your signature, 
then resize it. Preview automatically 
saves your signature for you. It’s now 
available for you to use in this and other 
documents whenever you like.

Another thing you can do with PDFs 
in Preview is combine them to make 
multi-page documents. To do this, 
open both the documents you’d like 
to combine and select Thumbnails from 
the View menu in each. You’ll now see a 
thumbnail view of both PDFs showing 

all their individual pages. To combine 
them, simply drag thumbnail pages 
from the sidebar in one document on 
to the thumbnail page in the sidebar of 
the other. When you’re done, select File 
> Save from the top menu bar. 

To edit or annotate an image or 
document, click the Edit Toolbar button 
(next to the search box). Its submenu 
includes tools for marking, cropping and 
adjusting colours, as well as the ability 
to add text comments. With a PDF open, 
click the Markup Tools button for the 
options to highlight, underline or strike 
through key passages of text.

You can add Shapes on a document 
to draw attention to certain parts or 
strike out areas. The Loupe tool creates 
a magnification effect on the page that 
enables you to zoom in on important 
parts. You can adjust the position and 
magnification level.

The great thing about Shapes and 
Loupes is they are saved as objects that 
can be edited, repositioned and deleted, 
even by another person you send the 
PDF to. Let’s see how to use these tools 
and learn what else Preview can do…

Get more from Preview
Find out about the powerful little app that’s packed full of features

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.11

You can fill in PDF 
forms, sign them 
and even combine 
PDFs to make multi-
page documents

HOW TO | ADD SHAPES AND A LOUPE TO A PDF DOCUMENT

1 Adding a Shape
We’ll start with a PDF document (created 

from a Pages template) that includes some 
images and text. We’re going to add an arrow 
and draw a circle around the contact details 
at the bottom. Go to View > Show Markup 
Toolbar (or click the Show Markup Toolbar 
icon). Click Shapes (a square and circle icon) 
to reveal some options. Click any of the 
Shapes to add it to the document.

3 Loop the Loupe
Now go to Tools > Annotate > Loupe 

to add a Loupe. This can be repositioned and 
resized, like a Shape, but it zooms in on the 
document beneath it. Click and drag the blue 
drag handle in and out to increase the size of 
the circle. Dragging the green drag handle 
around the Loupe increases (or decreases) 
magnification. Choose File > Save to save the 
file with all its new Shapes. 

2 Arrange shapes
Hover the pointer over a Shape and  

it turns into a hand icon. Click and drag to move 
the Shape to a new position. Blue drag handles 
also appear – click and drag these to resize the 
Shape. Some Shapes have an additional green 
drag handle – on a line or arrow you click the 
green handle to bend the line. Click the Shape 
Style and Border Color icons for style options for 
the selected Shape. 
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1 Quickest crop ever
Double-click an image and Preview will 

open and display it. Use the rectangle marquee 
tool to quickly drag a frame around the area you 
want to keep. Adjust by dragging the sides. Hit 
ç+K and the image will be cropped to the 
area you selected. To undo, hit ç+Z.

4 Adjust it
To change the size of the image, use 

Tools > Adjust Size. A drop-down menu appears 
that lets you change the size in a number of 
different ways. By having an idea of the true size 
to begin with, you’ll know what is required for 
the resizing job at hand.

6 Pick a percentage
Here we’ve reduced the dimensions by 

50 percent. The default resolution in most cases 
is 72 pixels per inch, which is fine for viewing 
on a (non-Retina) screen or the web, but not for 
printing (go for double that or more), let alone 
professional publishing (300ppi is optimum).

2 Save, use, forge on
With the crop in effect you can save the 

image with ç+S. This will overwrite the 
original picture. If you want to go back to the 
original, uncropped image, you can do so using 
Versions. Select File > Revert To, then click 
Browse All Versions.

5 Pick a value
Choose how you want to specify the 

resize. The simplest option is the percentage 
value but the others all have specific merits: 
pixels can be used to create perfect images 
for web posts, millimetres for page layout 
and centimetres for printing.

8 Stunning sliders
Use the sliders to adjust overall exposure 

and contrast, or tweak the image’s bright or dark 
tones separately. Use the Saturation slider to 
boost or subdue the colour; use the Sepia slider 
to create an antique effect. You can send, share 
or upload the image straight from Preview.

7 Time for an edit
You can quickly edit an image with 

Tools > Adjust Colour, or ç+å+c. The tool 
window that opens is also used in iMovie, and 
is similar to the advanced controls in iPhoto. 
These enable you to make quite precise 
adjustments to your image.

3 Check your size
Before resizing an image, check how big 

your original is. Preview zooms to display the 
full image by default; get the bigger picture 
using View > Actual Size, or press the ç+0 
(zero) shortcut. This will instantly show you just 
how big or small the image is.

HOW TO | EDIT IMAGES IN PREVIEW

Open a PDF document, click 
the Markup Tool and you can 
highlight, underline or strike 
through passages of text – 

perfect for making comments 
on shared work documents.

MARKUP TOOLS
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Your Mac comes with a host 
of apps installed and ready 
to use. There are apps for 
browsing the web, reading 

your emails, opening PDFs, and more – 
find out more at www.apple.com/uk/osx/
apps. We’ve already looked at some of the 
more utility-style apps you’ll use now and 
then, but there are also plenty of more 
general-purpose ones.

For instance, the Calculator app is 
capable not only of simple arithmetic 
but also of complex logarithmic 
calculations and logical operations – 
select Scientific or Programmer modes 
in the app’s View menu. It also supports 
Reverse Polish Notation, can convert a 
variety of units of measurement, and 
can save and print a ‘Paper Tape’ record 
of your calculations. The Chess app 

enables you to play against your Mac 
or another person. The DVD Player app 
does just what it says, while QuickTime 
enables you to enjoy media in a range 
of formats. Image Capture isn’t for 
capturing an image of your screen;  
it’s for importing images from a digital 
camera, iPhone or scanner. Stickies 
enables you to add reminders and notes 
on your Desktop.

Get to know the rest of the bundled apps that come with your Mac

SKILL LEVEL
Anyone can do it

IT WILL TAKE
15 minutes

YOU’LL NEED
OS X 10.10

More apps for your Mac

5 Font Book
If you don’t use your Mac for design or 

DTP, you might never open Font Book. For 
anyone who deals with fonts, though, it’s a 
great tool for installing/removing, previewing, 
printing and organising font families. It will also 
check font files to ensure they’re not corrupted.

1 Contacts 
Store contacts’ details here, including 

postal addresses, phone numbers and emails. 
When you need to send a message in Mail, start 
typing the person’s name and the email address 
will be pulled from your contacts. You can group 
contacts together, such as colleagues or family.

4 Photo Booth
It’s not likely to be the most used of your 

apps, but Photo Booth can be a lot of fun. As the 
name implies, it enables you to take a photo, or 
capture a video clip, and apply various effects, 
ranging from relatively subtle to downright daft. 
Great for messing about with friends.

2 TextEdit
It might not offer as much as Apple 

Pages or Microsoft Word, but TextEdit is super- 
quick and enables you to save work in various 
formats, including Word’s DOC and DOCX. 
TextEdit opens files in a variety of formats too, 
so you can work with RTF, TXT, DOC, DOCX, etc.

6 Dictionary
The dictionary built into OS X is 

particularly comprehensive. It has support for 
multiple dictionaries, integration with Wikipedia, 
gesture support and multiple word views. If you 
use a trackpad, you can look up a word within a 
document by tapping on it with three fingers.

3 Game Center
Many games from the App Store connect 

with Game Center. Sign in to the app with your 
Apple ID to connect with friends to compare 
your achievements in games, to challenge each 
other, and to know when someone is waiting for 
your next move in a turn-based game.

HANDY APPS  | ALSO INCLUDED WITH OS X
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1

2

3

4

5

1 Sign in…
To get started, click Sign In under Quick 

Links on the right-hand side. If you already have 
an Apple ID type in your details and click the 
Sign In button. Otherwise, click Create an Apple 
ID and follow the steps.

2 Top free apps
Once you’ve signed in, you can browse 

the charts or a particular category, or search for 
something specific in the top bar. Although you 

have to pay for most of the apps available in the 
App Store, there are plenty that are available at 
low cost or for free. The App Store has a handy 
chart showing the top free apps available on the 
store. Look at the right-hand column as you 
scroll down the Featured page to find it. While 
many of these apps are genuinely free, others 
include In-App Purchases (IAPs).

3 Find out more…
You can find out more about any app in 

the App Store by clicking its name. Every app’s 
page includes a selection of screenshots, and 
you may find that other people have posted 
reviews about their experiences with an app.

4 Download and install
To download an app, simply click the 

button marked with a price or the word ‘Free’  
(depending on whether it’s paid for or free). It 
will change to ‘Buy App’ or ‘Install App’; click 
again and enter your Apple ID’s password as 
confirmation. Paid-for apps will be charged to 
the payment method associated with your 
Apple ID. The app will download directly to your 
Applications folder, and you can monitor its 

progress by opening Launchpad or by moving 
the pointer over Launchpad’s icon in the Dock.

6 Buy once, 
use anywhere!

Apps you download get linked to your Apple ID 
and can be used on any Macs you own, or 
control, for personal use. So if you’ve bought 
something on your iMac and want a copy on 
your MacBook, sign into the Mac App Store on 
the latter and click Purchased, then click the 
Install button to the right of the app’s name. It 
won’t cost any extra! The ability to download 
apps you’ve bought at any time is handy for 
another reason: if you find your Mac is running 
low on storage space, you can delete an App 
Store purchase to free some space, safe in the 
knowledge that you can download it again later.

7 Keep apps up-to-date
Keeping your App Store apps up-to-date 

is extremely easy. Go to System Preferences  
> App Store and tick the relevant options to 
automatically update them to their latest 
versions. You can also choose to automatically 
download apps purchased on other Macs.

Using the Mac App Store
Take a trip to the Mac App Store and discover a world of apps

Want some new software? Your 
most obvious source is the App 
Store: select it from the  menu or 
click on its icon in the Dock or 

Applications folder. Most of Apple’s own apps, 
including the iWork suite (Pages, Keynote and 
Numbers), are available for instant download 
here. Other popular apps, including Microsoft 
Office for Mac, need to be sourced from 
elsewhere –sometimes as a download from their 
publisher’s own online store, although some still 
come on a DVD. Open the App Store though and 
you’ll see a huge selection of apps for your 
perusal. Let’s take a look at how to get started.

VISUAL GUIDE  
THE MAC APP STORE

Current 
featured apps

1  Featured apps and 

special promotions 

are displayed here.  

New & 
Noteworthy

2  Newly released 

apps from across 

all the categories are 

shown here. 

Quick Links

3  Use these to sign in, 

maintain your 

account details, and 

redeem App Store gift 

cards if you don’t want to 

register a bank card as 

your payment method.

Top Picks/
Categories

4  See which apps are 

most popular  

in a variety of categories.

Purchases and 
Updates

5  Hit the Purchases 

icon to view all of 

your App Store purchases 

and re-download them if 

necessary. The Updates 

icon enables you to 

quickly access both app 

and OS X updates.
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The best free 
Mac apps
Why spend a fortune on apps when you can 

get these brilliant ones for nothing?

Words: Kenny Hemphill  Illustration: Paul Blachford
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here are free apps and there 
are free apps. The App Store 
has given free apps as a 
whole a bit of a bad name. 
Take look at the top 10 free 
apps on the store and it’s not 
very enlightening. Of course, 

OS X El Capitan is the most downloaded free 
app there. Look for others and once again the 
results aren’t much help. It’s almost as if Apple 
doesn’t want you to find the really 
good stuff.

That’s where we come in. Every app 
on these pages has been given the 
MacFormat seal of approval. And 
in every case, the app is a solid 
alternative to a well-known 
paid-for app, in some cases saving 
you hundreds of pounds. 

Sure, the free apps aren’t as 
fully-featured as their commercial 
counterparts, but how many of those 
missing features do you need? In 
every instance featured here, the free app does 
the basics, and sometimes much more, very well.

You won’t find any demos or trial versions in our collection, 
though some of our choices offer in-app purchases. Make no 
mistake that the in-app purchases provide additional features 
and functions, but they’re not necessary to do the basics. 

Wunderlist is a prime example of how good free apps can be. 
Its free version is so good that we wonder how its paid-for 
rivals manage to survive.

There are other benefits to using free software. Much of it is 
open source and uses open document formats, rather than the 
proprietary formats favoured by applications like Adobe 
Photoshop. That makes it much easier to swap documents 
between applications, and offers a degree of future-proofing 
too. Even Microsoft Office demonstrates this; for the best part 
of a decade, it has used a documented XML format, enabling 
your documents to be opened in free alternatives such as 
LibreOffice, although some content may look different in them.

Can you use these tools in 
a professional workflow? 
Absolutely. Many of them are 
used in just that way. There are 
magazines laid out in Scribus, 
for example, and Google Docs 
is widely used for collaborative 
working in large organisations. 

The best thing about free 
apps, of course, is that trying 
them costs nothing other than 
your time. Download them, 
have a go. If it turns out they 
suit your needs, you’ve saved 
yourself some money.

Pushbullet  
pushbullet.com
This is a very niche little 
app, with no paid-for rival 
as such, but it allows you 

to see and dismiss all your iPhone 
notifications on your Mac. El Capitan’s 
Notification Center is good, but Pushbullet 
is a little more flexible. You can also send 
customised alerts between your devices 
with text, links and files.

Handbrake 
handbrake.fr
This app can convert 
many types of video, 
including DVDs you 

might have created with iMovie in the 
past, to formats that can be played back 
on Apple devices. It’s packed with 
advanced features, yet it’s easier to use 
than it first seems; you only really have to 
pick one of its Apple device presets.

Burn, burn-osx. 
sourceforge.net
Apple’s iLife apps no 
longer provide a way to 
burn your home videos as 

a DVD-Video. Perhaps you have a relative 
for whom that’s still the ideal way to share 
a video because they don’t have a 
computer. In that case, Burn – and a £20 
USB DVD writer, if there isn’t one built into 
your Mac, has you covered.

The Unarchiver 
unarchiver.c3.cx
At some point, you might 
have compressed and 
archived documents in 

a format such as a StuffIt archive – 
especially if you’ve been using computers 
since the ’90s. This capable little tool is 
likely to be able to unpack those archives. 
Then you’ll just need an app that can read 
the files it extracts.

Best for notifications

Best for video

Best for burning

Best for zips

Calling all iPhone addicts

Change the format of anything

Make your own CDs & DVDs

Four free apps you 
should own…

Expand your files
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Pixlr

Inkscape

Autodesk has a fine history 
of producing free apps. 
SketchBook Express and 
Motion FX are two of the 
better ones, and Pxlr is 

another. It enables you to easily edit images, 
add effects and filters, and blend one image 
with another. You can crop, straighten and 
re-size images.

The app’s auto fix feature adjusts colour and 
lighting at the click of a button. Some of Pixlr’s 
effects aren’t to our taste, but with hundreds to 
choose from you should have no difficulty 
finding some you like. 

In addition to myriad visual effects, there 
are 340 overlays and 200 borders, so you can 
create over two million combinations. 

Pixlr’s tools are laid out down the left-hand 
side of the image you’re working on. Clicking 
a tool opens a panel to display its options, with 
a thumbnail preview of its effect to show how 
it will affect your image. You can also adjust the 
intensity of effects before applying them.

Setting up a free pixlr.com account unlocks a 
few advanced features. There are no selection 

tools in the free versions of Pixlr, though if you 
pay £1.49 per month or £10.99 per year for 
a Pro membership, you gain access to selection 
and masking tools, among other things. 

If you use photo-editing apps mainly for 
tuning up images and adding effects before 
sharing them, Pxlr is ideal, packed with features 
and it won’t cost you a penny.

FREE
Autodesk
pixlr.com/desktop

FREE
Open source
inkscape.org

IMAGE EDITING  
PIXELMATOR 

VECTOR GRAPHICS  
ADOBE ILLUSTRATOR 

Inkscape is a vector drawing 
app with all the key tools 
you’d expect in an application 
of its type. So there’s a pen 
tool that enables you to draw 

Beziér curves, you can add text, and you can 
manipulate objects using the selection tools. 
It’s also easy to clone, copy and paste objects, 
and place them on separate layers.

If you’ve used Adobe Illustrator, you might 
find Inkscape takes a bit of getting used to 
because many tools they have in common 
have different names and aren’t where you 
might expect. Most are present, though. Take 
Illustrator’s Pathfinder palette, for example. In 
Inkscape, the same options for combining 
objects are called Boolean operations. 

There’s a tool similar to Illustrator’s Live 
Trace, which assists in turning a sketch or a 
bitmap image into vector art. And the use of 
nodes on paths makes them easy to edit; their 
apperance changes to indicate different 
features, and they can be selected, moved, 
rotated, and scaled using keyboard shortcuts – 
a godsend if constantly clicking and selecting 
with a pointer drives you up the wall.

New features in the latest release (0.91) 
include enhancements to the Find/Replace 
tool, a new Measurement tool, and a feature 
that allows you to swap the positions of 
selected objects or their stacking order.

There are tools missing when compared with 
Illustrator; there’s still no gradient mesh tool or 
proper colour management, but new features 
are being added all the time. 
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Wunderlist

Scribus

Describing Wunderlist as 
a list making app is a bit like 
describing Photoshop as a 
tool for editing photographs. 
It is a list-making app, but oh, 

what lists! You can use it to make anything 
from shopping lists to work schedules, and you 
can set alerts to remind you to perform tasks. 
Lists can be shared with colleagues and tasks 
delegated, and you can even publish them on 
the web for anyone to see when you send 
them the address.

Best of all, Wunderlist on the Mac syncs with 
Wunderlist on iOS, so you can create lists on 
one device and have them immediately – and 
we mean immediately – available on another. 
The iPhone version also includes an app for 

Apple Watch, which alerts you to tasks you 
need to complete. It’s also possible to break 
down large tasks into subtasks. The Activity 
Center alerts you as things happen on lists 
that you share with others – say, when a task 
is delegated to you. 

Wunderlist couldn’t be easier to use and 
sports the kind of collaborative features and 

syncing tools you’d normally have to pay a 
great deal for – Things, for example, charges 
you separately for its Mac and iOS versions, 
in order that you can sync them.

Wunderlist looks great too, with a choice 
of photographic backgrounds which work 
particularly well full-screen on the Mac. The 
app is quite simply brilliant. Get it.

FREE
6Wunderkinder
wunderlist.com

FREE
Open source
scribus.net

PRODUCTIVITY  

THINGS

PUBLISHING  

ADOBE INDESIGN

If you need a free tool for a 
printed project, this one’s 
well-worth a try. Scribus is an 
open-source page layout app 
which claims to offer press-

ready output. Several small magazines use it in 
their production workflow and it’s not difficult 
to see why when you look at the available 
features. Colour separations? Check. Support 
for CMYK and spot colours? Check? ICC colour 
profiles? Plenty of control over PDF output? 
You get the idea.

Scribus uses an open-source file format, 
which has been updated in the latest release, 
1.5, and doesn’t support older versions of the 
app. That’s not a problem if you haven’t used 
Scribus before. More of an issue might be the 

lack of support for InDesign and QuarkXPress 
files. But don’t let that put you off.

Scribus can open just about any image file 
you’re likely to need, and the latest version is 
able to store bitmap images, rather than just 
link to them.

There’s also a new feature called Symbols, 
which modifies instances of an object when 
the master item is modified. Version 1.5 also 

includes new type features. Associated 
licensing costs means there are no Pantone 
colour palettes in Scribus, but there are over 
100 other colour palettes including several 
with colour schemes of large organisations.

The interface, like many open-source tools, 
takes a bit of getting used to, but you’ll find 
plenty of help and tutorials in the Scribus wiki 
(http://wiki.scribus.net). 
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Dashlane is a password manager which uses 256-bit 
AES encryption to securely store passwords and 
other private data. Browser plug-ins for Safari, 
Firefox and Chrome enable you to generate secure 
passwords and save them, autofill those you’ve 

already saved, and automatically fill out forms. Unlike 1Password, 
Dashlane lacks a menu bar icon, so you’ll either have to open the app 
or a browser to access Dashlane’s features and data.

In addition to logins, Dashlane can store payment data (credit card 
numbers and bank account details), secure notes, and receipts.

In addition, its bold, 
bright dashboard leaves 
you in no doubt as to 
the integrity of your data.

You’ll have to pay £20.99 
per year if you want to sync 
passwords between your 
Mac and iOS devices. If not, 
Dashlane is free and 
a match for 1Password.

Sunrise was recently acquired by Microsoft. But don’t 
let that put you off, because it’s still free. It’s often 
billed as an alternative to OS X’s Calendar app, but 
it’s much more than that.

Sunrise can connect to Google Calendar, iCloud 
and Microsoft Exchange, as you’d expect. Of course, it’s also able to 
import your existing calendars. Beyond that, you can also link Sunrise 
to social media accounts such as FourSquare. By doing so, when you 
use FourSquare to check in every time you go to work or the gym, 
Sunrise will display a record of how many times you’ve gone to that 
place during the month.

The app also supports 
Facebook event invitations, 
enabling you to respond to 
them within the app rather 
than going to the website. 
And, like all the best calendar 
apps, Sunrise supports 
natural language input for 
creating events.

Well-practised and aspiring DJs will love Cross DJ 
Free because it can import tracks from your iTunes 
Library, and from elsewhere as long as they are MP3, 
AAC, AIFF, FLAC or Apple Lossless files. It sports 
a mixer with three-band equaliser, volume faders, 

cross-fader, and level meters. Naturally, it includes beat matching too. 
The app works with all the major brands of decks and controllers, 

with the exception of those designed specifically for Traktor Pro. You 
can only use two decks, rather than the four available in Traktor Pro. 

There’s no automatic 
cueing or cross-fading of 
tracks, and no automatic 
key detection either. 

However, Cross DJ Free 
has plenty to offer the 
bedroom DJ, and if you 
want to go further and mix 
video too, the full version 
of Cross DJ is only £22.99.

Darktable takes photos in the Raw format captured 
by your camera’s sensor and makes non-destructive 
edits to them. It works as a database, with a series 
of modules that perform operations on records 
(photos). For example, the Collect module enables 

you to search for images by tag, rating, and other metadata.
Other modules enable you to crop and rotate images, perform 

curve adjustments to change a picture’s tonality, and recover blown 
out highlights. Several modules add artistic effects: watermarks, 
frames, and vignettes, and 
you can soften images, add 
grain and simulate human 
low light vision. 

Darktable’s modular, 
open-source nature means 
it’s constantly evolving. Check 
it out if you miss Aperture’s 
processing tools and don’t 
want to spend on Lightroom.

Dashlane

Cross DJ Free Darktable

Sunrise
FREE Dashlane, dashlane.com

FREE Mixvibes, mixvibes.com FREE The Darktable team, darktable.org

FREE Sunrise Atelier, calendar.sunrise.am

PASSWORD MANAGER 
1PASSWORD 

DJ SOFTWARE 
TRAKTOR PRO 

PHOTO EDITING 
ADOBE LIGHTROOM

CALENDAR  
FANTASTICAL 

SSSSSAAAAAVVVVVIIIIINNNNNGGGGG 
££££££££££££££££8888888888888888...555555555555555777777777777777////////////////
MMOONNTTHH

SSSSSSSSSSSSSSSAAAAAAAAAAAAAAAVVVVVVVVVVVVVVVIIIIIIIIIIIIIIINNNNNNNNNNNNNNNGGGGGGGGGGGGGGG 
£££££3333399999.9999999999!!!!!

SSSSSSSSSSSSSSSAAAAAAAAAAAAAAAVVVVVVVVVVVVVVVIIIIIIIIIIIIIIINNNNNNNNNNNNNNNGGGGGGGGGGGGGGG 
£££££8888899999!!!!!

SSSSSSSSSSSSSSSAAAAAAAAAAAAAAAVVVVVVVVVVVVVVVIIIIIIIIIIIIIIINNNNNNNNNNNNNNNGGGGGGGGGGGGGGG 
£££££3333399999.9999999999!!!!!



100 PAGES OF TIPS AND ADVICE 
FOR ADOBE ILLUSTRATOR

ON SALE NOW!
www . m y f a v o u r i t e m a g a z i n e s . c o . u k / d e s i g n / s t u d i o - t r a i n i n g - a d o b e - i l l u s t r a t o r- 2 0 1 5



148  | OS X El Capitan Handbook

MAC APPS   |   The best free apps

OpenOffice’s mail merge wizard plugs a gap in Apple’s suite. Collaboration and user management are key features of Zoho. Google Docs is likely to be your first choice for survey analysis.

Google Docs is a hugely powerful 
set of online tools for sharing and 
collaborating on documents like 
spreadsheets and text files. The 
creator of a document always has 

control over who can read and edit documents, 
and you can review changes that have been made 
to documents and by whom. Beyond office suite 
essentials, the Forms feature makes it easy to build 
detailed surveys and analyse people’s responses.

If you’ve avoided OpenOffice 
because it used to be a non-native 
app, it’s time to give it another 
look because the latest version 
sits better alongside other Mac 

apps. It’s a smart choice if you need to personalise 
templated correspondence, thanks to its mail 
merge wizard. The ability to record and play back 
macros, which enable repetitive tasks to be 
performed quickly, is another reason to adopt it.

It’s four years since Microsoft 
last released a new version of 
Office for Mac, and If you’re 
tired of waiting for Office 2016, 
you’ll find plenty of alternatives 

both as web and Mac apps. The best of the 
latter category is LibreOffice, a full-featured 
office suite which surpasses Microsoft Office 
for Mac when it comes to the sheer number of 
apps bundled within it.

It lacks an equivalent of Outlook, but in 
other respects LibreOffice matches Office 2011. 
As well as modules for word processing, 
spreadsheets, and presentations, there’s 
a database, a drawing program, a database 
tool, a formulae and equations tool, and an 
app for creating and editing charts. There are 
also add-ons created by a huge community of 
developers, demonstrating one of the suite’s 
strengths as open-source software.

What’s more, LibreOffice supports a large 
number of file formats, including Microsoft’s 
proprietary .doc and .xls and XML-based .docx 
and .xlsx extensions. 

If you think LibreOffice may be a lightweight 
alternative to Microsoft’s behemoth, think 
again. Writer, for example, includes features for 
adding comments, tracking revisions, and 

accepting or rejecting changes. It’s spelling 
and grammar checker are excellent, and it has 
a large gallery of symbols, shapes and other 
graphics. Long document support is also great 
thanks to support for creating indexes, 
bibliographies, and tables of contents. 

However, Writer does lack the page layout 
mode available in both Microsoft’s Word 2011 

Three alternatives

Zoho is a set of online word 
processing, presentation, and 
spreadsheet tools. It also available 
as an app for iOS, and you can 
synchronise documents between 

that and the web app. The free version is limited, 
but there’s lots to like about it, including 1GB of 
storage, version tracking, and user management. 
Documents can be managed using Zoho Docs for 
Desktop, which syncs your work with your Mac.

LibreOffice
FREE The Document Foundation, libreoffice.org

OFFICE SUITE  
MICROSOFT OFFICE 2011 

LibreOffice Writer looks similar to Microsoft Word and can import Word documents, although some features aren’t imported.
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APACHE OPENOFFICE 
FREE Apache, openoffice.org

ZOHO DOCS 
FREE Zoho, zoho.com

GOOGLE DOCS 
FREE Google, docs.google.com
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When you open LibreOffice, 
this window presents 

pre-installed templates for 
you to choose from.

Calc is LibreOffice’s spreadsheet component, and it will be 
immediately familiar if you’ve ever used Microsoft Excel.

and Apple’s Pages, meaning that everything 
must be done inline. You can’t, for example, 
create text boxes and place holders for images 
and drag them around the page. For a free way 
to do that, try Scribus (see page 145).

The inestimable value of free
Calc, the spreadsheet tool, doesn’t support 
Visual Basic macros, but it does have plenty of 
other commendable features. The conditional 
formatting tool is excellent, for example. 
There’s a Scenario Manager to allow you to 
perform complex ‘What If…’ analyses, and 
a solver component which allows you to solve 
optimisation problems where the optimum 
value of a particular cell is dependent on 
constraints provided in other cells. 

LibreOffice’s presentation component, 
Impress, lacks some of the user interface 
refinement of Keynote and PowerPoint, and it 
lacks keyboard shortcuts, but it’s powerful 
enough for most of us. It has drawing and 
diagramming tools, animation and effects, and 
the Fontwork tool enables you to create 2D 
and 3D images from text. When it’s time to 
deliver your presentation, the slideshow mode 
allows you to choose between automatic and 
manual modes, set the duration for which 
slides are shown, and decide whether the 
pointer is visible. Impress supports multiple 
displays, enabling you to see the upcoming 
slide and your notes while the audience sees 
the current slide in the presentation.

Base, the database tool, acts as a front-end 
to several engines, including MySQL and 
Microsoft’s Access. However, it can also be used 

as a simple, standalone database. There are 
wizards to help you set up a database, and it 
can integrate with other LibreOffice apps. So, 
for example, Base can be used to hold records 
for a mail merge in Writer.

Draw can be used to create anything from 
quick sketches to technical drawings up to 
300x300cm in size. It’s strength, though, is as 
a diagramming and charting tool. Whether you 
need to draw an organisation chart, flowchart, 
or network chart, you’ll find the tools you need 
here. Smart connectors and glue points make it 
relatively simple to put charts together, and 
dimension lines automatically calculate and 
display linear dimensions as you draw.

Math, the equations and formula editor can 
be run as a standalone tool or provide its 
services from within any of the suite’s other 
components. Formulas can contain a range 

of elements including fractions, integrals, 
mathematical functions, and matrices. Like 
Math, Charts can be called from within any 
LibreOffice component. It allows you to create 
different types and styles of charts by simply 
providing it with the data to be presented. 

Bursting with content
The latest version of LibreOffice, 4.4.3, includes 
several new features, including the ability to 
digitally sign PDFs, and to share them on 
SharePoint, Microsoft’s OneDrive, and CMIS-
based content management systems.

This version also sees an overhaul of the 
user interface, with new menus and toolbars, 
a re-designed sidebar and a new colour 
manager. Version tracking capabilities have 
been beefed up too. 

 Key to LibreOffice’s appeal are the vast array 
of extensions and templates that are available 
for it. These are developed by a community of 
developers and LibreOffice enthusiasts, and 
they cover a wide range of features. Among 
many others, there are extensions to add 
a clip art gallery, support for importing and 
exporting to Google Docs and Zoho Office, 
several language tools that add support for 
dictionaries in languages other than English. 

While the templates available may lack the 
polish of those included with Apple’s Pages, 
Numbers and Keynote apps, that’s made up for 
in sheer quantity. There are hundreds of 
templates covering just about every kind of 
use you can image for a word-processing tool 
or spreadsheet.

If you’ve tried LibreOffice in the past and 
found it lacking, give it another go now 
because version 4.4.3 really is excellent.
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Gimp, an open-source bitmap 
image editor, has been around 
for as long as OS X has been. 
You can install it as a native 
application, otherwise you’ll 

have to install X11 first (http://apple.
co/1ML4qBk). 

While the app’s interface is very different 
to Photoshop, many tools found in Adobe’s 
heavyweight image editor are also provided 
here. There’s the lasso and magic wand for 
selection, a pen tool for drawing Bézier paths, 
a paintbrush, and a clone stamp. You can build 
up your images on multiple layers, too. 

Some tools can be hard to find if you’re used 
to something Photoshop – the Levels dialog is 
in the Color menu, for example. The good news 
is that the interface is customisable, so you can 
set it up just how you like, and have different 
environments for different tasks.

The app includes a full set of painting tools, 
including Brush, Pencil, Airbrush, and Clone. It 
features a powerful gradient editor and a blend 

Perl languages, and this scripting language 
support allows Gimp to be automated too.

Gimp isn’t perfect, of course. Its Text tool is 
in need of much improvement, and there are 
none of the 3D tools available in Photoshop to 
be found here. Nor does it support anything 
like Photoshop’s non-destructive Adjustment 
Layers for easy experimentation with colour 
changes. Other missing features are taken care 
of by third party plug-ins, such as support for 
the CMYK colour space, which is available in 
Separate+ (http://bit.ly/mf289separate).

Gimp is not a complete replacement for 
Photoshop, but it provides so many features 
found in Adobe’s venerable bitmap editor that, 
for most purposes, it’s a perfectly usable 
alternative. Thorough documentation and 
tutorials make it relatively easy to get started, 
and a large development community and user 
base mean Gimp’s constantly evolving.

tool, and you can import custom brushes and 
patterns. There’s full support for multiple layers 
and channels, including alpha channels, and 
the number of undo operations you can 
perform are limited only by the amount of disk 
space that’s available.

Tailor-made features
For selecting pixels, familiar rectangle, rounded 
rectangle, and lasso tools have you covered, as 
well as advanced path tools for creating Bézier 
curve and polygonal selections. Transformation 
tools include rotate, scale, shear and flip, and 
there are tools to fix lens distortion, barrel 
distortion and vignetting. 

Perhaps Gimp’s most important feature is 
that it’s extensible. Anyone can create plug-ins 
for it and share them – over 100 are already 
available (http://registry.gimp.org). Plug-ins 
can be written using the Scheme, Python and 

PicMonkey (picmonkey.com) is a free online photo editor that is able to import 
photos from your Mac, or a Dropbox, Facebook or Flickr account. It includes an 
auto-adjust feature that enables you to make one-click improvements to your 
images. It also includes tools that enable you to crop, sharpen, resize and adjust 
the colours in your photo. 

The app’s portrait tools enable retouching of skin, removing blemishes and 
even giving someone a spray tan. You can dramatically alter the look of your 
pictures with a cross-process effect, giving them unusual contrast and colours, 
and you can embellish them with text, an overlaid texture or a frame.

The basic editing tools are free, though you’ll have to put up with banner 
ads. For $4.99 (about £3) per month or $33 (about £21) per year, the Royale 
version removes ads and has more filters, fonts, and themes.

Gimp
FREE The Gimp Team, gimp.org

BITMAP IMAGE EDITORS  
ADOBE PHOTOSHOP CC 
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££££££££££££££88888888888888...55555555555557777777777777//////////////
MMOONNTTHH

PicMonkey

Gimp’s already extensive capabilities can be taken further by 
downloading plug-ins from a huge online repository.

Although Gimp’s interface is different to 
Adobe Photoshop, its layout – with tools 
and their options on the left and other 
palettes on the right – is familiar and 
eases you into free image editing.

You don’t even have to register to use the editing tools in the free version of PicMonkey.
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Blender is an open-source 3D 
animation and modelling 
tool. It incorporates a full 
game engine, enabling you 
to create a 3D game inside 

the app. It has photo-realistic shading with 
support for Open Shading Language, and it 
provides shaders for glass and translucency. 
A comprehensive set of rigging tools makes 
posing characters easy, and a pose editor and 
sound synchronisation enable you to bring 
your characters to life.

Studio One is undergoing 
something of a transition, and 
the new free version, now 
called Studio One Prime, 
wasn’t available as this issue 

went to press. However, it promises unlimited 
audio tracks, virtual instruments, FX and buses. 
It also enables real-time audio time stretching, 
resampling and normalisation. Nine audio 
native effects wil be accompanied by a single 
virtual instrument. Going by its predecessor, 
Studio One 2, Prime will be worth your time.

Move over Final Cut Pro X. 
Lightworks boasts supports 
for formats from SD to 4K and 
it can import, render, and 
export in the background 

while you carry on working. It has real-time 
effects, multi-camera editing and an interface 
that’s customisable. There’s a wealth of help in 
the form of tutorials at http://bit.ly/mf289light 
works to get you started. The Pro version 
(£249.99) adds support for hardware from 
Blackmagic, AJA and Matrox.

Cyberduck costs £16.99 from 
the Mac App Store, yet it’s 
available for free (or with 
a donation) from its website. 
It’s used to transfer files to 

and from FTP, SFTP, and WebDAV servers, and 
to Amazon CloudFront and S3, Google Cloud 
Storage and Rackspace Cloud Files. Servers can 
be bookmarked and added to Finder for quick 
access, and files can be edited directly from a 
server. There’s no two-pane view of local and 
remote files, but the app is otherwise excellent.

BBEdit has been the de facto 
text editor on the Mac for 
over a decade. TextWrangler 
is its free sibling and yet still 
packs in syntax colouring, 

cold folding – where you can show and hide 
sections of code – and direct access to files 
stored on FTP servers.

There are some tools missing from BBEdit, 
such as its Scratchpad ability to read from and 
write to Zip archives, but TextWrangler is a free 
app that should be in every Mac user’s arsenal.

One of the longest-standing 
free apps for OS X, Audacity 
is the perfect tool for making 
quick edits to audio files. The 
most recent version, 2.1, adds 

real-time previews of Audio Unit and BST 
effects. It also features a new noise removal 
tool, and the Spectral Selection feature allows 
you to click and drag to select frequency 
ranges to manipulate, as well as time periods. 
If you need to edit audio on a Mac, this is the 
best place to start.

3D MODELLING  
CINEMA 4D

MUSIC MAKING 
LOGIC PRO X

VIDEO EDITING  
FINAL CUT PRO X

FTP APP  
TRANSMIT

VIDEO EDITING  
BBEDIT

AUDIO EDITING  
ADOBE AUDITION
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FREE Blender Foundation, blender.org

FREE PreSonus, presonus.com

FREE EditShare, lwks.com

FREE CyberDuck, cyberduck.io

FREE Bare Bones Software, barebones.com

FREE Audacity Team, audacityteam.org

Blender

Studio One

Lightworks

Cyberduck

TextWrangler

Audacity
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1Password stores a wider variety of information than 
iCloud Keychain yet still syncs it between your devices.

lthough we’ve been singing the praises of 
free software in this feature, that isn’t to say 
you should ignore every app that has a price 
tag attached. These days you can buy highly 
capable apps of all kinds at affordable prices; 
something that might be attributed to 

Apple’s app stores skewing prices downwards. Many of 
these apps are far more ambitious than their price and your 
previous experience of low-cost software might suggest. 
We’re talking about the likes of Affinity Designer, Pixelmator 
and OneNote, which are strong, capable rivals to big names 
such as Adobe Illustrator, Adobe Photoshop and Evernote. 
Spending a relatively small amount encourages developers 
of these apps to continue investing effort in new features, 
which these days often come at a steady pace, and often 
without having to pay for a whole new version.

Affinity Designer (£39.99, Mac App Store) was a great app 
even from the start, yet features added since version 1.2 
have added significantly to its appeal. That version brought 
the ability to set text on a path, dashed lines, a corner tool, 
and vector slice export. It enables your undo history to be 
saved with documents, and features a new pixel alignment 
mode to aid user interface and web design. Version 1.2.1 
added support for Apple’s Force Touch trackpad on the new 
MacBook and MacBook Pro, enabling you to paint with 
pressure sensitivity without buying specialist hardware.

Microsoft’s OneNote (free, 
onenote.com) may not be as 
popular as Evernote, but it 
still has a great deal to offer. 
For a start, it doesn’t impose 
a 60MB monthly limit on 
uploads, as Evernote’s free 
tier does. Its latest version 
has the ability to search 
handwritten notes, and can 
record and play audio notes.

Pixelmator is an excellent example of OS X El Capitan’s Extensions feature, which makes 
the app’s Repair tool available from within other software.

Already a capable app for designers in its initial release, Affinity Designer continues to 
develop at a pace with new creative tools and leveraging Apple’s Force Touch trackpad.

When it’s worth paying
Affordable paid apps can return many times your investment

Djay (algoriddim.com) gained a ton of new features in 
version 1.1, including the ability to create video mixes, not 
just audio. It also supports an extended range of hardware 
controllers, and its media library has been beefed up by 
integration with iTunes and Spotify and video importing. 

Pixelmator (£22.99, Mac App Store) goes from strength to 
strength, with version 3.3 adding support for Handoff so 
you can switch between editing an image on your Mac and 
your iPad. It supports OS X’s Extensions too, boosting its 
value by making its Repair tool available within other apps.

When it comes to annotating images, Napkin (£29.99, 
Mac App Store) is a good alternative to Apple’s Preview. 
Version 1.5 adds two new visual styles when redacting 
information, with a choice of blurring or pixellating an area 
for a subtler aesthetic, rather than simply filling it with 
black. It also enables images to be cropped within the app, 
so you no longer have to open them in another tool to do 
that, and it follows the lead of many other good Mac apps 
by enabling you to match the style of surrounding text 

wherever you paste.
Finally, version 5.3 

of 1Password (£25.99, 
Mac App Store) is 
more tempting than 
ever as a replacement 
for iCloud Keychain, 
with improvements to 
the accuracy of filling 
out your identity in 
online forms, and 
new field types to 
store more varied 
data in your keychain.
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Back up with Time Machine 
Apple’s Time Machine is one of the easiest backup options around

ADVANCED   |   Time Machine

Time Machine is the Mac’s built-in backup 
system. All you need to provide to make it work 
is an external hard drive. Once set up, Time 
Machine makes hourly backups to the second 

drive of any changed files on your Mac.
This gives you an easy way to recover damaged and 

accidentally deleted files. Time Machine also allows you to roll 
back your whole OS to an earlier version if an update causes 
problems. It can also be leveraged by the Migration Assistant 
to move user accounts, files and settings to a new Mac, when 
the time comes.

If you own several Macs or even just one MacBook, Apple 
makes a combined wireless router and hard drive called 
AirPort Time Capsule which makes it easier to back up 
because you don’t have to think about connecting any cables 
(see boxout on page 157).

If you just want to use an external drive, it needs to be Mac-
formatted (see Disk Utility on page 164). Connect the drive to 
your Mac, and OS X will ask whether you want to set it up to 
use it with Time Machine. Using a drive to store Time Machine 
backups doesn’t mean you can’t also use it for other purposes 
– it will still appear as a regular hard drive in the Finder, and 
you can copy important files to it. However, it’s a good idea 
not to use this drive as a general place to store files. That’s not 
only to maximise the space available for Time Machine, but 
also because Time Machine won’t back up the drive you 
assign it to use. The backup of files on that drive would exist 
on the same drive as the originals, which would defeat the 
point of backing them up somewhat.

Within just a few clicks, you can be backing up your files. 
Then, every time you connect that drive, Time Machine will, 
after a few seconds, start backing up anything that’s changed 
or new. Once you’ve completed the quick and simple setup 
process, Time Machine is designed to need as little 
intervention from you as possible, and to be almost invisible 
until the point when you need to restore a file, at which point 
it will step in and save the day! 

3 Saving snapshots
Saving an hourly snapshot of everything 

on your Mac would fill your backup drive very 
quickly (even if you have a large external drive)
and it would take a while. Instead, Time Machine 
saves hourly backups for the past day, 
consolidated daily backups for the last month, 
and weekly backups beyond that, until your 
drive runs out of space. At that point, it will 
delete the oldest weekly backup. 

1 Incremental 
backups

Time Machine doesn’t simply copy 
or ‘clone’ everything that’s on your 
hard drive. Instead, once you’ve 
created the initial backup, it creates 
incremental backups and, using a 
clever piece of interface design, 
allows you to step ‘back in time’ to 
find a deleted file (see below).

2 Beware of 
deleting files

Time Machine is not an archive 
program, remember – it saves 
backups hourly, which introduces 
a potential pitfall. If you were to 
create a file and delete it within 
one of these hour-long intervals, 
no backup of that file will be 
created at all.

Time Machine offers several options for restoring 
files. Restoring a specific file or folder begins in the 
Finder. First, go to where the file or folder was on 
your drive. Next, open Time Machine, and after a 
few seconds your Finder window will change to 
reveal what looks like a series of windows 
stretching back into space. You’ll see a timeline on 
the right-hand side of the screen with dates 
marked on it. You can scroll back through the 
stacked windows using the arrows or by clicking a 
date in the timeline, until you find the file you want.

How to restore from  
Time Machine
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Setting up Time Machine is easy and it prompts you with a link to open 
its Preferences each time a new Mac-formatted drive is connected.

4 Auto-save  
and versioning

Time Machine captures the most recent state of 
data on your disk, and files you’ve deleted, 
rather than archiving multiple versions of the 
same file in a reliable way. If the latter is what 
you want, then you need to use the auto-save 
and versioning feature first introduced with OS 
X 10.7 Lion. Flick to page 158 for more details on 
how to set this up.

Use it in apps
Some apps support Time Machine 
directly. This is great if you know you 
changed something in a certain app 
and want to retrace your steps. You can 
step back through deleted cards in 
Contacts, for example.

5 Exclude files and folders
The capacity of the external drive you need 

depends on the size of your Mac’s internal drive, 
how much of that you expect to use, and how 
many old backups you want to store. Something 
twice the size will allow you plenty of room for 
backups. If you have a smaller drive, you can 
choose to exclude files or folders from backups. You 
might decide that since you can reinstall your apps, 
backing up the Applications folder is unnecessary.

6 Recovery disk
Be aware that Time Machine 

doesn’t create a bootable copy of 
your startup disk, which means 
that in the event of a catastrophic 
failure you’ll need a recovery disk 
to boot from before restoring your 
whole disk from your Time 
Machine drive. You may need a 
recovery disk prepared on a USB 
stick. Make sure your Time Machine 
drive is connected, start up holding 
down å+r and select ‘Restore 
from a Time Machine backup’. 

Time Machine can use any 
network-attached storage 
drive formatted as ‘Mac OS 
Extended (Journaled)’ that’s 
connected to your Mac over 
your local network (but, sadly, 
not the internet), including 
(naturally) a Time Capsule.  
Time Capsules aren’t exactly 
cheap (£249 for a 2TB model, 
£349 for a 3TB version) but 
you can guarantee that they 
will work seamlessly, 
providing a wireless backup 
solution that will keep your 
data secure and your mind at 
ease. In addition, a Time 
Capsule can turn any USB 
printer or external hard drive 
into one you can share across 
your network. If Time Capsule 
seems a bit expensive and 
you have a few external 
drives knocking around, you 
can use a USB drive attached 
to an AirPort Extreme base 
station as a backup solution, 
although Apple doesn’t 
officially support this.

Time  
Capsule
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Barring catastrophic hard drive 
failure, you need no longer worry 

about losing stuff if things go wrong

Thanks to OS X, lost work 
could largely become a 
thing of the past. Barring 
catastrophic hard drive 

failure, you need no longer worry about 
things going wrong. This is because OS 
X now has two clever systems built into 
it: Auto Save and Versions.

Provided you’re using an app that has 
support for these two features built in, 
OS X automatically saves your work. If 
you decide you want to jump back to 
an older version of a file – or recover 
part of it  – Versions enables that.

We’ll take a look at how these two 
systems work so that you can make the 

most of them. The first thing to know 
is that not all your apps will work with 
Auto Save and Versions, although many 
now do, particularly major applications. 
If you’re using older versions of iWork 
apps, they might need updating to 
ensure you’re running at least Pages 9.1, 
Keynote 5.1 and Numbers 2.1. Check by 
opening the app in question and going 
to Pages > About Pages, Keynote > 
About Keynote or Numbers > About 
Numbers. If you bought a boxed copy, 
go to http://bit.ly/iworkupdate to get 
the update. Other El Capitan apps, 
including TextEdit and Preview, are fully 
Auto Save and Versions compliant.

Crucially, though – and we can’t stress 
enough just how important this is – you 
have to save your file once, manually, 
before Auto Save and Versions are able 
to kick in. So if you start writing a letter, 
save it immediately and you won’t have 

to worry afterwards. But if you fail to 
do this, your Mac won’t record your 
changes at all because you’ve not yet 
told the system where to save them.

One thing that’s missing from the File 
menu in Versions-compliant apps is the 
Save As command. In its place you’ll see 
a Duplicate option, which pops up a 
second window with the contents of 
your document. Note that this copy isn’t 
initially saved, however, so make sure 
you do this before you start working on 
it or you risk losing work if something 
serious occurs, such as a power cut.

However, the Save As option is still 
available as an option in case you prefer 
to work that way, perhaps because it 
avoids the possibility of forgetting to 
save. Click the File menu to open it, then 
hold å. Notice that the Duplicate item 
changes to Save As. Let’s take a closer 
look at Versions and how it works…

1 2

3

4

Never lose your work again
Use Auto Save and Versions to safeguard your precious files

SKILL LEVEL
Anyone can do it

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11, an app 

with support for Auto 
Save and Versions

VISUAL GUIDE | BROWSING PREVIOUS VERSIONS

 
Current File

1  This is the document you’re working 

on; you can scroll through it.  

Previous Versions

2  You can browse back through time 

by clicking the windows in the stack 

of versions on the right. As well as restoring 

an earlier version as a whole, you can 

selectively copy from older versions and 

paste into the current version of your file. 

Timeline

3  To find an older version, hover over 

the timeline. Each notch is a version 

of that file, displaying when in time it was 

created. Click one to show it. 

Controls

4  Click Restore to recover the version at 

the front of the stack, or Done if you 

copied and pasted bits into the left window.
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1 Create your document
We’ll create a newsletter in Pages, though 

these steps work in apps such as TextEdit, too. 
First save the file somewhere on your Mac’s 
drive before you start to type anything into it. 
This will ensure that Auto Save and Versions 
can start their work. Use ç+S or File > Save.

4 Options menu
In the File menu, move the pointer over 

Revert To. If the current version of the file has 
been saved, the only option listed is Browse 
All Versions. Otherwise, you’ll also see Last 
Saved and Last Opened, and the time at 
which those events occurred.

6 Previous versions
Choose File > Revert To > Browse All 

Versions… to open up the timeline (shown 
opposite), with your current document on 
the left and previous versions on the right, 
giving you a quick side-by-side comparison 
of different document states.

2 Get to work
As you write, your file is automatically 

saved. If you quit the app, you won’t actually 
be prompted to save, since your changes have 
been stored automatically. Next time you open 
that file, the new work will be there waiting for 
you. That’s Auto Save in a nutshell.

5 Revert to Saved 
Choosing Last Saved takes the file back 

to that state, whether it was saved automatically 
or because you pressed ç+S. You can also 
revert to the file’s state when it was opened. 
Both options save the document again to 
make the restored version the latest version.

8 Bring it back
Once you’ve found the version you want, 

click Restore. Remember that OS X will save it as 
a new version, so if you later realise you actually 
want part of the content you lost by reverting, 
you can browse back in the timeline to copy it 
and paste it into the current version on the left.

7 Go back in time
Click one of the windows in the stack on 

the right to bring it forward so you can compare 
it to the current file. To move back to a specific 
time, use the timeline at the bottom right. As 
you hover over a notch, you’ll see when that 
version was saved. Click it to bring it to the front.

3 Save a version
As you work, there’s nothing stopping 

you from pressing ç+S or using File > Save. 
This obviously forces a copy of the document 
in its current state to be saved as a new version. 
This allows you to revert to this precise point in 
your work at any time.

HOW TO | MAKE THE MOST OF VERSIONS

Click a document’s name in the title 
bar and tick Locked to make a template. 

Choose File > Duplicate to make 
other documents based on it 

and preserve the original copy.

More options
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Recover from major problems
Tools to get you out of a sticky situation if OS X won’t start

QUICK LOOK  
RECOVERY MODE

1

2

3

4

Recovery is a built-in set 
of tools, hidden until you 
start up your Mac 
holding down ç+R 

when you hear the startup chime, 
that you’ll depend upon in a rare 
emergency – typically when some 
drastic glitch prevents OS X loading. It 
looks a lot like OS X proper, but its 
capabilities are limited to essential 
maintenance tools that will help you 
get up and running after a critical 
problem. Apple has made restoring a 
Mac from a Time Machine backup 

almost as easy as turning on that 
feature in the first place. In fact, it’s 
even possible to download and 
reinstall the whole operating system.

If you’re daunted by the prospect 
of fixing something you perhaps 
don’t understand, then there’s one 
feature of Recovery that you’ll find 
invaluable: its web browser. With it, 
you can search for solutions, go 
online to book a Genius Bar 
appointment at one of Apple’s retail 
stores, or look up the contact details 
of an authorised repair centre if there 
are no stores close to you. 

Recovery’s other features include 
the ability to reset any user account’s 
password, should one be forgotten. 
While this is undoubtedly useful, it also 
poses a security risk to the files stored 
on your Mac, so you should see page 
162 for instructions on how to restrict 
access to it. 

SKILL LEVEL
Could be tricky

IT WILL TAKE
From a few minutes 

to several hours, 
depending on the 
feature you need

YOU’LL NEED
OS X 10.11, a Recovery 

partition on your 
startup disk or a 

Recovery disk

Rescue options
1  Recovery provides 

three ways to 

restore or reinstall OS X: 

rolling back to an earlier 

state using Time Machine; 

installing OS X over itself, 

which can fix some kinds 

of problems; and erasing 

the internal disk first for a 

completely clean start.

Research 
a problem

2  The Safari 

web browser is 

available in Recovery 

to research problems.

Disk Utility
3  You can run 

diagnostic scans 

of your Mac’s storage, 

or erase it altogether.

Additional 
Utilities

4  In the Utilities 

menu, Firmware 

Password Utility increases 

your Mac’s security; 

Network Utility tests 

overall connectivity; and 

Terminal enables you to 

perform detailed 

diagnosis using various 

typed commands.

With Recovery, it’s 
even possible to 
download and 
reinstall the whole 
operating system



OS X El Capitan Handbook  |  161 

Recovery mode   |   ADVANCED

HOW TO | USE RECOVERY’S VARIOUS OPTIONS

1 Start Recovery Mode
To start Recovery from your Mac’s 

internal storage, hold ç+R at the startup 
chime. To start it from an external drive, hold 
å instead and, when a list of available startup 
volumes appears, choose the one with an 
external drive icon and ‘Recovery’ in its label.

4 Get Help Online
You can use this version of Safari to 

research your technical problem by visiting 
support.apple.com, to look more broadly with 
a search engine, and to browse to apple.com/
uk/retail to book a Genius Bar appointment for 
professional help at an Apple retail store.

6 Restore backups
If you haven’t excluded system folders 

from your backups, your Mac can be restored 
to an earlier state. Choose the Time Machine 
option, identify your backup disk, pick an earlier 
state from the list, and follow the prompts to 
restore it your startup disk. This can take a while.

2 Internet Recovery
If a Recovery partition isn’t available, 

holding ç+R will start Internet Recovery 
(on models released since OS X Lion, and some 
earlier models – see support.apple.com/kb/
HT4904). This shows a globe and a progress bar 
while the software is downloaded.

5 Disk problems
If OS X won’t start, select Disk Utility 

before resorting to more drastic options and 
check that your Mac’s drive is shown under 
Internal on the left. Select the row that isn’t 
indented and click First Aid in the toolbar to 
verify and attempt to repair structural problems.

8 Reset a password
If someone forgets their account 

password, choose Utilities > Terminal. Type 
resetpassword into that app and press ®. 
In the next window, select your startup disk, 
select the account from the list, type a new 
password into the boxes, and click Save.

7 Reinstall OS X
The Reinstall option downloads the same 

version of OS X you have and installs it over any 
existing copy, retaining your files and settings. 
This can fix some damage to the system. The 
download is several gigabytes, so it can take 
quite a while over slower internet connections.

3 OS X Utilities
When Recovery has loaded, it displays 

a list of four commonly needed tasks. ‘Get Help 
Online’ opens the Safari web browser. If your 
Mac uses Wi-Fi to get online, click the Wi-Fi icon 
at the top-right corner to ensure that it is 
connected to your usual network.

Check the  
connection

In Utilities > Network Utility, the Ping tab 
enables you to check that network traffic 
can reach other devices on your network 

and websites outside of it.
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There’s a lot you can do to lock down your Mac, including protecting data with a firmware password.

1 Turn off automatic login
It’s a risk if your Mac is set to log into a 

user account automatically on startup: all an 
intruder needs to gain access is hold down the 
power button to turn off the Mac, then restart. 
Automatic login can be disabled under Login 
Options in Users & Groups, or in Security & 
Privacy in the General tab.  

2 Obfuscate login details
The login window shows account names 

by default, leaving passwords to be guessed. 
Under Login Options, switch to ‘Name and 
password’ so both need to be entered to gain 
access. If you use Fast User Switching, set it to 
show an icon so the account name can’t be read 
from your screen. 

3 Restrict your abilities
The first user you create at setup is an 

Administrator with top-level rights. It’s safer to 
use a Standard account day-to-day, but an 
Admin is needed for system changes. Create a 
new admin user in the Users & Groups pane, log 
out, then log into the new account. Select your 
regular account and untick ‘Allow user to 
administer…’ to reduce its rights. 

4 Request password  
to wake

By default, waking a Mac from sleep or its 
screensaver allows access to whatever account 
was left signed in. Under General in the Security 
& Privacy pane, turn on the option that requires 
a password to wake, and set how soon it’s 
needed. Anything longer than five seconds 
presents a risk if your Mac is left unattended. 

5 Tighten Keychain 
security

Your account password also protects your 
Keychain, so just logging in gives Safari’s AutoFill 
feature, for example. The Keychain can be given 
its own password so that separate consent is 
needed. To do this, simply open Keychain Access 
(you’ll find it in /Applications/Utilities), right-click 
‘login’ in the Keychain list and choose then 
Change Password…

6 Lock the Keychain
In the same menu as mentioned in the 

tip above, choose Change Settings… for options 
that lock the Keychain when your Mac goes to 
sleep and after a period of inactivity. In Keychain 
Access’s preferences, you can add an icon to the 
menu bar to display the Keychain’s status and 
manually lock it. When it’s locked though 
background system services may prompt you 
for access. 

7 An unplugged hole
Without a firmware password, Recovery 

Mode gives the unfettered ability to reset any 
account’s password by typing resetpassword 

in Terminal. The Keychain password is unaltered 
by this, so an intruder won’t be able to read 
website logins in Keychain Access and Safari’s 
Passwords preferences, but they will have access 
to files stored locally. 

8 Set a firmware 
password

Restart your Mac and hold ç+R at the 
startup chime to start in Recovery mode.  
When it finishes loading, go to Utilities > 
Firmware Password Utility and set a password. 
Make sure you don’t forget this password – 
you’ll need it on rare occasions such as restoring 
your Mac from Time Machine, and to use other 
startup key combinations. 

9 P*55wrd tip
It goes without saying that a strong 

password is one that isn’t easily guessed by 
a person or worked out by a program (and don’t 
use the same password for everything!). 
Generally, a good password has letters, numbers 
and symbols. Be careful using symbols, though, 
as the keyboard layout in use at the password 
box may put them on unexpected keys.

Secure your Mac
Tighten your Mac’s security and ensure files and web accounts stay safe

When you first set up your Mac,  
the only security measure that’s 
enforced is that you add a password 
to your user account. The Setup 

Assistant makes no mention of extra measures 
you might want to enable, even though several 
are built into OS X. Bear in mind that the features 
we’re about to look at are defences against 
physical attack, rather than protection against 
online attacks such as security holes in your web 
browser or social engineering that tries to trick 
you into ill-advised action. 
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Some tasks take more 
effort than they merit. You 
may not mind renaming 
a bunch of files or resizing 

a photo now and then, but when you’re 
doing it several times a day, day after 
day, the novelty wears off quickly.

Luckily, there’s a handy app in OS X 
that can help with these repetitive tasks. 
It’s called Automator and it lives in your 
Applications folder.

Automator enables you to create 
different kinds of scripts (or ‘workflows’ 
as it calls them). You can choose from 
eight templates, of which four stand 
out. ‘Applications’ are standalone scripts 
that function like any other app on your 
Mac: you can double-click one to run 
the script, or drop files onto it to process 
them. ‘Services’ are scripts which can be 
accessed under an app’s name in the 
menu bar, or in the Finder by right-
clicking an item; while the ‘Folder Action’ 
type lets you create a ‘magic folder’ that 
performs a task when you drop a file or 
folder into it. ‘Dictation Commands’ 
enable you to create scripts that run 

when you speak to your Mac, as long 
as you’ve turned on that capability in 
System Preferences > Accessibility.

When you launch Automator it asks 
you to choose the type of workflow 
you’d like to create. Pick one and click 
Choose. You’ll then see a window like 
the one shown below. Drag actions 
from the left-hand pane into the right-
hand pane in the order that will achieve 
your task. Many actions have options to 
tailor their behaviour to your needs.

Your first script
To help get you up to speed with using 
Automator, we’ll make a simple script 
that takes some text you’ve copied from 
an existing document and turns it into a 
new text file. Launch Automator, select 
Application and click Choose.

Select Utilities under Library, and 
then drag the instruction ‘Get Contents 
of Clipboard’ into the right-hand pane. 
Select Text under Library and drag 
‘New Text File’ into the right-hand pane. 
Notice the way it’s connected to the first 
action. This tells you that the results of 

the first action (grabbing the text that’s 
been copied from the clipboard) have 
been passed to the next action (saving 
that text as a file).

There are four options available for 
this command. The first enables you 
to specify whether you want the text 
to be saved as a plain text (.txt) or 
formatted text (.rtf ) document. The 
second enables you to choose a 
filename. In most cases you’ll want to 
choose a different filename for each 
text file you create, so click the Options 
button at the bottom and tick ‘Show this 
action when the workflow runs’ so you 
can specify a name each time. The 
‘Where’ item enables you to specify a 
starting folder when saving the text file. 
You can ignore the final option.

Once done, choose File > Save and 
select a suitable location and name for 
your app, then click Save. Now test your 
app: copy some text to the clipboard, 
then run the app. Enter a filename and 
click Continue, then open the text file 
to verify that it worked. Congratulations, 
you’ve created your first script!

Save time and speed up the way you use your Mac with Automator

SKILL LEVEL
Taking things further

IT WILL TAKE
10 minutes

YOU’LL NEED
OS X 10.11

Automate repetitive tasks

VISUAL GUIDE | THE AUTOMATOR WINDOW

Choose actions
1  Automator has over 200 actions  

for you to choose from.

Variables
2  If your script demands it, you can 

use variables, such as text, folder 

locations or the current time and date. 

Input options
3  Automators receive input in different 

ways, such as dragged and dropped 

files, or user input in specific apps.

Record
4  Another way to automate things is to 

ask the app to record what you do, 

which creates a ‘Watch Me Do’ action.

Actions
5  All scripts are divided into actions; 

the key is combining them properly.

1
2

3

5

4
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When you buy a new 
hard drive, when you 
want to encrypt some 
files to carry around on 

portable storage, or when files are 
corrupt or apps exhibit unexpected 
behaviour such as crashing, the first 
tool you should turn to is Disk Utility. 

This isn’t the sort of app you’ll use 
every day, which is why it’s stored in 
the Utilities folder (itself located 
within your Mac’s Applications 
folder) – though that’s only one of 
the places you can run it from. In the 

event of a serious problem that 
stops you getting into OS X in the 
first place, you can start up in the 
Recovery system – see page 160 for 
details – to run the tool’s First Aid 
feature, which diagnoses and tries to 
repair damaged structures.

Disk Utility isn’t just about fixing 
problems. If you buy an external 
hard drive that isn’t preloaded with 
an app that preps it for use with a 
Mac, you’ll need to use Apple’s tool 
to reformat the drive.

If that drive happens to be a 
portable hard drive or a flash drive, 
you’ll probably want to encrypt it 
so that if it’s lost or stolen, your files 
aren’t immediately readable. In 
fact, Disk Utility can protect your 
disk with 128-bit or 256-bit AES 
encryption – levels of protection 
that are used by various parts of the 
US government.

Manage storage in Disk Utility
An essential tool for checking health and formatting and encrypting disks

SKILL LEVEL
Could be tricky

IT WILL TAKE
At least 10 minutes

YOU’LL NEED
Disk Utility

Disks/volumes
1  This pane lists all 

of the storage 

attached to your Mac – 

internal and external, 

and disk images. When 

the arrow next to a disk 

is pointing down, all of 

the volumes (partitions) 

on it are shown slightly 

indented below it.

Summary info
2  Select a volume or 

a disk to see an 

overview of its contents 

and some technical 

attributes to the right.

Operations
3  With a disk or a 

volume selected, 

certain items in the 

toolbar will be available 

to use – most notably 

‘Partition’ when a disk is 

highlighted, and ‘Erase’ 

when either is selected.

Menus
4  Look under File, 

Edit and Images to 

find options for altering 

the password for an 

encrypted disk, to verify 

an image is intact and to 

restore it to a disk.

Disk Utility can 
encrypt a disk and 
protect access to it 
with a password 
in the process

1 2

3

4

QUICK LOOK 
THE MAIN WINDOW 
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1 Run a health check
Select either a disk or a volume on the 

left, click First Aid in the toolbar and then click 
Run when asked to confirm the operation. Disk 
Utility will run some through some checks that 
everything is okay with your selection, and 
attempt to repair problems 

4 Format for Windows
To share a disk with a Windows PC, set its 

format to ‘MS-DOS (FAT)’ if the disk or volume is 
under 32GB in size, or ExFAT if it’s larger than 
that. Its label can be 11 characters long, but 
filenames can be longer, and both OS X and 
Windows will be able to write to it.

6 Partition a disk
To split a drive into smaller partitions – 

perhaps to limit space for Time Machine (see 
page 156), select it (not a volume on it) and click 
Partition. When you click the + below the pie 
chart, space will be reapportioned from the 
volume that’s selected (shown in blue).

2 Format a disk for Mac
When you buy storage, it’s likely to be 

formatted for use with Windows. On the left, 
select the disk or the volume on it, then click 
Erase. Set Format to ‘OS X Extended (Journaled)’. 
(If you selected the disk, set Scheme to GUID if 
you want to install a second copy of OS X on it.)

5 Encrypt without erasing
A Mac volume can be encrypted without 

erasing its contents – but back them up first! In 
Finder, select Go > Computer, hold ≈ and click 
the volume, choose ‘Encrypt…’ and then set a 
password and a reminder. After clicking Encrypt 
Disk, ≈-click the volume to check progress.

8 Securely erase a disk
Some researchers say it’s unnecessary to 

erase a modern hard disk multiple times before 
it’s sold or abandoned. But, If it makes you more 
comfortable, erase it to have a single partition, 
select that, click Erase, then Security Options 
and choose a number of passes to make.

7 Back up to a disk image
You can make a disk image from a folder 

(useful for archiving projects). Choose File > 
New Image > Image from Folder then select a 
folder and click Open. The image’s contents can 
be compressed and encrypted. To restore an 
image, choose Edit > Restore.  

3 Format as encrypted
Particularly with a portable drive, you 

might want to encrypt it to protect its contents 
in case it is lost. In this case, set ‘OS X Extended 
(Journaled, Encrypted)’ as the format. You’ll be 
asked to set a password, which will be required 
to access the drive upon connecting it to a Mac.

HOW TO | MANAGE AND PROTECT DISKS

RECOVERY
Your Mac’s drive contains 

a Recovery partition in case of 
an emergency – it just isn’t 
shown in Disk Utility. If you 

can’t get into OS X to run the 
First Aid feature, hold ç+R 

at the startup chime.
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M
acs and iOS devices run 
smoothly and efficiently, 
but nothing lasts forever 
and over time you will 
run into problems. 
Bloated apps, upgrades 

that stretch your device’s hardware 
resources, and more demanding apps and 
games can all make your Mac struggle. Even 
though OS X and iOS are incredibly robust 
operating systems, you will eventually 
encounter a problem.

In this feature, we’re going to look at 
common problems and how to fix them. In 
many cases, routine maintenance such as 
backing up and archiving old files and 
remembering to perform incremental updates 
to the operating system and apps makes a 
huge difference.

Resource-hogging apps, stalled updates and 
backups that take days to complete are all 
easy-to-address issues which, once resolved, 
will improve your Mac. We’ve got a slew of tips 
on how to fix system performance, file 
management, and network niggles. 

Some issues will only have reared their head 
when you made the leap of faith from one 
version of OS X to the next - almost certainly 
from Yosemite to El Capitan. If you’ve been 
part of the recent Apple Public Beta you may 
encounter additional gremlins.

Issues with photos no longer being where 
you expect to find them, and other files 
seemingly going missing, are common 
annoyances. Wi-Fi and network problems are, 
thankfully, fewer than Yosemite but El Capitan 
installation problems trip many users up, and 
iTunes 12 has had some unwelcome surprises 
for unwary users.

With El Capitan fresh out  of the gate this is 
a great time to learn about common Mac 
problems and prepare yourself for any trouble 
that might arise.
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Help! My Mac has slowed down
Is your Mac running slowly? 
These tips grease its cogs  
and shift it up a gear

How to speed up 
a Mac is one of the 
most common 
requests, not least 
with Macs which 

are more than a few years old. 
Slow performance is one of the 

most irritating things to happen to 
any user. The good news is that Apple 
tests upgrades to OS X against older 
machines and makes sure they’re 
capable of running everything 
correctly, so if you are experiencing 
slowdown it’s usually fixable.

Having said that, El Capitan was a 
significant operating system upgrade 
from Yosemite, with plenty of 
additional features.

If you are encountering slow 
performance, the very first stop 
should be to empty the Trash. OS X 
needs some free space to move files 
around, and typically we advise 
around 10 percent of your hard drive 
space, or at least 10GB.

Before you even start to examine 
your disk space, get rid of any 
unwanted files. Items stored in Trash 
are taking up valuable disk space, so 
right-click it and choose Empty Trash 
Now to purge them from your Mac. 

Check the available disk space by 
clicking Go > Computer from the 
Finder menu bar, selecting the icon 
for your main hard disk and choosing 
File > Get Info (ç+I). Available 
space is listed in the status bar (you 
might need to choose Show Status 

Bar). If you don’t have at 
least 10GB free, it’s time 
to delete or archive your 
old files. Good places to 
look are your Movies, 
Downloads and 
Documents folders. 
DaisyDisk (£7.99, 
daisydiskapp.com) can 
help you find space-hogging files. 
Applications tend to take up a lot of 
space. You can drag apps you no 
longer use to the Trash or use an app 
like AppZapper ($12.95 – about £8, 
appzapper.com) to get rid of them.

Creating a backup with Time 
Machine is a good idea before you 
start to trash files. Connect an unused 
or new external drive with sufficient 
space, and go to System Preferences 
> Time Machine to use it for backups.

Backing up to a directly connected 
hard drive is faster than using a drive 
such as the Time Capsule, which 
backs up over Wi-Fi. If you do have a 
Time Capsule, it’s a good idea to 
connect to it using an Ethernet cable 
for the first backup.

Even so, backing up several 
gigabytes of data will take an hour or 
two and will impact your Mac’s ability 
to perform other tasks. After the initial 
run, only incremental changes will 
need to be backed up, so it’s worth 
gritting your teeth and getting the 
first, full backup out the way. Then 
you can delete older, less critical files 
and folders, which should have the 

effect of making your Mac a little 
more sprightly. 

Turn off features
If you’ve freed up some hard drive 
space and are still experiencing slow 
performance, then it might be time 
to try disabling some features.

To begin, go to System Preferences 
> Extensions > All and deselect any 
extensions you aren’t using.

Open System Preferences > Energy 
Saver. On some older MacBooks, you 
may see a Better Battery Life and 
Higher Performance options. Choose 
the latter, then restart your Mac. This 
turns on the discrete graphics card, 
but it will drain the battery faster. 

A good trick for older Macs is to 
uninstall Flash. It’s a resource hog and 
drains your battery. Of course, you 
won’t be able to access Flash-based 
web content, but many sites have 
moved to a more modern HTM5 
implementation now. You can find a 
Flash uninstaller at http://adobe.
ly/1P9sdfw. In your web browser, 
remember to close down tabs and 

windows you no longer need as 
these are a drain on resources.

Quit some apps
App Nap is a built-in feature that 
slows down apps that are obscured 
by other windows and not currently 
doing something. If an inactive app is 
using valuable memory, recent 
versions of OS X will compress the 
data it has in memory. That isn’t 
always possible, in which case the OS 
will write incompressible data to disk 
to free up space for another app. You 
can tell OS X the memory used by 
those apps can be used right away by 
other things by quitting them.

If you find it hard to know which 
apps are open, in System Preferences 
> Dock make sure ‘Show indicators…’  
is enabled. To prevent napping apps 
reappearing after a restart, go to  > 
Log Out… and deselect ‘Reopen 
windows when logging back in’.

Turning off visual effects such as 
transparency, can deliver incremental 
but important performance gains. In 
System Preferences > Accessibility, 
turn on Reduce transparency. 

Even if text doesn’t seem blurry, go 
to System Preferences > General and 
toggle ‘Use LCD font smoothing’ to 
check its appearance before and after.

MacBooks that start up slowly may 
not have been fully shut down the 
last time. This can happen if you 
closed the lid of your MacBook before 
the shutdown process finished, so 
don’t be too hasty when powering 
down for the day. After following 
these tips, you should find OS X runs 
much faster than before.

It’s easy to check available disk space in 
Finder, yet DaisyDisk does a much better 
job at helping you clear out old files.

On Macs of a very low specification, disabling 
Yosemite’s extensive use of transparency 
effects should improve your experience.
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Monitoring CPU and RAM
1

Use Activity Monitor (in /Applications/Utilities) 
to establish what apps and processes are using 

up the most CPU or RAM. Its CPU tab lists active 
processes in a real-time view of what’s going on.

Switch to different stats
2

Activity Monitor details five different 
resources: CPU, Memory, Energy, Disk, and 

Network usage. Switch between them by clicking on 
the tabs at the top of the windows. If you think your 
Mac is running slowly, the CPU and Memory sections 
are likely to be of most interest.

Sort by usage
3 Each tab’s columns show how processes are 

using that particular resource. Typically the 
second column is the most important. Click a column 
name, such as % CPU or Memory, so the arrow points 
down to sort processes so the ones using the most 
amount of that resource are at the top. Items at the 
top of the list are usually the ones using the highest 
percentage of CPU power. Fluctuations and spikes in 
this are shown on the graph at the bottom. It’s 
perfectly normal for these to occur as you open an 
app, download a video or render a complex, layered 

image. If Safari shows a web-based game or video 
clip using a significant portion of the CPU even after 
you’ve stopped using it, it’s likely to have stalled.

Force quit unruly apps
4

When a process is shown in red, this is Activity 
Monitor’s way of saying it’s unresponsive. This 

is usually accompanied by unresponsive behaviour 
from the app in question. To force quit an item, click 
it in Activity Monitor’s list, then on the X at the left 
of the toolbar, then confirm you want to force quit.

Search and monitor
5 Use the Search bar to check on a specific 

program or process. If you have Dropbox or 
Spotify installed, it’s worth checking whether they 
are using too much network bandwidth, for 
example. You can check whether large backups  
or downloads are taking place in the Network tab.

Generating diagnostics
6 Choose View > run System Diagnostic to 

generate a diagnostics report that allows 
Apple to investigate issues with your Mac. Accept  
the privacy agreement, then enter your account’s 
password to allow Apple access for the test.

ENERGY USAGE
You can consult your apps’ energy usage 
by clicking the battery icon in the menu 
bar on a MacBook. In Activity Monitor, 
you can see which apps are using the 

most processing power. Click the Energy 
tab and then sort the Energy Impact 

column to see which apps are using the 
most power over time. Also consider 

installing Coconut Battery (free, coconut-
flavour.com), which provides information 

about how many charge cycles your 
battery has been through, and its 

remaining capacity and health status.

Visual Guide | Activity Monitor
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My Mac struggles with El Capitan
Discover how to make sure El Capitan speeds along on your Mac

The upgrade from 
OS X 10.10 to OS X 
10.11 introduced 
new versions of 
built-in apps that 

made greater use of iCloud for 
collaborative working. However, 
there have been teething troubles 
with syncing documents using 
iCloud Drive. 

Thankfully, the ongoing networking 
and Wi-Fi problems that plagued 
Yosemite are mostly a thing of the 
past. Having said that, people have  
reported a range of early day gremlins 
that cause El Capitan to stumble.

The good news is that issues are 
being mostly addressed by Apple in  
a series of software updates. If El 
Capitan is still giving you problems, 
the first thing you should do is make 
sure you have the latest update (10.11 
is currently the version, with 10.11.1 in 
Beta testing). Go to the App Store and 
click Updates. If any are available for 
OS X, they’ll be listed above app 

updates – click Update next to them, 
or Update All.

The same advice applies to 
troublesome apps: user feedback and 
technical updates contribute to 
frequent app improvements, so install 
newer versions whenever you can. 

You can set OS X to perform 
automatic updates for apps installed 
from the Mac App Store. Open 
System Preferences > App Store, 
select ‘Automatically check for updates’ 
and then enable all of the download 
and install options below.

Fixing Wi-Fi woes
El Capitan may have fixed most 
networking errors, but some users are 
still having trouble with Wi-Fi and 
Bluetooth accessories, try resetting 
your router. Mac’s NVRAM (see page 
171). Graphical issues were relatively 
common on Yosemite and may 
persist in El Capitan, particularly on 
Macs that struggle with its demands. 
8GB of free drive space and 2GB of 

RAM are essential. More 
of both is preferable.

It’s hard to update 
the graphics card on a 
Mac, but some older 
Macs have upgradable 
RAM. Use Crucial 
System Scanner (uk.
crucial.com) to 

determine if an upgrade is available 
for yours.

If upgrading your hardware is out 
of the question, try reducing the 
impact of the newer system features 
on your Mac. Widgets in Notification 
Center can be sacrificed in System 
Preferences > Extensions > Today; try 
deselecting real-time items such as 
Stocks and Weather.

On a Mac with a very low 
specification, visual effects on the 
Dock – magnification as you move 
over icons and, less so, animating 
icons as apps open – can get juddery. 

You can turn these off in System 
Preferences > Dock.

Many users hare reported bad 
battery life after upgrading to OS X El 
Capitan. This is caused by Spotlight 
re-indexing all of the files. If you find 
this is happening you should simply 
leave the Mac plugged in, and wait a 
day or two for the Spotlight indexing 
to complete (you can use your Mac 
while the index takes place). When 
Spotlight has finished indexing all of 
your files the battery life will improve. 
If that doesn’t work, try resetting the 
SMC (see page 171).

Some users have reported 
being stuck on a grey screen 
during the El Capitan 
installation. If this problem has 

affected you, then be aware that the OS X 
installation can be extremely slow. Be 
prepared to give it several hours to 
complete the installation. If you have left 
OS X alone for a few hours, and it still isn’t 
installing, reboot your Mac in Safe Mode 
(see the opposite page).

If you installed the beta version then 
you will still be on the beta program, and 
OS X will continue to install beta updates. 
This can cause problems down the line, 

and unless you are a developer you should 
move away from the beta and back to the 
regular version of OS X. Open System 
Preferences > App Store and look for this 
message: “Your computer is set to receive pre-
release Software Update seeds”. If you see it, 

click Change and Do Note Show Pre-release 
Updates. While this doesn’t remove pre-
release software from your system, it does 
mean you’ll migrate away from the Beta path 
during the next round of updates.

If you are experiencing problems with apps 
after updating, then you should check 
for an updated version. One problem is 
Microsoft Office, which frequently 
crashes on El Capitan. Microsoft has 
reported that it’s working with Apple 
for a fix, and should hopefully have the 
problem fixed as soon as possible. Apps  
in general become more reliable as 
updates are released.

Problems with upgrading to El Capitan

If you’ve been using the public beta version of  
El Capitan on your main machine, then you 
should move back to the regular version

Your Mac can be set to automatically install updates to its operating system, 
which can help to resolve problems with little effort on your part.

If upgrading your 
hardware is out of the 
question, try reducing 
the impact of the newer 
operating system
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What do I do in Safe Mode?
Start up an unruly Mac and perform automated fixes

If your Mac 
struggles to start 
up on occasion, 
Safe Mode can 
help fix it.

Sometimes this is caused by an app 
that automatically launches and 
crashes the system. Other possible 
causes include insufficient memory, 
faulty extensions or a corrupt 
document or web page that was 
open when you last shut down.

Use Safe Mode to free your Mac of 
whatever’s holding it back. In this 
mode, your Mac loads the operating 
system and only required kernel 
extensions, and it checks over the 
startup disk for errors and attempts to 
fix any it finds. The font cache, kernel 
cache and other system caches are 
deleted in case they are the cause of 
your problem.

Other items, including user-
installed fonts, Startup Items and 
Login Items, are prevented from 
opening automatically. While this 

may sound unintuitive – since you 
want to use those apps and sites 
manually once you’ve reached the 
desktop – using Safe Mode helps free 
your Mac of operational clutter. If you 
can’t recreate your problem while in 
this mode, restart your Mac as normal 
to see whether the issue returns.

Start in Safe Mode
To start in Safe Mode, restart your Mac, 
hold ß when you hear the startup 
chime, and release it when you see 
the Apple logo. MacBooks must first 
be plugged into a power source. You’ll 
need to log in to your user account 
even if your Mac normally does so 
automatically. If you use FileVault, you 
may need to log in twice after 
restarting with the ß key pressed.

Not everything you usually do on 
your Mac will work in Safe Mode. You 
won’t be able to play DVDs or capture 
video in apps like iMovie. Some input, 
output or other devices may be 
unavailable too. This is a temporary, 

thing however.
Although Safe Mode 

loads fewer things, it 
may take longer than 
usual for your Mac to 
finish starting up. This is 
because of the checks 
and attempts at error 
resolution it undertakes. 

These safety checks are broadly similar 
to the repairs performed by Disk 
Utility in OS X. Your Mac may restart if 
it finds an issue while checking your 
startup disk for errors. If your Mac 
restarts or shuts down repeatedly, you 
should book it in for a repair.

Once Safe Mode has completed its 
checks, simply restart your Mac to 
return to its normal state. Future 
restarts should be faster than before. 
If your Mac is still having problems or 
you get error messages when starting 
as normal, you may need to disable 
items that are set to load at startup.

To do this, go to System Preferences 
> Users & Groups, click your account 
name then Login Items. Note all the 
items that are listed. Next, select all the 
items in the list and click the – button. 
Restart your Mac. If your problem is 
gone, add items back to the list one at 
a time, restarting after each one. If the 
problem recurs, it’s likely that the last 
item you added is the cause. Remove 
it and restart again as confirmation. 
Downloading a new version of that 
app or extension may help. If not, 
you’ll need to do without it – also, try 
contacting its developer for support.

After tinkering in Safe Mode and restarting, you 
can confirm OS X has started as normal by opening 
System Information and selecting Software.

Mac users of a certain age may well 
remember a fix known as ‘zapping the 
PRAM’ – using a quirky key combination 
at startup to fix myriad problems. Modern 
Macs feature something similar, called 
NVRAM (Non-Volatile Random-Access 
Memory). This, along with resetting the 
SMC (System Management Controller) can 
fix a variety of startup and charging issues.

If settings in NVRAM are corrupt, or SMC 
is out of sync, your Mac will exhibit a variety 
of weird behaviours. The Mac may take a 
long time to start, display in the wrong 
resolution, or its time zone may be erratic. 
The SMC controls fans, status lights, the 

keyboard backlight and other components.
To reset NVRAM, shut down your Mac, 

press the power button and as soon as you 
hear a chime hold ç+å+p+r. You’ll 
hear a second chime. Let go of the keys and 
the Mac will start normally.

Resetting the SMC is a last resort after all 
other troubleshooting fails. If your Mac’s 
symptoms match anything listed under 
Indicators at http://apple.co/1N7tsy1 then 
you should reset the SMC by following the 
instructions for your type of Mac on that 
page. The process differs between Mac 
notebooks depending on whether their 
battery is removable, and for desktops.

Fixing NVRAM and SMC

NVRAM and SMC are low-level fixes that you should only try 
after you’ve exhausted all other self-help troubleshooting.

In Safe Mode, your 
Mac loads essential 
extensions, checks 
the startup disk 
and deletes caches
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I’ve lost track 
of my files
Discover how to find missing 
files and folders with our guide 
to smarter searching

The old days of 
remembering 
exactly where you 
stored every file are 
long gone. For most 
of us this is a good 

thing, as we rarely remembered 
where everything was.

Modern versions of OS X augment 
files in the Finder with a huge amount 
of metadata – additional information 
that describes a file’s data. A photo will 
have a name and a file type, but also 
all kinds of other information: when it 
was taken, what camera was used, 
where it was photographed, the 
camera’s aperture setting, dimensions, 
colour space, and so on.

All this information can be used to 
find files, no matter where they are 

located, using Spotlight. So, if you 
want to get better at finding files, you 
should learn to spot the metadata 
attached to each file. Select a file and 
choose File > Get Info. Look under the 
More Info section of the Info window 
to see what metadata is attached to 
that file. This is the sort of thing you 
can search for in Spotlight. If you want 
to view all the metadata for a file, 
open a Terminal window and type 
mdls followed by a space, then drag 
a file onto the window to add its path 
to the command and press ®.

El Capitan emphasises Spotlight’s 
ease of use in searching, assuming 
you would prefer to type what you’re 
looking for into a search field, rather 
than locate it in a familiar folder. So if 
you can’t find a specific file, press 

ç+[Spacebar] to call 
up the Spotlight search 
bar and type the file or 
folder name or a word it 
contains. Select a file in 
the results and hold 
down the ç key to 
view the path to where 
it’s stored. Click a result 

with ç held to open a Finder 
window at its location. 

If you’re going to rely on Spotlight 
to find files, it’s a good idea to start 
naming files intelligently so you can 
identify them. Try to include a 
description, project, version and even 
a date in the file’s name.

Getting back 
Finder locations
Sometimes you still end up digging 
around for files in Finder, though. 
Recent versions of OS X have changed 
a few things: new windows show the 
All My Files view by default, and a few 
of the pre-created folders in your 
home folder are no longer listed in the 
sidebar. However, both of these things 
are customisable to help you reach 
what you need more quickly.

You can drag any folder into the 
Favorites group in the sidebar to make 

it reachable in an instant. Folders can 
be added to the Dock by dragging 
them into the area to the right of the 
dividing line, and the appearance of 
these shortcuts, called Stacks, can be 
customised by ≈-clicking them.

To change the folder that new 
Finder windows display, go to Finder 
> Preferences > General and set ‘New 
Finder windows show’ to any folder.

Files created in iOS apps are stored 
in your iCloud Drive, yet you don’t 
have to open those files from within 
apps on a Mac, like you would in iOS. 
Choose Go > iCloud Drive or select 
the iCloud Drive shortcut in a Finder 
window’s sidebar to browse them. 
However, be careful about moving 
around files that are still syncing to 
your Mac (indicated by a progress bar) 
as this can cause them to be lost. 
Deleted files can be recovered in 
Settings > Advanced at icloud.com.

If you need to reinstate something in the sidebar you can do so by delving into Finder’s 
Preferences where you get choose what items show up there.

Spotlight is pretty easy to use, and it’s 
become easier than ever in El Capitan 
thanks to a new feature Apple’s calling 
Natural Language.

Natural Language replaces Apple’s old 
keyword system, found in Yosemite and 
earlier versions of OS X.

Previously, you could augment Spotlight 
searches with keywords, such as 
kind:document or date:2014. But in El 
Capitan you know use these keywords as a 
natural part of the search term, so you can 
say “images from 2014” or “mail messages 

from Jane”. Spotlight will make sense of the 
semantics of your search, and use that to 
return the right result.

Spotlight also returns far more results 
from online than before. Entering weather 
brings up weather results, and you can 
search for Premiere League results or stock 
market shares from Spotlight.

If you’re having trouble with Spotlight, 
then you should rebuild the Spotlight 
Index. Open Terminal and enter  
sudo mdutil -E /. Enter your password and 
Spotlight will begin to rebuild its index.

Secrets of Spotlight

Spotlight can search for files in which metadata matches 
certain attributes, such as type and creation date.

If you’re going to rely 
on Spotlight to find 
files, it’s a good idea 
to start naming files 
intelligently



OS X El Capitan Handbook  |  173 

Apple Genius |   ADVANCED

Get to grips with file permissions 
and manage all of your files

In OS X (but not iOS) 
you can have more 
than one user 
account – typically 
one for yourself and 
others for family.

At the heart of this sits a system 
known as File System Permissions and 
understanding this can make your life a 
lot easier. Every single item on your Mac 
– all the files you have created, and every 
file and folder in the operating system –  
has permissions attached to it.

These permissions determine who 
‘owns’ the file, and who else has access 
to it. In Unix, the system that sits 
beneath OS X, there are three types of 
access: reading, writing and executing. 
Read determines who gets to view the 
contents of a file, Write determines who 
gets to edit (and save) the file, and 
Execute determines which user 
accounts can run an app or script.

In OS X, you only get to change who 
owns the file, and who gets to read or 
write to it. You’ll need to dig into 
Terminal to adjust the execution status 
of files. But for the most part, you’ll be 
fine adjusting permissions inside OS X’s 
graphical interface.

Select any file, or folder, in OS X and 
choose File > Get Info (ç-I). Scroll 
down to find Sharing & Permissions. For 
most files, you will see your account 
name followed by (Me) and the privilege 
set to Read & Write. Below your account 
will be two further users: ‘staff’ and 

‘everyone’ (both typically set to Read 
Only.) The former group is all the 
accounts you have set up on your Mac, 
and the latter one includes any other 
accounts that may access your Mac 
(such as a Guest account or another Mac 
on your network).

You change the permission status of 
files and folders in the Get Info window. 
If you are the owner of the file, just click 
in the Privilege column next to staff or 
everyone and change them to Read & 
Write, Read Only, No Access (only for 
‘everyone’), or Write Only (for folders).

Most of the time you’ll want to 
change permissions on a file that you 
don’t own (typically because your access 
to it is blocked). This block may be 
because you have transferred the file 
from one user account space to another, 
or because you are trying to view files 
on a different user account. To change 
the permissions for a file, or folder, 
owned by another user, you first click 
the padlock icon in the bottom-right 
corner of the Get Info window. Enter an 
Admin user’s credentials and click OK. 
Now you can change the privileges.

If you have moved a file manually 
from one account to another, you may 
see the name field set to ‘system’ rather 
than your name (or the name of another 
user account). You can change the staff 
group to Read & Write and access the 
file that way, or make yourself the owner 
of the file. Click the + button and choose 
your account name from the list of Users 
& Groups, then click Select to add it to 
the item’s privileges. Click the Settings 
cog and choose ‘Make me the owner’. 

When it came to making an 
operating system for the 
iPhone and the iPad, Apple 
chose a different direction 
than it did for the Mac: 
a much simpler interface and 
a controlled environment. 

This control makes iOS 
a fast, safe and relatively 
trouble-free environment. 
The problem is that it comes 
at the expense of some 
powerful features. Unlike 
OS X, you have no direct 
access to files. Instead you 
have to access them from 
inside apps.

The first thing you should 
do is get your files into 
Apple’s iCloud Drive system. 
Transferring files to iCloud 
Drive makes them accessible 
across all iCloud Drive-
enabled apps, including all 
of Apple’s iWork apps and 
Microsoft’s Office suite. 

In the upcoming iOS 9 
you’ll be able to activate an 

iCloud Drive app by going to 
Settings > iCloud > iCloud 
Drive and switching on ’Show 
on Home Screen‘. This installs 
the iCloud Drive app on your 
iPhone or iPad’s Home screen, 
which is much more like 
using Finder in OS X.

If this isn’t enough, then 
you should investigate 
remote access software, 
which enables you to view 
and control your Mac from 
an iPhone or iPad. Parallels 
Access (http://bit.ly/1INfAVU) 
is the best of the bunch, 
because it formats OS X and 
its apps to fit perfectly on the 
smaller iOS screen, and it has 
a great interface. It costs 
£13.99 per year. For a free 
solution, search for Google’s 
Chrome Remote Desktop in 
the App Store on your iOS 
device, and install Chrome 
and the corresponding 
extension (http://bit.ly/ 
1hBQfFp) on your Mac.

Make iOS more like OS X

Choose ‘system’ in the Name list 
and click the – (minus) button to 
get rid of it. You’re now the owner 
of the file as if you’d created it. You 
can also use this method to make 
files owned by other people yours. 

Viewing folders in 
other accounts
A common problem is trying to 
view the contents of a folder on 
another account on your Mac. 
Choose Go > Computer and select 
your startup drive and then the 
Users folder on it to see folders for 
each user with an account on your 
Mac. Open a folder for an account 

that isn’t yours, and you’ll see a red 
Stop icon next to most folders. 
Trying to view the contents of one 
of these folders bring up the error: 
“The folder can’t be opened 
because you don’t have permission 
to see its contents.”

You can bypass this lock by 
adjusting the permissions. Select a 
locked folder, choose File > Get Info, 
click the Lock icon and enter an 
Admin user’s credentials. Click the 
+ button, choose your name from 
the list and click Select. Change 
your privilege to Read & Write and 
you’ll be able to access that folder 
as if it was in your account.

As long as you have access to 
an admin account, you can 
override permissions.
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iCloud’s giving me a headache!
Navigate your way smoothly through any clear air turbulence

Apple has 
designed iCloud 
to look like 
a single 

homogenous service, designed 
from the ground up, like email or 
the web. 

However, it’s important to 
remember that, just like these other 
parts of the internet, iCloud is really 
a collection of a few dozen different 
technologies and protocols that all 
just happen to be hosted on servers 
owned by Apple. So just because 
one part of iCloud is broken for you, 
it doesn’t mean that everything else 
will be too. iCloud Drive, for 
example is enabled separately for 
each app. If an app isn’t syncing 

data properly, make sure that this is 
actually turned on. In OS X you can 
do this in iCloud’s preferences by 
clicking the Options button next to 
iCloud Drive. In iOS, tap Settings > 
iCloud > iCloud Drive. If it’s enabled 
for all devices and your document 
still doesn’t sync, try moving the file 
out of the cloud altogether. Click 
iCloud Drive in the Finder sidebar 
(or choose Go > iCloud Drive from 
the menu bar) to see every 
document organised into 
subfolders by app (and any you’ve 
created). You can drag the problem 
file to your Desktop and it will be 
deleted from all other devices. Then 
you can drag it back, or recreate it 
afresh to correct any document 

Apple now has 
three separate 
but related 
photo syncing 
and sharing 

services that all rely on iCloud. 
iCloud Photo Library is the most 
comprehensive: it syncs your 
entire photo library to iCloud. 
If you have multiple devices 
signed in with the same Apple 
ID, they all sync to the same 
online library, so all your photos 
from all the devices appear 
online and on every device, 
although the syncing process 
automatically eliminates exact 
duplicates. This uses your 
iCloud storage quota, so unless 
you have a very small library, 

you may need to pay a monthly 
fee for extra online space.

My Photo Stream is a more 
limited service that only 
uploads photos taken in the last 
30 days, up to a limit of 1,000 
photos. It doesn’t count against 
your iCloud storage limit. The 
third service is iCloud Photo 
Sharing. This doesn’t count 
against iCloud storage either, 
and is limited to 5,000 photos 
per shared album. You can use 
this to upload photos to a 
cordoned-off area of iCloud that 
is shared with people that you 
invite. All are enabled in iCloud’s 
preferences under Photos on a 
Mac, and in Settings > Photos & 
Camera on iOS devices.

 Photo syncing explained

iCloud Photo Sharing lets you share albums with friends, even if they don’t use Apple kit.

If an app doesn’t appear to be syncing its data to iCloud, 
confirm in Settings > Mobile (or Mobile Data on iPads with 
cellular connectivity) that the app isn’t restricted to Wi-Fi.

You can check the service status of the various services that fall 
under the iCloud umbrella at http://apple.co/1UHD6Jc.

corruption. iCloud 
Drive was only 
introduced with 
iOS 8 and OS X 
Yosemite. On earlier 
versions, apps sync 
their data invisibly 
using ‘Documents 
in the Cloud’ and 
the only reliable 
way to clear iCloud 
data is to delete the 
app altogether.

You may find 
that some iOS apps 
don’t sync their 
data consistently. 
This may be 
because they are 
set to only sync over Wi-Fi, to 
preserve your cellular data allotment. 
This setting is also enabled 
independently for every individual 
app – you can change it by tapping 
Settings > Mobile Data and scrolling 
down to the list of apps. If the date 

and time on your device aren’t set 
automatically, then they can drift 
out of sync with the iCloud servers 
and this will very often prevent 
apps from uploading data to iCloud 
Drive because they can’t tell which 
is the most recent copy of the file. 
Check this in Settings > General > 

Date & Time. 
It is also worth 

checking that you are 
using the same Apple 
ID to sign in to iCloud 
on all your devices. 
If you have registered 
more than one email 
address as an Apple ID 
then you could have 
two unrelated iCloud 

If your iPhone’s date 
and time is incorrect, 
apps won’t be able to 
upload data to iCloud 
because they can’t tell 
which file is newest
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storage spaces that won’t share 
data with each other.

Darker clouds
Sometimes iCloud can actually sync 
data too well. Keychain syncing, for 
example, will distribute saved 
passwords to every device signed 
in with your Apple ID, and this 
includes Wi-Fi passwords for 
networks you connect to. If you 
use a mobile hotspot to provide 
internet access for a laptop, your 
iPhone will receive the password 
to connect to the hotspot too. 
This probably isn’t what you want, 
because your phone will try high-
bandwidth activities like syncing 
photos, even though it is still only 
connected to the internet via the 
SIM card in the mobile hotspot. 

Unfortunately, you can’t prevent 
iCloud Keychain syncing an 
individual password. So to prevent 
this happening, you’ll either have to 
turn off your iPhone’s Wi-Fi every 
time the mobile hotspot is on, or 
else disable keychain syncing on 
the iPhone (in Settings > iCloud).

Even if you don’t think you’ll use 
iCloud very much, there are some 
services that you should always 
enable. Find My Mac/iPhone/iPad, 
for example. This will show your 
device on a map if it is lost or stolen 
and lets you remotely lock it or 
erase all of its data. But if you buy 
a second-hand Mac, iPhone or iPad, 
the previous owner might still have 
their Apple ID associated with this 
device – even if the device itself has 
been reformatted or factory reset. 
(When buying a second-hand iOS 
device, ask the previous owner if 
they’ve followed the instructions at 
http://apple.co/1fbJkRA.) On a Mac, 
a previous owner may notice one 
day that an old device is still 
registered to their Apple ID and 
lock or erase it without realising the 
implications for you. The only sure 
way to protect yourself from this is 
to sign in to iCloud and enable Find 
My Mac using your own Apple ID. 
Find My Mac can only be enabled 
for one Apple ID at a time, so this 
will remove the previous owner’s 
connection to your device.

When you buy or sell a second-hand 
Apple device, it’s imperative that 
iCloud’s Find My Mac/iPhone/iPad 
service is disabled. Consequently, this 
disables Activation Lock on iOS devices.

When Apple Music 
first launched, 
there was a bug in 
iTunes version 12.2 
that scrambled 
your iTunes library 

if you had previously subscribed to 
iTunes Match. This was 
subsequently fixed in iTunes 
12.2.1, but if you signed up for the 
free trial of Apple Music before 
that  was released, your library will 
still be corrupted. If you see the 
wrong album art, or you click one 
song and another one plays, then 
this is why. 

Apple offers a solution to this 
problem at http://apple.co/1JgT6je 
which requires disabling iCloud 
Music Library on all your devices as 
its first step. You then need to 
update all of your computers to 
the latest version (currently 
12.3.0.44) to ensure the problem is 
unable to recur.

Next comes the unfortunate 
step of resetting your iCloud Music 
Library from one computer, which 
has the consequence of removing 
all of the music and playlists stored 

in it. You should, of course, ensure 
you have a local copy of any songs 
you own that weren’t purchased 
from the Store before you proceed 
to reconstruct the online library. 
After resetting the online library, 
you need to restart iTunes in Safe 
Mode (hold down ≈+å when 
opening iTunes). This has to be 
done on all of your computers, and 
afterwards you should check that 
songs that were previously faulty  
are now correct, and then turn on 
iCloud Music Library on all your 
other devices.

 Blank album art like this can happen when Apple Music corrupts your iTunes library.

Fixing iTunes library corruption caused by 
iTunes 12.2 means resetting the online library.

Apple Music has messed 
up my iTunes library
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Most home 
broadband 
routers are 
configured to 
work right out of 

the box on their default settings. 
However, sometimes we fiddle 

with settings when we’re trying to 
make things work and then forget 
to put them back again afterwards. 
Also, if you have had the same 
router for several years, it may be 
using out of date protocols. So let’s 
start with a look at the network 
settings that Apple recommends. 
To open the configuration panel of 
your router, enter the numeric IP 
address of your router into Safari’s 
address bar – usually ‘192.168.1.1’ 
but if that doesn’t work, go to the 
Network preferences pane, click 
Advanced, then click the TCP/IP tab. 
Your router’s address will be listed 
there. Every manufacturer’s router 
displays the settings in a slightly 
different way but normally there’ll 
be an ‘Advanced’ or ‘maintenance’ 

If you don’t know your router’s IP address, you can find it in the Network preferences pane.

If you have a 
new external 
drive that Time 
Machine won’t 
let you use for 

backups, make sure that it is 
formatted correctly. Time 
Machine can only write to disks 
if they are formatted as ‘Mac OS 
Extended (Journaled)’.

Most USB drives are sold pre-
formatted with the Windows 
NTFS format, so you’ll need to 
reformat them using Disk 
Utility. You also can’t have a 
slash character in the volume 
name. Disk Utility won’t let you 
create a volume with a slash in 
the name but if you have 
rename the volume using 
Finder, it will allow slash 
characters to slip past.

Sometimes Time Machine 
will fail with the message “An 
error occurred while copying 
files”. The first time this occurs, 
just run the backup again 
manually; it may succeed this 
time if the error was caused by 
a transient USB glitch. If it fails 
twice, use the Time Machine 
Buddy dashboard widget (free, 
bluedog.com.au) to see which 
file caused the problem. Try 
excluding this file in Time 
Machine’s preferences. If the 
backup then works, this file 
may be corrupt. Try deleting it 
and recreating it from scratch. 
As a last resort, turn Time 
Machine off, delete /Library/
Preferences/com.apple.Time 
Machine.plist. Then turn Time 
Machine back on again.

Trouble with Time Machine?

Help! I’m having network issues
If your Wi-Fi seems slow or unpredictable, try these simple fixes

An issue whereby 
Safari is slow to load 
a new site at first is 
fixable with new 
DNS settings

page that requires you to enter a 
username and password. If your 
router is still using the default 
password, your first job is to change 
it. If a hacker managed to connect 
to your router and access the admin 
page, they could reconfigure it to, 
among other things, redirect all 
your web searches.

The SSID is the name of the 
wireless network as it appears to 
other devices. This should be 
unique to your router. Most modern 
routers append a serial number to 
the name to make sure it is unique, 
such as SKYA123B. But there are still 
some routers using generic names. 
If two routers with the same name 
are in range of each other, your Mac 
can end up trying to connect to the 
wrong one, resulting in stalled 
network connections for you. The 
SSID should also be in ‘broadcast’ 
mode. Hiding the SSID doesn’t do 
anything to improve security 
because it’s very easy for hackers 
to grab it anyway.

False sense of security
MAC address filtering is also often 
mistakenly used as a security 
feature. The Media Access Control 
address (not related to the Apple 
Mac) is a unique serial number built 
into the hardware of every network 
device. Most routers will allow you 
to forbid specific MAC addresses 
from connecting, or alternatively 
only allow connections from a list of 
known MAC addresses. But this is 
just a convenience for network 
administrators. It is very easy for 
hackers to fake their MAC address, 
so you shouldn’t rely on it for 
security. In fact, all the security you 
need comes from the wireless 
encryption protocol, which should 
be set to WPA2, also sometimes 
called ‘WPA2 Personal’. This is the 
strongest encryption protocol 
available for Wi-Fi. If you have some 

older (pre-2004) hardware that 
doesn’t support WPA2-PSK, you can 
set your router to WPA/WPA2 mode, 
which will use WPA2 on anything 
that supports it, and the slightly less 
secure WPA to connect everything 
else. What you shouldn’t use is WEP. 
This protocol can be cracked in a 
few minutes using widely available 
hacking tools, so WEP security is 
essentially the same as none.

Now that we have AirDrop, 
moving the occasional file between 
your Macs and iOS devices is much 
easier than it used to be. But if you 
still have older Macs in your stable, 
you can occasionally come up 
against the old ‘There was a 
problem connecting to the server 
<foo>’ error message. The main text 
of the error message implies that 
the other computer might not be 
available or you might have its IP 

address wrong, when 
you know for a fact 
that the details are 
correct because it was 
working just yesterday. 
This is actually a 
problem with the 
network discovery 
mechanism that OS X 
uses to see other 
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computers on your local network. 
To shake it into action, you need to 
turn off Wi-Fi by clicking its icon in 
the menu bar (or go to System 
Preferences > Network > Wi-Fi) and 
then turn it back on again. Then 
choose Go > Connect to Server in 
Finder and enter the numeric IP 
address for the computer. If it’s a 
Mac, the address should begin 
with afp:// and for Windows 
machines use smb://. Once you 
have connected manually like this, 
your Mac should be able to 
exchange files with the other 
computer normally.

Yosemite sometimes seems to 
stall at the start of loading a new 
web page, but then once the first 
page on that site loads, all the links 
within that site open much more 
quickly. This can be fixed by 
changing your DNS server. 
Normally when you type ‘apple.
com’ into the address bar, Safari 
tells your router to contact the 
DNS server provided by your 
Internet Service Provider, which 
then converts the domain name 
into a numeric IP address that 
computers can understand. You 
can partly short-circuit this by 

supplying a DNS server address 
to OS X directly. Go to the Network 
preferences pane and click 
Advanced. Click the DNS tab and 
then the + button at the bottom-
left to add a new server. Enter 
‘8.8.8.8’ and ‘8.8.4.4’ (without the 
quotes), which are DNS servers 
provided by Google. Click OK, 
then Apply, and restart Safari. 
You should see an improvement 
in your page loading times.

Finally, if you think your settings 
are correct yet you still experience 
connection problems, try deleting 
your network preference files. In 
Finder, click Go > Go to Folder and 
enter ‘/Library/Preferences/
SystemConfiguration’. Drag the 
following five files to Trash: 

com.apple.airport.preferences.plist; 
com.apple.network.identification.
plist; com.apple.wifi.message-trac 
er.plist; NetworkInterfaces.plist; and 
preferences.plist.

When you restart your Mac, all 
of these files will be recreated with 
default or auto-detected values, 
which may be enough to get you 
back up and running.

Normally a single 
wireless access 
point has enough 
range to cover an 

entire house. If you add a Time 
Capsule, you should connect it  
to your router using an Ethernet 
cable and use AirPort Utility to turn 
off Wi-Fi on the Time Capsule.  
This keeps your home network as 
simple as possible. If you have a 
very large house, or an old one 
with thick stone walls and lots of 
nails in the floorboards, you may 
need extra Wi-Fi access points to 
reach every room. If you do this, 
make sure that you turn off the 
DHCP server on every device 
except for your router. DHCP is  
the service that assigns local IP 
addresses to each computer on 
your network, and you don’t want 
two Wi-Fi access points fighting 
with each other.

Likewise, only enable Network 
Address Translation (NAT) on your 
broadband router. If two devices 
are using NAT, your network will 
effectively be split into two 
subnetworks, and some services 
such as FaceTime and online 
games might find it hard to reach 
the internet across this split.

Some older networked drives or 
printers might have been set up 
with a static IP address. They work 
fine until you change internet 
provider and get a new broadband 
router. This is because the new 

router has a different default range 
of IP addresses that are clashing 
with the static address on your old 
device. If you can, change the 
device to use DHCP so it always 
receives a valid address from the 
router. If it doesn’t allow this, you’ll 
have to pick a new static IP address 
that lies outside of the range of IP 
addresses that the router can 
supply via DHCP. So, if the router 
configuration page says the DHCP 
server has an ‘End IP address’ of 
192.168.1.254, change this to 
192.168.1.250 and then assign 
192.168.1.251 to your printer or 
networked drive.

Troubleshooting 
network peripherals

 If your broadband router already provides Wi-Fi networking, it’s best to turn off Wi-Fi on your 
Time Capsule. Also check that DHCP and NAT services are provided by just one access point.

Every router’s configuration page looks slightly different, but they all have essentially the 
same basic settings, including IP address ranges and Wi-Fi security protocol.

Narrowing the range of IP addresses that your router dishes out using DHCP will enable you to 
assign those whose last part is outside of that range to old devices that need a fixed address.

If you have a single access point at home, you 
should turn Wi-Fi off on your Time Capsule.
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